15:01:28 <ChrisPriceAB> #startmeeting OPNFV TSC
15:01:28 <collabot> Meeting started Tue Mar  3 15:01:28 2015 UTC.  The chair is ChrisPriceAB. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:28 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:01:28 <collabot> The meeting name has been set to 'opnfv_tsc'
15:01:32 <dlenrow> #info dlenrow
15:01:35 <ChrisPriceAB> #info Chris Price
15:01:41 <bryan_att> #info Bryan Sullivan
15:01:43 * ChrisPriceAB morning dneary
15:01:46 <ulik> #info Uli Kleber
15:01:46 <frankbrockners> #info Frank Brockners
15:01:58 * ChrisPriceAB dneary are you cdub today?
15:02:10 <tapio__> #info Tapio Tallgren (Nokia)
15:02:29 <fuqiao> #info fuqiao (proxy
15:02:39 <ChrisPriceAB> #topic Approval of previous minute
15:03:06 <ChrisPriceAB> #agree TSC approved the previous minutes
15:03:13 <ChrisPriceAB> #topic Agenda Bashing
15:03:59 <Gerald_K> #info Gerald Kunzmann (DOCOMO)
15:04:21 <bryan_att> #info I would like to add a discussion about OpenStack blueprint deadlines and how we act in a coordinated manner across OPNFV.
15:05:55 <ChrisPriceAB> #chair dnaery
15:05:55 <collabot> Warning: Nick not in channel: dnaery
15:05:55 <collabot> Current chairs: ChrisPriceAB dnaery
15:05:56 <dlenrow> #info I'll help
15:06:00 <ChrisPriceAB> #chair dlenrow
15:06:00 <collabot> Current chairs: ChrisPriceAB dlenrow dnaery
15:06:02 <Gerald_K> i'll help
15:06:12 <ChrisPriceAB> #chair bryan_att
15:06:12 <collabot> Current chairs: ChrisPriceAB bryan_att dlenrow dnaery
15:06:20 <ChrisPriceAB> #chair Gerald_K
15:06:20 <collabot> Current chairs: ChrisPriceAB Gerald_K bryan_att dlenrow dnaery
15:06:28 <dlenrow> nary a naery
15:06:38 <ChrisPriceAB> #topic Review of NFV#9 meeting
15:07:43 <bryan_att> #info Chris at TST meeting at ETSI, proposed a contribution re similarity between reqs & defs on Phase 2 for testing
15:08:29 <bryan_att> #info ... similarities etc call for closer collaboration with OPNFV
15:10:04 <bryan_att> #info ... we need to get access to the ETSI proposals e.g. a link if it can be open
15:10:26 <bryan_att> #info ... Chris will add a note to the list on what was stated in case we dont have access
15:10:56 <dlenrow> #info CP stated to SDO collab meeting agreed to LOI between ETSI and OPNFV
15:11:02 <bryan_att> #info ... ETSI plans to write a letter of intent re cross-group coorindation, leveraging work across groups
15:11:51 <bryan_att> #info ... cross-consortia discussion went on later, anyone there to share what happened?
15:12:03 <bryan_att> #info Parviz was there
15:12:32 <Gerald_K> #info TMF, ETSI NFV, 3GPP SA5 will work closely together
15:12:36 <bryan_att> #info ... TMF, ETSI ISG, 3GPP SA5 will work to enhance the mgmt stack. Immediate OPNFV impact may be minimal
15:13:13 <bryan_att> #info ... TMF ZOOM will work with ISG on Phase 2 POCS
15:13:16 <julien_ZTE> #info JUlien
15:13:48 <bryan_att> #info ... Work in SA5 will inform specs for MANO stack
15:14:24 <bryan_att> #info ... open question is how to coordinate the ISG IFA WG (interfaces & arch) and SA5
15:15:02 <bryan_att> #info ... ZOOM is being used as "marketing collateral" to influence the industry on NFV
15:15:28 <Gerald_K> #info http://docbox.etsi.org/ISG/NFV/05-CONTRIBUTIONS/2015/NFV(15)000057_Further_collaboration_between_OPNFV_and_ETSI_NFV.docx  (ETSI Portal; closed for ETSI members)
15:15:47 * ChrisPriceAB thanks gerald
15:15:48 <Gerald_K> #info (available to ETSI members)
15:15:48 <bryan_att> #info Dave L was there; ETSI was happy OPNFV supported it also.
15:16:11 <dneary> #info dlenrow adds that ETSI NFV leadership was very happy that OPNFV attended, and were also apologetic about the lack of agility/bureaucracy in the ETSI process
15:16:48 <Gerald_K> #info no action items for OPNFV from that workshop
15:17:12 <ChrisPriceAB> #topic OPNFV Release 1 Naming
15:17:49 <dneary> We didn't
15:17:56 <ChrisPriceAB> #info Ray sent the suggestions on names out to the list based on current inputs
15:18:01 <bryan_att> #info Ray asks if we settled on "A" and real names
15:18:36 <bryan_att> #info Chris: we haven't voted on methodology - that should be implicit in the vote
15:19:00 <bryan_att> #info ... we need to trim the options; any we can drop, or any higher priority?
15:19:31 <bryan_att> #info ... it can be anything at this point - we have not eliminated all but "A" e.g.
15:19:40 <Gerald_K> #info in OpenStack there is also a legal review
15:19:54 <Gerald_K> #info we should also do this filter before doing the voting
15:20:25 <bryan_att> #info ... e.g. for (TM)
15:20:34 <dneary> #info The filter is to names which could lead to trademark issues (like Amazon, perhaps)
15:20:55 <Gerald_K> see chat window of GTM
15:21:19 <Pranav_> #info Pranav Mehta
15:21:48 <bryan_att> #info I like fictional rivers
15:22:19 <dneary> Arno or Avon are easy to write & spell names
15:22:21 <bryan_att> #info how about Phoenix
15:22:36 <rprakash> #info what about "anchor" holding OPNFV together a river name
15:22:40 <joekidder> rubicon
15:24:05 <bryan_att> #info or Styx
15:24:06 <Gerald_K> #info alphabetical order has benefit of being "predictable" and will avoid for the same discussion all over
15:24:51 <bryan_att> #info Chris: OK to allow Ray to simplify the list and get legal approval, run a doodle etc?
15:25:08 <fuqiao> Avon is a trademark I think
15:25:17 <Gerald_K> yes
15:25:54 <bryan_att> #info Frank: only the TSC can vote?
15:26:25 <bryan_att> #info Chris: good question - put to the TSC, community, or anyone?
15:26:41 <bryan_att> #info Ray: it would be hard to open it too wide
15:27:22 <bryan_att> #info Dave keep it simple, to the tech-discuss list.
15:27:47 <AndreaP> #info I'd go with the community voting if feasible
15:28:01 <Gerald_K> #info Chris: it is a community right to have a vote on this
15:28:10 <bryan_att> #info Frank: we should include name with vote
15:28:53 <Gerald_K> are all tsc members also member of the tech-discuss list ?
15:29:02 <ChrisPriceAB> #agree That voting shall be open to all participants of the opnfv-tech-discuss list, we will ask voters to enter their name when voting.
15:29:28 <ChrisPriceAB> #topic opnfv-tech-discuss topic filters
15:29:31 <Parviz> #info Parviz Yegani
15:29:52 <bryan_att> #info Ray: topic filter email sent out last week - use Gerrit name rather than repo name
15:30:22 <ChrisPriceAB> #undo
15:30:22 <collabot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1d5c610>
15:30:26 <ChrisPriceAB> #info Ray: topic filter email sent out last week - use Jira name rather than repo name
15:30:33 * ChrisPriceAB slight correction
15:32:17 <bryan_att> #info Bryan: why do we need to change
15:32:48 <Gerald_K> #info why not use filter on email client side?
15:33:27 <Gerald_K> #info if you want to address a specific project, use a specific tag in the email subject
15:33:40 <ChrisPriceAB> #info A tag includes the project tag [BGS] in the e-mail header
15:34:05 <Gerald_K> #info you can choose in the mailman config which tags to receive
15:34:51 <Gerald_K> # should be "disabled" by default. anyone who wants to use it can "enable" it
15:34:59 <Gerald_K> #info should be "disabled" by default. anyone who wants to use it can "enable" it
15:37:46 <rprakash> #info enable auto-filtering in subject-line with project-name=repo-name or project specified tag and this optional
15:38:13 <ChrisPriceAB> #agree TSC agrees to enable filters on opnfv-tech-discuss, Ray will provide clarification on the wiki.
15:38:46 <bryan_att> #info Chris: need to address project naming conventions etc
15:39:05 <bryan_att> #info ... call for a proposal for project name & tool chain proposals
15:39:50 <rprakash> #info Project naming conventions, repo names, Jeera project tags (volunteers?)
15:39:50 <rpaik> #link https://wiki.opnfv.org/developers/project_page_template
15:40:11 <bryan_att> #info Ray: project page template can include instructions
15:40:17 <ChrisPriceAB> #action Ray & Chris to update the project page template and project key facts sections to reflect the naming needs across Jira/mail/repositories
15:40:51 <ChrisPriceAB> #topic Maintaining project leader, committer & contributor list
15:41:31 <bryan_att> #info Ray: Aric had an idea for source info better than the wiki
15:41:34 <ChrisPriceAB> #info Ray explains that the current method of managing project leader, committer and contributors on the wiki is creating some confusion.
15:43:02 <bryan_att> #info Aric: wiki list can be modified - have to go back and review changes; adding a list of contributors to the repo would enable automatic reports
15:43:04 <ChrisPriceAB> #info aric proposes that when a project is created a file is created in the repository that describes the current list of committers & project lead.
15:44:57 <rprakash> #info "commiters" should be in repo, but contributors can be many and change , so access control should be for commiters?
15:44:57 <pals> #info pals
15:46:10 <bryan_att> #info Frank: it would be good to have HTTP access to the wiki so that it can be easily synced with the wiki
15:46:27 <bryan_att> #info ... "access to the repo"...
15:46:53 <bryan_att> #info ... key project facts should be stable and visible on the wiki - a uniform source of info
15:47:06 <bryan_att> #info +1 to Frank's proposal
15:47:41 <aricg> #info https://gerrit.opnfv.org/gerrit/gitweb?p=releng.git;a=summary
15:48:07 <bryan_att> #info Aric: gitweb doesn't need authentication
15:48:50 <ChrisPriceAB> #action frankbrockers to work with aric to prototype autogenerating key project facts onto the wiki pages.
15:49:09 <bryan_att> #info Luke: will look into how to render the content on the wiki
15:49:12 <ChrisPriceAB> #undo
15:49:12 <collabot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1def2d0>
15:49:13 <ChrisPriceAB> #undo
15:49:13 <collabot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x1defd10>
15:49:26 <ChrisPriceAB> #action frankbrockers and hinds to work with aric to prototype autogenerating key project facts onto the wiki pages.
15:50:07 <bryan_att> #info Chris: every project needs a leader / contact person
15:50:49 <ChrisPriceAB> #action hinds to propose a security project for documentation and activity
15:51:09 <ChrisPriceAB> #topic Development tool training, Jira, Gerrit, Git, Jenkins
15:51:10 <rpaik> need to drop off
15:51:50 <bryan_att> #info Chris: not all are familiar with tools e.g. agile, jira, tying to gerrit etc
15:52:06 <bryan_att> #info ... some members would be willing to do basic walkthrus
15:52:19 <bryan_att> #info +1
15:52:44 <bryan_att> #info ... how do we move forward
15:52:56 <bryan_att> #info Bryan just get people started setting up the sessions
15:53:20 <bryan_att> #info Chris: will do that, record on GTM etc for later use
15:53:30 <ChrisPriceAB> #action chris to oraganise training sessions and record them for others to follow
15:53:36 <rprakash> #info some tutorial and recording of training sessions for getting started on tools
15:53:54 <bryan_att> #topic Release 1 Updates
15:54:27 <bryan_att> #info Chris: goal is R1 happens when we have achieved our intent, but is time-boxed
15:54:45 <bryan_att> #info ... Uli captured some text on that
15:55:19 <bryan_att> #info Uli: sent an email with text, and put it on an etherpad
15:55:19 <ulik> #link https://etherpad.opnfv.org/p/release1
15:56:20 <bryan_att> #info ... Added Chris' intro, comments, and a summary, functionality, documentation, operations environment, availability
15:56:48 <bryan_att> #info ... should serve as a R1 description - we can continue to edit on etherpad
15:56:49 <frankbrockners> UliK: How does this relate to the email from Chris: http://lists.opnfv.org/pipermail/opnfv-tsc/2015-February/000487.html
15:57:07 <bryan_att> #info ... first sentence sets the overview
15:57:22 <bryan_att> #info Frank: how relates to Chris' email
15:57:51 <bryan_att> #info Uli: took the email and comments, with the result being the current text on etherpad
15:58:30 <bryan_att> #info Chris: R1 is not addressed on wiki yet. Do we need a specific page for it, and other things related?
15:59:04 <bryan_att> #info Uli: we need that, for openness on what we want to achieve beyond TSC and OPNFV
15:59:08 <bryan_att> #info +1
15:59:26 <rprakash> #info +1
15:59:54 <bryan_att> #info Frank: public info can set things in stone - marketing team may want to edit the storyline
16:00:18 <bryan_att> #info ... barebones tech detail could be used by marketing to create the  public storyline
16:00:19 <julien_ZTE> #info +1
16:00:55 <bryan_att> #info +1 - it would be good to get marketing directly involved in public messsaging
16:01:44 <bryan_att> #info Frank: we can add components as tag lines as they get firmed up, and avoid the marketing type description
16:02:05 <bryan_att> #info Uli: we are not too early - 7 weeks left and we should know now what we want there
16:02:33 <bryan_att> #info Frank: just recommend tht we let marketing craft the "tagline" (descriptive text)
16:03:03 <bryan_att> #info Chris: this is worth starting to collect on the wiki
16:03:43 <bryan_att> #info Prathima: will create the marketing message given the basic input from the TSC
16:04:41 <bryan_att> #info Uli: should we get basic agreement on the existing descriptive content now
16:05:08 <bryan_att> #info Chris: defer that due to MWC focus - focus on our intent for the wiki
16:05:33 <ChrisPriceAB> #agree to begin to describe release one on the OPNFV wiki page, capturing the intended activities and objectives
16:06:00 <ChrisPriceAB> #action ulik to begin to put this material on the wiki page
16:06:25 <ChrisPriceAB> #topic Project plans & tracking
16:06:28 <frankbrockners> #link https://wiki.opnfv.org/get_started/get_started_installer_approach
16:07:30 <ChrisPriceAB> #info Frank indicates there are a number of deployment tools being worked on.  Each has a status page showing current activity.
16:07:42 <bryan_att> #info Frank: on BGS, we have three (Fuel, Foreman, OpenSteak) efforts on basic installer - page  linked has info on each
16:07:54 <ChrisPriceAB> #info Frank invites OPNFV members to look into the status pages and help where they are able to.
16:08:32 <bryan_att> #info ... opportunities to help in various places
16:08:46 <ChrisPriceAB> #info the team is starting to put the material into Jira for more public visibility
16:08:49 <bryan_att> #info ... 50% are certain April date is achieveable
16:09:00 <bryan_att> #info ... thus we need more hands on deck
16:09:25 <ChrisPriceAB> #info Frank asks for more engineers to engage where possible in order to hit the April deadline.
16:09:53 <ChrisPriceAB> #info ulik outlines the current activity in CI, they are currently focused on integrating with other projects for automated test
16:09:54 <bryan_att> #info Uli: for Octopus, hackfest showed Jenkins setup etc
16:10:59 <bryan_att> #info Bryan: would be great to get info on presentations and takeaways from the hackfest, on the wiki
16:11:10 <ChrisPriceAB> #link https://wiki.opnfv.org/events/meetupfeb19-2015
16:11:58 <bryan_att> #info Palani: for FuncTest, jira project was created. Any TSC guidelines on creating user stories?
16:12:32 <ChrisPriceAB> #info pals outlines the functest activity.  Jira is created and the team is looking to structure the epics/stories/activities for clarity.
16:12:33 <bryan_att> #info Frank: create a bunch of epics for various installer approaches for a high level grouping purpose
16:13:09 <bryan_att> #info ... individual cases underneath avoids flat high-level confusion
16:13:25 <bryan_att> #info Palani: have outlined 5 stories in basic FuncTest
16:13:53 <bryan_att> #info ... prototyping / development - two are working incl Morgan, started using devstack & tempest
16:14:20 <bryan_att> #info ... tech issues are being worked; I'm not duplicating that effort
16:14:57 <bryan_att> #info ... using devstack are started using tempest tests on OpenStack in a VM
16:15:14 <ChrisPriceAB> #info palani looking for volunteers to work on stories.
16:15:27 <bryan_att> #info ... would be great to assign stories to get community action
16:15:49 <bryan_att> #info Chris: just need to be people willing to do the work, not committers
16:16:02 <bryan_att> #info Palani: will create stories and send to the list
16:17:35 <bryan_att> #info Frank: Tim and Dan were successul/mostly on bringing up Foreman in Intel lab - should sync up with them on testing e.g. Robot once we have a stable environment. Running tempest in top eg. via CI should be possible
16:17:49 <bryan_att> #topic Documentation
16:19:10 <rprakash> #info Chris has documenation template
16:19:41 <bryan_att> #info Chris: reach out if you want to help on thdocumentaiton
16:20:01 <Gerald_K> #info https://wiki.opnfv.org/documentation_projects/opnfv_documentation
16:22:09 <ChrisPriceAB> #info ulik Uli K is leaving im2bz2p__ (MIke Young) will stand in his place.
16:22:14 <ChrisPriceAB> #topic OpenStack blueprint handling
16:22:58 <Gerald_K> #info request in last week meeting to submit BPs, but there was no process defined yet how to handle this
16:23:49 <Gerald_K> #info proposed BPs should be as visible and aligned among multiple projects
16:24:14 <ChrisPriceAB> #info Brian outlines the need to have a well formed set of ideas on how we will work toward openstack.
16:25:38 <Gerald_K> #info Chris: proposal to have 30mins discussion prior to next TSC call
16:26:06 <bryan_att> #info Bryan: can someone provide info on the deadline
16:26:15 <ChrisPriceAB> #info he asks for OPNFV to coordinate internally before discussing too much externally to reduce confusion
16:26:30 <ChrisPriceAB> #link http://www.openstack.org/blog/2015/02/sign-up-for-openstack-upstream-training-in-vancouver/
16:28:08 <Gerald_K> #info Dave will send mail with details on it
16:29:21 <Gerald_K> #info final call for BPs for L-release will be Vancouver meeting in May
16:30:18 <Gerald_K> #info reviewer resources is currently a bottleneck in OpenStack
16:31:19 <Gerald_K> #info we need reach out to people involved in OpenStack
16:32:26 <bryan_att> #info Bryan: I take the result of this as that Requirements projects are not cadenced with OPNFV releases
16:32:27 <Gerald_K> #info Bryan: requirement projects are not linked to OPNFV release timeline
16:32:36 <Gerald_K> #undo
16:32:36 <collabot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1d86510>
16:34:19 <Gerald_K> #info Gerald: we may need high-level description of the BPs in the Wiki, but shall use OpenStack terminology in the OpenStack Launchpad
16:34:24 <ChrisPriceAB> #link https://wiki.opnfv.org/community
16:34:26 <bryan_att> #info Bryan: we will also meet on IRC to tune the doctor blueprints e.g. for alignment with copper
16:35:09 <dneary> ChrisPriceAB, I will add the OpenStack release information, suggest we have similar for OpenDaylight, Open vSwitch, DPDK, Linaro, OpenContrail and other projects
16:35:25 <dneary> A kinf of knowledge base about how decisions get made in upstream projects
16:36:10 <bryan_att> #info DaveN will add the OpenStack release information, suggest we have similar for OpenDaylight, Open vSwitch, DPDK, Linaro, OpenContrail and other projects
16:36:29 <ChrisPriceAB> #topic Project Approvals
16:36:32 <bryan_att> #info ... and a knowledge base about how decisions get made in upstream projects
16:36:47 <ChrisPriceAB> Data Collection for failure prediction - OPNFV failure prediction:
16:36:57 <ChrisPriceAB> #link https://wiki.opnfv.org/requirements_projects/data_collection_of_failure_prediction
16:37:11 <bryan_att> #info ???/Huawei: goal is to avoid failures in advance
16:38:48 <bryan_att> #info ...(sharing screen)
16:39:17 <Gerald_K> #info presenter is Linghui Zeng/Huawei
16:39:51 <bryan_att> #info ... ETSI has defined general requirements for failure prediction
16:40:14 <bryan_att> thanks
16:41:38 <bryan_att> #info ... most important is data collection and depends upon real-time data sources; second major component is a failure predictor
16:42:27 <bryan_att> #info ... goal of this project is to investigate functional gaps and identify data needing to be collected
16:43:10 <bryan_att> #info ... current gaps known are e.g. re state of guest OS
16:43:21 <Gerald_K> #info architecture: predictor will provide input to Doctor module
16:43:48 <Gerald_K> #info data collection is done by Ceilometer, Zabbix, ...
16:44:27 <bryan_att> #info ... predictor will send notifications to other handlers e.g. doctor module
16:44:52 <Gerald_K> #info first goal is to focus on the data collector
16:45:51 <Gerald_K> #info Chris: scope is to find out data that shall be collected, but is not yet available
16:47:24 <bryan_att> #info Bryan: is the scope limited to what is available thru OpenStack?
16:48:46 <Gerald_K> #info the first release will not consider the interface to "FaultManagement"
16:50:43 <Gerald_K> #info Linghui: data collection is different to Doctor data collection
16:53:57 <Gerald_K> #info investigates on how to hook various open source monitors in Monasca
16:56:19 <ChrisPriceAB> #startvote TSC to approve the creation of the collector (data collection for failure prediction) project? (+1, 0, -1)
16:56:19 <collabot> Begin voting on: TSC to approve the creation of the collector (data collection for failure prediction) project? Valid vote options are , +1, 0, -1, .
16:56:19 <collabot> Vote using '#vote OPTION'. Only your last vote counts.
16:56:27 <Pranav_> #vote +1
16:56:29 <dlenrow> #vote +1
16:56:31 <bryan_att> #vote +1
16:56:32 <Gerald_K> #vote +1
16:56:35 <ChrisPriceAB> #vote +1
16:56:35 <frankbrockners> #vote +1
16:56:36 <tapio__> #vote +1
16:56:36 <im2bz2p__> #vote +1
16:56:42 <fuqiao> #vote +1
16:56:57 <dneary> I'm not an official proxy today
16:57:09 <ChrisPriceAB> #endvote
16:57:09 <collabot> Voted on "TSC to approve the creation of the collector (data collection for failure prediction) project?" Results are
16:57:09 <collabot> +1 (9): frankbrockners, fuqiao, dlenrow, bryan_att, Pranav_, ChrisPriceAB, im2bz2p__, tapio__, Gerald_K
16:58:30 <ChrisPriceAB> #action everyone cheer for bryan for taking notes
16:58:36 <aricg> who is the lead on data_collection_of_failure_prediction ?
16:59:33 <ChrisPriceAB> #endmeeting/me  use Linghui Zeng as the proposer until it is clarified