#opnfv-meeting: OPNFV Blueprint handling and OpenStack community discussions

Meeting started by ChrisPriceAB at 13:33:16 UTC (full logs).

Meeting summary

    1. Chris Price (ChrisPriceAB, 13:33:23)
    2. Dirk Kutscher (dku, 13:33:31)
    3. Uli Kleber (ulik, 13:33:32)
    4. Bryan Sullivan (bryan_att, 13:33:44)
    5. Dave Neary (dneary, 13:34:37)
    6. Steve Gordon (sgordon, 13:34:45)

  1. agenda (ChrisPriceAB, 13:35:12)
    1. Introduction to the OpenStack feature processes (ChrisPriceAB, 13:35:34)
    2. Overview of the OPNFV community page for OpenStack (ChrisPriceAB, 13:35:34)
    3. Requirements project leader responsibilities (ChrisPriceAB, 13:35:34)
    4. OPNFV community building and OpenStack coordination (ChrisPriceAB, 13:35:34)
    5. Next steps and planning (ChrisPriceAB, 13:35:34)

  2. Introduction to the OpenStack feature processes (ChrisPriceAB, 13:37:09)
    1. Ildiko outlines that there is some discrepancy between the currently submitted OPNFV blueprints and what the OpenStack community expects in a blueprint (ChrisPriceAB, 13:37:55)
    2. she describes that there should be a more implementation focus on the blueprints which is not there today (ChrisPriceAB, 13:38:17)
    3. The blueprint process is now implemented in gerrit in OpenStack with a review process carried out in that toolchain. (ChrisPriceAB, 13:38:45)
    4. many OPNFV blueprints are currently only submitted in etherpad which does not fall into the process. (ChrisPriceAB, 13:39:30)
    5. russellb points out that almost all projects use a combination of Gerrit and Launchpad. ildikov says that blueprints get uploaded to Launchpad once they have been approved in Gerrit, it is not the starting point any more (dneary, 13:41:22)
    6. full openstack specification template is intended to guide provision of clear problem statement / use case definition and detailed solution proposal (sgordon, 13:41:56)
    7. The project repo "${project}-specs" is used for spec submission in Gerrit (dneary, 13:42:13)
    8. what sgordon is referring to -- here is an example for Nova: http://git.openstack.org/cgit/openstack/nova-specs/tree/specs/liberty-template.rst (russellb, 13:42:55)
    9. https://wiki.openstack.org/wiki/Blueprints (sgordon, 13:43:49)
    10. process documentation: https://wiki.openstack.org/wiki/Blueprints (russellb, 13:43:51)
    11. dneary asks for a best practice of a blueprint that improved and was finally accepted in Kilo as an example to refer to (ChrisPriceAB, 13:43:55)
    12. https://github.com/openstack/nova-specs/blob/master/specs/liberty-template.rst (ChrisPriceAB, 13:44:53)
    13. https://github.com/openstack/nova-specs (ChrisPriceAB, 13:45:05)
    14. ACTION: Ildiko will look for a good example of a specification that went through improvement to adoption as a case study for the OPNFV community. (ChrisPriceAB, 13:45:35)
    15. http://specs.openstack.org/openstack/nova-specs/ (russellb, 13:45:47)

  3. Overview of the OPNFV community page for OpenStack (ChrisPriceAB, 13:46:58)
    1. Dave describes the community page as it is being developed. Initially as a landing page for openstack activity in OPNFV, it is evolving from that already. (ChrisPriceAB, 13:47:52)
    2. https://wiki.opnfv.org/community/openstack (r-mibu, 13:48:12)
    3. Dave states the goal of the page will be to see at a high level which rojects in OPNFV is generating blueprints, who is responsible for them and what stage they are in (ChrisPriceAB, 13:48:18)
    4. this will provide us with a method of engaging as a community with OpenStack (ChrisPriceAB, 13:48:44)
    5. Dave points out the Doctor project has done this and asks other projects to begin to work in this way (ChrisPriceAB, 13:49:10)
    6. Dave outlines that we have the "telco group" in OpenStack as a community we should be working very closely with. (ChrisPriceAB, 13:49:58)

  4. OPNFV community building and OpenStack coordination (ChrisPriceAB, 13:50:03)
    1. There is a need to establish a blueprint review process in OPNFV where we can focus on bringing the blueprints forward to an implementation centric document (ChrisPriceAB, 13:50:34)
    2. we need some planned effort to review blueprints coming out of OPNFV to ensure that we are not delivering point solutions that risk architectural fragmentation in the upstream community (bryan_att, 13:50:44)
    3. We want to be a good partner to the OpenStack project, that we have thought about how the work will be done and who will do the work in OpenStack (ChrisPriceAB, 13:51:02)
    4. we need to be able to articulate the need for the feature in a broader context to motivate why we need to feature in OpenStack (ChrisPriceAB, 13:51:30)
    5. we additionally have a chance to garner support from the ETSI opensource WG to motivate features upstream. (ChrisPriceAB, 13:51:51)
    6. My points about the overlap between the state/event awareness mechanisms related to Fault Mgmt and the similar need for this in Promise and Doctor, were intended to raise the need for such coordinated design of common elements (bryan_att, 13:51:53)
    7. Bryan agrees that we need to perform due dilligence in OPNFV before upstreaming to OpenStack (ChrisPriceAB, 13:52:42)
    8. Not rush into OpenStack features that are half-baked. (ChrisPriceAB, 13:53:01)
    9. dneary points out that we now have a set of blueprints upstream where we can work through these issues in full view of the OpenStack community (ChrisPriceAB, 13:53:32)
    10. bryan_att asks how we make that discussion happen in OPNFV. (ChrisPriceAB, 13:54:16)
    11. deadlines for Liberty have not yet been set (russellb, 13:54:46)
    12. #1 question is What is the real deadline? (bryan_att, 13:54:46)
    13. dneary indicates that now is the time for us to focus on the development of our blueprints. (ChrisPriceAB, 13:54:53)
    14. #2 question is can we create a new weekly meeting to align on blueprints, or use our existing meetings - let's get agreement today (bryan_att, 13:55:34)
    15. you can get insight into past schedule from Kilo here: https://wiki.openstack.org/wiki/Kilo_Release_Schedule (russellb, 13:55:42)
    16. Question #1 the deadline is indicated on the OpenStack process page. The real deadline for blueprint review is in May. (ChrisPriceAB, 13:55:51)
    17. ideally specifications need to be well framed *before* openstack summit (sgordon, 13:55:53)
    18. we also need new maillist filter for blueprint discussion (Yuriy, 13:56:33)
    19. ACTION: dneary will identify a suitable time for blueprint develoment activities in OPNFV. (May be the Thursday tech-call time, unconfirmed...) (ChrisPriceAB, 13:56:42)
    20. I assume "well-framed" means clarity on exactly what modules/functions need to be patched and how, from the description given at the start of this meeting (bryan_att, 13:57:00)
    21. I'm not sure we in OPNFV are adequately aware of Openstack code details to enable us to create that "well-formed" a blueprint in 6 weeks - but I am willing to support any effort to try - and if there is flexibility in the needed detail level, even better - but we should set expectations going in on what detail level we expect to provide (bryan_att, 13:58:54)
    22. ACTION: Requirement project leads ensure all blueprints are listed on the openstack community page. (ChrisPriceAB, 13:59:19)
    23. there are people who are quite familiar with OpenStack code base. Lets give it a try. (Ashiq, 13:59:38)
    24. ACTION: Establish discussion calls to have the blueprints ready for review by the end of may (ChrisPriceAB, 13:59:43)
    25. https://review.openstack.org/#/c/130678/ (ildikov, 13:59:50)
    26. https://blueprints.launchpad.net/ceilometer/+spec/self-disabled-pollster (ildikov, 13:59:50)
    27. ACTION: project leaders to add blueprints in flight to the OpenStack community page for tracking (dneary, 14:00:09)
    28. ACTION: dneary to ensure we have weekly meetings for blueprint review and improvement (dneary, 14:01:06)
    29. ulik says we should not have an additional meeting (dneary, 14:02:01)


Meeting ended at 14:02:01 UTC (full logs).

Action items

  1. Ildiko will look for a good example of a specification that went through improvement to adoption as a case study for the OPNFV community.
  2. dneary will identify a suitable time for blueprint develoment activities in OPNFV. (May be the Thursday tech-call time, unconfirmed...)
  3. Requirement project leads ensure all blueprints are listed on the openstack community page.
  4. Establish discussion calls to have the blueprints ready for review by the end of may
  5. project leaders to add blueprints in flight to the OpenStack community page for tracking
  6. dneary to ensure we have weekly meetings for blueprint review and improvement


Action items, by person

  1. dneary
    1. dneary will identify a suitable time for blueprint develoment activities in OPNFV. (May be the Thursday tech-call time, unconfirmed...)
    2. dneary to ensure we have weekly meetings for blueprint review and improvement
  2. UNASSIGNED
    1. Ildiko will look for a good example of a specification that went through improvement to adoption as a case study for the OPNFV community.
    2. Requirement project leads ensure all blueprints are listed on the openstack community page.
    3. Establish discussion calls to have the blueprints ready for review by the end of may
    4. project leaders to add blueprints in flight to the OpenStack community page for tracking


People present (lines said)

  1. ChrisPriceAB (52)
  2. sgordon (16)
  3. russellb (15)
  4. dneary (10)
  5. bryan_att (8)
  6. collabot (6)
  7. ildikov (5)
  8. dku (1)
  9. Yuriy (1)
  10. r-mibu (1)
  11. Ashiq (1)
  12. B_Smith_ (1)
  13. ulik (1)


Generated by MeetBot 0.1.4.