14:02:23 <ChrisPriceAB> #startmeeting OPNFV TSC
14:02:23 <collabot> Meeting started Tue Mar 10 14:02:23 2015 UTC.  The chair is ChrisPriceAB. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:02:23 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:02:23 <collabot> The meeting name has been set to 'opnfv_tsc'
14:02:34 <ChrisPriceAB> #topic roll call
14:02:37 <frankbrockners> #info Frank Brockners
14:02:39 <bryan_att> #info Bryan Sullivan
14:02:40 <ChrisPriceAB> #info Chris Price
14:02:40 <ulik> #info Uli Kleber
14:02:44 <Ashiq> #info Ashiq Khan
14:02:47 <dku> #info Dirk Kutscher
14:03:03 <HKirksey> #info Heather Kirksey
14:03:08 <plynch> #info Pierre Lynch
14:03:17 <fuqiao> #info fuqiao (proxy for denghui)
14:03:33 <ChrisPriceAB> #topic approval or previous minutes
14:03:39 <ChrisPriceAB> #agree minutes approved
14:03:50 <tapio__> #info Tapio Tallgren
14:04:01 <ChrisPriceAB> #topic Agenda Bashing
14:04:12 <Gerald_K> you can add me as chair, then I will support minute wrtiing
14:05:13 <dlenrow> #info dlenrow
14:05:20 <cdub> #info Chris Wright
14:05:29 <Wenjing> #info Wenjing
14:05:40 <Parviz> #info Parviz
14:05:45 <LouisF> #info Louis Fourie
14:05:45 <ChrisPriceAB> #topic Update from the board f2f
14:06:15 <Thinh_> #info Thinh Nguyenphu
14:11:58 <Gerald_K> discussion on whether OPNFV should issue certificates; discussion moved to kind of trademark
14:12:26 <Gerald_K> #info discussion on whether OPNFV should issue certificates; discussion moved to kind of trademark; need to come back to this discussion in April
14:13:05 <rpaik> #info add certification discussion to the TSC call close to Release 1
14:13:12 <ChrisPriceAB> #chair Gerald_K
14:13:12 <collabot> Current chairs: ChrisPriceAB Gerald_K
14:13:15 <ChrisPriceAB> #chair rpaik
14:13:15 <collabot> Current chairs: ChrisPriceAB Gerald_K rpaik
14:14:43 <aricg> Calling in is not working for me.
14:15:48 <ChrisPriceAB> #topic Hack-fest planning and updates
14:17:04 <Gerald_K> #info discussion to collocate with OpenStack summit. openstack would prefer not to have two hackfest at the same time.
14:18:06 <Gerald_K> #info ongoing dicussion on how to best engage with openstack community?
14:18:06 <dlenrow> Whistler OPNFV team building weekend :)
14:19:02 <Gerald_K> #info talk to Telco WG and OpenStack event team
14:19:37 <rpaik> #info working with OpenStack community to organize our participation at the Vancouver OpenStack summit
14:21:07 <bryan_att> #info IMO we need OPNFV-centric events
14:21:14 <Gerald_K> #info hackfest planned for OPNFV summit in Q4 2015. question whether additional hackfest middle of this year would be needed?
14:22:16 <bryan_att> #info I agree that we want to integrate with the upstream communities, not park an OPNFV meeting in the middle of their events - so we need some events that are OPNFV-centric
14:22:19 <Gerald_K> #info idea of "virtual hackfests" to avoid travelling
14:23:30 <aricg> oh, finally in.
14:24:17 <bryan_att> #info I also support virtual hackfests, but I think they are less successful as a community outreach method - but OK for existing projects to focus on quick progress
14:24:48 <cgoncalves> bryan_att: +1 on having OPNFV-centric events, but still also having co-located with upstream community events
14:25:17 <ChrisPriceAB> #agree The TSC agrees to follow the existing schedule for summits and determine the need for an additional event later in the year.
14:25:50 <ChrisPriceAB> #topic Follow up- Development tool training, Jira, Gerrit, Git, Jenkins
14:26:34 <Gerald_K> #info looking for volunteers to organize those sessions
14:27:24 <ChrisPriceAB> #info bryan asks if we have a quick guide to how we intend to use the tools
14:28:12 <Gerald_K> #info No. Currently each project is using the tools in different ways.
14:29:03 <bryan_att> #info Chris suggests that we might mandate project leads to get trained on the tools
14:29:54 <Gerald_K> #info Eric has written a Wiki page on this
14:30:07 <ChrisPriceAB> #link https://wiki.opnfv.org/developer
14:30:10 <TNadeau> Look at the wiki. Jira can intercept tags inside of comments. In particular its good to refer to the base bug ID
14:30:27 <ChrisPriceAB> #info contains information on how to work with the tools
14:30:56 <frankbrockners> #link https://wiki.opnfv.org/developer
14:30:56 <Gerald_K> this is why we need a training... what is a "base bug ID"?
14:31:30 <ChrisPriceAB> #action Ray to look into LinuxFoundation training on the OPNFV toolchain
14:32:24 <frankbrockners> #link https://wiki.opnfv.org/developer/contribution_guidelines - also has a reference to git commit styles.
14:32:50 <Gerald_K> #info Uli mention it may only be a problem of WHERE to find this information.
14:33:02 <bryan_att> #info I don't see any specific conventions listed on that page - e.g. something even as simple as the git commit message - but there are also likely things that will come up as conventions in practice - we need to collect and publish them
14:33:08 <fdegir> #info Fatih Degirmenci
14:33:47 <dneary> Is the best approach task-related? What are the basic tasks people need to be able to do?
14:34:05 <ChrisPriceAB> #info Fatih offers to work on a training session regarding Jenkins and Jira
14:35:29 <ChrisPriceAB> #info Iben to help Fatih on OPNFV related information to clarify project needs.
14:35:40 <dlenrow> Do we expect the BGS-derived deployment will require dev training or will it be so intuitive you don't need training? Getting to point where you need to use tools may be gated by getting OStack/ODL installed and configured
14:37:09 <ChrisPriceAB> #action Fatih, Iben and Aric will look to build training material for OPNFV
14:37:27 <bryan_att> #info +1 to putting the docs in git so that we can update them using the tools themselves
14:37:41 <aricg> Someone have a link to the opnfv getting started /documentaion repo?
14:37:44 <frankbrockners> +1 on using the repo for docs rather than wiki
14:37:48 <dlenrow> We want doc in source control. treat like code. Wiki doc doesn't lend itself to that.
14:37:52 <ChrisPriceAB> It does not exist yet.
14:38:15 <zhipeng_> +1 for a doc git repo
14:39:47 <Pranav> #info Pranav
14:43:17 <aricg> #info Key facts are served via iframe https://wiki.opnfv.org/get_started
14:45:25 <ChrisPriceAB> #topic Update on OPNFV hardware @LF data center
14:45:46 <aricg> #info this is the new plugin for serving the keys facts: https://www.dokuwiki.org/plugin:scrape
14:45:49 <ChrisPriceAB> #info ray outlines that the hardware order has been delivered to the LF Data Center
14:46:05 <ChrisPriceAB> #info currently doing inventory of items prior to installation.
14:46:40 <ChrisPriceAB> #info Konstantin will provide a detailed update at the  next TSC call.
14:48:09 <ChrisPriceAB> #topic Update on the Release 1 naming
14:49:04 <ChrisPriceAB> #info Ray describes that we should reduce the list of names from the list to reduce the scanning isues and time for infringements.
14:49:11 <Gerald_K> #info list was sent to legal counsel for review. recommendation to reduce number of names first to top 5, then they will execute the legal check
14:49:44 <aricg> thoughts: https://www.surveymonkey.com/
14:49:57 <ChrisPriceAB> #info Ray will start a vote on the mailing list for the top choices
14:50:35 <ChrisPriceAB> #info the vote should be out today, it will close by Monday next week.
14:51:19 <ChrisPriceAB> #info this will reduce the list of the top 5 for a name search
14:54:10 <ChrisPriceAB> #topic Discussion on awards programs for the OPNFV technical community
14:54:57 <Gerald_K> #info awards program can be run once a year to top contributors (e.g. at the end of a release)
14:58:50 <ChrisPriceAB> #info cdub indicates seperating into categories may be a good idea in OPNFV
14:58:58 <dlenrow> Most valuable upstream worker awards
14:59:19 <dlenrow> Something analogous to OpenStack hidden influencers (code is not the only coin of the realm)>
14:59:50 <dlenrow> OPNFV OpenStack MVP, OPNFV ODL MVP
15:00:01 <rpaik> #info possible categories: documentation, collaboration, testing, integration
15:03:45 <ChrisPriceAB> #action ray to begin discussion on the lists about OPNFV recognition and awards.  A concrete proposal is required for budget approvals.
15:04:26 <ChrisPriceAB> #topic Project plans & tracking - for release 1
15:04:51 <frankbrockners> #link https://wiki.opnfv.org/get_started/get_started_installer_approach
15:05:33 <ChrisPriceAB> #info frankbrockners provides an update on the BGS project.  Each team is working on the backlog of development for the release 1 timeframe.
15:05:52 <ChrisPriceAB> #info the team is looking to establish commonality and converging on those areas.
15:06:26 <ChrisPriceAB> #info the team has begun moving to Jira for backlog management, not yet complete but the idea is to increase transaprency and visibility into the project.
15:07:43 <B_Smith_> when is the call for bgs today
15:08:28 <ChrisPriceAB> #action frankbrockners and konstantin to establish communication channels regarding the hardware configuration for the linuxfoundation data-center.
15:08:34 <aricg> This page? https://wiki.opnfv.org/pharos/pharos_specification
15:08:58 * ChrisPriceAB yes aricg that's the current information
15:09:48 <ChrisPriceAB> #info the plan is not to have manual instalation occuring on the linuxfoundation hardware.  This should be deployed using the existing toolchain.
15:10:08 <frankbrockners> #link https://jira.opnfv.org/browse/BGS-7?jql=project%20%3D%20BGS  - Jira for BGS
15:10:13 <ChrisPriceAB> #info octopus overview
15:10:36 <ChrisPriceAB> #info Uli indicates the project has begun working in Jira and that the working mode is now Jira based.
15:11:03 <ChrisPriceAB> #info octopus is awaiting build scripts to be made available from the projects
15:12:14 <ChrisPriceAB> #info the scripts are currently described on an etherpad outlining how they should be structured
15:12:58 <ChrisPriceAB> #info fdegir indicates there are some syntactical scripts being enabled on the CI pipeline
15:13:35 <fdegir> #info Link to BGS build/deploy script blueprint/proposal https://etherpad.opnfv.org/p/BGS_CI
15:13:36 <ChrisPriceAB> #info functiontest update
15:14:00 <ChrisPriceAB> #info palni and morgan have ben working with Tempest and Rally against a manually installed BGS environment
15:14:04 <ChrisPriceAB> #undo
15:14:04 <collabot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1c17090>
15:14:10 <ChrisPriceAB> #info palani and morgan have ben working with Tempest and Rally against a manually installed BGS environment
15:14:44 <ChrisPriceAB> #info the team is working with the tools currently and how to integrate that with CI
15:15:21 <ChrisPriceAB> #info documentation for release 1
15:15:43 <ChrisPriceAB> #undo
15:15:43 <collabot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1df2f50>
15:16:36 <ChrisPriceAB> #info fdegir explains that the toolchains required to be installed on the hardware should be made known to the linuxfoundation team as backlog items
15:17:10 <ChrisPriceAB> #info documentation for release 1
15:17:44 <ChrisPriceAB> #info Trevor describes that clear demarcation between documentation activities will be important to set the scope for release 1
15:18:12 <ChrisPriceAB> #link https://wiki.opnfv.org/documentation_projects/opnfv_documentation
15:20:05 <ChrisPriceAB> #info Iben explains that not all documentation should be captured in the documentation project but should be drawn out of project specific documentation areas
15:22:33 <tapio__> Chris, I could try to help with the documentation project
15:24:18 <Gerald_K> #info TSC discussed to hire a technical writer to bootstrap the documentation
15:25:10 <bryan_att> #info suggest to run a poll and give people time to consider the need for a writer
15:27:52 <ChrisPriceAB> #topic Creation review for the Resource Scheduler project
15:28:36 <rpaik> #info Presenter is Zhiqi Wang
15:29:15 <Gerald_K> #info ++++
15:29:19 <Gerald_K> #undo
15:29:19 <collabot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1cbfe10>
15:29:24 <Gerald_K> #link https://wiki.opnfv.org/requirements_projects/resource_scheduler
15:29:46 * ChrisPriceAB thanks gerald_k :)
15:29:54 * cdub has to drop
15:35:56 <bryan_att> #info quick comment is that Congress gets data from various sources not just Nova - and Copper focuses on policy engine features through and beyond Congress
15:39:01 <rpaik> #info recommendation for close coordination with OPNFV project teaams like Copper & Promise
15:47:36 <rpaik> #info Discussion on if there is a need to add more details in the Planned Deliverables section
15:49:54 <rpaik> #startvote Do you approve create of the Resource Scheduler Projects (+1, 0, -1)
15:49:54 <collabot> Unable to parse vote topic and options.
15:49:59 <bryan_att> #vote +1
15:50:02 <ulik> #vote +1
15:50:46 <rpaik> #startvote Do you approve create of the Resource Scheduler Projects? (+1, 0, -1)
15:50:46 <collabot> Begin voting on: Do you approve create of the Resource Scheduler Projects? Valid vote options are , +1, 0, -1, .
15:50:46 <collabot> Vote using '#vote OPTION'. Only your last vote counts.
15:50:46 <rpaik> [08:49am] collabot: Unable to parse vote topic and options.
15:50:51 <ulik> #vote +1
15:51:00 <dlenrow> #vote +1
15:51:14 <bryan_att> #vote +1
15:51:14 <Pranav> #vote +1
15:51:15 <LouisF> #vote +1
15:51:19 <ChrisPriceAB> #vote +1
15:51:23 <tapio__> #vote +1
15:51:24 <fuqiao> #vote +1
15:51:26 <frankbrockners> #vote +1
15:52:10 <aricg> can I have a project lead please.
15:52:28 <rpaik> #endvote
15:52:28 <collabot> Voted on "Do you approve create of the Resource Scheduler Projects?" Results are
15:52:28 <collabot> +1 (9): Pranav, frankbrockners, fuqiao, LouisF, bryan_att, ChrisPriceAB, tapio__, dlenrow, ulik
15:52:36 <dlenrow> Congratulations resource scheduler
15:53:14 <aricg> please have the porject lead email me @ opnfv-helpdesk@rt.linuxfoundation.org
15:53:16 <ChrisPriceAB> #topic openstack community update
15:53:58 <ChrisPriceAB> #link  https://wiki.opnfv.org/community/openstack
15:54:12 <bryan_att> #info FYI I added draft blueprint info for Copper to the page
15:54:26 <ChrisPriceAB> #info dneary outlines some of the challenges in engaging in openstack and our responsibilities when engaging with the commuinty
15:54:55 <ChrisPriceAB> #info the openstack community page on the OPNFV wiki is intended to be a common information repository for our openstack actiities
15:55:36 <ChrisPriceAB> #info dneary outlines the blueprint process for openstack, including the level if detail required including implemementation details and high level use cases associated with the feature
15:56:31 <ChrisPriceAB> #info dneary invites all project with active blueprints to list them on the wiki page so the community can collaborate on them
15:56:58 <ChrisPriceAB> #info the target is to be ready by May with OPNFV blueprints with the right level of detail and structure
15:57:18 <bryan_att> #info The first idea is to develop a comprehensive/reusable event-driven policy engine support across Openstack core components - the first step is to investigate current Openstack support for such event-driven operation. The second idea is to extend the data sources supported by Congress for specific OPNFV use cases.
15:59:19 <ChrisPriceAB> #info meetings may be planned for "blueprint best practices" in order to have consistency.
16:00:23 <ChrisPriceAB> #endmeeting