14:07:05 <ulik> #startmeeting Octopus Team meeting
14:07:05 <collabot> Meeting started Mon Mar 23 14:07:05 2015 UTC.  The chair is ulik. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:07:05 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:07:05 <collabot> The meeting name has been set to 'octopus_team_meeting'
14:08:06 <rprakash> #info yes we can start with Recap on test & Performance meeting
14:08:31 <alexpilotti> o/
14:11:57 <ulik> #topic -	Recap from Test&Performance meeting
14:12:33 <fdegir> #info https://etherpad.opnfv.org/p/octopus
14:12:47 <fdegir> #info Look for How to Connect Servers from Labs to OPNFV Jenkins
14:12:50 <ulik> #info Fatih explains that the current plan opens the LF lab so jenkins slaves can listen to the central master
14:13:20 <rprakash> #info Short term solution -Labs opening firewall on Server using JNMP - its on opnfv site (any links?)
14:13:22 <ulik> #info there may be some limitations with some permission issues
14:13:29 <iben> didn’t the spirent jenkins server also get tested?
14:13:50 <fdegir> #info The method explained in Etherpad is called JNLP
14:14:08 <fdegir> #info and a server from Ericsson lab is currently connected to OPNFV Jenkins
14:14:17 <aricg> build.opnfv.org
14:14:41 <fdegir> #info https://build.opnfv.org/ci/
14:15:28 <ulik> #info Fatih shows how Ericsson lab connects to LF jenkins
14:16:54 <ulik> #info This way, a lab has full control, e.g. disconnect for maintenance purpose
14:17:39 <ulik> #info Fatih encourages to test this by connecting any local jenkins slave.
14:18:06 <ulik> #info Intel lab is using this
14:20:28 <ulik> #info no action open on octopus side now. Test and Performance team needs to come back to us
14:21:15 <ulik> #info Question about labs talking to each other. Fatih doesn't expect this at the moment.
14:21:54 <ulik> #info Iben explains that for ODL, Spirent listens to the artifacts repository.
14:22:18 <ulik> #info Fatih thinks this might be good for later releases but not release 1.
14:25:00 * dfarrell07 was double muted, but wanted to +1/offer help to working with ODL to test weekly artifacts (I'm working on that in upstream ODL Integration team)
14:25:14 <ulik> #topic Define way to use hartdware
14:26:58 <ulik> #info Jerry explains which jobs would have hardware dependencies or which would better run in virtual environment
14:27:23 <ulik> #info Fatih explains we have the necessary information only from Fuel track.
14:27:57 <alexpilotti> hi guys, as iben introduced during the call, my company (Cloudbase Solutions) will help in the documentation effort for OPNFV
14:29:13 <alexpilotti> we have also a strong experience in the CI domain (we run the OpenStack Hyper-V CI for Nova, Neutron and Cinder), so hopefully we might help in Octopus too
14:32:37 <ulik> hi alexpilotti, Good to hear!
14:34:12 <ulik> #info Jerry explains from experience using virtual machines for the builds and the way to use VLANs
14:36:42 <rprakash> #link https://wiki.opnfv.org/get_started/foreman_quickstack_status
14:37:15 <ulik> #info Tim Rozet reports from BGS how they use network during deploy
14:37:41 <fdegir> for foreman/quickstack
14:38:07 <ulik> #chair fdegir jerryz
14:38:07 <collabot> Current chairs: fdegir jerryz ulik
14:39:07 <ulik> #chair iben
14:39:07 <collabot> Current chairs: fdegir iben jerryz ulik
14:40:15 <rprakash> #info is thre a topology digram for the configuration you expalined now?
14:41:50 <ulik> #info one deploy server could serve multiple PODs
14:42:14 <trozet> #info see Topology section: https://wiki.opnfv.org/get_started_experiment1
14:42:45 <trozet> rprakash ^
14:43:28 <ulik> #info there will be no issue when a lab uses same installer. The issue comes up, when using different installers in LF environment.
14:45:21 <ulik> #info Iben explains from experience at Spirent for this.
14:46:26 <ulik> #info Iben will share some documentation with the team.
14:46:48 <rprakash> #info Iben sure we like to see that on opnfv site with links added for different labs
14:48:27 <ulik> #topic artifact repository
14:49:43 <rprakash> #info Google Storage to be used for OPNFV  Artifacts
14:50:13 <fdegir> #info https://wiki.opnfv.org/wiki/artifactrepos#what_will_be_used_as_artifact_repository_for_opnfv
14:50:45 <ulik> #info aric explains the possibilities with Google store
14:51:36 <fdegir> #info We will need to be able to pick the latest artifact from Google Storage
14:51:55 <fdegir> #info This will be made available while we move
14:52:33 <ulik> #info Prakash asks why not use Swift on LF hardware and Aric explains that we don't have big hard drives
14:53:11 <fdegir> #info Google Storage is blocked in China - this may require further thinking
14:53:20 <ulik> #info Jerry explains that Google is not available from China
14:53:41 <ulik> #info Another shortage are missing backups
14:54:41 <ulik> #info Google shares between different locations, but there is no SLA.
14:55:02 <ulik> #info this could be sufficient, since build artifacts can be rebuilt if necessary.
14:55:17 <fdegir> #info as long as we have full traceablity
14:56:23 <aricg> http://storage.googleapis.com/opnfv-test/opnfv-P0000.iso
14:58:11 <rprakash> #link http://storage.googleapis.com/opnfv-test/opnfv-P0000.iso
14:58:52 <rprakash> #info mirror this repo on each lab if acceptable to all
14:59:29 <ulik> #action Jerry, Iben, Fatih, to think about how to setup mirrors or other to solve this.
14:59:40 <fdegir> and Aric as well
15:00:21 <ulik> #endmeeting