14:00:14 <ChrisPriceAB> #startmeeting OPNFV TSC
14:00:14 <collabot> Meeting started Tue Mar 24 14:00:14 2015 UTC.  The chair is ChrisPriceAB. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:14 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:00:14 <collabot> The meeting name has been set to 'opnfv_tsc'
14:00:22 <ChrisPriceAB> #topic roll call
14:00:27 <ChrisPriceAB> #info Chris Price
14:00:31 <colindixon> #info colindixon for Tom Nadeau
14:00:38 <dku> #info Dirk Kutscher
14:00:40 * ChrisPriceAB welcome colin
14:00:53 <ulik> #info Uli Kleber
14:01:06 <colindixon> ChrisPriceAB: good to be here
14:01:26 <frankbrockners> #info Frank Brockners
14:02:12 <colindixon> I’m now on the audio as well
14:03:44 <ChrisPriceAB> #topic approval of previous meeting minutes
14:03:50 <ChrisPriceAB> #agree minutes approved
14:03:59 <Ashiq_> #info Ashiq Khan
14:04:02 <ChrisPriceAB> #topic Agenda Bashing
14:04:09 <ChrisPriceAB> #link https://wiki.opnfv.org/wiki/tsc
14:04:29 <dlenrow> #info dlenrow
14:05:56 <Wenjing> #info Wenjing Chu
14:06:22 <ChrisPriceAB> #info discuss release artifacts in the context of the releases wiki
14:06:25 <ChrisPriceAB> #link https://wiki.opnfv.org/releases
14:06:31 <julien_ZTE> #info Julien
14:08:12 <plynch> #info Pierre Lynch
14:08:14 <ChrisPriceAB> #topic OpenStack community status
14:08:37 <rpaik> #link https://wiki.opnfv.org/community/openstack
14:09:05 <colindixon> rpaik: it usually helps if you add a short description at the end of the line after the link
14:09:16 <ChrisPriceAB> #info dneary outlines blueprint review is occuring on the Thursday technical community calls
14:09:19 <colindixon> something like #link https://wiki.opnfv.org/community/openstack The OpenStack community tracking page
14:09:28 <rpaik> thanks will do :-)
14:10:12 <ChrisPriceAB> #info work has been done on reviewing the propsals and work is ongoing to develop the blueprints to a point where we are ready to add them to the upstream gerrit for further discussion and review
14:10:24 <ChrisPriceAB> #info the idea is to do the work in the target community as soon as we are ready
14:11:08 <bryan_att> #info I will be providing the Copper blueprints in the ceilometer template this week, starting today I will upload the first versions
14:11:11 <ChrisPriceAB> #info dneary outlines we would like to establish best practices and a repeatable process for OPNFV projects to engage
14:11:26 <rprakash> #link https://wiki.opnfv.org/community/openstack
14:11:39 <ChrisPriceAB> #info Prakash outlines the list on the community page only addresses blueprints for the OPNFV requirements projects.
14:11:44 <ChrisPriceAB> #undo
14:11:44 <collabot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1ddc050>
14:12:02 <ChrisPriceAB> #info dneary outlines the list on the community page only addresses blueprints for the OPNFV requirements
14:12:33 <ChrisPriceAB> #info dneary describes that blueprints to be reviewed by the community should be handled through the community page.
14:13:06 <bryan_att> #info Dave - what does "sent off to Openstack" mean? I think we will be submitting the blueprtints as individual members of the Openstack projects, right?
14:13:14 <ChrisPriceAB> #info current blueprint activity is targetting Liberty which will be release in October of 2015
14:13:49 <ChrisPriceAB> #chair rpaik
14:13:49 <collabot> Current chairs: ChrisPriceAB rpaik
14:13:53 <ChrisPriceAB> #chair dneary
14:13:53 <collabot> Current chairs: ChrisPriceAB dneary rpaik
14:14:04 <ChrisPriceAB> #chair colindixon
14:14:04 <collabot> Current chairs: ChrisPriceAB colindixon dneary rpaik
14:14:07 * ChrisPriceAB hehe
14:14:59 <colindixon> #info dneary says that “while you’re free to do what you want, we suggest you do an internal review process (inside OPNFV) first so that blueprints that go to OpenStack aren’t rejected out of hand”
14:15:05 <dneary> bryan_att, "sent off" was bad phrasing on my part
14:15:06 <Gerald_K> #info Ashiq suggests that all blueprints from OPNFV should go through this review process
14:15:06 <ChrisPriceAB> #info Ashiq_ makes the suggestion that all OPNFV blueprints shoudl participate in the review process before being submitted to openstack
14:15:14 <dneary> Yes, Thursday at
14:15:38 <dneary> Thursday at 9am EST/1pm UTC
14:17:11 <ChrisPriceAB> #info bryan_att asks what is required for a blueprint to be reviewed by OPNFV before it is submitted to openstack.
14:18:00 <ChrisPriceAB> #info dneary reccomends the bar be set low in OPNFV, the technical discussion on the submission should be done in the openstack community process.
14:18:42 <ChrisPriceAB> #info bryan_att asks who will measure and "approve" the submission of proposals
14:19:31 <dneary> bryan_att, It's a two-step review process - 1. OPNFV sanity check, 2. Technical review and iteration in OpenStack
14:20:29 <bryan_att> #info it sounds like we are saying "do diligence" but setting no concrete expectations for that. That's OK but let's be clear. We are not setting up any specific review process internal to OPNFV
14:21:08 <rpaik> #info ChrisPraiceAB also suggest considering resource availiability within OPNFV before submitting blueprints
14:21:23 <bryan_att> #info We have to be able to resource the blueprints but that's just part of the diligence - don't propose what you can't deliver on\
14:22:36 <LouisF> do requirements projects need to be submited as an OS blueprint?
14:23:05 <dneary> Who submits the blue-print is the person who is requesting the feature - the "committers" on the project are committed to seeing the project success, and thus to having developer resources which can implement the process through to upstream acceptance
14:24:05 <dneary> #info ChrisPriceAB reiterates that there are lots of communities, which do things differently, and we need to be respectful of upstream processes
14:25:20 <rpaik> #info frankbrockners asks if it makes sense to use our dev tools (e.g. gerritt) for the review process
14:25:29 <bryan_att> #info dneary: agreed - the committers of blueprint patches are the discrete participants in the Openstack community that represent the consensus of the OPNFV project, and should be somehow agreed as such (the OPNFV representative) by the OPNFV project.
14:27:04 * ChrisPriceAB frankbrockners flying in the blueprint processing skies
14:28:17 <dneary> Sorry - I think I mistaked voices
14:31:21 <rpaik> #info ChrisPriceAB asks can we form a core group for this activity?
14:32:35 * ChrisPriceAB dneary maybe more an ear to bend than a neck to grab!
14:33:03 <dneary> OK
14:33:29 <dneary> I will add my name to that page, and think about how to structure things a bit better
14:33:43 <rpaik> #info dneary is our contact for this activity with OpenStack community
14:33:48 <ChrisPriceAB> #topic Arno release candidacy and final release activities
14:35:40 <rprakash> #link https://wiki.opnfv.org/releases
14:36:01 <rpaik> #info release candiate activities highlight issues/things that need to be fixed
14:37:40 <rpaik> #info ChrisPriceAB suggests April 9th as the first release candidate date.  2nd release candidate the following week.
14:40:15 <rpaik> #info frankbrockners adds we need a definition of a candidate prior to April 9th
14:40:43 <rprakash> #info Release Candidates scope per track/stack should be defined by next week TSC meeting March 31st
14:43:46 <rprakash> #info Final cut release should be cut by April 21st
14:44:31 <ChrisPriceAB> #link https://wiki.opnfv.org/releases OPNFV release page
14:44:56 <dneary> colindixon, I'm not so nervous, mostly because OPNFV has not (yet) been developing a lot of new code
14:47:41 * ChrisPriceAB agreed, we are dependant on stable releases, it's our config that will cause problems. :)
14:48:02 <julien_ZTE> #info Currently, we can not build the BGS(Fuel) ISO successfully if we plan to provide the resource to provide the ISO because of the Great FireWall
14:49:20 <ChrisPriceAB> #info frankbrockners describes the documentation needs as: hardware platform state, installed system state, user guide, validation completed
14:49:46 <julien_ZTE> #info I suggest ISO the relevant resources both will be released
14:49:50 <rpaik> #info ChrisPriceAB suggests documentation format should be PDF & ISO
14:55:49 <rpaik> #info Can bring ISO behind a firewall and bring-up on a Pharos-like environment
14:59:45 <bryan_att> info: +2 to a deterministic install experience!
15:00:37 <frankbrockners> #link https://etherpad.opnfv.org/p/bgs
15:00:41 <bryan_att> #info  +2 to a deterministic install experience! we need to be sure that it works and is not as chaotic/painful as the current experience in installing these components.
15:01:23 <julien_ZTE> # info agree with bryan_att, it is very difficult now.
15:01:57 <ChrisPriceAB> #info #info frank is referring to line 16 on the etherpad
15:04:40 <B_Smith_> Should we have secure checksum of some kind?
15:05:10 <ChrisPriceAB> #agree to the release vehicle being:
15:05:10 <ChrisPriceAB> - ISO image (BGS supplied)
15:05:10 <ChrisPriceAB> - Documentation (user guide - describing key functionality supplied, installation procedure, target system state - BGS supplied)
15:05:10 <ChrisPriceAB> - Documentation (test scenarios that release complies with - FuncTest supplied)
15:05:10 <ChrisPriceAB> - Documentation (hardware guide - Pharos supplied)
15:10:18 <frankbrockners> #agree Automatic testing will not be part of the release artifacts
15:10:35 <rprakash> #info rc0 on april2, rc1 on april9, rc2 onapril 16 and fianl rel 1 cut on 21 , test and verify on April 22 - lable, cerate repo etc and release 1on April 23rd
15:11:25 <iben> #link - openstack release schedule - https://wiki.openstack.org/wiki/Kilo_Release_Schedule
15:12:11 <iben> #link https://wiki.openstack.org/wiki/Release_Cycle openstack release cycle definitions
15:12:34 <Parviz> #info Paviz Yegani
15:12:55 <tapio__> #info Tapio Tallgren (Nokia)
15:13:53 <tapio__> Sorry for being late, I forgot about the daylight savings thing... And then I had irc problems
15:19:32 <rpaik> #info question are we trying to portray Release 1 vs. OPNFV architecture?
15:20:19 <bryan_att> #info We need to ensure we convey that OPNFV is publishing a complete, out-of-the-box NFVI reference platform. Just a picture with boxes and lines does not capture that.
15:21:47 <bryan_att> #info We need to capture the vision in a graphic, not necessarily the architecture. ODL
15:23:06 <bryan_att> #info ODL has a diagram that is less useful in capturing the vision (and includes things outside ODL's scope), as compared to OpenStack's, We need something less detailed and more objective-evoking.
15:24:03 <rprakash> #link https://wiki.opnfv.org/oscar/project_proposal.
15:24:39 <dneary> Documenting OPNFV as a pipeline, basically?
15:24:55 <dneary> With OpenStack and ODL as inputs, and an NFV platform as an output?
15:27:11 <bryan_att> #info We need to capture the vision of OPNFV as a system integration project that simplifies NFVI while it provide a comprehensive platform
15:27:44 <dneary> Maybe take inspiration from Jenkins?
15:35:14 <bryan_att> #info The call for inputs should include the expectation that all diagram proposals will identity the targeted audience for the diagram. There will be different audiences that people are thinking of as most important.
15:36:08 <bryan_att> #info IMO the key audience will be those who attend conferences at which the OPNFV graphic is presented, and those that visit the OPNFV website.
15:37:49 <ChrisPriceAB> #action rpaik to call for a discussion on the diagramattic representation for OPNFV.  (Later this week)
15:40:01 <ChrisPriceAB> #topic Arno Project plans & tracking
15:40:13 <ChrisPriceAB> #info BGS updates for Arno
15:40:32 <ChrisPriceAB> #link https://etherpad.opnfv.org/p/bgs The BGS team high level schedule for Arno
15:42:26 <ChrisPriceAB> #link https://wiki.opnfv.org/get_started/get_started_system_state defined end system state for BGS
15:43:16 <ChrisPriceAB> #link https://wiki.opnfv.org/pharos/pharos_specification defined hardware state for deployment
15:44:08 <ChrisPriceAB> #info work is needed on defining the stable installed Networking state of the get_started_system_state wiki page
15:45:01 <ChrisPriceAB> #info there is a target to have this wiki defined by the end of the week for the installers to build toward
15:46:12 <ChrisPriceAB> #info ulik outlines the octopus readiness
15:46:34 <ChrisPriceAB> #info there is further work to be done with the functest team to identify structure/triggers
15:47:00 <ChrisPriceAB> #info for artifact storage google storage was proposed but is not able to be acessed from China at all
15:47:01 <iben> #action iben to document how ci and testing is done for openstack storage
15:48:14 <ChrisPriceAB> #info Jonas asks if CI will work on mechanisms for build time as we have common libraries in genesis for deplyment
15:48:19 <ChrisPriceAB> #undo
15:48:19 <collabot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1cf67d0>
15:48:28 <ChrisPriceAB> #info Jonas asks if CI has mechanisms for build time as we have common libraries in genesis for deplyment
15:49:15 <ChrisPriceAB> #info Fatih answers that Jenkins jobs have been seperated based on where the commits are being generated to only build relevant artefacts.
15:49:38 <ChrisPriceAB> #info Morgan describes the state for functest
15:50:09 <ChrisPriceAB> #info the intention is each of the toochains should be able to run autonomously by Jenkins
15:50:36 <ChrisPriceAB> #info the robot framework and rally framework is ongoing for automation development, this includes tempest work also
15:50:54 <ChrisPriceAB> #info the vIMS is due to be ready by the end o f this week, or next week
15:51:06 <ChrisPriceAB> #info the vPing project in ongoing
15:51:24 <morgan_orange> #link https://wiki.opnfv.org/pharos_testing
15:53:31 <ChrisPriceAB> #link https://wiki.opnfv.org/pharos_testing testing wiki page
15:57:15 <dneary> frankbrockners, https://wiki.opnfv.org/get_started_experiment1 has a hardware & services state diagram - is this the kind of thing you need in the "Target state"?
15:59:00 <dneary> Just checking - did VIM-NBI come up for discussion?
15:59:08 <dneary> I may have missed it
15:59:21 <ChrisPriceAB> noe not yet, needed to ensure we get some Arno discussions sorted this week...
15:59:22 <frankbrockners> dneary: yes - this is very similar to what we're looking for.
15:59:55 <frankbrockners> dneary: just needs to be synch'ed with everyone and generalized
15:59:57 <dneary> frankbrockners, Hopefully it can be made reusable
16:00:12 <dneary> ChrisPriceAB, OK - that's fine
16:00:18 <frankbrockners> dneary: this is what we discussed on the BGS call yesterday. Jonas promised to send out a strawman as well.
16:00:21 <ChrisPriceAB> #link https://wiki.opnfv.org/documentation_projects/opnfv_documentation documentation project proposal
16:00:57 <dneary> frankbrockners, Good. I think that's been up for a while (I was looking for an older, less detailed, version yesterday, and couldn't find it)
16:01:23 <dneary> I have to sign off...
16:01:24 <frankbrockners> dneary: more detail is good
16:01:28 <ChrisPriceAB> thanks dneary
16:03:13 <ChrisPriceAB> #endmeeting