15:02:31 <frankbrockners> #startmeeting BGS weekly meeting
15:02:31 <collabot> Meeting started Mon Mar 30 15:02:31 2015 UTC.  The chair is frankbrockners. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:02:31 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:02:31 <collabot> The meeting name has been set to 'bgs_weekly_meeting'
15:02:45 <frankbrockners> #topic administrivia
15:02:55 <frankbrockners> #chair pbandzi
15:02:55 <collabot> Current chairs: frankbrockners pbandzi
15:03:07 <frankbrockners> #chair ChrisPriceAB
15:03:07 <collabot> Current chairs: ChrisPriceAB frankbrockners pbandzi
15:03:20 <frankbrockners> #chair dneary
15:03:20 <collabot> Current chairs: ChrisPriceAB dneary frankbrockners pbandzi
15:04:23 <rprakash> #info I can take it
15:05:01 <frankbrockners> #chair rprakash
15:05:01 <collabot> Current chairs: ChrisPriceAB dneary frankbrockners pbandzi rprakash
15:05:13 <arnaud_orange> hi guys
15:05:25 <dneary> I'll be happy to #chair anyone else too
15:06:19 <dneary> #topic Committer approval - Daniel Smith
15:06:35 <dneary> #agreed Daniel Smith is approved as a committer for BGS
15:06:46 <dneary> #topic Upcoming agenda
15:06:46 <rprakash> #info Glue between different activities for different installers and Daniel will be be commiter
15:07:00 <dneary> #undo
15:07:00 <collabot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1e0e910>
15:07:03 <dneary> #undo
15:07:03 <collabot> Removing item from minutes: <MeetBot.ircmeeting.items.Topic object at 0x1ddc910>
15:07:10 <dneary> #info Glue between different activities for different installers and Daniel will be be commiter
15:07:17 <dneary> #topic Upcoming agenda
15:07:33 <rprakash> #info we need to continue our meeting
15:08:14 <dneary> #info Frank reminds everyone that Easter Monday is next weekend, and is a holiday for many regular participants. He suggests we should maintain the meeting at the same time.
15:08:25 <dneary> #info Dave proposes cancelling or moving the call
15:08:25 <bryan_att> let those who can meet, meet
15:08:36 <dneary> What is the critical mass?
15:08:38 <rprakash> #info frank agreed we need to have meeting Monday or Tuesday?
15:08:57 <dneary> #info Bin suggests moving it to Tuesday 7th, 9am PST (the hour after the TSC meeting)
15:09:02 <rprakash> #info Tuesday 9 AM PDT is the suggession
15:09:32 <dneary> #agreed Meeting moves to 9am PDT on Tuesday 7th April
15:09:44 <rprakash> #action The BGS Monday meeting is moved to Tuesday  8-9 AM PDT
15:09:54 <dneary> #undo
15:09:54 <collabot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x1edb0d0>
15:10:05 <dneary> rprakash, Only one of agreed or action needed
15:10:15 <dneary> #topic Work items for first release
15:10:38 <dneary> Someone is echoing
15:11:46 <dneary> #info People are working towards a final system state, Frank asks if we have reached a final state yet?
15:12:45 <rprakash> #info Network topology to be agreed for documentation
15:13:31 <dneary> #info Not yet at a common conclusion (Szilard from Ericsson)
15:13:53 <dneary> Yes, we can hear you
15:13:53 <rprakash> #link pharos:pharos_specification [Wiki]
15:15:01 <rprakash> #link https://wiki.opnfv.org/pharos/pharos_specification
15:16:02 <rprakash> #info for first implementaion it will be to LF and there are two PODS there
15:16:18 <rprakash> #link https://dl.dropboxusercontent.com/u/12773330/opnfv_hw_pics/OPNFVHardwareFront.jpg
15:17:56 <dneary> Who is the current speaker?
15:18:05 <arnaud_orange> someone from ericson
15:18:11 <dneary> I missed the name
15:18:57 <malla> Stefan Berg From Ericsson
15:19:01 <dneary> Thanks malla
15:19:14 <bryan_att> everyone should link their phone call to the GTM session if possible
15:19:16 <dneary> I heard trozet earlier trying to get in
15:19:30 <rprakash> #info Design of Network is more important for simple LF implementaion (Stefen Ericson), Chris supports that
15:19:31 <dneary> bryan_att, I'm not on GTM, just phone
15:20:22 <rprakash> #info lets continue discussion through email to get to an agreement
15:21:32 <rprakash> #info storage single and High availability - Ceph connectivity in question
15:23:09 <rprakash> #info in BGS they use for artifacts repo
15:23:15 <rprakash> #link http://artifacts.opnfv.org/
15:23:17 <fdegir> Octopus decision regarding Google Storage only applies to Artifact Storage Manager
15:23:26 <fdegir> for CI purposes
15:23:37 <fdegir> this has no relation to BGS "internals"
15:23:40 <dneary> #info Dan Radez says that the issue is that we have a line item - "we'll use Ceph for storage" - with no idea what that means for a deployment. Frank submits that someone needs to take the action to consolidate the various views into one common target platform
15:24:09 <rprakash> #info BGS will have different storage requirement than Octopus for Ceph
15:25:17 <dneary> #action Peter Bandzi'""&-"
15:25:23 <dneary> #undo
15:25:23 <collabot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x1e077d0>
15:25:53 <rprakash> #action Peter Bandzi to drive the process of repo for ceph for release 1 (work with community to get a conclusion by next week)
15:26:12 <dneary> #action Peter Bandzi takes on the task of leading the discussion to converge on the reference target installation of OPNFV so that we can deploy to it next Thursday
15:26:18 <dneary> #undo
15:26:18 <collabot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x1c80610>
15:26:45 <dneary> rprakash, You think it's "the process of the repo" or "the reference target deployment"?
15:27:02 <dneary> I understood the latter, and I thought it was broader in scope than just ceph
15:27:17 <dneary> #undo
15:27:17 <collabot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x1e07410>
15:27:22 <dneary> #action Peter Bandzi takes on the task of leading the discussion to converge on the reference target installation of OPNFV so that we can deploy to it next Thursday
15:27:54 <dneary> #topic Common set of Puppet manifests for installation of common components
15:30:58 <dneary> #info trozet describes the Ceph configuration being used (one Ceph "controller" on each of the controller nodes, and OSDs on every node), and some continuing issues with VXLAN creation for OpenDaylight and OVS
15:32:48 <rprakash> #info san use drat version for ceph to allow experiment rather than merge
15:32:50 <dneary> #info Question: "where can I find the script you use to configure Ceph?" Frank suggests putting it into git, Tim will put it into Gerrit and mark it as "Draft", as per Dan Radez's suggestion
15:33:52 <dneary> Who is that speaking right now?
15:33:59 <fdegir> Szilard
15:34:03 <dneary> Thanks
15:38:13 <dneary> #info Frank reiterates that common pieces used by both Fuel & Foreman need to be in the repo ASAP
15:38:20 <rprakash> #info most common pieces that is across different BGS tracks should be listed on wiki
15:40:51 <rprakash> #info yaml files for different Vendor blades need to be consolidated by Peter Bandzi
15:41:39 <dneary> Are those yaml files tool dependent?
15:42:59 <rprakash> #info need common shim/wrapper for API call for Blade servers by different Vendor hardware
15:43:52 <rprakash> #info send the etherpad link for this to BGS asap for Peter to review
15:45:06 <dneary> #topic Contents of OPNFV release ISO for r1
15:45:06 <rprakash> #info Deployment Automation an Hardware adopter's to be shared
15:45:49 <dneary> #info Need something well defined from a release perspective - contains everything we need (OpenDaylight, OpenStack + dependencies, base OS, installer)
15:46:49 <dneary> #info Frank: Should install the jumphost off an ISO, and allow a user to deploy other hosts from there
15:47:17 <dneary> #info Tim: It doesn't make any sense to assume that provisioning host doesn't have internet access
15:48:34 <dneary> #info Chris: What we provide as a deliverable is different from what we use ourselves - want to enable consumers of what we are producing, potentially behind a firewall
15:49:03 <dneary> #info Tim asks if there's a proposal of which packages to include
15:49:28 <dneary> #info Dan says that a base OS installer plus OpenStack plus OpenDaylight plus all dependencies would be a huge issue
15:49:35 <dneary> #undo
15:49:35 <collabot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1e07ad0>
15:49:44 <dneary> #info Dan says that a base OS installer plus OpenStack plus OpenDaylight plus all dependencies would be a huge image - bigger than a CD
15:51:08 <dneary> #info Frank says, do we want an all in one package that installs independent of having internet access?
15:51:27 <bryan_att> #info We need a deterministic install. If we are pulling upstream resources there is the likelyhood that something will break for someone.
15:52:18 <bryan_att> #info At the least we need to pull defined versions of the resources as used in the final release build
15:55:28 <dneary> #info Dave says, if the goal is to enable an installation to someone who has no internet access, then other alternatives are possible - we can ship packages without that being a bootable install media
15:55:37 <bryan_att> #info  e.g. from our own artifact repository if needed
15:55:46 <dneary> #info Bryan says that approach would be fragile
15:56:30 <bryan_att> #info I would not put too strong a focus on internet-limited labs / users, to the detriment of the community re a reliable install experience
15:57:00 <dneary> #info Chris says there's an expectation that we have an installable media - is there any reason not to do an ISO?
15:58:22 <bryan_att> #info for CI-focused labs / users, it may make sense to pull directly from the upstream but only if we are OK with the fact that things will break, in different ways for different users
15:59:37 <dneary> #info Dave says that there's a lot of decisions and work to happen for a bootable media - host OS, packages, installer, scripts - and it feels like some of those decisions have not been discussed yet
16:00:21 <dneary> #info Dan says the issue he has is the work involved in creating an ISO would endanger the other tasks that need to be done for the release
16:01:37 <bryan_att> #info I'm happy to be convinced that this is an overstated concern - looking for any evidence as to how we can achieve a deterministic install experience while dynamically pulling from the internet the upstream code
16:02:19 <dneary> #info Tim suggests that we could bring up an installer host, which would pull in all of the upstream stuff, in the interests of limiting the footprint and work involved
16:04:23 <dneary> #agreed BGS team to continue to figure out if an install media is feasible as an approach, Chris to bring this discussion back to the board to set expectations for the release
16:05:38 <dneary> ChrisPriceAB, frankbrockners: Does the #agreed above accurately reflect the agreement?
16:06:02 <dneary> frankbrockners, I have to run to another meeting
16:06:26 <bryan_att> #info sounds good to me, if we can ensure a specific tested package version is installed
16:08:37 <rprakash> #agreed That the target you have an installable disk that installs the OS on the Controller and Compute node and additional packages can be downloaded from Internet or private mirror as may be the case
16:09:19 <rprakash> #info Still Chris want's to ensure we do feasible to get like iso discussed
16:10:57 <dneary> #endmeeting