14:00:45 <ChrisPriceAB> #startmeeting OPNFV RC0 Meeting - Release image readiness
14:00:46 <collabot> Meeting started Thu Apr 2 14:00:45 2015 UTC. The chair is ChrisPriceAB. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:46 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:00:46 <collabot> The meeting name has been set to 'opnfv_rc0_meeting___release_image_readiness'
14:00:58 <ChrisPriceAB> Please # in if you are attending the RC0 meeting.
14:01:06 <ChrisPriceAB> #topic roll call
14:01:10 <frankbrockners> #info Frank Brockners
14:01:12 <ChrisPriceAB> #info Chris Price
14:01:18 <fdegir> #info Fatih Degirmenci
14:01:27 <aricg> #info Aric Gardner
14:01:30 <jerryz> #info Jerry Zhao
14:02:18 <rprakash> thanks Bin
14:02:20 * ChrisPriceAB will give it a few minutes before moving on. Grab coffee now!
14:02:34 * ChrisPriceAB starting in 3 minutes
14:02:44 <frankbrockners> Quick Q: Is the meeting IRC only or is there also an audio channel?
14:03:13 <ChrisPriceAB> IRC only
14:03:16 <frankbrockners> thx
14:03:45 <rprakash> p
14:03:48 <rprakash> ok
14:04:23 <aricg> jerryz: Need to talk to you after the meeting.
14:04:39 <jerryz> aricg: ok
14:04:57 <bryan_att> is the release candidate meeting on now?
14:05:03 <ChrisPriceAB> ok, I was hoping to see trevor_intel, morgan on the call
14:05:08 <ChrisPriceAB> yes bryan_att
14:05:13 <trozet> can someone provide the go to meeting link please?
14:05:18 <ChrisPriceAB> Ok, getting started
14:05:23 <frankbrockners> IRC only
14:05:25 <ChrisPriceAB> #topic Agenda for the meeting
14:05:28 <dneary> Hi all
14:05:28 <bryan_att> I don't see any GTM info in the invite. Can you post it here?
14:05:30 <frankbrockners> trozet: IRC only
14:05:37 <bryan_att> OK
14:05:37 <trozet> ah ok. Thanks
14:05:45 <dneary> Is there a call? Invite says IRC meeting, there's no GTM details
14:05:54 <frankbrockners> dneary: IRC only
14:05:56 <dneary> Oh good
14:06:09 <ChrisPriceAB> #info RC execution reporting and issue logging – Fatih/Aric
14:06:10 <dneary> frankbrockners, Sorry to make you repeat yourself
14:06:21 <ChrisPriceAB> #info Project reports on RC completion and next RC readiness – Project Leads
14:06:31 <ChrisPriceAB> #info Actions and activities planned - All
14:06:45 <ChrisPriceAB> #info any other topics people would like to see on the meeting?
14:06:56 <ChrisPriceAB> #chair aricg
14:06:56 <collabot> Current chairs: ChrisPriceAB aricg
14:07:09 <ChrisPriceAB> #chair fdegir
14:07:09 <collabot> Current chairs: ChrisPriceAB aricg fdegir
14:07:13 <frankbrockners> agenda looks good to me
14:07:14 <ChrisPriceAB> Ok, miving on
14:07:24 <ChrisPriceAB> #topic RC execution reporting and issue logging – Fatih/Aric
14:07:45 <ChrisPriceAB> fdegir, aric want to fill us in, please use #info
14:08:06 <fdegir> #info Fuel and Foreman images have successfully built and stored on OPNFV Artifact Repository
14:08:25 <fdegir> #info Links to Fuel ISO and build logs
14:08:36 <fdegir> #link http://artifacts.opnfv.org/genesis/fuel/opnfv-32.iso
14:08:46 <fdegir> #link https://build.opnfv.org/ci/job/genesis-fuel-daily-master/32/consoleFull
14:08:55 <fdegir> #info Links to Foreman ISO and build logs
14:09:02 <fdegir> #link http://artifacts.opnfv.org/genesis/foreman/opnfv-4.iso
14:09:12 <fdegir> #link https://build.opnfv.org/ci/view/genesis/job/genesis-foreman-daily-master/4/consoleFull
14:09:31 <fdegir> #info Fuel and Foreman Daily Jenkins jobs have also been enabled
14:09:48 <fdegir> #info they will build latest master every night and store latest images on OPNFV Artifact Repository
14:09:50 * ChrisPriceAB there goes the answer to my next question :)
14:10:13 <fdegir> anything missing?
14:10:21 <ChrisPriceAB> #info Any questions on the RC0 status?
14:10:59 <jerryz> #info is ISO required for other installers to make it to R1?
14:11:02 * ChrisPriceAB think I have an internet freeze...
14:11:41 <radez> #info could the link be posted with reqs for R1?
14:12:05 <frankbrockners> #info Arno RC schedule is here
14:12:07 <frankbrockners> #link https://wiki.opnfv.org/releases/arno/releasecandidates
14:12:45 <radez> thx frankbrockners
14:12:51 <ChrisPriceAB> #info jerryz: That is the expectation, it would be very hard to catch up when we have only 2 RC - deploy weeks
14:13:04 <fdegir> #info Metadata for Fuel and Foreman are also stored on Artifact Repository
14:13:21 <fdegir> #info The SHA1s used for building ISOs are stored in metadata files
14:13:29 <fdegir> #link http://artifacts.opnfv.org/genesis/fuel/opnfv-32.properties
14:13:37 <fdegir> #link http://artifacts.opnfv.org/genesis/foreman/opnfv-4.properties
14:14:03 <ChrisPriceAB> #info thanks fdegir, any other questions/comments or I will move on
14:14:20 <jerryz> #info ChrisPriceAB: we can get deploy.sh to work but build.sh still need some work for Compass
14:14:51 <trozet> ChrisPriceAB: are we going to talk about R1 later in the meeting?
14:15:12 <ChrisPriceAB> #info yes we will do R1 planning and actions as the last point
14:15:18 <ChrisPriceAB> #topic Project reports on RC completion and next RC readiness – Project Leads
14:15:45 <ChrisPriceAB> #info frankbrockners can you report on BGS? RC0 and moving to RC1 readiness
14:16:33 <frankbrockners> #info Sent out a request for status to the alias yesterday. Got details for Foreman and Fuel deployment approaches.
14:16:54 <frankbrockners> #info Details are summarized on the BGS wiki as part of the release plan
14:17:08 <frankbrockners> #link https://wiki.opnfv.org/get_started/get_started_release_plan
14:17:43 <frankbrockners> #info For RC0: Successful built for Foreman and Fuel deployment approaches
14:18:40 <frankbrockners> #info For RC0: Common puppet manifests mostly in place - some patches still in gerrit. See wiki for details.
14:19:13 <ChrisPriceAB> #info Q: So equivalent of code freeze achieved, with bug-fixes pending?
14:19:15 <frankbrockners> #info R1 readiness: Teams active on deploy scripts.
14:19:34 <frankbrockners> #info R1 will also depend on LF infra fully available.
14:20:01 <ChrisPriceAB> Pharos can report on HW readiness
14:20:03 <frankbrockners> #info "bug fixes" pending is appropriate
14:20:08 * ChrisPriceAB (or aricg)
14:20:27 <frankbrockners> #info One clarification would be good to have here:
14:20:48 <trozet> #info R1 question. Can we get a description on the wiki of what "deploy.sh" is supposed to do exactly. Just want to have the right expectations clear for everyone.
14:21:06 <frankbrockners> #info Teams are working on the assumption that "deploy.sh" will *not* include any testing. I.e. testing is run *post* installation and is independent from deploy
14:21:17 <rprakash> ok
14:21:24 <frankbrockners> #info Is this everyone's understanding?
14:21:41 * frankbrockners Thanks Tim. You were quicker than I
14:21:43 <ChrisPriceAB> #info erm: Yes. Deploy should install the SW, validation shall occur post install as a standard functest suite.
14:22:06 <jerryz> #info but testing may need some input from deploy.sh, url, username, password,etc
14:22:08 <radez> I believe we have been firing of tempest as part of our deploy, but I think that can be carved off
14:22:13 <radez> trozet: correct? ^
14:22:20 <frankbrockners> #info Robot and Tempest would be installed independently from any install/deploy approach
14:22:44 <rprakash> #info as part of post install processes
14:23:32 <ChrisPriceAB> #info Q: As part of RC1 readiness have we identified consistent user names and passwords to be used?
14:23:36 <trozet> radez: right, but it can be easily removed and moved to a separate playbook
14:24:02 <jerryz> #info how about self-contained virtualized deployment test
14:24:35 <radez> #info foreman has tempest fired off as part of deploy but it can be separated without trouble
14:24:43 <trozet> #info ChrisPriceAB: no I don't think we have standards user/pass. We have been using octopus/octopus for all OpenStack user/pass and "Op3nStack" for linux root login
14:24:48 <ChrisPriceAB> trozet, I think it should be OK to have a deploy validation done as part of the toolchain. Would be nice to have it as a seperately punted Jenkins job though...
14:25:10 <ChrisPriceAB> #action BGS team to resolve consistent user names for RC1.
14:25:13 * ChrisPriceAB :D
14:25:35 <trozet> ChrisPriceAB: I agree, one script should provision the hosts, another should kick off necessary tests for CI
14:25:44 <ChrisPriceAB> ok, looking to move to CI reporting.
14:25:51 <ChrisPriceAB> last questions?
14:25:52 <frankbrockners> #info user names goes beyond BGS... - given that you have to reconfigure the switches every time you switch installers
14:25:59 <trozet> #info ChrisPriceAB: still have a question about deploy.sh
14:26:04 <frankbrockners> #info so an AI for pharos
14:26:20 <ChrisPriceAB> #action Pharos team to provide consistent usernames for infrastucture.
14:26:21 <aricg> #info HW readiness Wiring started yesterday, should be completed today.
14:26:29 <ChrisPriceAB> hang on aricg
14:26:34 <trozet> #info so deploy.sh will not require to boot the iso created by build.sh? or deploy the install server?
14:27:17 <frankbrockners> #info my understanding is that deploy.sh will need to deploy the jumphost/install server
14:27:29 <ChrisPriceAB> #info trozet & bgs team please clarify deploy sequence details in the BGS project.
14:27:31 <frankbrockners> #info though it does not need to work off the ISO
14:28:03 <frankbrockners> ChrisPriceAB - we can do for deploy - as long as we're clear on what testing would do
14:28:11 <radez> #info so build.sh iso needs to deploy.sh but not vise versa?
14:28:15 <trozet> #info for OPNFV purposes I would vote to use a VM and not rebuild baremetal install server with an ISO, for speed and reliability
14:28:25 <ChrisPriceAB> #info CI readiness report. RC0 and moving to RC1 readiness.
14:28:34 <frankbrockners> Assumption is that testing would run off a different server - i.e. not on one of the 6 ones which forms a POD
14:28:37 <frankbrockners> correct?
14:28:59 <ChrisPriceAB> jerryz, will you report CI status?
14:29:24 <fdegir> #info CI jobs that verify changes that are done in genesis/common, genesis/fuel, and genesis/foreman are now activated
14:29:27 <jerryz> yes
14:29:38 <rprakash> #info go ahead Jerry
14:29:56 <fdegir> #info any change in genesis repo that is still pending for review needs to rebase to master
14:30:15 <fdegir> #info in order to get them tested with fuel and foreman verify jobs
14:30:17 <jerryz> #info CI jobs created and triggered periodically for build.sh
14:30:49 <jerryz> #info artifacts uploaded to google storage after each build
14:31:26 <fdegir> these are the daily jobs
14:31:35 <fdegir> they are triggered every night
14:31:55 <fdegir> and only valid for fuel and foreman
14:32:07 <ChrisPriceAB> #info Q: are the on commit and on merge jobs in place as well?
14:32:24 <trozet> fdegir: and common?
14:32:39 * ChrisPriceAB I would hope so :D
14:32:40 <fdegir> #info Jobs run for each commit are in place
14:32:58 <jerryz> #info gerrit trigger in job template
14:33:09 <fdegir> #info any commit that touches genesis/common, genesis/fuel, and genesis/foreman will trigger verify job
14:33:27 <ChrisPriceAB> #info Q: artifacts uploaded at each build or nightly?
14:33:38 <fdegir> #info artifacts are uploaded nightly
14:33:47 <fdegir> #info no artifact is uploaded from verify and merge jobs
14:33:59 <ChrisPriceAB> thanks.
14:34:02 <fdegir> #info work is still in progress for merge jobs
14:34:22 <ChrisPriceAB> #info RC1 readiness report, pending actions on Deploy & Test?
14:34:36 <ChrisPriceAB> #info for CI
14:34:55 <jerryz> #info depending on how to test deploy, with what resource?
14:35:19 <fdegir> #info We are waiting for BGS and FuncTest to provide mechanisms to deploy and test
14:35:22 <jerryz> #info: deploy job template is there, no resource for deploy jobs yet
14:35:47 <fdegir> #info We currently download ISOs from Google Storage in deploy phase as "dummy" jobs
14:36:04 <fdegir> #info it will be replaced with real deployment once it is ready
14:36:11 <ChrisPriceAB> #info Q: so pending actions on functest and bgs to complete scripts in Jira?
14:36:17 <fdegir> #info correct
14:36:36 <jerryz> #info slaves for deploy need to be in plae
14:36:48 <jerryz> #info s/plae/place
14:36:56 <fdegir> #info LF hardware is the prerequisite for RC1
14:37:14 <fdegir> #info as we lack build and deploy resources at the moment
14:37:20 <ChrisPriceAB> #info OK, more question on CI? otherwise I will move to Pharos
14:37:51 <ChrisPriceAB> #info Pharos (LinuxFoundation infra) RC1 readiness report?
14:37:58 * ChrisPriceAB over to you aricg
14:38:00 <rprakash> #info artur did you create mass juju fillers for rc0 in genesis
14:38:29 <aricg> #info Wiring started yesterday, some hangups, should complete today
14:38:51 <rprakash> #info ok done for ci on juju track
14:39:29 <ChrisPriceAB> #info Q: will we provide scripts for deploy tools for switch config etc? (maybe a better q for trevor_intel)
14:39:39 <arturt> #info rprakash yes
14:40:05 * ChrisPriceAB pleas keep info to on topic comments for capture in the minutes
14:40:07 <trozet> #info ChrisPriceAB I dont think that is necessary. We have an agreed upon VLAN layout for the target system that should work with any installer
14:40:24 <ChrisPriceAB> #info ok, thanks trozet
14:40:35 <frankbrockners> #info I have a different understanding
14:40:54 <frankbrockners> #info depending on installer hosts send packets either VLAN tagged or not
14:41:13 <frankbrockners> #info based on this, switch config would differ (either switch applies VLAN tag or not)
14:41:20 <trozet> #info no reason to use tagging unless we don't have enough ports per server. We agreed on this in the meeting yesterday.
14:41:23 <frankbrockners> #info requires clarification from teams
14:41:44 <ChrisPriceAB> #info action: bgs team to clarify if any abstraction is required from the Pharos project for deploy and add Jira jobs where neccessary.
14:41:50 * ChrisPriceAB or solve in house for R1.
14:42:29 <ChrisPriceAB> #info functest RC1 readiness report.
14:42:43 * ChrisPriceAB anyone on form the funtcest project?
14:43:25 * ChrisPriceAB just trying to pull someone in from the other channel.
14:43:40 <rprakash> #info is new project lead assigned for func test?
14:44:22 <aricg> #info the new commiters now have access. https://git.opnfv.org/cgit/functest/tree/INFO
14:44:33 <ChrisPriceAB> #info currently the acting is trevor_intel, nominations have started
14:45:04 <ChrisPriceAB> #info unable to secure functest reporting for RC1 readiness.
14:45:42 <ChrisPriceAB> #action ChrisPriceAB to secure functest updates and preparation for RC1 is on track
14:45:46 <ChrisPriceAB> #info RC1 readiness for opnfvdocs
14:46:18 <ChrisPriceAB> #info opnfvdocs repo was created yesterday, tooling is being prepared and we expect to get foundation templates in place over the weekend.
14:46:45 <ChrisPriceAB> #info risk that we will not be ready for RC1, although I hope to have a clear structure and all Jira actions in place with templates by that time.
14:47:23 <frankbrockners> Can we add an explicit deliverable for docs to RC1?
14:47:33 <ChrisPriceAB> #info opnfvdocs team will help project teams complete the documentation in the templates in order to arrive at Release 1
14:47:40 <ChrisPriceAB> #info expected documents include:
14:47:50 <ChrisPriceAB> #info - Release documentation
14:47:51 <rprakash> #info is all documentation work being scheduled through Jira?
14:47:59 <dneary> ChrisPriceAB, Have the access issues of the functest team all been resolved?
14:48:05 <ChrisPriceAB> #info Installation docuemtation
14:48:16 <dneary> (sorry - off-topic for docs)
14:48:22 <ChrisPriceAB> #info - User guides, leveraging references to upstream documentation
14:48:32 <ChrisPriceAB> #info - Test coverage documentation
14:48:53 * ChrisPriceAB dneary more or less yes. trevor_intel helped me with it the other noght
14:48:55 <ChrisPriceAB> night
14:49:03 <dneary> OK, thanks
14:49:34 <dneary> ChrisPriceAB, Do docs templates exist already, or do they need creating?
14:49:39 <ChrisPriceAB> #info the release documentation will derive from project source document files in order to enable the documents to be maintained with the projects.
14:49:47 * dneary would like to help for BGS/Foreman docs
14:49:59 <ChrisPriceAB> #info opnfv docs while produceing release specific content will not replicate project specific infrmation
14:50:24 <frankbrockners> #info Ask: Can we agree on an RC1 milestone for docs?
14:50:28 <ChrisPriceAB> #info any questions on the opnfvdoc progress. (the little there is)
14:50:37 <dneary> frankbrockners, RC1 is next Thursday?
14:50:48 <frankbrockners> dneary: yes
14:50:56 <ChrisPriceAB> #info We can, due to easter being in the middle I am not confident on what to set as a goal.
14:51:04 * ChrisPriceAB yes next thrursday
14:51:19 <frankbrockners> #info How about "draft doc templates available to projects"
14:51:21 <dneary> ChrisPriceAB, So, when you say that OPNFV docs will not have project specific information, what do you mean?
14:51:25 <ChrisPriceAB> #info tooling, templates and Jira actions might be a good start
14:51:37 <dneary> frankbrockners, I would say RC1 is good for template/draft, but too close for final docs
14:51:48 <dneary> RC2 for final
14:51:49 <frankbrockners> dneary: agreed
14:51:52 <dneary> s/final/RC
14:52:11 * ChrisPriceAB I mean documentation that describes instalation instructions for a deployment toolchains should be stored in the deployment toolchain repository and extracted into the opnfvdocs documentation
14:52:59 <dneary> So there's an overall OPNFV doc describing the target deployment, functest, CI pipeline, and separate docs for the specific installers?
14:53:05 <ChrisPriceAB> #action opnfvdocs project to ensure templates are available for all Release 1 projects by RC1, with associated structure and documentation 'guidelines'
14:53:07 <dneary> If that's right, makes sense to me
14:53:53 * ChrisPriceAB dneary, well each project (SDN options, installer options, storage options should provide documentation of that component option
14:53:54 <frankbrockners> dneary: sounds like a good objective. can we info it?
14:54:20 <dneary> frankbrockners, objective = OPNFV docs, or RC1 as target date?
14:54:41 <ChrisPriceAB> #topic Actions and activities planned
14:54:46 <frankbrockners> dneary: "OPNFV doc describing the target deployment, functest, CI pipeline, and separate docs for the specific installers"
14:54:46 <dneary> #info there will be an overall OPNFV doc describing the target deployment, functest, CI pipeline, and separate docs for the specific installers and projects
14:54:56 <frankbrockners> dneary: thx
14:54:57 <ChrisPriceAB> #info pending actions, let's capture needed steps leading to RC1.
14:54:58 <dneary> Oops... topic changed on me
14:55:08 * ChrisPriceAB sorry dneary
14:55:12 <dneary> nm
14:55:36 <ChrisPriceAB> Aside from the action points captured, what are causing concerns for projects, what are people waiting on?
14:55:54 * dneary needs to leave - meeting at top of the hour and s/t to do before then
14:55:58 <frankbrockners> let's quickly capture the key things
14:56:04 <frankbrockners> HW availability
14:56:18 <ChrisPriceAB> #info LF hardware should be available by the end of this week. CI needs to move targets to the LF lab and begin building/deploy testing there.
14:56:24 <frankbrockners> Functest has test frameworks installed
14:56:31 <dneary> ChrisPriceAB, I'll be helping with docs, but I have no need/desire to be a committer. I'll be going through Gerrit
14:56:35 <frankbrockners> deploy scripts run on LF HW
14:56:46 <rprakash> #info for BGS/JuJu we gat POD5 next week so thats the wait for hold up you asked
14:56:52 <fdegir> builds will also need to be moved to LF infra
14:56:58 <ChrisPriceAB> #info functest needs to migrate all work into the repository so it can begin to be tested against target automatically.
14:57:10 <ChrisPriceAB> dneary perfect!
14:57:59 <frankbrockners> #info and functest infra (tempest, robot) needs to be avail on LF HW by RC1
14:58:01 <ChrisPriceAB> other pending work items, this will be my "list of activities to chase down" for the coming week
14:58:22 <ChrisPriceAB> ok, we are running out of time.
14:58:41 <trevor_intel> The key poeple for functest were not on our earlier call and need some coordination over next few weeks ... I took AR to setup functest meeting Tues 1 hour before TSC
14:58:52 <ChrisPriceAB> thanks every-one for attending. Congratulations to the Fuel and Foreman teams for passing RC0
14:59:11 <ChrisPriceAB> great thanks trevor_intel
14:59:17 <ChrisPriceAB> ok, ending here. thanks all
14:59:22 <ChrisPriceAB> #endmeeting