14:59:09 <frankbrockners> #startmeeting BGS weekly meeting
14:59:09 <collabot> Meeting started Mon Apr 13 14:59:09 2015 UTC.  The chair is frankbrockners. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:59:09 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:59:09 <collabot> The meeting name has been set to 'bgs_weekly_meeting'
14:59:18 <iben_> #opnfv-octopus
14:59:22 <iben_> got it!
14:59:41 <frankbrockners> #info Draft agenda: https://wiki.opnfv.org/meetings/bgs#april132015
14:59:58 <frankbrockners> #topic roll call
15:00:22 <frankbrockners> could you info in if you're participating in the BGS meeting?
15:00:35 <pbandzi> #info pbandzi
15:00:44 <radez> #dradez
15:00:45 <frankbrockners> #info Frank Brockners
15:00:50 <radez> #info dradez
15:01:14 <Malla> #info Malla
15:01:30 <dneary> #info dneary
15:01:43 <dfarrell07> #info dfarrell07
15:01:56 <HKirksey> #info hkirksey
15:02:33 <[1]JonasB> #info Jonas Bjurel
15:03:08 <fdegir> #info fdegir
15:03:42 <frankbrockners> #topic agenda bashing
15:03:45 <ChrisPriceAB> #info Chris Price
15:03:49 <frankbrockners> #link https://wiki.opnfv.org/meetings/bgs#april132015
15:03:52 <mdolan> #info Mike Dolan
15:03:58 <frankbrockners> #info any updates on the draft agenda?
15:04:56 <frankbrockners> let's switch to the first real agenda topic
15:05:01 <frankbrockners> #topic Code scanning requirements for OPNFV (Mike, Heather)
15:05:11 <frankbrockners> Heather, Mike - could you lead this discussion?
15:05:37 <mdolan> do I need to use any #'s for the meetbot? (Sorry, my first OPNFV IRC meeting)
15:05:46 <dfarrell07> mdolan: always a good idea
15:05:53 <ChrisPriceAB> Yes, you #info
15:05:58 <mdolan> ok, thanks
15:06:02 <dfarrell07> For general notes, `#info <message>`
15:06:14 <dfarrell07> For link: `#link <link> <description>`
15:06:20 <mdolan> #info We are looking for the full details of the packages that are being pulled in by the scripts to understand the licensing involved
15:07:16 <mdolan> #info Frank referred me this morning to Jonas Bjurel and Daniel Smith for Fuel and Tim Rozet and Daniel Radez for Foreman
15:07:59 <mdolan> # so I guess we'll go down that path, but we really just need to know beyond the code in the OPNFV git repos, what other 3rd party codebases are being pulled in by any script
15:08:03 * dfarrell07 can help with ODL part of that, FYI
15:08:11 <mdolan> #info so I guess we'll go down that path, but we really just need to know beyond the code in the OPNFV git repos, what other 3rd party codebases are being pulled in by any script
15:08:26 <radez> mdolan: should we get into those details outside this meeting?
15:08:46 <rprakash> #info rprakash
15:08:47 <ChrisPriceAB> #info Does that include code being pulled into code that we are pulling?
15:08:57 <ChrisPriceAB> and so on and so forth
15:09:39 <mdolan> #info radez: yes, probably best to connect 1x1 I guess, just wanted to make everyone aware that we need to document what these other packages are, where they come from and the licensing. It would probably be good to setup a process to capture it at code time, but for the first release we're likely going to have to do it a bit manually looking at what was done already.
15:10:01 <radez> #info ack, we'll be in touch
15:10:07 <dneary> mdolan, What level of detail do you need? Is it enough to say "based on CentOS 7.1-1046" or whatever, and only document the delta?
15:10:56 <[1]JonasB> #info lets get in touch for the fuel repos
15:11:10 <mdolan> #info "based on CentOS 7.1-1046" is a bit broad, but it depends on the use case - there are a lot of packages in "CentOS"
15:12:04 <rprakash> #info Believe that should be done as part of code review by  respective team
15:12:07 <mdolan> #info How many upstream projects are being pulled in? I also noticed the artifacts.opnfv.org and it appears there are binaries, we need to ensure the corresponding sources used to build those are available
15:13:28 <mdolan> #info that was all I had - just wanted to get the right contacts and make sure everyone is aware of this requirement
15:13:54 <mdolan> #info frankbrockers thanks for your pointers to the right contacts this morning
15:13:56 <frankbrockners> mdolan: how quickly do you need the info?
15:14:00 <dneary> mdolan, OK. So a more precise base is useful: "Based on CentOS Minimal ISO, 7.1-1046" with extra packages installed would be good enough?
15:14:05 <mdolan> info: this week
15:14:12 <rprakash> #info automatic detection of licenses is not practical and hence code review is the better way and each track like Fuel, Foreman setup their own code erveiw teams and licensing being one as[pect to revieqw
15:14:23 <HKirksey> Are the fuel and foreman leads sufficient to get all the info relevant to Arno?
15:14:29 <mdolan> #info dneary yes, better
15:14:37 <frankbrockners> #info component/artifact details info to be supplied to Mike Dolan by end of this week
15:14:45 <mdolan> #info dneary, ideally with a link to the source for that as well
15:15:08 <frankbrockners> ok - can we switch to the next topic?
15:15:13 <dneary> mdolan, My question was whether it sufficed to point to the origin, and delegatesources to that project
15:15:50 <dneary> mdolan, BGS developers don't install everything from source, it would be nice to point to the binaries from 3rd party projects and not need to document the sources
15:16:02 <frankbrockners> mdolan: Perhaps you can add a line or two on what the core problem is that we're trying to tackle with the ask
15:16:10 * dneary fades back into the shadows and lets topic move on
15:16:25 <mdolan> #info dneary I think the answer is that depends, are we distributing the binaries from OPNFV? What license is the binary under? (e.g. GPL probably has a different answer than Apache binary)
15:16:38 <dneary> mdolan, It's going to be an aggregate work
15:17:03 <dneary> mdolan, My main concern is not to add work to teams that are pushing hard for a deadline if possible
15:17:58 <mdolan> #info trying to keep this as light weight as possible; we can do some cleanup after the release, but we also can't violate the licensing requirements from the upstream projects
15:18:05 <frankbrockners> ok - let's switch to the next topic
15:18:10 <frankbrockners> #topic BGS status and workplan review
15:18:51 <frankbrockners> #info LF HW is available by now
15:19:29 <ChrisPriceAB> #info Are we fully wired up and functional?
15:19:37 <frankbrockners> #info One ask by the RC1 review meeting was that we agree on common usernames for use by CI. Do we have a suggestion here?
15:19:43 <trozet> frankbrockners: LF HW isn't ready according to octopus call
15:20:49 <frankbrockners> trozet: Thanks - so is anyone here to give us an update. Seems, I read Konstantin's email the wrong way
15:21:13 <trozet> frankbrockners: I think fdegir gave the update in the octopus meeting that it still wasn't ready
15:21:52 <fdegir> yes since we haven't got notification regarding the availability of LF hw
15:22:12 <rprakash> #info ready is described as LF Hardware + Jenkins Master /Salve connection
15:23:08 <fdegir> #info For Octopus to use the LF HW, we need to connect needed servers to OPNFV Jenkins
15:27:20 <rprakash> #link https://wiki.opnfv.org/wiki/jenkins#jenkins_slaves
15:28:00 <frankbrockners> ok - let's keep moving
15:28:12 <rprakash> #link https://build.opnfv.org/ci/computer/
15:28:15 <frankbrockners> do we have an update on the common user names?
15:28:41 <frankbrockners> what usernames are used right now?
15:29:42 <rprakash> what username admin per track like Fuel, Foreman or ?
15:29:44 <trozet> #info Foreman uses "Op3nStack" as root password for machines.  Uses "octopus" for user,pass, and tokens for openstack services
15:30:42 <[1]JonasB> frankbrockners: the one Tim proposed is as good as anyone, why not go for it
15:31:06 <frankbrockners> [1]JonasB: Works for me
15:31:16 <ChrisPriceAB> #info Only thing I can think is to simplify them a little.  and maybe make them OPNFV specific rather than based on a component name.
15:31:19 <frankbrockners> can we agree on Tim's suggestion?
15:32:05 <frankbrockners> ChrisPriceAB: We can do opnfv/opnfv ?
15:32:07 <trozet> #info root password has to be 8 characters thats why it is not octopus :)
15:33:00 <ChrisPriceAB> #info well at least 8 chars.  :)
15:33:20 <ChrisPriceAB> genesis! or something?
15:33:26 <frankbrockners> ChrisPriceAB: Any better suggestion than what Tim proposed?
15:33:33 <SzilardCserey_ER> default Fuel password is: r00tme
15:33:48 <SzilardCserey_ER> that's another alternative :)
15:34:43 <ChrisPriceAB> I was just stating the preference for something related to OPNFV, I'm not religious by any means.  We are setting precedents though.
15:34:44 <SzilardCserey_ER> Op3nStack is good for me :)
15:34:59 <rprakash> #inof suggest all tracks get an id like 10 for fuel, 20 for foreman, 30 for compass , 40 for Juju and so on so forth and each one use root password as octopusxx where xx=d for theire track
15:35:02 <radez> how about openplatformfornetworkfunctionvirtualization?
15:35:06 <frankbrockners> how about opnfvstack?
15:35:16 <SzilardCserey_ER> :))
15:35:23 <frankbrockners> +1 on openplatformfornetworkfunctionvirtualization
15:35:24 <radez> that's more that 8 chars :)
15:35:26 <ChrisPriceAB> nice radez!
15:35:32 <trozet> lol radez
15:35:41 * trozet starts counting
15:35:44 <ChrisPriceAB> I'm good with that Frank
15:35:51 <[1]JonasB> Is this the best spend time, cant we do this off-line
15:35:55 * ChrisPriceAB still counting. fingers - toes ....
15:36:06 * frankbrockners agreed Jonas
15:36:35 <trozet> opnfvstack is fine
15:36:36 <frankbrockners> Let's go with opnfv/openplatformfornetworkfunctionvirtualization for
15:36:40 <frankbrockners> for now
15:36:51 * ChrisPriceAB :s
15:36:52 <SzilardCserey_ER> +1
15:37:12 <rprakash> #info every entry to CI must have an ID and thus octopus+ID like octopus10 for Fuel, octopus20 for Foreman .. will be better
15:37:33 <frankbrockners> #info opnfv/openplatformfornetworkfunctionvirtualization as username / password
15:37:57 <trozet> frankbrockners, are you kidding?
15:38:01 <trozet> i hope so
15:38:18 <frankbrockners> nope - you'll never type this anyway
15:38:33 <narindergupta> rprakash, frankbrockners juju uses the ssh keys and default root password id disabled. Also uses username as ubuntu.
15:38:44 <frankbrockners> am looking to close this discussion - just need *some* agreement here
15:38:51 <trozet> so if we want to login to a server to debug an issue, root password is that
15:38:53 <trozet> ...
15:39:05 <frankbrockners> trozet: new suggestion?
15:39:08 <trozet> i think opnfvstack is good enough
15:39:18 <frankbrockners> ok - let's use that one then
15:39:19 <trozet> generic to the project, is 8 characters
15:39:21 <SzilardCserey_ER> ok
15:39:30 <rprakash> #info agreement is difficlut let each track decide what they think is their way and document it
15:39:41 <frankbrockners> #agree opnfv/opnfvstack as username/password
15:39:48 <frankbrockners> let's switch to project updates
15:39:48 <Malla> #info opnfv/opnfvbgs
15:39:59 <frankbrockners> #undo
15:39:59 <collabot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1c9dad0>
15:40:11 <frankbrockners> Malla: let's stay with the above
15:40:23 <frankbrockners> let's switch topics to
15:40:35 <frankbrockners> RC1 get well and RC2 readiness
15:40:37 <Malla> ok, I am fine with both.. :)
15:40:48 <frankbrockners> Jonas or Tim - could you give an update?
15:40:58 <frankbrockners> on where things are?
15:41:10 <trozet> #info Foreman is going to commit deploy.sh after this meeting
15:41:24 <trozet> #info ready to test on LF hardware
15:41:55 <ChrisPriceAB> Sweet!  Does that deploy to baremetal or virtually?
15:41:58 <[1]JonasB> #info We're working on something autodeployable for this Thu, no gold edges but a start.
15:42:03 <frankbrockners> trozet: Has this been tested in another lab (e.g. Intel)?
15:42:06 <trozet> baremetal
15:42:28 * ChrisPriceAB :D
15:42:32 <trozet> frankbrockners: I'm testing it on an internal lab in redhat.  I need a real env to try on
15:43:08 <trozet> frankbrockners: I might try intel pod1 and kill the baremetal foreman there.  Was hoping I could test/debug on LF gear
15:43:25 <ChrisPriceAB> We have Jenkins to the intel lab now.  Can we trial it automated there???
15:43:36 <[1]JonasB> frankbrockners: I think we need to schedule time in LF for troubleshooting and dry-runs for the two tracks.
15:43:48 <trozet> ok I'll try to get it running in intel pod1
15:43:52 <trozet> then we can try to hook it to jenkins
15:44:34 <frankbrockners> [1]JonasB: Agreed. I thought that HW would be ready. So that at least the "HW doctors" would have access to it
15:45:11 <trozet> #info will try to get deploy.sh working on Intel POD1 then connect to jenkins
15:45:53 <fdegir> we have a server from intel lab connected to jenkins
15:46:02 <fdegir> is that the one you are talking about trozet?
15:46:02 <frankbrockners> [1]JonasB, trozet: Could you touch base with Konstantin and Aric to get access to LF HW as early as possible?
15:46:31 <trozet> fdegir: which server?  I'm using POD1
15:46:38 <trozet> frankbrockners: ack
15:46:51 <[1]JonasB> frankbrockners: I've given Konstantin the info he asked for to admit access.
15:47:32 <frankbrockners> thanks [1]JonasB, trozet
15:47:33 <fdegir> we need to check it with morgan_orange and trevor_intel
15:47:39 <fdegir> regarding what that intel server is
15:47:56 <fdegir> https://build.opnfv.org/ci/computer/intel-build/
15:50:08 <frankbrockners> [1]JonasB: Could you detail "something autodeployable for this Thur" a bit further? Would this be to LF HW?
15:52:18 <frankbrockners> Any additional updates for the different deployment tools and their "RC2" readiness?
15:52:54 <frankbrockners> seems like this is not the case
15:53:06 <[1]JonasB> #info This week will do nested deployment and get that working flawlessly. From there it should be a straight forward task to write the python HW adaptor for LF.
15:53:29 <frankbrockners> thanks [1]JonasB
15:53:35 <[1]JonasB> #info LF or not depends on the availability.
15:54:24 <frankbrockners> #topic additional status updates - docs and testing
15:54:44 <frankbrockners> #info Any updates on docs for BGS?
15:55:06 <frankbrockners> #info Victor submitted a "template": https://gerrit.opnfv.org/gerrit/#/c/268/
15:55:37 <frankbrockners> #info which is our main project page in .rst format
15:55:58 <frankbrockners> #info what are the plans to have userdocs for the different deployment approaches?
15:56:10 <[1]JonasB> #My self will focus on docs this week.
15:56:30 <frankbrockners> [1]JonasB: Could you #info that?
15:57:31 <[1]JonasB> #info I will focus on docs this week, I will probably propose templates for relesenotes and indstallation and userguide.
15:58:14 <frankbrockners> trozet, dradez: any thoughts from a Foreman perspective?
15:59:26 <trozet> frankbrockners: haven't really thought about that
15:59:39 <trozet> frankbrockners: still need to update the wiki.  That's what ive been using so far
16:00:59 <frankbrockners> agreed - we could translate the wiki into a .rst - but would still need to be sanitized (I would expect that this is what Jonas thinks of as well)
16:01:40 <frankbrockners> we're at the top of the hr...
16:01:50 <[1]JonasB> Lets agree on the templates, filling it with content after we have agreed should be fairly easy.
16:01:57 <trozet> ok
16:02:28 <frankbrockners> #info Jonas will supply templates for releasenotes, user- and installationguide
16:03:09 <frankbrockners> let's close for now... let's use #opnfv-bgs a bit more actively... we're less than 2 weeks from the official release date...
16:03:46 <frankbrockners> thanks everybody - am keeping fingers crossed that LF HW will become available asap...
16:03:50 <frankbrockners> #endmeeting