15:00:28 <frankbrockners> #startmeeting BGS weekly meeting
15:00:28 <collabot> Meeting started Mon Apr 27 15:00:28 2015 UTC.  The chair is frankbrockners. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:28 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:00:28 <collabot> The meeting name has been set to 'bgs_weekly_meeting'
15:00:33 <ulik> sorry for abrupt ending....
15:00:53 <frankbrockners> could those of you who attend the BGS meeting #info in please
15:01:05 <morgan_orange> #info morgan_orange
15:01:16 <Malla> #info Malla
15:01:20 <frankbrockners> #info Frank Brockners
15:01:22 <davidmichaelkarr> #info David Karr
15:01:33 <MatthewL2> #info Jun Li
15:01:38 <fdegir> #info Fatih Degirmenci
15:02:02 <chigang> #info chigang(Justin)
15:02:04 <trozet> #info Tim Rozet
15:02:20 <HKirksey> #info Heather Kirksey
15:02:34 <pbandzi> #info Peter Bandzi
15:02:34 <rprakash> #info rprakash
15:02:40 <ulik> #info uli
15:04:14 <frankbrockners> #topic agenda bashing
15:04:25 <frankbrockners> #link https://wiki.opnfv.org/meetings/bgs?&#april272015 - draft agenda
15:04:35 <frankbrockners> anything else we should add to the agenda for today?
15:05:23 <frankbrockners> if there aren't any additional topics, we can move to the first item
15:05:37 <frankbrockners> #topic Functest status update (incl. tests planned for Arno, testing requirements)
15:05:44 <dneary> #info dneary
15:05:54 <frankbrockners> Morgan, could you give us a brief update on where things are?
15:06:19 <frankbrockners> Special interest is in what tests are run for Arno - and what infra BGS can use/expect
15:06:33 <morgan_orange> #info 5 functests on Arno
15:06:52 <morgan_orange> #info Bench from rally, Tempest from Rally, ODL suite using Robot Framework, vPing, vIMS
15:07:24 <morgan_orange> #Rally manual and automated tests OK, we have to clean the tests (to keep only successful tests)
15:07:47 <morgan_orange> #Rally tested on Ericsson POD and Orange POD => to be tested on LF POD when available
15:07:54 <morgan_orange> oups
15:08:01 <morgan_orange> #info  manual and automated tests OK, we have to clean the tests (to keep only successful tests)
15:08:09 <morgan_orange> #info  tested on Ericsson POD and Orange POD => to be tested on LF POD when available
15:08:27 <morgan_orange> #info ODL pbandzi working on it on Intel POD 2
15:08:51 <[2]JonasB> #info Jonas Bjurel
15:09:00 <morgan_orange> #info vPing successfully manually tested on Orange POD, adaptation in progress by Malla, shall be committed tomorrow and documented
15:09:29 <morgan_orange> #info for vIMS, team had trouble accessing the POD, no feedback since last week
15:09:49 <morgan_orange> #info documentation initiated (to be completed)
15:10:11 <morgan_orange> any question?
15:10:15 <frankbrockners> #info Where can one find details on which tests will be run by Rally, Tempest, Robot?
15:10:47 <lmcdasm> #info Daniel Smith
15:11:38 <morgan_orange> #link rally scenario are here https://git.opnfv.org/cgit/functest/tree/testcases/VIM/OpenStack/CI/suites (butneed to be clean a little bit)
15:11:44 <trevor_intel> #info Trevor Cooper
15:12:01 <morgan_orange> #link ODL: https://git.opnfv.org/cgit/functest/tree/testcases/Controllers/ODL/CI/test_list.txt
15:12:05 <[1]JonasB> 8ep65e
15:12:49 <morgan_orange> #info Rally tempest so far still more than 70 errors on smoke tests (on E/// and Orange PoD) under investigation
15:14:04 <frankbrockners> #info What are the FuncTest plans from a user perspective for R1? Are we running FuncTest just as part of the CI toolchain on LF HW - or are we making Functest available to users directly (to do smoke testing of their installations)?
15:15:05 <morgan_orange> #info my view is both. It must be integrated in the CI (on LF) but also on other POD (interesting to get bench figures) and we should write a "user" guide to allow people having installed their OPNFV solution to perform the same tests on their solution
15:15:26 <lmcdasm> #agreed
15:15:43 <lmcdasm> feedback loop from individuals is vital
15:15:54 <morgan_orange> #info functest documentation describes (or shall describe) the testcases, the tools needed (robot and rally) and the procedure to perform the tests
15:16:23 <frankbrockners> #info does documentation also cover how the tools will be installed (for user-driven testing)?
15:17:11 <morgan_orange> #info yes => needed because there is some customization to be planned depending on the installation (login password of Openstack to source the rc file for instance)
15:17:31 <frankbrockners> perfect - thanks morgan_orange for the great update
15:17:54 <frankbrockners> any additional notes/questions on functest - or can we move on?
15:18:21 * frankbrockners taking silence as no...
15:18:26 <frankbrockners> #topic LF hardware config: changes / finalization
15:18:45 <frankbrockners> pbandzi could you give us an update on the most recent plans and discussions?
15:18:54 <pbandzi> yes
15:19:25 <pbandzi> #info we plan to work with erricson to configure POD1
15:20:07 <pbandzi> #info plan to set vlan 411 as deafult for public network which I hope will get rid of unneded VLAN0 tag
15:20:45 <pbandzi> #info need to agfee on maintanence windoiw with both teams Fuel and Foreman
15:21:25 <pbandzi> that's all
15:21:25 <frankbrockners> pbandzi: Do you have a suggestion for the maintenance window?
15:21:50 <pbandzi> #info can be done also after this meeting from my side
15:22:24 <frankbrockners> so that would be 9-10am PDT == 6-7pm CET...
15:22:30 <frankbrockners> does this work for everyone?
15:22:41 <frankbrockners> (i.e. no LF lab access during that time)
15:22:42 <[1]JonasB> OK with me
15:22:52 <frankbrockners> trozet: ok for you?
15:22:58 <trozet> not really
15:23:08 <trozet> well
15:23:18 <frankbrockners> any other suggestion - we can do tomorrow
15:23:38 <trozet> yeah tomorrow would be better if possible
15:23:49 <trozet> was hoping to try to deploy everything in the next hour or so
15:23:51 <frankbrockners> how about 9am CET == 12am PDT
15:24:00 <frankbrockners> tomorrow
15:24:07 <pbandzi> #info for me it's ok as well
15:24:15 <[1]JonasB> What time?
15:24:16 <pbandzi> #undo
15:24:18 <pbandzi> undo
15:24:27 <trozet> that's fine with me
15:24:47 <frankbrockners> Jonas - suggestion is 9am CET == 12am PDT tomorrow (Apr/28)
15:25:38 <frankbrockners> [1]JonasB>
15:25:46 <frankbrockners> [1]JonasB: suggestion is 9am CET == 12am PDT tomorrow (Apr/28)
15:25:57 <[1]JonasB> Ok
15:26:12 <frankbrockners> sounds like we found a window.
15:27:07 <frankbrockners> #agree maintenance window to perform config changes to LF HW: 9am CET (==12am PDT - midnight) to 10am CET (1am PDT) on Apr/28
15:27:18 <frankbrockners> anything else on LF HW config?
15:27:48 * frankbrockners does not seem to be the case... moving on
15:27:53 <frankbrockners> #topic BGS status and workplan review
15:28:22 <frankbrockners> Jonas or Tim - could you give us a quick update on where things are from a deployment tool perspective?
15:29:03 <trozet> #info Was able to deploy a single node on Friday.  I think the network setup is good now in UCS
15:29:24 <trozet> #info needed a patch for our deploy to work with current LF environment where Admin network has no internet access and need to NAT to public
15:29:36 <trozet> #info have a patch for that issue and going to try it out here shortly.
15:29:50 <trozet> end of status
15:29:57 <frankbrockners> thanks tim
15:30:02 <frankbrockners> Jonas?
15:30:07 <rprakash> # tim good progress
15:30:13 <[1]JonasB> #info No new status since last Fri
15:30:41 * frankbrockners that was really brief :-)
15:30:48 <frankbrockners> thanks Jonas
15:31:25 <frankbrockners> as a prep for the TSC - could all of you review https://wiki.opnfv.org/releases/arno/releasereadiness and update to reflect the latest status?
15:31:44 <trozet> ok will look at it today
15:31:59 <frankbrockners> trozet: thanks
15:32:21 <frankbrockners> [1]JonasB - could you take a look as well?
15:32:27 <[1]JonasB> Will
15:32:47 <frankbrockners> pbandzi - could you look at the LF HW piece on the wiki?
15:32:57 <pbandzi> yes
15:33:09 <frankbrockners> thanks guys - just record this as an action:
15:33:29 <frankbrockners> #action trozet: Update  https://wiki.opnfv.org/releases/arno/releasereadiness to reflect most recent status
15:33:40 <frankbrockners> #action pbandzi: Update  https://wiki.opnfv.org/releases/arno/releasereadiness to reflect most recent status
15:33:51 <frankbrockners> #action [1]JonasB: Update  https://wiki.opnfv.org/releases/arno/releasereadiness to reflect most recent status
15:34:13 <frankbrockners> #info Any additional urgent issues that require attention?
15:35:16 <frankbrockners> #info No additional urgent issues mentioned...
15:35:26 <frankbrockners> looks like we're done with the agenda.
15:35:35 <frankbrockners> anything else that needs to be covered?
15:35:57 <frankbrockners> going once...
15:36:11 <frankbrockners> going twice...
15:36:30 <frankbrockners> thank you
15:36:35 <frankbrockners> #endmeeting