#opnfv-meeting: OPNFV Test and Performance

Meeting started by trevor_intel at 14:02:03 UTC (full logs).

Meeting summary

    1. Trevor Cooper (trevor_intel, 14:02:15)
    2. Morgan Richomme (morgan_orange, 14:03:00)
    3. Ana Cunha (anac, 14:03:00)
    4. Jose Lausuch (jose_lausuch, 14:03:12)
    5. Fatih Degirmenci (fdegir, 14:03:28)
    6. Manuel Rebellon (ManuelR_Sandvine, 14:03:56)
    7. Martin Taylor (martin_taylor, 14:04:46)
    8. ulik (ulik, 14:05:13)
    9. https://global.gotomeeting.com/public/prelogin.html#numbers/primary/305553637 (jose_lausuch, 14:07:33)

  1. Functest (trevor_intel, 14:08:38)
    1. release 1 status (trevor_intel, 14:08:58)
    2. 1. Benchtest - Rally, finalizing scenarios 2. Tempest with funcational tesing on OS 3. Open Daylight. 4. vPing - few lines of Python (trevor_intel, 14:10:57)
    3. vIMS test ... Heat templaes to deploy VNF components and VM that generates load (trevor_intel, 14:12:24)
    4. http://artifacts.opnfv.org/functest/docs/functest.html (morgan_orange, 14:12:32)
    5. Main issue ... need ability to spin up VMs ... cannot do that with OS API or Horizon (trevor_intel, 14:12:51)
    6. to install SW from public internet need to get out from OS ... settting up neutron router has been a challenge (trevor_intel, 14:14:01)
    7. Foreman deployment on Intel POD ... does not support Heat (trevor_intel, 14:14:41)
    8. LF has 2 PODs ... 1) Fuel 2) Foreman ... still issues re. firewall (trevor_intel, 14:16:17)
    9. Morgan can connect to jump host ... green light for Foreman install. Expect to do Rally and tempest test cases next week (trevor_intel, 14:17:22)
    10. https://wiki.opnfv.org/opnfv_functional_testing (morgan_orange, 14:17:36)
    11. next week should have heat support on Fuel deployment (trevor_intel, 14:19:39)
    12. How to cordinate access wtih testing on the PODs? Daily BGS call being used to coordinate for Rls 1 activities (trevor_intel, 14:23:52)
    13. On Monday functest will sync with BGS for green light to test (trevor_intel, 14:24:41)
    14. for synchronization => #opnfv-bgs and #opnfv-testperf (morgan_orange, 14:26:24)
    15. POD 2 Intel needs reinstallation of Foreman setup wtih more mature version (trevor_intel, 14:28:14)
    16. wait for finalization of deployment versions before updating PODs ... focus on Linux Foundation for rls 1 (trevor_intel, 14:30:07)
    17. documentation progress made ... still some work to do. For now just concentrationg on manually running tests .... then automate with Jenkins (trevor_intel, 14:31:34)
    18. need volenteers to read docs and improve it (trevor_intel, 14:32:16)
    19. https://wiki.opnfv.org/releases/arno/releasereadiness (trevor_intel, 14:33:34)
    20. Requested for new committers (trevor_intel, 14:36:54)
    21. 2 new committers ... voting process by email ... Morgan to count votes and let TSC knwo outcome (trevor_intel, 14:38:43)
    22. Restart this timeslot for weekly meeting ... will still be used for functest and pharos (trevor_intel, 14:40:19)
    23. works for most (trevor_intel, 14:40:35)

  2. Beyond R1 (trevor_intel, 14:41:10)
    1. tests for R1 are based on existing test suites ... define our own additional test cases with KPIs (trevor_intel, 14:42:23)
    2. sync with ETSI test scenarios re. predepolyment testsing (trevor_intel, 14:43:02)
    3. 1) New VNFs to be automated and tested ... Open Source 2) Proprietary VNFs ... e.g. SBC (trevor_intel, 14:46:52)
    4. ACTION: Trevor invite Maryam to this meeting to give overview of vSwitch testing (trevor_intel, 14:47:18)
    5. ACTION: Trevor - Post release 1 follow up with ETSI and how to work together (trevor_intel, 14:53:26)
    6. yardstick planned to be aligned with reco from ETSI testing working group (morgan_orange, 14:54:05)
    7. ACTION: Morgan create Wiki Page for functest activites after release 1 ... all provide input (trevor_intel, 14:56:48)

  3. Pharos (trevor_intel, 14:57:08)
    1. focus on yardstick to be planned next week (30') (morgan_orange, 15:00:38)
    2. next meeting spend 30 min on Yardstick project (trevor_intel, 15:01:44)


Meeting ended at 15:01:51 UTC (full logs).

Action items

  1. Trevor invite Maryam to this meeting to give overview of vSwitch testing
  2. Trevor - Post release 1 follow up with ETSI and how to work together
  3. Morgan create Wiki Page for functest activites after release 1 ... all provide input


People present (lines said)

  1. trevor_intel (35)
  2. morgan_orange (9)
  3. dneary (3)
  4. collabot (3)
  5. jose_lausuch (3)
  6. ulik (3)
  7. ManuelR_Sandvine (2)
  8. fdegir (1)
  9. martin_taylor (1)
  10. anac (1)


Generated by MeetBot 0.1.4.