13:58:09 <ulik> #startmeeting octopus weekly meeting
13:58:09 <collabot> Meeting started Mon May 11 13:58:09 2015 UTC.  The chair is ulik. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:58:09 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
13:58:09 <collabot> The meeting name has been set to 'octopus_weekly_meeting'
13:59:07 <ulik> #info Hi everybody! Let's start weekly octopus call.
13:59:19 <ulik> #topic roll call
13:59:46 <ulik> #info Participants, please type #info
13:59:49 <dneary> Hi ulik
13:59:54 <fdegir> #info Fatih Degirmenci
13:59:57 * ulik Hi!
14:00:00 <dneary> #info dneary
14:00:01 <ulik> #info Uli
14:00:03 <zhifeng> #info zhifeng
14:00:04 <trozet> #info Tim Rozet
14:00:10 <dneary> Lurking mostly
14:00:12 <MatthewL1> #info Jun Li
14:00:15 <kun_huang> #info Kun Huang
14:00:46 <ulik> #topic Agenda bashing
14:01:03 <ulik> #info I have put to agenda:
14:01:17 <ulik> #info Rollcall - Agenda bashing - Action item review - Arno Release follow-up - Maintenance for Arno Release - Vancouver OpenStack summit - next meeting
14:01:40 <rprakash> #info rprakahs
14:02:04 <ulik> anything I should add?
14:02:30 <ulik> should we look at open or unassigned Jira's?
14:03:07 <fdegir> why not
14:03:19 <ulik> ok
14:03:19 <kun_huang> interested in Arno status
14:03:42 <ulik> Arno release follow-up is on it
14:04:00 <ulik> #info adding open or unassigned Jira's to agenda.
14:04:15 <narindergupta> #info
14:04:20 <ulik> no other proposal, so let's start.
14:04:33 <ulik> #topic action item review
14:04:34 <narindergupta> #info narindergupta
14:05:25 <ulik> #info Action from last week: ulik and vlaza: add a note how to comment on documents under "document tracking"
14:06:04 <ulik> I think I didn't do it. vlaza?
14:06:42 <ulik> #info still open
14:07:31 <ulik> #info Action from last week: ulik: ask around... and then let's come back with the question whether we need something of octopus in arno docs.
14:08:00 <ulik> I think we clarified in TSC call and we provide one document
14:08:35 <MatthewL1> well but we should try more docs
14:08:43 <ulik> fdegir: I saw you prepared it for the release. Is everything done?
14:09:00 <fdegir> #link https://wiki.opnfv.org/octopus/jenkins_slave_connection
14:09:01 <MatthewL1> since many things are envolving, not only our ci-infra etc
14:09:25 <fdegir> MatthewL1: perhaps you can type your suggestions here
14:09:30 <fdegir> and we discuss it next meeting
14:09:52 <fdegir> and ulik can bring to TSCs attention with the reasons
14:10:26 <MatthewL1> the TSC said that because that many of our Docs will change some day, I think this doesn't quite reasonable
14:11:17 <MatthewL1> the codes in BGS and fuctest will envoled also in the future
14:12:39 <MatthewL1> and the code structure may change someday
14:12:49 <fdegir> do we have a deliverable?
14:13:10 <fdegir> a spec, code which is used for building something, test spec, etc?
14:13:22 <MatthewL1> the other four docs and may be the jjb in releng
14:13:36 <fdegir> sorry to say that but I don't see point in discussing this further
14:13:48 <fdegir> you can take some time during TSC call and explain these there
14:13:52 <ulik> The jjb system is used for building.
14:14:23 <MatthewL1> this is my opinion, so welcome any comments
14:14:40 <fdegir> since we have disagreemnts in very basic definitions - which is good, don't take it wrong
14:14:49 <fdegir> and I think TSC is the one who takes decision
14:14:56 <fdegir> and the current decision is to include one document
14:15:00 <MatthewL1> of course
14:15:23 <fdegir> we already have documents as well so this doesn't add an extra work
14:15:41 <fdegir> but how relevant is the CI documents is the question
14:15:51 <fdegir> when one looks at it from "release" point of view
14:16:21 <MatthewL1> well
14:16:30 <ulik> I think we should include if the way we do things helps Arno to come up.
14:16:53 <ulik> E.g. jjb allows project to control their own builds.
14:16:53 <MatthewL1> yep this is the point which I agree
14:17:36 <ulik> Let's work on a clear proposal what and why to include. Should I action you MatthewL1?
14:17:45 <MatthewL1> ok
14:17:57 <fdegir> I thought we had an agreement last week
14:18:10 <fdegir> which ulik, you also pointed same
14:18:35 <MatthewL1> something we may not make very clear that time
14:18:40 <fdegir> but anyway, if that's the way, that's the way
14:19:06 <ulik> ok. Let's move on.
14:19:14 <fdegir> I think we have more important things to do rather than arguing on what document to include
14:19:31 <ulik> #topic Arno Release follow-up
14:19:39 <MatthewL1> yep...
14:19:46 <ulik> fdegir, can you give us an update?
14:20:12 <fdegir> #info Still not much progress on BGS work in CI
14:20:28 <fdegir> #info LF lab reconfigured due to some networking issues
14:20:39 <ulik> I thought Foreman is triggered by CI?
14:20:41 <fdegir> #info This will require some changes for Foreman
14:21:10 <fdegir> #info Not all Foreman scripts are in OPNFV Gerrit
14:21:22 <fdegir> #info Foreman deployment was done using stuff from Github
14:21:43 <trozet> fdegir it should be the same now.  Frank merged the commits
14:21:44 <fdegir> #info Foreman hasn't been retriggered since last week due to 1st point: LF reconfiguration
14:22:24 <fdegir> trozet: jobs haven't been updated yet
14:22:33 <trozet> fdegir: do you need me to change the IP on the jumphost or help with anything to redeploy?
14:22:38 <fdegir> trozet: and inventory file is also outdated
14:22:53 <fdegir> trozet: that would be good
14:22:58 <fdegir> we can retrigger deployment
14:23:01 <ulik> So LF reconf is completely done now?
14:23:17 <fdegir> there are still some issues which Fuel team is talking to LF
14:23:24 <ulik> And jenkins slaves up?
14:23:43 <fdegir> ulik: pod2 jumphost is still down
14:23:47 <fdegir> aricg is working on it
14:23:51 <aricg> yep
14:23:54 <ulik> Will they need multiple reconf's?
14:24:11 <fdegir> don't have all the details - perhaps bgs meeting will help us get more info
14:24:47 <ulik> OK. Can we trigger all the tests functest wants to be part of Arno?
14:24:59 <fdegir> perhaps we can action trozet for inventory update, trozet for checking with fuel team to see if it is ok to retrigger foreman deployment, and fdegir for retriggering deployment
14:25:42 <ulik> #action trozet for inventory update
14:25:49 <fdegir> #info openstack-bench-test, smoke-test, and vping-test can be triggered
14:25:59 <fdegir> #info vims-test is still hello world
14:26:27 <fdegir> #info some test cases fail and FuncTest is troubleshooting them
14:26:27 <ulik> can we action somebody from fuel?
14:26:38 <trozet> fdegir: what is the inventory update?  Is that the yaml settings file?
14:26:38 <fdegir> for what?
14:26:46 <fdegir> trozet: yes
14:27:02 <trozet> fdegir: that shouldn't need updating, it isnt based on IP addresses
14:27:29 <fdegir> trozet: so you don't need any updates for latest changes in LF lab?
14:27:43 <ulik> trozet for checking with fuel team to see if it is ok to retrigger foreman deployment - shouldn't we check with aric whether reconf is completed instead?
14:27:58 <trozet> fdegir: I just need to check to see if we need to change the IP address on the jumphost.
14:28:07 <fdegir> when I asked to trozet or radez last week whether we can trigger foreman deployment again
14:28:08 <trozet> ulik: Konstantin sent out an email Friday saying the changes were complete
14:28:17 <fdegir> I got an answer that it might cause issues for fuel
14:28:23 <fdegir> that's the reason for checking with fuel guys
14:28:40 <ulik> Who from Fuel is here?
14:29:10 <aricg> pod2 online
14:29:22 <fdegir> lmcdasm is here but he might not be the one who is working on this specific problem
14:29:36 <fdegir> stefan_berg isn't here
14:29:48 <ulik> aricg: do you have more requests from Fuel that might affect Foreman?
14:30:19 <aricg> this is dans last address: Hello.
14:30:20 <aricg> I think that since DHCP /ARP is a broadcast address, simply changing the subnet is not going to address the issue (since it will broadcast at 255.255.255.255 - all addresses),  DHCP separate requires VLAN tagging or a L2 subnet separation as far as I know.
14:30:44 <trozet> aricg: thats not correct
14:30:47 <aricg> right
14:30:48 <aricg> inet 172.30.10.72  netmask 255.255.255.0  broadcast 172.30.10.255
14:30:53 <aricg> it should be seperate now.
14:31:03 <aricg> so. I think that everything can move forward
14:31:18 <fdegir> can we action trozet to get input from bgs meeting and the we retrigger deployment?
14:31:34 <fdegir> since he's the one who is here from bgs at the moment
14:32:03 <lmcdasm> i am here as  well - however, not logged in.. discussion with SBerg and team... we can see that the DHCP server seems to be listening on all interfaces (including Public) on the POD2
14:32:05 <trozet> fdegir: OK I'll look into it shortly then let you know to redeploy.  morgan_orange you arent using the POD right?
14:32:06 <lmcdasm> not sure if that is still valid.
14:32:43 <lmcdasm> further to my comment, since the router and the switch are not the same thing
14:33:09 <lmcdasm> anything inside that fabric is going to see the DHCP request, since there isnt a vlan seperating them and the router (that cordons off the broadcast network) is not on the same box at all
14:33:29 <lmcdasm> so if you are sending an untagged ARP, then everyone in that fabric is going to see it (the UCS fabric is not a l3 switch)
14:34:04 <ulik> I am a bit confused now. aricg said it should be seperate now.
14:34:16 <lmcdasm> im referring tot he mail from Konstantiv
14:34:33 <lmcdasm> where a different subnet was assigned.. while you can assign a different subnet, DHCP is before IP assigned
14:34:39 <aricg> who setup the vlans for the new config?
14:34:44 <lmcdasm> so if all the nodes are still sitting on the same piece of wire then you are done
14:35:05 <aricg> >> Move POD2 interfaces into vlan 412 and test it out
14:35:05 <trozet> so we don't have separate VLANS? Konstantin set it up I think
14:35:12 <lmcdasm> if there was a new VLAN introduces that fine, however the DHCP server should be setup to listen on that vlan only and not all
14:35:38 <lmcdasm> i saw that Konstantin provisioned the new VLANs in his mail - however was the correspoding VLAN setup (on the NICs on POD2) done as well?
14:35:59 <aricg> lmcdasm: I dont see anything about the new vlan on pod 2 having been done
14:36:05 <trozet> lmcdasm: We don't need tagging, just different VLANs in the switch
14:36:12 <trozet> so there doesnt need to be any vlan configuration on the jumphost
14:36:15 <lmcdasm> hey there.
14:36:22 <lmcdasm> sorry - lemme get the mail
14:36:30 <lmcdasm> true seperation Konstantine said would need a maintenance window
14:36:41 <lmcdasm> so he provisioned a new subnet as i understand and provided some vlan tags
14:36:51 <lmcdasm> that means that to get your separation your JS host must use that vlan only
14:37:00 <lmcdasm> if you are listening on all (untagged) NICs on your JS host
14:37:07 <lmcdasm> then anything that is in that UCS fabric is gonna see it
14:37:08 <trozet> lmcdasm: I think thats setting the fabric interconnect VLAN
14:37:20 <trozet> pbandzi, did you do that for LF pod2?
14:37:27 <pbandzi> yes
14:37:31 <trozet> great thanks
14:37:55 <pbandzi> I think you just need to start auto deploy again with new public subnet
14:39:28 <ulik> Is it clear now? If there are more networking details, we should move that offline. What I would like to understand is: Is Foreman still blocked by the reconfiguration we do for Fuel?
14:39:52 <pbandzi> trozet: in fact no any change for pod2 except  IP address
14:40:08 <trozet> ulik: No I don't think so.  Just need to change the ip address then we can trigger from Jenkins
14:40:31 <ulik> OK. Then I don't need to action you any more.
14:41:25 <ulik> Third part of fdegir's proposal was retriggering deployment
14:41:56 <fdegir> which requires 5 minutes of work to start using foreman scripts from opnfv gerrit
14:42:04 <fdegir> which I can fix it once the meeting is over
14:42:08 <ulik> So we don't need action #2, but can retrigger deployment.
14:42:21 <ulik> should I action you for 5 minutes?
14:42:24 <fdegir> nope
14:42:28 <ulik> :-)
14:42:41 <ulik> OK.
14:42:53 <ulik> So anything we have to do on the Fuel side?
14:43:10 <fdegir> I'm not sure
14:43:20 <fdegir> we have to listen the meeting and take action based on the outcome
14:44:28 <ulik> OK.
14:44:44 <ulik> Just scrolled back to fdegir's report from tests.....
14:45:03 <ulik> That was on POD2?
14:45:11 <fdegir> I think so
14:45:13 <fdegir> Chris called for help with analysing test failures
14:45:41 <ulik> OK so we are done with everything on POD2?
14:45:57 <fdegir> we had deployment and testing there
14:46:02 <fdegir> but they were manually triggered
14:46:16 <fdegir> so we didn't have full/unattended run
14:46:24 <ulik> How's the plan to get that automated?
14:46:35 <fdegir> there will be one jobs
14:46:44 <fdegir> that is triggering the build, deploy, and test jobs
14:46:46 <fdegir> in sequence
14:47:30 <fdegir> and that's it for Arno
14:47:41 <ulik> Sounds like a handful of 5/minutes tasks on your side :-)
14:47:55 <fdegir> that's already there
14:47:59 <fdegir> just connecting jobs
14:48:07 <fdegir> daily-master is the one that is the "parent" job
14:48:18 <fdegir> and build, deploy, functest jobs are there as well
14:48:34 <fdegir> so 1 more 5 minutes I think - excluding troubleshooting
14:49:00 <ulik> OK so I can safely report that octopus is finished on POD2, but a bit more work for POD1 to come.
14:49:14 <fdegir> I wouldn't say "finished"
14:49:15 <ulik> ?
14:49:19 <fdegir> but almost there
14:49:57 <ulik> OK. I mean we do Arno status for Octopus here and not for BGS.
14:50:09 <fdegir> again, almost there
14:50:16 <fdegir> we still have 2 x 5 minutes work to do
14:50:42 <ulik> :😃
14:51:14 <ulik> so this was status of Arno....
14:52:06 <ulik> I think we have to jump a bit in agenda... sorry
14:52:15 <ulik> #topic Vancouver summit
14:53:01 <ulik> #info we don't have a separate session, but I think it would be good to know who will be there from octopus team.
14:53:15 <ulik> I will be there.
14:53:20 <fdegir> me too
14:53:29 <zhifeng> I will be there.
14:54:04 <ulik> sounds like not many more.
14:54:18 <ulik> #topic next meeting
14:54:33 <ulik> Should we have a meeting next Monday?
14:55:38 <ulik> OK. Let's try to skip it.
14:55:39 <[1]JonasB> join/opnfv-bgs
14:55:42 <radez> ulik: I'll be around too
14:56:08 <ulik> Good. So 4 of us. Let's try get together shortly then.
14:56:14 <fdegir> yes
14:56:39 <ulik> #info no meeting on May 18.
14:56:59 <ulik> #info we have to skip topic Maintenance for Arno.
14:57:19 <fdegir> we will have lots of time for it
14:57:21 <ulik> so we end the meeting in time....
14:57:24 <fdegir> also a proposal is waiting
14:57:33 <fdegir> which I don't have a link
14:57:41 <ulik> ?
14:57:54 <fdegir> #link https://wiki.opnfv.org/get_started/release_and_maintenance
14:58:10 <fdegir> so we can read it and think about what implications it could have on octopus
14:58:15 <fdegir> action to everyone :D
14:58:22 <ulik> will have a look. But we need close now for BGS.
14:58:37 <fdegir> thanks everyone
14:58:38 <ulik> #endmeeting