#opnfv-meeting: OPNFV BGS Arno release readiness - daily check in

Meeting started by frankbrockners at 16:00:08 UTC (full logs).

Meeting summary

    1. Jonas Bjurel ([1]JonasB, 16:00:13)
    2. Frank Brockners (frankbrockners, 16:00:13)
    3. Fatih Degirmenci (fdegir, 16:00:20)
    4. Peter Bandzi (pbandzi, 16:00:47)
    5. Tim Rozet (trozet, 16:01:05)
    6. Jose Lausuch (jose_lausuch, 16:02:01)

  1. updates on functional testing (frankbrockners, 16:03:36)
    1. POD1 fresh installed, I'll run tests today and tomorrow (jose_lausuch, 16:03:55)
    2. the node will be released to BGS on Monday (jose_lausuch, 16:04:03)
    3. From moday on we will have nightly re-deploys ([1]JonasB, 16:04:50)
    4. Morgan Richomme (morgan_orange, 16:04:51)
    5. test status page updated (morgan_orange, 16:05:57)
    6. https://wiki.opnfv.org/r1_tempest (morgan_orange, 16:06:05)
    7. https://wiki.opnfv.org/r1_rally_bench (morgan_orange, 16:06:12)
    8. http://opnfv.orange.org/test/opnfv-nova-13052015_0542.html (morgan_orange, 16:06:40)
    9. http://opnfv.orange.org/test/ (morgan_orange, 16:06:59)
    10. vPing failed on POD 2 but could be due to previous test (will check and clean existing networks) (morgan_orange, 16:07:25)
    11. functest doc updated (morgan_orange, 16:09:48)
    12. JIRA on config set to resolved (morgan_orange, 16:10:05)
    13. there are plans for a "r1_robot" wiki to show results similar to tempest and rally (per pbandzi) (frankbrockners, 16:11:27)
    14. docs update, formatting and content completion ongoing across teams. (ChrisPriceAB, 16:13:55)

  2. updates on docs (frankbrockners, 16:14:22)
    1. docs update, formatting and content completion ongoing across teams (per ChrisPriceAB) (frankbrockners, 16:15:07)
    2. docs identified and content completion ongoing. (ChrisPriceAB, 16:15:16)
    3. focus on terminology and facts in rags (ChrisPriceAB, 16:15:37)
    4. will provide and inventory and jira jobs by Monday (ChrisPriceAB, 16:17:02)

  3. updates on POD1 and POD2 autodeployment (frankbrockners, 16:18:00)
    1. POD1 autodeploy driven by Jenkins complete ([1]JonasB, 16:18:34)
    2. Healtchecks all show green ([1]JonasB, 16:18:49)
    3. https://build.opnfv.org/ci/view/genesis/job/genesis-fuel-deploy/7/consoleFull ([1]JonasB, 16:19:10)
    4. functest will start working on POD1 ([1]JonasB, 16:19:28)
    5. We will not run nightlys on POD1 before night between 18 and 19 to give functest air time ([1]JonasB, 16:20:10)
    6. A patch was submitted to make vPING work for Fuel, one more patch will be needed to avoid manual intervention ([1]JonasB, 16:20:57)
    7. The ODL - OS HA proxy issue is a little bit more open ended than we first thought / would have hoped. Working on it ([1]JonasB, 16:21:59)
    8. We know what the issue is, quite related to Fuel. But the solution is time consuming, and maybe not in the direction we would like to go. ([1]JonasB, 16:24:39)
    9. We have a prototype doing things in other ways wich seems to work, but to much change to dare throwing it in now! ([1]JonasB, 16:25:42)
    10. updates on POD2 / Foreman-Quickstack deploy tool (frankbrockners, 16:28:02)
    11. installation of the iso foreman in Orange POD1 OK (morgan_orange, 16:29:08)
    12. BUT installation failed because of network card order (morgan_orange, 16:29:38)
    13. Tim proposed to use a branch of his github to fix the issue (morgan_orange, 16:30:06)
    14. working on the patch for external network creation (trozet, 16:33:26)
    15. hoping to be able to finish testing on intel pod and get a gerrit review tomorrow (trozet, 16:33:49)
    16. foreman build and deploy are ready (per fdegir) (frankbrockners, 16:36:32)
    17. standalone FuncTests were run before as well (per fdegir) (frankbrockners, 16:36:48)
    18. but morgan_orange's latest smoke jobs weren't run yet (functest-opnfv-jump-2 that is) (fdegir, 16:37:06)
    19. waiting on green light from functest to start autodeploy of POD2 (frankbrockners, 16:37:06)
    20. fdegir to check with morgan_orange, trozet and phladky before doing anything (fdegir, 16:39:42)
    21. on POD2 to enable nightly autodeploy (fdegir, 16:40:02)
    22. I don't know if we want to enable nightly deploy yet do we? Aren't folks still debugging functest issues real time during hte day? (trozet, 16:40:34)
    23. Nightly runs are triggered around 00:00 UTC (fdegir, 16:41:53)
    24. AGREED: Nightly (00:00 UTC) autodeploys on POD2 from now onwards (frankbrockners, 16:47:19)
    25. As a side note, if there is no change in genesis repo, nightly runs are skipped by default (fdegir, 16:47:29)
    26. This can be adjusted later on (fdegir, 16:47:35)
    27. Artifact/ISO naming: we currently store ISOs with build numbers: opnfv-23.iso for example. (fdegir, 16:50:00)
    28. this will be changed to date-timestamp: opnfv-2015-05-13_02-01-35.iso for example. (fdegir, 16:50:17)
    29. Artifact/ISO retention policy: We can perhaps remove all the ISOs but latest 7(?). (released ISO(s) will be excluded from automatic removal.) (fdegir, 16:50:44)
    30. AGREED: ISO builds will use UTC timestamp for numbering purposes - at least for now (frankbrockners, 17:01:49)


Meeting ended at 17:02:09 UTC (full logs).

Action items

  1. (none)


People present (lines said)

  1. frankbrockners (85)
  2. fdegir (69)
  3. morgan_orange (35)
  4. ChrisPriceAB (27)
  5. [1]JonasB (25)
  6. jose_lausuch (12)
  7. trozet (10)
  8. pbandzi (5)
  9. collabot (3)
  10. arnaud_orange (1)


Generated by MeetBot 0.1.4.