#opnfv-meeting: Doctor project

Meeting started by cgoncalves at 13:02:56 UTC (full logs).

Meeting summary

  1. OpenStack Summit report (related to Doctor) (Gerald_K, 13:05:01)
  2. roll-call (r-imbu, 13:06:04)
    1. Agenda for today: https://etherpad.opnfv.org/p/doctor_meetings (cgoncalves, 13:08:43)
    2. Bryan Sullivan (bryan_att, 13:10:52)

  3. OpenStack Summit report (related to Doctor) (Gerald_K, 13:13:24)
    1. https://global.gotomeeting.com/join/409154429 (Gerald_K, 13:13:57)
    2. 30min Doctor BreakOut session: presented content of deliverable, mainly focus on use cases and implementation plan (Gerald_K, 13:15:58)
    3. Doctor deliverable: https://wiki.opnfv.org/_media/doctor/doctorfaultmanagementandmaintenance.pdf (cgoncalves, 13:16:06)
    4. Doctor deliverable: https://wiki.opnfv.org/_media/doctor/doctorfaultmanagementandmaintenance.pdf (Gerald_K, 13:16:25)
    5. Offline meetings with core developers of Ceilometer and Nova; received positive feedback on both BPs (Gerald_K, 13:17:24)
    6. BPs got accepted in the design summit sessions; approval in the OpenStack Gerrit is expected; updates to BPs required (Gerald_K, 13:19:03)
    7. Ildiko confirmed that current state is good; next step is to start implementation from easier use case (Gerald_K, 13:20:35)
    8. first changes to BPs have been submitted to address comments from Summit (Gerald_K, 13:21:06)
    9. Intel started to develop code related to Tomi's Nova BP (Gerald_K, 13:22:12)
    10. https://review.openstack.org/#/q/topic:bp/mark-host-down,n,z (Gerald_K, 13:22:23)
    11. https://review.openstack.org/#/c/169836/ (r-mibu_, 13:22:38)
    12. https://review.openstack.org/#/c/169836/ (Gerald_K, 13:22:48)
    13. Bryan_att: we should collect BP contributors at OPNFV Wiki page, e.g. how is contributing/engaged? (Gerald_K, 13:24:10)
    14. https://wiki.opnfv.org/community/openstack?s[]=openstack (cgoncalves, 13:24:46)
    15. ACTION: Carlos to update Wiki (Gerald_K, 13:25:18)
    16. Bryan_att: intend is to see who is actively contributing to/on behalf of OPNFV; track status of BP as it develops (Gerald_K, 13:27:35)
    17. Ceilometer BP: https://review.openstack.org/#/c/172893/ (Gerald_K, 13:30:38)
    18. Bryan_att: we need to start cross-project coordination in OPNFV for some broader topics, e.g. regarding policy (Gerald_K, 13:31:54)
    19. ACTION: Bryan_att to send suggestion on the list (Gerald_K, 13:32:39)

  4. Report from informal meeting with ETSI NFV REL, OPNFV HA and OPNFV Doctor at NFV #10 in Sanya (Gerald_K, 13:33:21)
    1. informal session on request by ChinaMobile (HA team) with REL group; mainly introduction on OPNFV project and working style (Gerald_K, 13:34:42)
    2. outcome: proposal to have better connections between organisations/team, e.g. have a dedicated contact person from each project (Gerald_K, 13:35:27)
    3. inital concern about overlap between requirements of REL and OPNFV, but different levels of requirements; OPNFV is more detailed and focused on gaps with upstream projects (Gerald_K, 13:36:42)
    4. REL contact person is Gurpreet Singh (Gerald_K, 13:38:00)
    5. he is working on "active monitoring" (Gerald_K, 13:38:25)
    6. bryan_att are there specific things coming out of REL that could be helping our implementation? Tommy: don't think so; REL has already created specification with number of requirements that should be considered (Gerald_K, 13:40:43)
    7. bryan_att do we assume IFA group is taking action based on REL requirements? Tommy: currently postponed (Gerald_K, 13:41:57)
    8. Dan: there are already elements that have been considered e.g. as metadata in the VIM; there are attributes that are immutable; there are "design constraints" (not real policies) available (Gerald_K, 13:44:02)
    9. bryan_att: OPNFV should move faster to turn our concepts into requirements, e.g. HA capabiltiy of VNF will trigger certain actions in fault mgmt to ensure such HA (Gerald_K, 13:45:04)
    10. Dan: some of the attributes have already been identified in Phase1 (Gerald_K, 13:45:33)
    11. bryan_att: should be documented in our Wiki (Gerald_K, 13:45:52)
    12. Tommy: coming back to Doctor, one action from last meeting was to keep contact with Gurpreet. Tommy volunteered to do this. (Gerald_K, 13:46:54)
    13. AGREED: Tommy is contact person towards REL for Doctor (Gerald_K, 13:47:33)

  5. Status of deliverable (Gerald_K, 13:48:41)
    1. https://wiki.opnfv.org/_media/doctor/doctorfaultmanagementandmaintenance.pdf (Gerald_K, 13:49:00)
    2. first version generated; next step is to fix editorial bugs and finalize review comments (Gerald_K, 13:50:21)
    3. ACTION: address open review comments (Gerald_K, 13:50:52)

  6. Doctor promotions (Gerald_K, 13:51:20)
    1. Gerald_K to become committer/contributor of Doctor (Gerald_K, 13:52:10)
    2. on the last topic: I suggest specifically that the reliability-related VNF/service attributes that ETSI is discussing be tracked on the OPNFV wiki (or in some doc published on the wiki) and we further define how a reliability/fault/policy system will use those attributes, e.g. for orchestration and closed-loop reliability policy management. (bryan_att, 13:52:57)
    3. open nominations for committers/contributors from April 8th (Gerald_K, 13:53:50)
    4. The goal is that we actively push the envelope on developing the VNF package atttribute support that will impact code we upstream in OpenStack, and SDNC projects, for fault mgmt etc (bryan_att, 13:54:09)

  7. Next meeting (Gerald_K, 13:54:33)
    1. June 2nd (Gerald_K, 13:54:42)
    2. https://wiki.opnfv.org/developer/committer_promotions committer promotion process (ChrisPriceAB, 13:55:11)


Meeting ended at 13:55:57 UTC (full logs).

Action items

  1. Carlos to update Wiki
  2. Bryan_att to send suggestion on the list
  3. address open review comments


Action items, by person

  1. bryan_att
    1. Bryan_att to send suggestion on the list
  2. UNASSIGNED
    1. Carlos to update Wiki
    2. address open review comments


People present (lines said)

  1. Gerald_K (41)
  2. cgoncalves (11)
  3. bryan_att (5)
  4. collabot (5)
  5. ChrisPriceAB (4)
  6. r-imbu (4)
  7. ManuelR_Sandvine (2)
  8. r-mibu_ (1)


Generated by MeetBot 0.1.4.