14:00:38 <uli-k> #startmeeting Octopus weekly meeting
14:00:38 <collabot> Meeting started Mon Jun  1 14:00:38 2015 UTC.  The chair is uli-k. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:38 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:00:38 <collabot> The meeting name has been set to 'octopus_weekly_meeting'
14:01:12 <uli-k> Hi all, please type #info, if you will attend the octopus meeting
14:01:16 <uli-k> #info Uli
14:01:22 <zhifeng> #info zhifeng
14:01:33 <dandruta> #info
14:01:57 <MatthewL3> #info Jun Li
14:01:59 <meimei1> #info meimei
14:02:01 <dandruta> #info dandruta
14:03:00 <uli-k> Great, so let's start with agenda bashing.
14:03:08 <uli-k> #topic Agenda Bashing
14:03:15 <uli-k> I have planned:
14:03:25 <uli-k> Rollcall, Agenda bashing, Action item review, Feedback from Vancouver OpenStack summit, Arno Release Finalization, Prepare Maintenance for Arno Release, Starting work on B-Release, AoB
14:03:42 <uli-k> #info Anything I have forgotten to add?
14:04:30 <uli-k> looks like you are fine with the agenda.
14:04:44 <MatthewL3> yep
14:04:47 <uli-k> #topic Action item review
14:04:49 <zhifeng> yes
14:05:09 <uli-k> #info Action from May 4: ulik and vlaza: add a note how to comment on documents under "document tracking"
14:05:25 <uli-k> I didn't add a note.
14:05:40 <uli-k> vlaza: are you there? Did you add something?
14:06:01 <MatthewL3> ping vlaza
14:06:25 <uli-k> ok. I have to trigger him offline....
14:06:38 <uli-k> I will retype the action, so it is easier to track.
14:06:42 <narindergupta> #info Narinder Gupta
14:07:03 <uli-k> #action (May 4) ulik and vlaza: add a note how to comment on documents under "document tracking"
14:07:30 <uli-k> #info Action from May 4: ulik: ask around... and then let's come back with the question whether we need something of octopus in arno docs.
14:08:09 <uli-k> we had not many, but a few discussions around that. I think there will be only one octopus doc in Arno as part of the package.
14:08:25 <uli-k> #info suggest to close.
14:09:02 <uli-k> #info ACTION from May 11: trozet for inventory update
14:09:21 <fdegir> #info Fatih Degirmenci
14:09:25 <uli-k> ping trozet - didn't see you in roll-call
14:09:26 <trozet> #info Tim Rozet
14:09:34 <uli-k> Hi!
14:09:58 <trozet> hi :)
14:10:06 <uli-k> trozet, did you do the inventory update suggested on May 11?
14:11:00 <uli-k> I think that was before the LF lab change of POD2....
14:11:19 <trozet> hmm
14:11:43 <trozet> you mean the yaml inventory file?
14:11:54 <uli-k> guess so.
14:12:03 <trozet> oh
14:12:12 <uli-k> But I think we should also do some documentation for this.
14:12:14 <trozet> for LF lab change you mean when we subnetted the public subnet further
14:12:22 <trozet> and changed pod2's subnet?
14:12:46 <uli-k> I think that's what we were talking on May 11 (which is ages away now.....)
14:12:55 <trozet> haha yeah I'm trying to remember
14:13:07 <trozet> for us we didn't need to make an inventory file change because we dont care about IPs
14:13:11 <trozet> we get htem dynamically at deploy time
14:13:19 <trozet> so there was no change necessary
14:14:11 <uli-k> This is great to hear. I had been very disappointed about our technology, when I got the feeling that lab network setup needs to be hard-coded.
14:14:30 <uli-k> So you say there is nothing to do?
14:14:47 <uli-k> Then let's just close the action.
14:14:48 <trozet> no theres nothing to do for that
14:14:52 <uli-k> ok.
14:14:57 <uli-k> #info closed.
14:15:12 <uli-k> I didn'tz find other open #actions.
14:15:48 <uli-k> #topic Feedback from Vancouver OpenStack summit
14:16:14 <uli-k> Anything to feed back to the octopus team?
14:16:27 <uli-k> Fatih did nice presentation on OPNFV day.
14:16:33 <uli-k> Thanks, Fatih!
14:16:46 <fdegir> np
14:16:59 <uli-k> #info Thanks fdegir for presenting octopus on OPNFV day.
14:17:31 <uli-k> did you get any suggestions from the audience after the presentaiton? (don't remember any form Q&A)
14:17:37 <fdegir> nope
14:18:35 <uli-k> I went to a Triple-O session during the summit and was wondering whether we should somehow get benefit from that....
14:19:17 <uli-k> thoughts?
14:20:09 <MatthewL3> only I can say is that I have little knowledge of tripleO, maybe there are some experts...
14:20:51 <MatthewL3> I have searched some of its software architecture
14:21:10 <uli-k> In principle it's openstack on openstack.... But they use it also somehow for install.
14:21:24 <MatthewL3> yep
14:21:36 <uli-k> So we could run our CI on openstack-organized VMs.
14:22:11 <uli-k> It sounds cool, but will it help?
14:22:17 <MatthewL3> it's a choice, however, it's a big project then...
14:22:57 <MatthewL3> many codes/debug are needed
14:23:27 <uli-k> Maybe I add it to R2 etherpad, so we don't forget, when we go forward to more virtualization in CI......
14:23:51 <MatthewL3> yep it's good to put it on the etherpad
14:24:18 <uli-k> I saw only fdegir in VC. Were more people there?
14:25:08 <uli-k> OK - that's why everybody is so quiet! :D
14:25:21 <uli-k> So let's move on.
14:25:24 <MatthewL3> yep it's a pity..
14:25:56 <uli-k> #topic Arno Release Finalization
14:26:28 <uli-k> I didn't hear much from BGS.... but there are just 3 days left
14:28:02 <uli-k> I saw 2 new Jira topics by fdegir. They sound relevant.
14:28:55 <uli-k> fdegir, do you need somebody to take them?
14:30:36 <fdegir> yes
14:31:23 <uli-k> Can somebody go for OCTO-70 and OCTO-71, please.
14:31:54 <uli-k> Anything else we need to do the next 3 days?
14:33:34 <uli-k> ... Arno has got boring for us.
14:33:46 <uli-k> so let's move on.
14:34:05 <uli-k> #topic Prepare Maintenance for Arno Release
14:35:04 <uli-k> When TSC decides Arno is ready, we need to label everything in repos that is part of the release.
14:35:38 <uli-k> After that, on master we will work for B-Release.
14:36:22 <uli-k> So when somebody needs to fix a bug in Arno, we need a branch.
14:37:20 <ChrisPriceAB> hey uli-k, for TripleO that is what is running the in the Ericsson Lab in Montreal for the nested virtualization deployments.
14:38:40 <uli-k> hey ChrisPriceAB, good info. I will add it to the etherpad....
14:39:20 <MatthewL3> more details?
14:39:22 <ChrisPriceAB> do we have a label strategy and procedure in place for the release? T-3 days
14:39:53 <ChrisPriceAB> MatthewL3 check with dan smith (after Arno has shipped please)
14:40:05 <MatthewL3> ChrisPriceAB: ok
14:40:25 <uli-k> I never did labeling and branching with git. So what do we need to do centrally and what do we need to document for developer so they do the bugfix properly?
14:41:43 <fdegir> aricg and the new Release Manager could perhaps help here
14:42:02 <aricg> Hi guys.
14:42:11 <fdegir> hi
14:42:12 <ChrisPriceAB> Well, a documented procedure for the project leads.  Then an artifact cutting run needs to be scheduled.
14:42:45 <ChrisPriceAB> The branch is rather easy and after the fact.  The hard part is coordinating the release.
14:42:52 <ChrisPriceAB> hey aricg
14:42:55 <uli-k> Hi, aricg, can you help us a bit about labelling procedure
14:43:27 <aricg> Sure.
14:44:04 <fdegir> I think it would be good to build both ISOs using same sha1, deploy/test based on them and get feedback from functest and bgs
14:44:23 <fdegir> once they give OK, we can tag that sha1
14:44:52 <fdegir> so we have consistent baseline for arno for different installers
14:45:13 <uli-k> Yes. both installers must be on same baseline.
14:45:13 <fdegir> we perhaps need to tag functest, opnfvdocs, and octopus repos together with genesis
14:45:21 <uli-k> Yes.
14:45:31 <uli-k> and maybe something in releng
14:45:39 <fdegir> sure
14:45:57 <uli-k> and pharos docs.
14:46:12 <fdegir> #info Repos to be tagged
14:46:17 <ChrisPriceAB> So when do you need to tag and build the ISO's?
14:46:25 <fdegir> #info genesis, pharos, functest, octopus, releng, opnfvdocs
14:46:40 <fdegir> it would be good to do that by wednesday morning latest
14:46:53 <fdegir> if things go wrong, we can have yet another try in the afternoon
14:47:07 <ChrisPriceAB> Thursday = release, Wednesday = build and validation of tagged releases then uploading artifacts etc.  ( all in one day :O )
14:47:20 <fdegir> :D
14:47:36 <ChrisPriceAB> hehe, cutting it to the bone fdegir.  I like your style.  (although break out in a sweat)
14:47:38 <uli-k> That should be the plan, since validation should happen automatically.
14:47:46 <ChrisPriceAB> and if it fails?
14:48:12 <fdegir> I'm watching bgs channel
14:48:17 <fdegir> and there is still heavy discussion there
14:48:24 <uli-k> We could start the job right after TSC vote tomorrow.
14:48:35 <fdegir> so I'm not sure if they guys will say OK if we ask them lets tag the stuff
14:48:45 <fdegir> I think we should raise this question during BGS meeting
14:49:09 <uli-k> So it is Wednesday early morning (china time hehehe). which gives us a Wednesday of about 39 h for making it happen.
14:49:34 <fdegir> ChrisPriceAB: what do you think?
14:49:43 <fdegir> when we should go for cutting the release?
14:50:26 * jose_lausuch just realized there is a hot topic here :)
14:50:28 <ChrisPriceAB> well we need the BGS team to say go.  Which means we need to dhcp issue resolved...
14:51:06 <fdegir> so BGS has the final say
14:51:17 <uli-k> But you didn't expect fdegir to say Thursday would be fine....
14:51:25 <ChrisPriceAB> uli-k can you get the labels and procedures documented for the project leads and send that out for discussion.  Once we are ready to go we can have nominated committers label the branches accordingly and set off the artifact cutting.
14:51:54 <ChrisPriceAB> that has to be understood.  or we get caught up delaying due to lack of coordination
14:52:19 <ChrisPriceAB> the BGS/functest team have today and tomorrow to sort out the issues.
14:52:35 <ChrisPriceAB> It should be functest stating if they are ready, not BGS.  But in all it's everyone
14:53:12 <uli-k> Right.
14:53:28 <fdegir> aricg: do you have a tagging procedure which we can steal from?
14:53:34 <fdegir> odl perhaps since you do that stuff there
14:53:46 <uli-k> Aricg, I would need some help, what the PLs exactly need to do (stealing the tagging procedure... :D)
14:53:57 <aricg> roger
14:54:12 <fdegir> also we need to identify the tagging - what it would be: arno, opnfv-arno, or what
14:54:22 <fdegir> not jsut the procedure but the tag itself
14:54:31 <fdegir> so aricg and uli-k :D
14:54:42 <uli-k> And I hope, when we tag our scripts that will make sure we always use the same stuff from upstream.
14:55:02 <uli-k> (not only odl, but also non-LF projects)
14:55:11 <fdegir> if we're not using branch/latest
14:55:51 <uli-k> All elements to be tagged should be on master (latest)
14:56:03 <aricg> okay this is what odl does. https://lists.opendaylight.org/pipermail/release/2015-February/001323.html
14:56:34 <fdegir> #info Tagging procedure for ODL
14:56:41 <fdegir> #link https://lists.opendaylight.org/pipermail/release/2015-February/001323.html
14:56:42 <uli-k> ChrisPriceAB, is Arno_1.0.0 ok as tag?
14:56:52 <ChrisPriceAB> Hey uli-k, it's Goerge Zhao form Huawei that drives the ODL release process.  You might try having a chat to him about it.
14:57:16 <aricg> and here is the job associated with the release https://jenkins.opendaylight.org/odlautorelease/job/autorelease-helium-worker/467/
14:57:19 <uli-k> Thanks. Good hint.
14:58:05 <ChrisPriceAB> seems fine.  let's walk the TSC through the procedure on the call tomorrow.  It's first thing in the agenda: https://wiki.opnfv.org/wiki/tsc
14:58:21 <ChrisPriceAB> we can vote on tags, steps and roles all at once.  ;)
14:58:27 <uli-k> OK
14:58:56 <ChrisPriceAB> do we have a release job defined in octopus?
14:59:09 <ChrisPriceAB> like aricg showed for odl?
14:59:18 <fdegir> not that I know of
14:59:32 * ChrisPriceAB is starting to sweat even more :s
14:59:58 <fdegir> but we will already have ISOs there so we don't need to rebuild stuff
15:00:02 <fdegir> tagging can be done manually
15:00:05 <fdegir> artifact storage as well
15:00:13 <fdegir> for arno
15:00:21 * pbandzi we are about to start BGS weekly
15:00:24 <ChrisPriceAB> so we go manual for Arno?
15:00:25 <uli-k> Let's put some actions for that before clearing the field for BGS
15:00:28 <fdegir> I think so
15:00:37 <uli-k> yes.
15:00:45 <aricg> I think we just need to rename the artifacts that are generated from the tagged spots in the repo
15:00:54 <fdegir> yes
15:00:55 <aricg> then the cleanup script will never match and delete them
15:01:06 <aricg> and we can link to them on whatever page you guys want.
15:01:28 <aricg> I was hoping that the would be linked from here: https://dl.dropboxusercontent.com/u/12773330/downloadpage.png
15:01:29 <fdegir> what could go wrong!
15:01:35 <fdegir> :D
15:01:45 <uli-k> #action aricg and uli-k working on tagging procedures
15:02:16 <uli-k> #action ChrisPriceAB necessary voting and decision on tag names in TSC tomorrow
15:03:01 <uli-k> fdegir, can you help with the manual tagging?
15:03:17 <fdegir> I can with whatever you need
15:03:32 <fdegir> but may not be possible since I'm not a committer in other projects
15:03:38 <fdegir> can talk later on
15:03:41 <uli-k> #action fdegir and aricg for the manual tagging
15:03:42 * pbandzi is asking if BGS weekly can be started
15:03:43 <lmcdasm> i can commit what you need
15:03:46 <lmcdasm> just ping me
15:04:02 <uli-k> ok. just wanted to fix that in the minutes before we close.
15:04:18 <uli-k> Let's move to #opnfv-octopus for discussion more details.
15:04:23 <uli-k> #endmeeting