13:59:44 <ChrisPriceAB> #startmeeting OPNFV TSC
13:59:44 <collabot> Meeting started Tue Jun  2 13:59:44 2015 UTC.  The chair is ChrisPriceAB. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:59:44 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
13:59:44 <collabot> The meeting name has been set to 'opnfv_tsc'
13:59:50 <ChrisPriceAB> #topic roll call
13:59:58 <ChrisPriceAB> #info Chris Price
14:00:12 <Tapio_ta> #info Tapio Tallgren
14:00:13 <Wenjing> #info Wenjing Chu
14:00:28 <dneary> Dave here
14:00:38 <morgan_orange> #info Morgan Richomme
14:01:27 <uli-k> #info Uli Kleber
14:01:47 <cdub> #info Chris Wright
14:01:52 <ChrisPriceAB> #chair rpaik
14:01:52 <collabot> Current chairs: ChrisPriceAB rpaik
14:01:55 <dku> #info Dirk Kutscher
14:01:58 <ChrisPriceAB> #chair dneary
14:01:58 <collabot> Current chairs: ChrisPriceAB dneary rpaik
14:02:07 <ChrisPriceAB> #chair uli-k
14:02:07 <collabot> Current chairs: ChrisPriceAB dneary rpaik uli-k
14:02:41 <rprakash> #info rprakash
14:02:51 <bryan_att> #info Bryan Sullivan
14:03:15 <ChrisPriceAB> #topic Approval of previous minutes
14:03:35 <frankbrockners> #info Frank Brockners
14:03:50 <ChrisPriceAB> #agree TSC approves the previous minutes
14:03:55 <ChrisPriceAB> #topic Agenda Bashing
14:04:07 <ChrisPriceAB> #link https://wiki.opnfv.org/wiki/tsc
14:04:11 <bryan_att> Agenda item: refresh of committer and contributor lists for projects - we need to ensure we know who is active and in what role, and ensure the documentation reflects the reality
14:04:48 <bryan_att> Agenda item: toolchain/workflow for documentation management in gerrit
14:05:13 <ljlamers> #info Larry Lamers (VMware)
14:05:21 <dlenrow> #info dlenrow
14:05:46 <ildikov> #info Ildiko Vancsa
14:06:23 <hui> #info Hui
14:06:55 <ChrisPriceAB> #topic Introducing Debra Scott (OPNFV Release Manager)
14:07:57 <dlenrow> Debra is HP's latest gift to the community :)
14:08:15 <ChrisPriceAB> #info Debra will work with our community to establish our release processes and shepherd our projects through future OPNFV releases.
14:08:26 * ChrisPriceAB appreciates HP's generosity
14:09:02 <ChrisPriceAB> #topic Arno Project plans & tracking
14:09:21 <ChrisPriceAB> #info discuss ongoing release activities.
14:12:03 <rpaik> #info Chris reports that release documentation needs to be finalized tonight/tomorrow morning
14:15:28 <frankbrockners> #link https://wiki.opnfv.org/meetings/bgs#june12015
14:15:41 <ChrisPriceAB> #info BGS status update
14:15:50 <rajeev> #info Rajeev Koodli
14:21:27 <ChrisPriceAB> #info three remaining issues in the BGS project which we hope to complete prior to release.
14:21:33 <ChrisPriceAB> #info functest update
14:22:12 <ChrisPriceAB> #info morgan outlines that there have been discrepancies in executing testing when altering the platform.
14:22:35 <ChrisPriceAB> #info morgan describes that all issues are known and able to be defined and documented in the release.
14:23:18 <ChrisPriceAB> #info Issues in upstream community bugs result in limitations in our platform that are not able to be solved prior to the release.
14:25:26 <ChrisPriceAB> #info documentation updates are required prior to release, stability remains an issue but is not able to be solved with the current release components.
14:25:49 <ChrisPriceAB> #info every-one is exhausted  :-)  (understandably)
14:34:23 <rpaik> #info morgan_orange reports that there will be documentation on tests that are failing
14:35:04 <ChrisPriceAB> #info CI update
14:35:39 <ChrisPriceAB> #info octopus has prepared a release procedure to be reviewed
14:35:46 <ChrisPriceAB> #topic Release process, labeling and artifact cutting
14:36:03 <uli-k> #link https://wiki.opnfv.org/octopus/releasepipeline
14:36:03 <ChrisPriceAB> #link https://wiki.opnfv.org/octopus/releasepipeline release process
14:36:47 <dneary> ChrisPriceAB, I'll be able to help with the minutes in a few, but haven't been at keyboard so far.
14:37:21 <ChrisPriceAB> thanks dneary
14:37:38 <ChrisPriceAB> #info Uli walks through the process described on the above link
14:40:08 <julien_ZTE> #info Julien
14:44:31 <rpaik> #info Want to go through steps outlined by Uli on Wedesday (June 3rd) in preparation for the release on Thursday
14:48:18 <RayNugent> #info propose that we identify a cut off time/date so that the prep for the release has time to execute
14:48:46 <ChrisPriceAB> #info Uli asks the TSC for a decision on the release tag format.
14:49:06 <ChrisPriceAB> #info cdub agree that a format is needed and should work well with updates.
14:49:12 <fdegir> #info Proposed formats are
14:49:19 <julien_ZTE> #info using Openstack alike named tag
14:49:20 <fdegir> #info release/arno (ODL way)
14:49:25 <fdegir> #info 2015.1.0
14:49:32 <fdegir> #info Arno.2015.1.0
14:49:39 <fdegir> #info arno_1.0.0
14:49:56 <tapio__> OpenStack kilo is 2015.1
14:50:37 <tapio__> Sorry, it is 2015.1.0
14:51:02 <ChrisPriceAB> #agree TSC agrees to use arno.2015.1.0 as our release tag
14:51:31 <julien_ZTE> #info arno_2515.1.0?
14:51:36 <tnadeau> #info looks ok to me.
14:51:36 <ChrisPriceAB> #agree TSC agrees to use stable/arno as our stable branch
14:52:43 <fdegir> are we releasing the source code?
14:52:56 <fdegir> on artifacts.opnfv.org?
14:53:50 <fdegir> the documentation could say that "clone the repo and checkout the tag arno.2015.1.0"
14:55:18 <ChrisPriceAB> #info frankbrockners asks for the artifact storage to include /scripts and /images
14:56:19 * ChrisPriceAB has lost audio... someone please take notes
14:59:52 <julien_ZTE> #info source code tag link, image or iso and documents will be released?
15:03:20 <ChrisPriceAB> #topic Arno landing page review
15:03:38 <dneary> ChrisPriceAB, #link?
15:03:56 <ChrisPriceAB> #info Ray demonstrates the Arno download landing page
15:04:08 <HKirksey> There’s not link at this point
15:04:23 <dneary> Thanks HKirksey
15:06:21 <ChrisPriceAB> #link https://wiki.opnfv.org/documentation/Arno current release documents
15:06:25 <cgoncalves> consider agreeing on the date format (MM/DD/YYYY vs DD/MM/YYYY). maybe change to YYYY/MM/DD ?
15:10:40 <fdegir> don't agree with lab connection document
15:10:50 <fdegir> that was one of the marketing points saying "connect your lab"
15:11:34 <ChrisPriceAB> Could we add a link on the landing page reffering to our global labs and pointing to a doc?  Maybe rpaik we can ask brandon
15:15:08 <ChrisPriceAB> #topic Arno support
15:16:26 <ChrisPriceAB> #info a support mailing address exists support@opnfv.org
15:17:27 <ChrisPriceAB> #info this can be set with a mailing list that is open for anyone to post to that we can use for OPNFV support
15:18:30 <ChrisPriceAB> #info consensus would indicate a mailing list alias called opnfv-user would seem to be the best approach
15:18:36 <rpaik> #action create a mailing list called “opnfv-user”
15:18:36 <dneary> So what SLA do we offer?
15:18:44 <dneary> 48h?
15:18:56 <ChrisPriceAB> #info support offered for OPNFV is community support, with no sla's associated.
15:19:01 <dneary> :-)
15:19:08 <ChrisPriceAB> :)
15:19:11 <dneary> ChrisPriceAB, Thanks for spelling that out
15:19:27 <tapio__> Where do people report bugs in Arno?
15:19:39 <dneary> Yes - users@opnfv.org
15:19:54 <dneary> There are 600 people on the TSC?
15:21:12 <rpaik> #info use Jira to report bugs
15:21:41 <dneary> First, enable users to talk to each other, and let's listen.
15:21:56 <dneary> First key question is, who are the users?
15:22:13 <dneary> ChrisPriceAB, The issue is you're asking someone to volunteer to be an OPNFV community manager
15:22:16 <dneary> It's a big task
15:24:23 <tnadeau> i volunteer Dave Neary as community manager. *)
15:24:50 <dneary> tnadeau, Only if you want it done poorly... /me doesn't do overcommitment as well as KVM
15:24:59 <ChrisPriceAB> #info establishing an ask-bot to the users mailing list.
15:25:05 <ChrisPriceAB> #undo
15:25:05 <collabot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1d91890>
15:25:14 <ChrisPriceAB> #info establishing an ask-bot to the users mailing list could be a valuable addition in the future.
15:25:16 <dneary> askbot, or Stack Overflow, or Discourse
15:25:26 <dneary> All worth exploring, but not as last minute decisions
15:25:30 <tnadeau> is there a way to move this release engineering discussion to another chat?
15:25:33 <ChrisPriceAB> #topic WiKi structure & Layout
15:25:36 <tnadeau> is this is a good use of the TSC call time?
15:25:40 <dneary> Let's fill the need as it becomes better understood
15:26:03 <dneary> tnadeau, Release is the main thing on the TSC plate this week...
15:26:06 <tnadeau> dreary would be awesome at community manager 8)
15:26:14 <dneary> dreary?
15:26:21 <dneary> Is that a Freudian slip?
15:26:25 <tnadeau> do you really need the TSC for these discussions?
15:26:34 <tnadeau> I'm not sure most of the technical discussions need us here
15:27:35 <bryan_att> let's take the wiki offline and I can help you there
15:28:30 <bryan_att> i don't think we need to hire someone for this
15:28:42 <bryan_att> it should be volunteer based
15:28:49 <ChrisPriceAB> #info dneary raises the point that a community manager for OPNFV would be able to handle many of these issues
15:29:15 <tnadeau> i agree. we don't need to hire someone for this
15:29:22 <tnadeau> volunteer(s)
15:29:44 <tnadeau> dreary - autocomplete - sorry!
15:29:45 <dneary> bryan_att, ChrisPriceAB: Not a pre-release activity, but I do think it's right to have it on the agenda ~now
15:29:47 <uli-k> tnadeau, are you volunteergin
15:29:49 <uli-k> ?
15:29:52 <dneary> Nope, I'm on mute
15:29:53 <tnadeau> nfw
15:30:01 <RayNugent> #info I agree with dneary, community management is a full time job and we'll need a dedicated person to do the job
15:30:08 <dneary> bryan_att requested better definition of ask
15:30:13 <ChrisPriceAB> #topic Development process/project categories
15:30:13 <dneary> I can certainly help with that
15:30:36 <julien_ZTE> # volunteer for this
15:31:16 <dneary> rpaik, If you want to see if we can put together a sketch of a community manager job description which could be used as a basis for TSC/board discussions, I'd be happy to collaborate with you on that. What do you think?
15:31:59 <rpaik> dneary, sounds good. let’s meet after Arno is out the door :-)
15:32:34 <ChrisPriceAB> #info cdub thinks the process may need review, preferably done after the release.
15:34:13 <ChrisPriceAB> #info dlenrow indicates some additional work could improve the way the projects integrate with the overall OPNFV project
15:34:43 <ChrisPriceAB> #agree to postpone the discussion until after Arno is released
15:34:58 <dneary> rpaik, OK
15:35:45 <ChrisPriceAB> #topic OPNFV Release 2 "marquee feature" discussion
15:37:48 <ChrisPriceAB> #info Ray indicates some concern that focusing on a feature a thematic approach may be better.
15:39:02 <ChrisPriceAB> #info of the topics under discussion dneary describes SFC as a theme due to it's functional breadth
15:40:59 <ChrisPriceAB> #info uli-k states that the value of OPNFV can be easily identified when considering a feature set that combines a number of upstream components
15:41:50 <bryan_att> I would suggest that defining a harmonized model-driven abstraction of configuration requirements/constraints will be helpful, especially if we can get some upstream activity to align the abstractions across VIM domains (controller and orchestrator) - we need this for all the OPNFV policy projects
15:42:20 <ChrisPriceAB> #info Rajeev indicates that a clear definition of what we are trying to achieve with the marquee feature is required
15:46:26 <dlenrow> my read on our governance is that this is domain of BOD, not TSC. We should have technical input, but this is not a "technical" question per se.
15:47:08 <dneary> I'd prefer to say "HA + fault management" instead of carrier grade
15:47:37 <RayNugent> We can define "carrier grade" anyway we wish
15:48:07 <uli-k> There is an official definition of "carrier grade"
15:48:16 <rpaik> Policy is the third area
15:48:37 <dneary> uli-k, RayNugent: This discussion is why I'd prefer avoiding carrier grade
15:48:49 <RayNugent> policy is the 4th area
15:49:04 <dneary> RayNugent, what was the 3rd?
15:49:08 <dlenrow> Policy (intent) is the only area :)
15:49:13 <RayNugent> how about carrier grade phase 1
15:49:40 <bryan_att> i can't say that we can develop a comprehensive model for intent-driven resource/lifecycle VIM in 6 months, but we can start with use cases and delivery core/essential aspects of this in 6 months, and expand as we go
15:49:54 <rpaik> I have Policy, HA/Fault mgmt, SFC
15:50:16 <bryan_att> I also think that focus on reliability, performance, security ("telco-grade") is another key goal for the next 6 months
15:50:27 <dneary> rpaik, Those are the 3 I had
15:50:39 <julien_ZTE> #info from the link https://www.opnfv.org/about, carrier-grade is OPNFV's one of targets "OPNFV will establish a carrier-grade, integrated, open source reference platform that industry peers will build together to advance the evolution of NFV and to ensure consistency, performance and interoperability among multiple open source components"
15:50:41 <RayNugent> I specifically called out carrier grade several time
15:51:04 <RayNugent> guess I need to #info more :-)
15:51:10 <dneary> dlenrow, Policy is hugely important, but given the state of the Nova scheduler rewrite and Congress, I don't know how high your expectations can be for 6 months time
15:51:10 <dlenrow> Need quantitative metrics for stability,scalability, performance, etc. for select use cases
15:51:41 <morgan_orange> we initiated a discussion on these aspects in functest/Pharos last thursday
15:51:51 <RayNugent> dlenrow agree!
15:51:57 <dlenrow> dneary: agreed that it's a long road and with bryan_att that we should start yesterday.
15:51:58 <morgan_orange> we collect already some KPI from Rally, we shall be able to collect from several sources
15:53:03 <dku> carrier-grade or not -- I think what is important for R2 is to provide at least a new feature (theme) that is relevant for users (operators)
15:53:08 <dneary> dlenrow, Yes - to have it happen in a year, you can't wait 6 months to start :-)
15:53:34 <RayNugent> #info rpaik please add carrier grade as a suggestion
15:53:40 <rpaik> #info discussion that SFC and Faulat mgmt/HA maybe achievable in 6 months.  Will need more time for Policy
15:53:40 <bryan_att> upstream communities will not address VNF package and metadata requirements for us - neither will ETSI - we have to get started and drive this
15:53:47 <ChrisPriceAB> #topic Release 2 planning
15:54:00 <cdub> Please add "define carrier grade"
15:54:15 <uli-k> This defines carrier grade: http://scope-alliance.org/sites/default/files/documents/scope-technical-position.pdf
15:54:19 <RayNugent> #info SFC+HA=carrier grade phase 1
15:54:22 <rpaik> RayNugent, I think the suggestion is that carrier grade = Fault mgmt + HA
15:54:30 <cdub> It's meaningless buzzword for opnfv platform
15:54:41 <dlenrow> We didn't have a CI so we couldn't run an SR. Arno provides the starting place.
15:55:06 <RayNugent> carrier grade is a journet over several releases but FM+HA is a great start
15:55:10 <cdub> Sfc != carrier grade, SFC is a network featire5
15:55:12 <dku> 6 months for SFC may actually be optimistic (this requires OpenStack development, IMO)
15:55:26 <uli-k> dku: agree
15:55:39 <bryan_att> carrier grade also means ability to perform as expected, and to be immune to threats
15:56:09 <rpaik> #link https://wiki.opnfv.org/simultaneous_release_process_and_guidelines wiki page for simultaneous release process
15:56:22 <bryan_att> performance requirements can be concrete and validated; also immunity to common attacks and vulnerabilities
15:56:40 * cdub has to drop
15:57:11 <julien_ZTE> #info can we output a schedule like openstack, https://wiki.openstack.org/wiki/Liberty_Release_Schedule
15:57:25 <ChrisPriceAB> #action Debra to initiate the development of the release plan for release 2
15:57:45 <ChrisPriceAB> #info dlenrow and uli-k to head up the community team
15:58:07 <RayNugent> #info julian_ZTE agree with schedule proposal
15:58:11 <ChrisPriceAB> #topic AOB
15:58:11 <dlenrow> Instead of saying carrier grade we could say foo, where foo is defined quantitatively around performance, scalability, availability, etc.
15:58:31 <ChrisPriceAB> #endmeeting