14:00:32 <uli-k_> #startmeeting octopus weekly meeting
14:00:32 <collabot> Meeting started Mon Jun  8 14:00:32 2015 UTC.  The chair is uli-k_. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:32 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:00:32 <collabot> The meeting name has been set to 'octopus_weekly_meeting'
14:00:48 <uli-k_> Hi all!
14:00:57 <uli-k_> #topic rollcall
14:01:17 <meimei2> hi,Uli
14:01:23 <uli-k_> please type #info, if you plan to participate in octopus call
14:01:40 <Malla> Hi Ulrich, cloud you please past the gomeeting link
14:01:43 <meimei2> #info meimei
14:01:46 * uli-k_ (this was to all)
14:01:55 <fdegir> #info Fatih Degirmenci
14:02:00 <Malla> #info Malla
14:02:01 <chigang> #info chigang
14:02:06 <uli-k_> #info this is IRC only meeting. No GTM
14:02:09 * fdegir will be on and off - in another meeting
14:02:14 <Malla> ok thanks
14:02:41 <chenshuai123> #info chenshuai
14:02:48 <trozet> #info Tim Rozet
14:02:53 <uli-k_> #info Let me start again with thanks to all who helped to make Arno happen!
14:03:22 <uli-k_> #info and I know that Fatih has taken really big efforts for this.
14:03:51 <zhifeng> #info zhifeng
14:04:02 <uli-k_> #info Thanks to you and to everybody!
14:04:45 <fdegir> np
14:04:50 <uli-k_> #info For today we have some important things to do, which shouldn't wait too long, as well.
14:04:52 <fdegir> and thx to everyone
14:04:52 <MatthewL2> # Jun Li
14:04:58 <trozet> Thankd fdegir for being around all hours to help
14:04:59 <ljlamers_> #info Larry Lamers
14:05:10 <uli-k_> So let's go for the agenda.
14:05:21 <uli-k_> #topic Agenda bashing
14:05:38 <uli-k_> I have on agenda: Action item review - Arno CI quick retrospective (what was good, what we can improve, what was not so good) - Arno maintenance (High prio Jira issues) - Starting work on B-Release - AoB
14:05:44 <uli-k_> Anything else?
14:07:08 <uli-k_> #info Looks like everybody is fine with agenda.
14:07:18 <uli-k_> #topic Action item review
14:07:41 <uli-k_> #info Action: (May 4) ulik and vlaza: add a note how to comment on documents under "document tracking"
14:08:24 <uli-k_> vlaza is not here. and I didn't do anything. But do we need that at the moment?
14:08:42 <uli-k_> Probably yes, for Arno maintenance.....
14:09:08 <ChrisPriceAB> I missed the ap.  what are we after specifically?
14:09:45 <uli-k_> We felt there was missing description how to comment on docs.
14:09:59 <ChrisPriceAB> As in Gerrit?
14:10:04 <uli-k_> yes.
14:11:03 <uli-k_> I think I do some re-wording and not spend too much time on it now....
14:11:13 <ChrisPriceAB> Ok, easy enough.  So some form of "this is how gerrit works" when reviewing guide.
14:11:23 <ChrisPriceAB> Probably broadly needed.
14:11:34 <MatthewL2> https://review.openstack.org/Documentation/intro-quick.html there are some info here
14:11:54 <uli-k_> #action ulik_ and vlaza check and improve description how to comment on documents
14:12:11 <uli-k_> next ap:
14:12:23 <uli-k_> #info aricg and uli-k working on tagging procedures
14:12:28 <uli-k_> This is done :D
14:12:46 <uli-k_> #info closed. Arno is tagged...... :D
14:12:58 <uli-k_> next ap:
14:13:10 <uli-k_> #info ChrisPriceAB necessary voting and decision on tag names in TSC tomorrow
14:13:17 <uli-k_> #info also done.
14:13:32 <uli-k_> #info fdegir and aricg for the manual tagging
14:13:40 <uli-k_> #info also done.
14:14:06 <uli-k_> #topic Arno CI quick retrospective
14:14:07 <ChrisPriceAB> one last question, did anyone open a Jira on the docs project for that action item?  I didn't see one there
14:14:23 <uli-k_> you mean the first ap?
14:14:30 <ChrisPriceAB> on the docs team yes.
14:15:02 <uli-k_> I didn't check. But thanks for the reminder.
14:15:12 <MatthewL2> we can include it in our octopus project I think
14:15:34 <uli-k_> #info for action item 1, Jira should be opened.
14:15:52 <MatthewL2> in docs project also is ok
14:16:04 <uli-k_> ChrisPriceAB do you think it should be in DOCS?
14:16:25 <ChrisPriceAB> If it's a request on the docs project, open it on the docs project.
14:16:34 <uli-k_> :D
14:16:40 <ChrisPriceAB> That's why Jira is cross project enabled. ;)
14:17:08 <uli-k_> I meant do you think it should be a docs-task?
14:17:33 <uli-k_> to me it feels like one.....
14:17:54 <uli-k_> I think it's not very important where we put it....
14:18:19 <uli-k_> Let's go for Arno CI retrospective.
14:19:00 <uli-k_> any feelings what went badly or great?
14:19:41 <trozet> #info question about CI with regards to patches
14:20:02 <trozet> #info why when we submit a fix for our deployment tool, the jenkins verify job doesnt try to execute a deploy job?
14:20:11 <trozet> i think this would be an improvement
14:20:19 <fdegir> trozet can we leave improvements to later
14:20:26 <fdegir> we have been working with arno
14:20:32 <fdegir> and didn't have time for "improvements"
14:20:56 <fdegir> please creat a jira item
14:21:02 <trozet> ok
14:21:03 <fdegir> and feel free to start working on it
14:21:34 <trozet> #info will submit Jira and work on this item
14:21:58 <uli-k_> I think in that case we should do some discussion also how to do it.....
14:22:20 <fdegir> yes
14:22:29 <fdegir> we can have the discussion in the jira story
14:22:31 <uli-k_> We should discuss how to select where the test deploy is done, etc.....
14:22:34 <fdegir> and then come to a conclusion
14:22:35 <trozet> uli-k: via Jira comments or in the meeting?
14:22:41 <trozet> k
14:22:48 <fdegir> we can't do bare-metal deployment for each and every patchset
14:22:54 <fdegir> we don't have enough resources
14:23:05 <fdegir> anyway, this we can take into agenda next week
14:23:16 <trozet> fdegir: I was thinking patch-sets which either touch the deploy directories or have a keyword in them to trigger the job
14:23:17 <trozet> k
14:23:22 <uli-k_> Let's do a start in Jira, but I expect we need meeting to come to conclusion....
14:23:35 <fdegir> uli-k_: agreed
14:24:08 <uli-k_> ok. back to Arno feedbacks.....
14:24:43 * fdegir can start
14:24:52 * uli-k_ goahead
14:25:04 <fdegir> here is what I think
14:25:06 <fdegir> #info The good
14:25:12 <fdegir> #info Cooperation and collaboration between Octopus, BGS and FuncTest was really good
14:25:28 <fdegir> #info BGS and FuncTest people offered help with CI and stepped in with job updates and so on while no CI people were around
14:25:56 <fdegir> #info thanks to trozet, radez, morgan_orange, jose_lausuch, lmcdasm, jonasbjurel and stefan_berg
14:26:18 <fdegir> #info The things to improve
14:26:23 <fdegir> #info Get a common understanding regarding what the CI is
14:26:42 <MatthewL2> I think we do have some people around...
14:26:45 <fdegir> #info Improve the documentation - especially with regards the way of working with git/gerrit, etc.
14:26:56 <fdegir> MatthewL2: can I finish
14:27:02 <fdegir> you can comment on it later on
14:27:03 <MatthewL2> ok
14:27:16 <fdegir> #info The bad
14:27:33 <fdegir> #info this is a long list so won't put all of them here
14:27:40 <fdegir> #info No help offered by CI team
14:27:52 <fdegir> #info Always good ideas but too little hands on work
14:28:28 * fdegir has full of ideas but lacked the luxury of talking about them
14:28:39 <fdegir> #info Arguing unnecesarily regarding low-prio items while hot issues with arno were standing still
14:28:59 <fdegir> #info Too less authority over infra tools such as Jenkins
14:29:21 <fdegir> #info Not taking stories from backlog
14:29:32 <fdegir> that's all from me
14:29:35 <fdegir> thx for listening
14:29:46 <fdegir> (not all but these are the ones I dared to share)
14:31:14 <uli-k_> MatthewL2, your first sentence sounds like you can even address something about fdegirs
14:31:21 <uli-k_> 's "bad"
14:31:32 <MatthewL2> to be honest, thx for the suggestions from fdegir, jenkins are key tool in CI, however, some people may have other backgrouds, some day, they may help.
14:32:00 <uli-k_> agree. I think this is one of the reasons for "the bad".
14:32:13 <MatthewL2> I agree that a deep understanding of jenkins is needed, fdegir is an expert here
14:32:13 <fdegir> I didn't talk about the background of the people
14:32:17 <uli-k_> (at least on our side)
14:32:24 <fdegir> my comment was regarding "willingness to help"
14:32:50 * trozet is willing to help :)
14:33:03 * fdegir likes the idea
14:33:12 <MatthewL2> yep, peolpe should more active
14:33:28 * uli-k_ agrees.
14:33:56 <uli-k_> fdegir: message taken. Let's try to improve.
14:35:17 <uli-k_> My perception:
14:35:30 <uli-k_> #info the good
14:36:13 <uli-k_> #info sometimes struggling, we still made it for Arno without causing troubles.
14:36:28 <uli-k_> #info to improve
14:36:58 <uli-k_> #info we were very late with the final release preparation (my fault....)
14:37:26 <uli-k_> #info that caused some hectic beginning of last week, but we made it.
14:37:59 <uli-k_> #info for the next release (which should be Arno maintenance) we must be better in time.
14:38:29 <uli-k_> all others can go into R2 improvements ;-)
14:39:38 <uli-k_> do others wish to share?
14:41:11 <uli-k_> looks like we should move on....
14:41:40 <uli-k_> #topic Arno maintenance (High prio Jira issues)
14:42:12 <uli-k_> #info Thanks fdegir to put most important steps to Jira.
14:42:38 <fdegir> I probably missed some other very important stuff as well :D
14:42:49 <fdegir> please feel free to log them
14:43:36 <uli-k_> yes. But we can start with the stuff you already put there....
14:43:44 <uli-k_> I think several issues are already assigned.
14:43:49 <fdegir> yes
14:43:52 <fdegir> and when I say maintenance work I firstly mean that we must continue providing feedback fro CI to community
14:44:07 <fdegir> so when trozet sends a patchset go stable/arno
14:44:21 <fdegir> he must get basic verify feedback from jenkins
14:44:24 <fdegir> and so on
14:44:51 <fdegir> #info Please have a look at the list below to see these very basic stories and feel free to take them
14:44:59 <fdegir> #link https://jira.opnfv.org/browse/OCTO-88?filter=10200
14:45:50 <fdegir> how to handle releases automatically is something we need to work as well
14:46:04 <fdegir> but this can perhaps be incorporated to R2 work
14:46:26 <uli-k_> OCTO-80 - OCTO-88 are assigned.
14:46:28 <fdegir> and if we can't get it done on time, arno 1.1 release can be done manually as well
14:46:35 <MatthewL2> yep, octo-77 have give some discriptions
14:48:02 <uli-k_> MatthewL2, do you know how long it will take you?
14:48:57 <MatthewL2> I will try, fdegir also can give some help here, i think
14:49:07 <fdegir> MatthewL2: yes
14:49:11 <MatthewL2> anybody can feel free to do that
14:49:16 <fdegir> ping me whenever you have questions
14:49:28 <MatthewL2> fdegir: thx
14:50:09 <uli-k_> OCTO73-76 are still unassigned.
14:50:39 <uli-k_> who can take some?
14:51:16 <fdegir> OCTO-73 is actually a parent story
14:51:41 <uli-k_> So only 3 are missing...
14:51:47 <chenshuai123> I take 73-76
14:51:52 <fdegir> so MatthewL2 can take it since he is working with most of the subtasks
14:52:07 <MatthewL2> fdegir: Ok
14:52:25 <uli-k_> OK MatthewL2 take OCTO-73 and chenshuai123 the rest.
14:52:45 <fdegir> ok
14:53:00 <uli-k_> Did we miss one of the new tasks?
14:53:44 <uli-k_> looks good....
14:53:46 <fdegir> I think we're godd
14:53:48 <fdegir> good
14:54:15 <uli-k_> So with those the basics to work on Arno branch should be fine.
14:54:26 <fdegir> until proven otherwise
14:54:31 <uli-k_> :D
14:54:44 <uli-k_> I think it's the basics.
14:54:54 <fdegir> yes
14:54:56 <uli-k_> And for Arno basics should do it.
14:55:40 <uli-k_> Nice improvements like the one mentioned by trozet today, I think should go into B-River.
14:56:04 <uli-k_> says B-River to make ChrisPriceAB think about a real river :D
14:56:33 <trozet> uli-k_: yeah sometimes I am scared to commit a big deploy change, because I didn't have a testbed to try it on, so it would be nice if Jenkins verified it
14:56:33 <uli-k_> trozet, is it ok to do that in B-River?
14:56:40 <fdegir> and might require much more thinking such as doing deployment on virtual env
14:56:48 <trozet> uli-k_ yeah
14:56:51 <fdegir> since we have limited hw
14:57:01 <trozet> yeah we could do virtual to start with
14:57:12 <trozet> we would need another server though
14:57:20 <fdegir> yep
14:57:32 <fdegir> but this is already in our B braindump etherpad
14:57:43 <fdegir> uli-k_: perhaps you can share the link once you change the subject
14:57:54 <uli-k_> I think if we really can show what we need, we can beg ChrisPriceAB for money.
14:57:58 <fdegir> so people go there and see what we dumped and comment bag
14:58:01 <fdegir> back
14:58:05 <chigang> trozet:  I am trying to deploy foreman , maybe i can try test it
14:58:10 <uli-k_> ok ok ok
14:58:22 <uli-k_> #topic Start thinking about B-River
14:58:35 <uli-k_> #link https://etherpad.opnfv.org/p/octopusR2
14:58:54 <uli-k_> fdegir says everything is already there ;-)
14:59:06 * fdegir didn't say that :)
14:59:12 * uli-k_ :D
14:59:13 <fdegir> jsut a starting point
14:59:32 <uli-k_> yes. I will send the link to community then.
14:59:42 <trozet> chigang: appreciate the offer.  We should have CI verification as well though for code changes to deployment tools before a patch is +1'ed by jenkins
15:00:02 <uli-k_> #action uli-k_ to send the link to R2 etherpad to community to trigger feedback
15:00:03 <fdegir> trozet: I like the idea in general
15:00:30 <fdegir> but CI also means fast feedback
15:00:36 <fdegir> anyway
15:00:41 <fdegir> we talk about it on etherpad
15:01:38 <uli-k_> I guess when we share the link, we will get a lot of wishes by BGS and others....
15:01:49 <fdegir> yes
15:01:54 <fdegir> and that is what we really need
15:02:09 <fdegir> other projects were quiet mostly - apart from functest and bgs
15:02:24 <fdegir> they're starting up so it is good time to poke them again
15:02:49 <MatthewLi2> the word poke is good...
15:02:50 <uli-k_> But don't expect too much from projects that didn't use CI yet.
15:03:24 <fdegir> yep
15:04:05 <uli-k_> I would propose we wait for some input before we start digging into next steps to implement.
15:04:30 <fdegir> that I agree
15:04:33 <fdegir> may I suggest something
15:04:36 <uli-k_> So even while BGS is not waiting for us to close today, I wouldn't go on too long....
15:04:41 <uli-k_> of course!
15:04:56 <fdegir> can we get demo or something for tripleO, zuul, etc
15:05:06 <fdegir> from whoever knows them either in the team or in the community
15:05:26 <uli-k_> Great idea!
15:05:26 <MatthewLi2> I have setup an environment in my lab of zuul
15:05:29 <fdegir> so we could all be on the same page when we tgen
15:05:43 <fdegir> MatthewLi2: can you do the demo?
15:05:56 <fdegir> live one please - as few slides as possible
15:06:03 <MatthewLi2> fdegir: it needs some time, I will try
15:06:12 <fdegir> whenever you make it
15:06:24 <trozet> fdegir: tripleO?
15:06:29 <MatthewLi2> fdegir: ok
15:06:30 <trozet> why do you want that?
15:06:46 <fdegir> there was a discussion last week(?)
15:06:51 <fdegir> don't remember
15:07:00 <fdegir> someone mentioned that
15:07:13 <trozet> fdegir: I can help you with some tripleO info
15:07:19 <uli-k_> I listened to their session in summit... They claimed they can support something during install....
15:07:30 <uli-k_> can you also do a demo ?
15:07:34 <uli-k_> :D
15:07:51 <trozet> so foreman/quickstack may change to use something called RDO Manager
15:07:57 <trozet> which is tripleO combined with some other stuff
15:08:10 <trozet> RDO manager has a good user guide online, and videos
15:08:34 <trozet> basically RDO Manager/triple O deploys an "undercloud"
15:08:55 <trozet> which is a small opentack setup, which in turn uses ironic to deploy the "overcloud" (the real OpenStack instance) to baremetal
15:09:05 <aricg> heres one https://github.com/Aricg/PackStackSandBox ;)
15:09:21 <MatthewLi2> good
15:09:26 <fdegir> :D
15:09:28 <uli-k_> Sounds like we can have some fun next week?
15:09:58 <fdegir> hopefully
15:10:09 <trozet> aricg: whats the packstack link for?
15:10:31 <aricg> uses teh RDO stuff, only two nodes tho, no ha etc.
15:10:50 <aricg> its pretty easy to work with
15:11:50 <trozet> aricg: OK, but thats RDO, not RDO manager...just to clarify for folks
15:12:05 <uli-k_> Could we do the following: 1.) aricg shows packstack 2.) trozet shows RDO+tripleO 3.)MatthewLi2 shows zuul?
15:12:24 <uli-k_> does it make sense that way?
15:12:38 * trozet is wondering what that has to do with octopus ?
15:12:43 <aricg> I dont think my pack stack is actually useful for this project.
15:13:20 <aricg> I was just chiming in that RDO is pretty mature and easy to work with
15:13:33 <trozet> aricg: oh, yeah our deploy stuff uses RDO
15:13:40 <trozet> similar to what you are doing with packstack
15:13:43 <trozet> but with quickstack
15:13:48 <uli-k_> I think this could help us to create some verify deployments or stuff.
15:13:53 <aricg> the RDO manager look great
15:14:18 <trozet> rdo manager you can do virtual deployments
15:14:25 <uli-k_> But let's not go to far away when looking into the installers. That's better done by BGS.
15:14:32 <aricg> like if CI could just reboot say only the storege nodes.
15:14:58 <aricg> with some kind of api, and we didnt have to do a full tear down with each commit
15:15:14 <trozet> well I think RDO manager is faster than what we have
15:15:28 <trozet> because a lot of stuff is prebuilt into the images loaded onto the nodes
15:15:41 <trozet> and then puppet executes stand alone on the box
15:15:49 <trozet> rather than master/agent mode
15:16:00 <aricg> ideally, in my mind, the full rebuild could be a weekly thing, and the rest of the time, just updates to the affected components
15:16:40 * uli-k_ wonders how we can re-focus to octopus
15:16:45 * aricg leaves
15:17:49 <uli-k_> I think we have to look closer to these ideas.....
15:17:50 <trozet> uli-k_: I think the right path is, we decide if we are going with RDO manager or not, and if so
15:18:01 <trozet> then we do a OPNFV tech discuss walkthrough
15:18:10 <trozet> and include bgs and octopus
15:18:35 <uli-k_> for such decision we would need to see the idea more closely.
15:18:44 <fdegir> agree
15:18:55 <fdegir> the reason for me asking for demos is to get some more knowledge
15:18:59 <trozet> uli-k_: I mean us as foreman/quickstack BGS decides if we are switching to RDO manager
15:19:02 <fdegir> before deciding anything
15:19:34 <trozet> fdegir: yeah I'm new to it as well, just trying things out on my server with it in the last few days
15:19:34 <uli-k_> should we do the following: 1.) aricg shows RDO manager 2.) trozet shows RDO+tripleO 3.)MatthewLi2 shows zuul?
15:19:52 <trozet> #1 and #2 are the same thing
15:19:56 <trozet> (pretty much)
15:19:57 <aricg> wait RDO manager uss tripleO
15:19:58 <MatthewLi2> uli-k_: I will try
15:20:18 <fdegir> yes, that's how all this discussion started
15:20:25 <fdegir> the idea was t get tripleO demo
15:20:34 <uli-k_> ok let's summarize.
15:20:39 <trozet> https://www.youtube.com/watch?v=731INn1GDmk&feature=youtu.be
15:20:47 <trozet> ^good RDO manager walkthrough
15:20:58 <uli-k_> Aricg and trozet, can you do a demo for RDO manager and TripleO?
15:21:33 <aricg> trozet is on the forefront of that, I have only looked at it
15:21:45 <trozet> uli-k_: I would like to learn more about it myself first, before I demo it :)
15:22:24 <uli-k_> ok. Looks like both trozet and MatthewLi2 need a bit of time before the demo.
15:22:25 <aricg> Theres actually a zuul job for triple-O labled experimental here: http://status.openstack.org/zuul/
15:22:45 <MatthewLi2> aricg: yep
15:23:04 <MatthewLi2> it's used in openstack
15:24:08 <uli-k_> OK. What about the following. Next week we look at other R2 stuff, in 2 weeks/3 weeks we get demos?
15:24:35 <trozet> uli-k_: OK that sounds good to me
15:24:44 <MatthewLi2> uli-k_: ok
15:24:57 <uli-k_> OK. I put some summary in 'agrees and 'actions ....
15:25:12 <uli-k_> #agreed to work on R2 etherpad next week
15:25:31 <uli-k_> #action MatthewLi2 to prepare zuul demo
15:25:52 <uli-k_> #action trozet to prepare RDO/TripleO demo
15:26:09 <uli-k_> #info demos are planned for in 2/3 weeks.
15:26:12 <uli-k_> OK?
15:26:24 <trozet> k
15:26:33 <fdegir> ok
15:26:39 <uli-k_> #topic AoB
15:27:17 <uli-k_> then let's close the meeting.
15:27:30 <uli-k_> #info thanks everybody. Great meeting!
15:27:46 <uli-k_> #endmeeting