14:00:07 <uli-k> #startmeeting Octopus weekly team meeting
14:00:07 <collabot> Meeting started Mon Jun 29 14:00:07 2015 UTC.  The chair is uli-k. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:07 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:00:07 <collabot> The meeting name has been set to 'octopus_weekly_team_meeting'
14:00:17 <uli-k> wow meetbot works!
14:00:31 <uli-k> #topic roll call
14:00:44 <uli-k> please type #info yourname
14:00:55 <uli-k> #info Uli
14:00:58 <radez> #info Dan Radez
14:01:16 <fdegir> #info Fatih Degirmenci
14:01:19 <MatthewLi> #info Jun Li
14:02:32 <uli-k> I saw some more people chatting around.... Guess they will join later...
14:02:41 <uli-k> #topic agenda bashing
14:02:58 <trozet> #info Tim Rozet
14:02:58 <uli-k> #info I have: Action item review / Feedback Arno maintenance proposal / Proposal for Releng project / Starting work on B-Release
14:03:11 <uli-k> Anything else?
14:03:12 <zhifeng> #info zhifeng
14:03:16 <meimei1> #info meimei
14:03:57 <uli-k> sounds like everybody is happy with the agenda.
14:04:06 <uli-k> so let's move in
14:04:15 <uli-k> #topic action item review
14:04:37 <uli-k> #info Action item: 1. uli-k and vlaza check and improve description how to comment on documents
14:04:46 <bryan_att> #info Bryan Sullivan
14:05:07 <uli-k> #info I didn't have a chance to talk to vlaza, so we have to carry it on. Very sorry. It is already old.
14:05:18 <uli-k> #action uli-k and vlaza check and improve description how to comment on documents
14:05:35 <uli-k> #info Action item: 2. uli-k to send the link to R2 etherpad to community to trigger feedback
14:05:41 <uli-k> #info done.
14:05:45 <fdegir> document generation mechanism needs improvements already
14:06:07 <fdegir> but that's something we need to take separately
14:06:32 <uli-k> Yes. do we have concrete proposals? Maybe also in the R2 etherpad?
14:06:48 * uli-k sorry, didn't check .....
14:06:53 <fdegir> we'll look at that once we find vlaza
14:07:14 <MatthewLi> yep he don't show up for times recently
14:07:18 <uli-k> Yeah. Maybe somebody has early vacations?
14:07:29 <fdegir> could be
14:07:51 <uli-k> anyway...
14:08:01 <bryan_att> I have proposed that sphinx be integrated more consistently for doc generation. still having to figure it out on my own for now
14:08:11 <uli-k> #info Action item: 3. MatthewLi2 to prepare zuul demo
14:08:23 <fdegir> bryan_att: yep, that's one of the things
14:08:24 <MatthewLi> ok
14:08:36 <uli-k> #info MatthewLi2, last week you said, we can do it on July 6.
14:08:46 <MatthewLi> I have completed some works recently, so I can work for this now
14:08:55 <uli-k> Just let me know to put it on agenda.
14:09:22 <MatthewLi> ok, I will do some work this week
14:09:29 <uli-k> #info Action item: 4. trozet to prepare RDO/TripleO demo
14:09:56 <uli-k> trozet, it seems you have at least one more week, since we cannot do two demos next week ;)
14:09:59 <trozet> uli-k: yeah I think radez is going to host it next monday, I will be dialed in as well
14:10:03 <trozet> oh
14:10:11 <trozet> OK when do you want to do it?
14:10:19 <uli-k> OK. First ready, first demo.....
14:10:20 <fdegir> uli-k: MatthewLi didn't say 6th of July last week
14:10:22 <uli-k> :D
14:10:33 <uli-k> sorry, then misunderstood..
14:10:47 <fdegir> it was trozet who said 6th of july for tripleo/rdo
14:10:48 <MatthewLi> fdegir: yep I am on a vocation last week
14:10:49 <uli-k> ..or bad memory, getting old.
14:11:09 <uli-k> OK. defeated. Bad memory.
14:11:17 <MatthewLi> if gives one more week, it will be better, hha
14:11:22 <fdegir> just to make sure we get good demo from dradez and trozet :D
14:11:31 <uli-k> :D
14:11:35 <uli-k> Good then....
14:11:50 <uli-k> #agree next week demo RDO/TripleO
14:11:59 <trozet> ok
14:12:14 <uli-k> did I miss an action point?
14:12:25 * uli-k wonders about his bad memory
14:12:39 <fdegir> I think that was all
14:12:50 <uli-k> Thanks. Appreciate. So let's move on.
14:12:54 <radez> so monday next week is the set day correct?
14:13:04 <uli-k> Yes.
14:13:16 <radez> any particular time or should Ijust choose somehting?
14:13:26 <uli-k> I will put it on agenda at wiki.opnfv.org/meetings/octopus
14:13:39 <fdegir> perhaps a demo notification should be sent to everyone?
14:13:41 <uli-k> in octopus weekly meeting.
14:13:50 <fdegir> so the others can see it as well
14:13:55 <radez> got it
14:13:56 <uli-k> Yes.
14:14:09 <trozet> yeah its going ot take up the octopus meeting time slot right?
14:14:09 <MatthewLi> yep, an email is needed
14:14:22 <uli-k> So any additional info I should include in the invite?
14:14:33 <fdegir> gotomeeting?
14:14:40 <trozet> bluejeans
14:14:44 <MatthewLi> one problem is that youtubu can't be reached in China
14:15:10 <radez> uli-k: I'll make a link for you to include
14:15:26 <uli-k> I think GTM will work in most companies. We can use our GTM.
14:15:42 <MatthewLi> that's fine
14:15:43 <fdegir> gtm screen sharing doesn't work on linux
14:15:45 <uli-k> radez, you like different desktop sharing?
14:15:50 <uli-k> boo
14:15:53 <uli-k> ok.
14:16:01 <radez> yea, I won't beable to screen share in gtm
14:16:20 <uli-k> ok. waiting for your link.
14:16:20 * fdegir things redhat guys use redhat ;-)
14:17:05 <uli-k> #action radez and uli-k to send out the invitation to mailing list for the demo.
14:17:18 <bryan_att> ulik, when ready, I have one AOB item
14:18:10 <uli-k> ok. Should we do it at AoB (end of the meeting) or you want to squeeze in now?
14:18:23 <bryan_att> whenever
14:18:28 <bryan_att> now is good
14:18:39 <uli-k> 5min?
14:18:39 <bryan_att> Add R2 goal for adding in additional components to the Arno (or Arno++) install... we need to begin developing scripts etc to add optional VIM components (e.g. an Ansible installer for Congress) as part of CI/CD tool extensions (extended from the basic OpenStack / ODL install)
14:18:42 <uli-k> :D
14:19:14 <uli-k> That doesn't sound like a maintenance topic for Arno.
14:19:21 <MatthewLi> ansible congress?
14:19:27 <bryan_att> We need a repo structure for these optional scripts, and a place in the CD process for them to be invoked
14:19:50 <bryan_att> Octopus is about more than Arno maint, right?
14:20:13 <bryan_att> btw "Arno++" means arno updated for Kilo and Lithium
14:20:23 <uli-k> Right. I just wanted to understand why you said arno++. Such a topic should be Brahmaputra.
14:20:39 <bryan_att> OK, but Arno++ was shorter...
14:20:45 <chenshuai_> is Arno++  anther branch?
14:21:03 <uli-k> There is no Arno++
14:21:03 <bryan_att> No, just a current trunk version of Arno
14:21:09 <fdegir> then master
14:21:18 <uli-k> Why do you say Arno?
14:21:19 <bryan_att> don't get hung up on names - it's the goal that's important
14:21:22 <chenshuai_> i see
14:21:26 <uli-k> OK R2
14:21:40 <uli-k> Any reason why this isn't R2?
14:21:45 <bryan_att> Because we are starting from what we have now, arno, and extending it
14:22:03 <uli-k> Yes. That's exactly what R2 is about. Take R1 and extend it.
14:22:14 <uli-k> Arno maintenance is maintenance. Not extending.
14:22:24 <bryan_att> All our CI/CD tools for R2 are based upon that, right? So this ask is just to add additional components such as Congress using Ansible as an installer script tool
14:22:55 <uli-k> Yes. All R2 tooling will be based on what we have now.
14:22:59 <bryan_att> so call it R2, it's OK. But is the goal clear for this item? I can create a Jira issue.
14:23:11 <fdegir> bryan_att: can you put this to etherpad first
14:23:18 <fdegir> to get better understanding
14:23:21 <fdegir> have discussion
14:23:26 <fdegir> and then create items in backlog
14:23:33 <bryan_att> We will provide some work on it, e.g. get VMWare to submit their Ansible installer
14:23:42 <uli-k> #link etherpad.opnfv.org/p/octopusR2 we collect all R2 stuff.
14:23:47 <fdegir> rather than dumping entire thing as subject to jira item
14:23:50 <MatthewLi> yep, I am familiar with ansible and congress, so make that clear
14:23:59 <bryan_att> Is it not clear now? I can answer additional questions here.
14:24:05 <bryan_att> We need to move faster in R2
14:24:12 <fdegir> but we have been discussing stuff on etherpad
14:24:24 <MatthewLi> maybe my expression makes some mistake
14:24:29 <fdegir> and we haven't even started creating stories for already existing items
14:24:30 <bryan_att> Not much time for rounds of discussion. lets get started on work
14:24:34 <fdegir> :D
14:24:46 <fdegir> if there is noone who understands the details
14:24:49 <fdegir> or do the work
14:24:51 <fdegir> there is no work
14:24:56 <fdegir> we have lots of items to fix
14:24:59 <fdegir> and very few hands
14:25:00 <bryan_att> but I will put it on etherpad.
14:25:07 <fdegir> please
14:25:19 <bryan_att> So, last question: who where does not understand what I am suggesting?
14:25:25 <bryan_att> "who here"
14:25:47 <fdegir> I can't answer this on behalf of everyone
14:25:55 <fdegir> I don't have the details for example
14:26:02 <fdegir> and we need to see it
14:26:04 <fdegir> and prioritize
14:26:22 <fdegir> if you look at the etherpad
14:26:28 <fdegir> there are lots of items we have been discussing there
14:26:37 <fdegir> what is the difference between this item and the rest?
14:27:01 <bryan_att> OK, I will put the level of details I see needed on the etherpad and you can ask for more. For us, this is #1 after moving Arno (Brahmaputra) to trunk in the CI/CD process
14:27:07 <fdegir> https://etherpad.opnfv.org/p/octopusR2
14:27:16 <bryan_att> So afa priority, #1
14:27:22 <fdegir> for us, fixing arno maintenance is #1
14:27:30 <fdegir> so this is #2 without looking the rest of the items
14:27:39 <bryan_att> OK, we can start there
14:27:41 <fdegir> and it might go down in the list
14:27:52 <fdegir> I'm just pointing the reality
14:27:53 <MatthewLi> such as congress used for what,why we need this, need some explains, there maybe somebody don't familiar with this
14:27:59 <fdegir> so I'm a messenger
14:28:02 <bryan_att> but if we move it forward there is no reason the work cant proceed
14:28:13 <fdegir> and that's our problem as Octopus team
14:28:19 <bryan_att> we dont need someone else's blessing to do work in OPNFV...
14:28:24 <fdegir> we move forward pretty slow
14:28:27 <uli-k> There is a limitation of bandwidth of the workers.
14:28:28 <bryan_att> contribution-driven
14:28:38 <uli-k> So you contribute it?
14:28:42 <bryan_att> we will do the work, and get others to help as we can
14:29:08 <fdegir> this is not about blessing bryan_att
14:29:10 <bryan_att> yes, I am not asking you to do something for me, other trhan yhelp create the structure for optional components in the CI/CD process
14:29:15 <fdegir> this is about us being community
14:29:19 <fdegir> helping each other
14:29:20 <bryan_att> we will provide the scripts etc
14:29:31 <fdegir> and if people suffer under  other pressing issues
14:29:38 <fdegir> I think that has highest priority comparing the rest
14:30:14 <bryan_att> understood - all that's needed is the time to approve patches etc - we will provide the patches as quickly as we can come on board with the current CI/CD toolchain
14:30:23 <fdegir> that's fine
14:30:32 <fdegir> I'm not against anyone contributing to OPNFV
14:30:36 <fdegir> stating the facts
14:30:50 <fdegir> and we have only 2 active  committers who review stuff
14:30:59 <bryan_att> we are not committers (yet) so can't participate directly in the review process - we will need help from those who hold the reviewer role
14:31:20 <bryan_att> make us a committer (I will identify who) if needed
14:31:27 <bryan_att> and it will move faster
14:31:27 <fdegir> but we will go into details for releng proposal
14:31:33 <fdegir> to talk about how to make things moving faster
14:31:44 <uli-k> right. We'll do our best. and appreciate that you do the scripts yourself.
14:31:44 <fdegir> which perhaps is a good opportunity talk about why things are like this
14:32:04 <bryan_att> thanks for the time; good enough for now
14:32:09 <uli-k> ok. so let's go back to agenda.
14:32:24 <uli-k> #topic Feedback Arno maintenance proposal
14:32:35 <uli-k> #link https://wiki.opnfv.org/releases/stablebranch
14:33:13 <uli-k> I got some feedback which I can add to the wiki before the TSC tomorrow.
14:33:45 <uli-k> mostly clarifications about some cases what can be included on a stable branch.
14:34:20 <uli-k> Examples: 1. We won’t fix a bug in stable if the bug has a suitable work around
14:35:12 <uli-k> So anything you want me to carry to the TSC for this?
14:36:16 <uli-k> I am a bit wondering what the TSC will say to the proposal of the stable branch maintenance team.
14:37:12 <uli-k> And I am wondering about plans to have a Arno SR (service release which could be more than maintenance).
14:37:27 <uli-k> At least Frank talks about a SR.
14:37:35 <ChrisPriceAB> Hey Guys, just watching.  Anyone can participate in reviews, only committers however can merge.  It is good for non-committers who want to become committers to demonstrate a history of reviewing before being nominated to committer.
14:38:06 <uli-k> ?
14:38:30 * ChrisPriceAB was reading backwards, previous topic
14:39:25 * uli-k ok. It's not an issue about committer nomination.... only about there are only few people doing the work
14:39:43 <ChrisPriceAB> yep, was just saying anyone can.
14:40:14 <uli-k> Looks like nobody wants to give me something about the https://wiki.opnfv.org/releases/stablebranch.
14:40:20 <uli-k> Then we can move on.
14:40:33 <uli-k> #topic Proposal for Releng project
14:41:09 <fdegir> I can give quick summary
14:41:22 <uli-k> Fatih, I think it would be great if we can have common understanding, so everybody will support new releng project.
14:41:44 <uli-k> In this spirit I like to see this. :D
14:41:47 <fdegir> #info Release Engineering - Releng project was proposed last week 2015-06-23 and sent for community for feedback
14:42:31 <fdegir> #info The purpose with proposing releng is to continue what we've been doing in formal way
14:43:01 <fdegir> #info During Arno, releng was the place where all automation, CI, tooling was realized
14:43:23 <fdegir> #info By the people who knows what is needed and has the expertise
14:43:59 <fdegir> #info So, proposed releng project aims to provide service to OPNFV community to cover automation/tooling needs
14:44:20 <fdegir> #info This could be realizing input provided by Octopus and creating CI pipelines
14:44:39 <fdegir> #info Realizing analytics needs for testing projects by creating scripts, installing tools, and so on
14:45:11 <fdegir> #info or other tooling/autoamation needs which we are not aware as of yet
14:46:05 <fdegir> #info Other issues we experienced was not having real world coverage
14:46:27 <fdegir> #info Proposed releng project aims to provide this as well by having committers from Asia, Europe, and Americas
14:46:48 <fdegir> #info Releng committers also come from 5 projects: Octopus, BGS, Functest, Pharos, Docs, LF
14:47:19 <fdegir> #info with broad experience in their own areas and automation who can represent their projects, provide input, and more importantly write code
14:47:40 <fdegir> #info Minor details is that all committers belong to different companies so we have very broad coverage
14:47:56 <fdegir> any questions/comments?
14:48:08 <chenshuai_> that's great and fair
14:48:19 <uli-k> Yes.
14:48:25 <chenshuai_> I have a question
14:48:28 <fdegir> yes
14:48:38 <chenshuai_> for "Releng committers also come from 5 projects: Octopus, BGS, Functest, Pharos, Docs, LF"
14:48:55 <chenshuai_> does that mean only these 5 projects?
14:49:04 <fdegir> these were the ones that were active during Arno release
14:49:26 <chenshuai_> could we accept other further projects if they need us help
14:49:26 <fdegir> and the committers will continuously be refreshed based on the acitvity in the repo
14:49:47 <fdegir> yes
14:49:48 <chenshuai_> fair enought
14:49:58 <chenshuai_> ok, I am fine
14:50:06 <fdegir> this is not a closed group
14:50:09 <fdegir> this is wide open
14:50:23 <fdegir> and everyone who wants to give hand is welcomed
14:50:24 <uli-k> Most of this is things that were originally planned in Octopus, and then realized in releng repo.
14:50:52 <uli-k> Only octopus team had too many committers from beginning.
14:51:00 <fdegir> I can perhaps say that Octopus looks at things from CI/CD point of view
14:51:10 <fdegir> but releng looks at them from raw automation
14:51:23 <fdegir> some things might not be part of CI/CD, such as analytics
14:52:07 <fdegir> any other questions/comments?
14:52:19 <uli-k> Maybe it gets clearer when you explain what remains in octopus.
14:52:32 <fdegir> I can list few of the items
14:52:32 <MatthewLi> fdegir: analytics is the scope of releng?
14:52:38 <uli-k> (since all that was done by Octopus for Arno)
14:53:16 <fdegir> MatthewLi: yes, as stated in project proposal, tooling issues will be handled by releng if it gets approved
14:53:41 <fdegir> releng will be common/neutral place for all testing projects
14:53:47 <fdegir> to provide tooling
14:54:02 <fdegir> going back to uli-k question
14:54:02 <MatthewLi> fdegir: such as what has proposed the dashboard api raised by morgan?
14:54:08 <fdegir> MatthewLi: yes
14:54:27 <fdegir> #info Octopus will continue providing key information when it comes to CI/CD aspects
14:54:41 <MatthewLi> fdegir: I think this maybe a little out of what will be included in releng
14:54:41 <fdegir> #info and continue writing real stuff in same way in releng repo
14:55:42 <fdegir> #info Few of the exampels are: working with upstream, virtualizing deployments, evaluating/employing CI/CD tools, providing guidance to other projects when it comes to CI/CD
14:55:56 <fdegir> MatthewLi: please don't look at the name of "releng"
14:56:02 <fdegir> the idea is provide the tooling
14:56:17 <fdegir> this could be rst2pdf, tox, sphinx, analytics, etc.
14:56:37 <MatthewLi> fdegir: ok
14:56:41 <fdegir> #info releng project is about automation/tooling
14:56:49 <fdegir> #info you can see it as infra project perhaps
14:56:59 <uli-k> Can we say Octopus is using the tooling to setup the pipeline?
14:57:31 <fdegir> Octopus pipelines are setup using tooling provided by releng
14:57:39 <fdegir> like we did for Arno
14:57:53 <fdegir> #info For Octopus people; there is no change in way of working
14:58:05 <fdegir> #info except their patches will be reviewed by mopre people
14:58:11 <fdegir> #info and gets deployed faster
14:58:19 <fdegir> #info which is a huge improvement
14:58:56 <uli-k> .. and nobody will leave octopus when joining releng :D
14:58:56 <meimei1> Can I understand that releng will be a group of tools development?
14:59:09 <fdegir> yes
14:59:19 <fdegir> we have MatthewLi there as well
14:59:22 <fdegir> as committer
14:59:39 <fdegir> meimei1: this was one of the areas that lacked proper handling
14:59:46 <uli-k> we are reaching the full hour now.
14:59:55 <MatthewLi> I am watching around I want to listen other's opinion
14:59:57 <fdegir> #info and the tooling work was done on best effort basis by people from different projects
15:00:04 <uli-k> So we have to move to opnfv-octopus to go on with these questions.
15:00:16 <fdegir> #info releng project puts all these contributors together
15:00:24 <fdegir> #info making self forming team a real project
15:00:33 <fdegir> ok
15:00:52 <frankbrockners> folks - r u done?
15:01:01 <uli-k> Need to close official meeting now. But I like to encourage you to go on on our own channel. So everybody will be happy with the proposal.
15:01:08 <uli-k> yes.
15:01:17 <uli-k> #endmeeting