12:59:47 <morgan_orange> #startmeeting Functest weekly meeting
12:59:47 <collabot> Meeting started Tue Jul  7 12:59:47 2015 UTC.  The chair is morgan_orange. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:59:47 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
12:59:47 <collabot> The meeting name has been set to 'functest_weekly_meeting'
12:59:53 <morgan_orange> #info Morgan
13:00:06 <jose_lausuch> #info Jose Lausuch
13:02:20 <jose_lausuch> hi guy_rodrigue, we are "infoing" the names
13:02:51 <pbandzi> #info pbandzi
13:03:17 <guy_rodrigue> #info guy_rodrigue
13:03:28 <pbandzi> do we running goto metting as well?
13:03:35 <morgan_orange> no just IRC this time
13:03:59 <jose_lausuch> I wonder what time is in China
13:04:06 <jose_lausuch> if they are OoO already...
13:04:06 <fuqiao> #info fuqiao
13:04:14 <fuqiao> 9pm
13:04:28 <morgan_orange> hum it is then still to late for you
13:04:34 <jose_lausuch> ja... normal working hours :D
13:04:45 <morgan_orange> we could do it earlier
13:04:51 <fuqiao> I have got use to this
13:04:54 <jose_lausuch> what about the people in USA?
13:05:06 <morgan_orange> this slot was more dedicated for Asia
13:05:13 <fuqiao> Might be too early for the U.S.
13:05:15 <morgan_orange> we know alternate the meeting
13:05:17 <morgan_orange> now
13:05:33 <morgan_orange> but as this meeting was planned for China we could probably set it earlier
13:05:36 <fuqiao> Yes, I have seen the invitation
13:05:44 <morgan_orange> anyway thnaks fuqiao for joining
13:06:05 <fuqiao> Thank you for arranging the alternative
13:06:08 <jose_lausuch> davidmichaelkarr: there?
13:06:16 <jose_lausuch> maybe too early for him
13:06:25 <morgan_orange> #topic organization
13:06:36 <morgan_orange> #info 3 new possible commiters
13:06:49 <morgan_orange> #info need an official statement. so far only +1
13:07:06 <morgan_orange> #info any objection for promoting D.Karr?
13:07:22 <jose_lausuch> Nop
13:07:47 <morgan_orange> #info no objection
13:07:48 <fuqiao> Not from my side~
13:08:01 <morgan_orange> #info same question for Mei Mei (contribution on test for ONOS)
13:08:24 <davidmichaelkarr> I can see this from my phone, but yes, it's a bit early for me. I can try to do this next time, but it requires extra planning.
13:08:24 <morgan_orange> a bit formal but this is the process
13:08:46 <morgan_orange> #info no objection
13:08:51 <jose_lausuch> Nop
13:09:01 <morgan_orange> #last question for V.Boucher (vIMS clearwater in Functest)
13:09:04 <jose_lausuch> davidmichaelkarr: what time is it there?
13:09:07 <jose_lausuch> No objection from my side
13:09:08 <morgan_orange> #undo
13:09:08 <collabot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2cd5a50>
13:09:20 <morgan_orange> #info last question for V.Boucher (vIMS clearwater in Functest)
13:09:25 <morgan_orange> #info no objection
13:09:35 <morgan_orange> #info requests will be sent to LF to add them in committer list
13:09:39 <davidmichaelkarr> 6:10am.
13:09:59 <morgan_orange> #info some contributors shall also be removed (0 activity and no answer to a previous mail asking for cleaning)
13:10:19 <morgan_orange> #topic Functest Jira for R2
13:10:33 <jose_lausuch> #info https://jira.opnfv.org/issues/?jql=project%20%3D%20FUNCTEST
13:10:34 <julien_ZTE> #info Julien
13:10:42 <morgan_orange> #link https://wiki.opnfv.org/testing
13:10:59 <morgan_orange> #info macro list at the end of the page
13:11:07 <morgan_orange> #2 JIRAs already declared
13:11:23 <morgan_orange> #undo
13:11:23 <collabot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2be6810>
13:11:39 <morgan_orange> #info Common JIRAs already described (2 declared in Functest)
13:11:53 <jose_lausuch> regarding the 3rd one
13:11:56 <jose_lausuch> I am a bit confused
13:12:06 <jose_lausuch> reading at the email from Trevor
13:12:07 <anac1> #info Ana C
13:12:14 <jose_lausuch> how many Dashboards will we have?
13:12:20 <jose_lausuch> Pharos/test?
13:12:22 <morgan_orange> you mean the one with the pharos slide deck?
13:12:26 <jose_lausuch> yes
13:12:34 <morgan_orange> yes I answered to him that I was also a bit puzzled
13:12:50 <morgan_orange> oups forgot to reply to all
13:12:51 <jose_lausuch> there isn't clarity about who does what
13:12:54 * fdegir thinks we need 2 dashboards
13:12:59 <jose_lausuch> hehe :p
13:13:10 <morgan_orange> but I told him that the presentation was misleading regarding the scope of the different project
13:13:13 * jose_lausuch thinks so too, or thought so too
13:13:21 <fdegir> we need some kind of booking system/dashboard to show which lab/pod is doing what
13:13:29 <fdegir> and the other dashboard is for test results
13:13:32 <jose_lausuch> yes
13:13:35 <morgan_orange> I think Pharos shall deal only with testbeds status, availability, planning, ...)
13:13:36 <jose_lausuch> that was my assumption
13:13:51 <fdegir> yep - that's why slide 5 is kind of confusing
13:13:51 <morgan_orange> ok so we are in line
13:14:24 <morgan_orange> #info to be discussed with Trevor but Pharos slide deck was a bit confusing. tests must be out of scope of Pharos
13:14:30 <anac1> what's the difference between COM-1 and COM-9?
13:14:34 <fdegir> and dashboard, CI/CD
13:14:42 <anac1> sorry COM-1 and COM-8
13:14:47 <fdegir> dashboard=test dashboard
13:14:55 <fdegir> or results db/analytics
13:14:57 <davidmichaelkarr> Leaving now (not even dressed yet).
13:15:21 <morgan_orange> #info pharos dashboard = status, availability, planning, tooling versus test dashboard (collecting and displaying test results)
13:15:26 <jose_lausuch> ok, davidmichaelkarr. We'll send around the MoMs
13:15:45 <morgan_orange> #action contact Trevor to clarify Pharos slide deck
13:15:50 <morgan_orange> #undo
13:15:50 <collabot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x2c37950>
13:15:55 <jose_lausuch> will we have a time slot on thursday to discuss this?
13:16:00 <morgan_orange> #action morgan_orange contact Trevor to clarify Pharos slide deck
13:16:06 <morgan_orange> I thin so
13:16:22 <fdegir> I think Trevor has an action for tsc meeting today
13:16:36 <morgan_orange> it was related to Pharos or to the test strategy?
13:16:36 <fdegir> not sure if he'll present those slides
13:16:42 <fdegir> pharos
13:16:52 <morgan_orange> hum ok we will see then
13:17:29 <morgan_orange> pbandzi: do you plan some refactoring of the ODL test suite?
13:17:50 <jose_lausuch> I think we can start working on COM-3, at least the definition or design
13:18:00 <morgan_orange> jose_lausuch: guy_rodrigue strated working on result collection, it will make sense to be involved
13:18:05 <jose_lausuch> morgan_orange: I dont see any Task for the DB
13:18:06 <pbandzi> #info I plan to make ODL test result in one log file
13:18:27 <morgan_orange> yes we should add one I can edit now, it will be probably more in releng
13:18:43 <jose_lausuch> that was my next question
13:18:46 <fdegir> jose_lausuch: anac1 : what is COM?
13:18:55 <pbandzi> morgan_orange I saw your discussion about having test result in json. so I will probably make the results also to json format
13:18:56 <jose_lausuch> who is responsible for the DB? Functest or releng?
13:18:59 <anac1> the tasks in the link
13:19:04 <jose_lausuch> since guy_rodrigue already started working on that
13:19:24 <jose_lausuch> fdegir: ttps://wiki.opnfv.org/testing at the end
13:19:37 <jose_lausuch> "h" missing
13:19:43 <morgan_orange> I think it makes sense to do it in releng, then fdegir must grant guy_rodrigue as Releng committer
13:19:53 <jose_lausuch> ok
13:20:14 <guy_rodrigue> ok
13:20:21 <morgan_orange> #info creation of COM-10 to create the no SQL DB supporting data collection
13:20:50 <jose_lausuch> did we decide where the DB will be deployed?
13:20:52 <jose_lausuch> LF HW?
13:21:20 <morgan_orange> it shall be reachable form any PODs, Europe, US, China, Antarctica,...
13:21:24 <fdegir> I think we can get help from aricg for place to put the DB
13:21:34 <jose_lausuch> aricg: ping
13:21:37 <anac1> replicated?
13:21:47 <jose_lausuch> for now I think its ok if its not replicated
13:21:52 <jose_lausuch> although that would be nice to have
13:22:00 <morgan_orange> #info anac1 COM-1 and COM-9 were the same, reallocation of COM-9 to DB
13:22:18 <jose_lausuch> taking advantatge of one of the nicest features of Mongo
13:22:21 <jose_lausuch> but first things first
13:22:42 <anac1> yes, but hthe design should hold long term...
13:22:56 <jose_lausuch> yes
13:22:59 <jose_lausuch> you are right
13:23:06 <jose_lausuch> it also dependes on the HW we have to deploy it
13:23:12 <jose_lausuch> how many servers and so on
13:23:28 <jose_lausuch> maybe R2 is not replicated and we add a JIRA for R3 for replication?
13:23:31 <jose_lausuch> I dont know
13:24:41 <morgan_orange> Mongo shall support this kind of think, we may have a look to see the level of contraints
13:24:50 <morgan_orange> the informations are not critical for real time
13:25:06 <guy_rodrigue> and what is the strategy we finally agreed on for data collection ?
13:25:08 <morgan_orange> assuming that we are able to backup in case of problem
13:25:16 <jose_lausuch> if it runs on a VM or in a Docker inside a server we could make use of replication
13:26:14 <morgan_orange> guy_rodrigue: you mean push from project in the DB according to an API, versus each project pushes its logs/reults somewhere then an agent populate the DB?
13:26:33 <guy_rodrigue> yes
13:26:37 <anac1> agree
13:26:42 <jose_lausuch> my assumption was that each project pushes its results to the DB directly
13:26:52 <anac1> common api?
13:26:58 <jose_lausuch> REST?
13:27:05 <anac1> agree
13:27:07 <guy_rodrigue> yes REST was the idea
13:27:07 <fdegir> +1 for common
13:27:25 <guy_rodrigue> +1 for common
13:27:36 <fdegir> if things change, will impact all test FWs
13:27:56 <fdegir> which is harder if everyone does their own thing
13:28:07 <fuqiao> Agree
13:28:44 <anac1> anyone working on api spec?
13:28:49 <morgan_orange> yes I would prefer that each procjet could be independant (just push their results somewhere)
13:29:03 <morgan_orange> then an agent uses the APIs, and of course if project wants to use the API they can
13:29:57 <guy_rodrigue> that could work too
13:30:02 * ChrisPriceAB thinks it's worth providing each project a common reporting API
13:30:18 <fdegir> if we diverge right in the beginning, it would be harder to make it common later on
13:30:30 <ChrisPriceAB> yep
13:30:31 <jose_lausuch> +1 for common too
13:30:43 <morgan_orange> ok we can vote...
13:31:14 <anac1> we can help with api spec, if no one has started
13:31:41 <jose_lausuch> new task for JIRA? :)
13:31:55 <morgan_orange> guy_rodrigue: anac1 jose_lausuch ok to work on this API? we could discuss it during the OPNFV hackfest
13:32:05 <guy_rodrigue> yes
13:32:07 <jose_lausuch> sure
13:32:09 <anac1> ok
13:32:10 <ChrisPriceAB> worth doing a spec on the wiki in order to get crowdsourcing, then moving it to gerrit once "relatively stable"
13:32:35 <anac1> spec is already a jira task in yardstick, can we link to that?
13:32:37 <morgan_orange> yes guy_rodrigue already worked on the data model https://wiki.opnfv.org/collection_of_test_results
13:33:12 <anac1> https://jira.opnfv.org/browse/YARDSTICK-64
13:33:16 <morgan_orange> anac1: as it is common and we decided to put all the common testing task in Functest, I will create on jira here and link it to teh one in yardstick, ok?
13:33:27 <anac1> sure
13:33:38 <anac1> works for me
13:33:46 <morgan_orange> #action morgan_orange create a JIRA for Common reporting API
13:33:50 * ChrisPriceAB thinks it would be good to have someone assigned to a functest jira task that links to the other related tasks
13:34:49 <morgan_orange> can we switch to the data model first proposal?
13:34:56 <morgan_orange> there were some exchanges on the mailing list
13:35:00 <jose_lausuch> if we follow this approach, we might not need to push things to artifactory
13:35:12 <morgan_orange> yes
13:35:40 <morgan_orange> so my argument was not good because at the moment  in jenkins we must add a piece of code to push results
13:35:48 <morgan_orange> so this piece of code versus a REST API...
13:35:57 <morgan_orange> better to have a clear common API
13:36:06 <morgan_orange> using a beautifull NoSQL DB
13:36:08 <morgan_orange> :)
13:36:09 <anac1> yes
13:36:13 <jose_lausuch> yep
13:36:31 <morgan_orange> so back to data model
13:36:39 <jose_lausuch> as for the data model that guy_rodrigue proposes
13:36:58 <jose_lausuch> there were some discussions I triggered about having another table for POD info
13:36:59 <morgan_orange> #link https://wiki.opnfv.org/collection_of_test_results
13:37:09 <jose_lausuch> what do we agree on that?
13:37:15 <morgan_orange> I suggested to Trevor to propose something for the POD description
13:37:29 <guy_rodrigue> jose_lausuch also proposed that we might have a description for each POD
13:37:30 <jose_lausuch> do we put the HW description into the result table as well?
13:37:54 <anac1> what is included?
13:37:58 <morgan_orange> #info shall we have another table for POD info
13:38:11 <jose_lausuch> trozet said: I don't think a seperate data structure for POD is necessary.  The test result should contain the POD it was ran on, along with fuel/foreman, and virtual or baremetal.
13:38:42 * ChrisPriceAB agrees
13:38:42 <morgan_orange> it depends on the level of details you put into your POD description
13:38:45 <fdegir> I think it should refer to the pod
13:38:58 <fdegir> and then pharos gets that info
13:39:10 <morgan_orange> for the test today you need to know: POD name, installer type, instllation mode (cirtual versus bare metal)
13:39:15 <fdegir> on pod dashboard or whatever
13:39:39 <jose_lausuch> the problem I see is that installation_mode is not attached to the POD, any pod can run any installation type
13:39:41 <morgan_orange> but we may imagine that it would be interested to compare results assuming from the same tuite with the same installer on different hardware
13:39:59 <anac1> yes
13:40:17 <fdegir> pod name should be there with installer name etc
13:40:27 <fdegir> but not low level details
13:40:30 <jose_lausuch> exactly
13:40:33 * icbts refer to pod name, but somewhere record what that pod was at the time (hardware could change over time, better to know if POD ABC today == POD ABC three months from now)
13:40:36 <jose_lausuch> pod name and installer type yes
13:40:45 <jose_lausuch> but the hw types, switches and so on
13:40:57 <fdegir> as icbts points out
13:40:58 <jose_lausuch> this is not so relevant and it could be another separated table
13:41:09 <morgan_orange> ok so if I try to summarized
13:41:13 <fdegir> that part should be taken care of by pharos
13:41:29 <morgan_orange> in test objects we have the pod name, the date and the installer
13:41:47 <morgan_orange> then in pharos they have a low level description of the POD including hardware, switches, accelleration cards
13:41:55 <morgan_orange> and pharos is able to manage the history of the POD
13:42:06 <morgan_orange> i.e 3 months ago snapshot of the hardware was that
13:42:10 <morgan_orange> now it is that
13:42:15 <jose_lausuch> does it mean that we dont include the hw info in our DB, right?
13:42:41 <morgan_orange> no but I assume the same DB could be used by Pharos to store POD's info
13:42:47 <morgan_orange> to be discussed with Trevor
13:42:55 <jose_lausuch> ok, thats fine
13:43:01 <anac1> some test cases need hw info
13:43:12 <anac1> how to you correlate results?
13:43:14 <morgan_orange> yes but if we have the POD name and the date
13:43:15 <ChrisPriceAB> yes, all you should need is a reference to the POD that pharos provides, then look-up the details
13:43:20 <morgan_orange> we shall be able through Pharos description
13:43:27 <morgan_orange> to retrieve the compelte hardware config
13:43:28 <jose_lausuch> exactly
13:43:41 <anac1> using the same db?
13:43:55 <jose_lausuch> to be agreed with Pharos, but its an option
13:44:10 <jose_lausuch> or maybe they have already their own ideas to get this info
13:44:27 <anac1> check with pharos
13:44:33 <morgan_orange> to be discussed during a thursday meeting
13:44:38 <anac1> agree
13:44:39 <morgan_orange> let me info the last discussions
13:45:02 <morgan_orange> #info for test project keep only basic POD information (POD name, installer)
13:45:04 <ChrisPriceAB> Sounds like a conversation with pharos and CI on the DB and schema's would be useful.
13:45:11 <morgan_orange> #info low level details shall be available in Pharos
13:45:30 <morgan_orange> #info discussion to be planned with Pharos to validate that
13:45:49 * fdegir thinks CI agreed :)
13:46:07 * ChrisPriceAB ;)
13:46:14 <morgan_orange> I think Trevor will need some troops to work on that
13:46:56 <fdegir> i think this could be associated with test db work
13:47:15 <fdegir> pharos provides the needs for db and releng realizes it
13:47:29 <ChrisPriceAB> ack
13:47:40 <ChrisPriceAB> based on funtest et. al. requirements
13:47:42 <morgan_orange> that is great that a project realizes everything you need... :)
13:48:17 <fdegir> :)
13:48:38 <morgan_orange> ok that is all for today
13:49:18 <morgan_orange> fuqiao: we could move the functest asian time earlier next time
13:49:26 <morgan_orange> 21 is still too late
13:49:47 <morgan_orange> will discuss offline
13:49:57 <fuqiao> Hehe, ok. If it is not too inconvenient for the others
13:50:00 <jose_lausuch> but we had a doodle where everyone voted :)
13:50:00 <morgan_orange> maybe last topic
13:50:07 <morgan_orange> #topic OPNFV hackfest
13:50:25 <morgan_orange> jose_lausuch: and myself will be present
13:50:38 <morgan_orange> #link https://etherpad.opnfv.org/p/OPNFV_at_ODL
13:51:06 <morgan_orange> for the moment there is a slot for a status on Functest/Qtip/Vperf
13:51:22 <morgan_orange> we could organize an ad hoc session on the common API / DB with Releng
13:51:30 <morgan_orange> do you want to discuss other topics?
13:52:08 <morgan_orange> ok so we can close the meeting
13:52:16 <morgan_orange> thank you
13:52:20 <morgan_orange> #endmeeting