14:03:16 <fdegir> #startmeeting Octopus Weekly Meeting
14:03:16 <collabot> Meeting started Mon Aug 10 14:03:16 2015 UTC.  The chair is fdegir. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:03:16 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:03:16 <collabot> The meeting name has been set to 'octopus_weekly_meeting'
14:03:21 <dneary> #info Dave Neary
14:03:24 * fdegir thanks dneary
14:03:25 <dneary> :-)
14:03:34 <fdegir> didn't notice the whitespace
14:03:44 <fdegir> #topic roll call
14:03:59 <fdegir> can we #info again please
14:04:04 <fdegir> sorry for the waste
14:04:08 <fdegir> #info Fatih Degirmenci
14:04:15 <meimei> #info meimei
14:04:24 <trozet> #info Tim Rozet
14:04:55 <fdegir> I think we have enough people to start
14:04:59 <fdegir> #topic Agenda Bashing
14:05:14 <fdegir> I'm still trying to catch things up so will use last week's agenda as below
14:05:46 <fdegir> #info action item review / lab compliancy / E2E CI / Jira Issues / B-Release CI work
14:06:11 <fdegir> #topic Action Item Review
14:06:56 <fdegir> #info First action item is on uli-k and trozet
14:07:02 <fdegir> #info uli-k and trozet to bring to the TSC whether Brahmaputra should be released using LF lab or differently.
14:07:16 <fdegir> trozet: did you have chance to look at this together with uli?
14:07:33 <trozet> #info we asked last TSC meeting, ChrisPriceAB said he would have to find out
14:07:51 <trozet> so still unknown
14:07:56 <fdegir> ok, then I keep action on you until we get answer from ChrisPriceAB
14:08:05 <trozet> k
14:08:52 <fdegir> #action uli-k trozet: report back once ChrisPriceAB clarifies the need of doing Brahmaputra release on LF Lab
14:09:08 <fdegir> next action is on chigang
14:09:11 <fdegir> chigang: ping
14:09:19 <fdegir> #info chigang to try on a POD to apply new naming scheme to a slave.
14:09:27 <meimei> renaming scheme?
14:09:29 <meimei> ok
14:09:32 <fdegir> yes
14:09:40 <meimei> About renaming scheme, I suggest we name the slave like this:   [provider]-[CI/DEV]-[Virtual/Metal],
14:09:40 <meimei> Is that ok?
14:09:55 <meimei> for example,  a node named huawei-ci-virtual is provided by huawei, and is CI-dedicated, and we can implement a virtual deployment on it.
14:10:17 <fdegir> I had some thoughts about it but not had time to come back yet
14:10:29 <fdegir> lets keep the discussion until next meeting
14:10:35 <fdegir> and finalize it then
14:10:42 <meimei> I have put this on ehterpad
14:10:58 <fdegir> the reason is that we might not be able to dedicate slaves to ci or dev only
14:11:02 <fdegir> or just for deployment
14:11:22 <fdegir> but we discuss it on etherpad
14:11:34 <fdegir> I assume chigang didn't have time to try naming scheme yet
14:11:38 <fdegir> so keeping action open
14:11:45 <fdegir> #action chigang to try on a POD to apply new naming scheme to a slave.
14:11:47 <meimei> I think the node for CI must be more stable
14:12:02 <meimei> If you donot have any other suggestion, I will have a try on huawei's lab, and drive pharos to put this naming convention into lab acceptance criteria.
14:12:12 <fdegir> meimei: I have suggestions
14:12:17 <meimei> ok
14:12:28 <meimei> wait for your suggestion
14:12:30 <fdegir> can we keep this for later - we might need to share community labs between ci and dev
14:12:34 <aricg> meimei: we will need to cordinate on name changes, they require a new secret.
14:13:02 <fdegir> and aricg says, lab contact should be around while doing the name change
14:13:26 <fdegir> #info slave name change requires coordination since it requires a new secret
14:13:43 <fdegir> #info slave naming scheme work is still going on
14:13:57 <fdegir> and the last action item is on uli-k regarding Octopus committer list
14:14:08 <fdegir> I think it is still open
14:14:21 <aricg> ?
14:14:32 <aricg> Not this? https://wiki.opnfv.org/releng
14:14:39 <fdegir> aricg: nope
14:14:47 <fdegir> aricg: octopus has many silent committers
14:15:08 <fdegir> and uli-k was going to check with them if they're going to help out or not
14:15:13 <aricg> Ah,
14:15:13 <fdegir> and then clean up the list
14:15:27 <fdegir> #action uli-k to contact silent committers and encourage them to start working.
14:15:43 <fdegir> I think this was the last action item
14:15:46 <fdegir> moving on
14:16:00 <fdegir> #topic lab compliancy
14:16:24 <fdegir> #info meimei put some input to etherpad regarding this
14:16:28 <fdegir> #link https://etherpad.opnfv.org/p/octopusR2
14:16:45 <fdegir> #info Under the heading Octopus requirements on lab compliance
14:16:56 <meimei> yes,I have put a list in etherpad,this depends on the discussion result in TSC
14:17:21 <fdegir> please have a look at it and share your thougths
14:17:28 <meimei> ok
14:17:40 <fdegir> #info thx meimei for starting it up
14:17:54 <meimei> Octopus requirements on  labs compliance:
14:17:54 <meimei> 1. Dedicated to E2E CI
14:17:54 <meimei> 1. We require your lab or specified POD in your lab be CI dedicated, that is it will be available for CI usage all time.  If it will be used for development these activities can be interrupted by CI anytime, and E2E CI will be implemented on your lab on timer/daily, or maybe merge-triggered.
14:17:54 <meimei> 2. Automatic Reconfiguration
14:17:55 <meimei> We require your lab have specific scripts for automatic reconfiguration  that will be executed by CI before a E2E CI job is executed on your lab.
14:17:55 <meimei> 3. Keep online
14:17:55 <meimei> We require your lab connected to jenkins and online 24x7. CI team shall be notified when some maintenance is scheduled.
14:17:56 <meimei> 4. Maintainable
14:17:56 <meimei> We require the admin access to your lab to troubleshooting CI issues.
14:17:57 <meimei> 5. Standard name
14:17:57 <meimei> We require your lab connected to jenkins master by a standard name,  just like: [provider]-[CI/DEV]-[Virtual/Metal],  for example,  a node named huawei-ci-virtual is provided by huawei, and is CI-dedicated, and we can implement a virtual deployment on it.
14:17:58 <meimei> Based on this specification, we can easily put these nodes with the same purpose into a pool,  e.g. for E2E CI ,  and implement E2E CI  using a  round-robin mechanism.
14:18:28 <fdegir> #info once it is settled, it will be provided to pharos and the OPNFV community as input
14:18:47 <fdegir> anyone wants to add anything regarding lab compliance?
14:19:17 <fdegir> moving on to next item; Definition of E2E CI
14:19:26 <fdegir> #topic E2E CI
14:19:41 <fdegir> #info We've been having some discussions within Octopus team regarding E2E CI
14:20:04 <meimei> Last week we disccussed about E2E CI,  but have not finished.
14:20:16 <meimei> I think we must reach an agreement to work better on release-B.
14:20:31 <fdegir> #info due to lack of resources, current E2E CI is quite limited; done by timer /daily and limited in scope
14:20:52 <fdegir> and it is not close to what E2E CI tbh
14:21:04 <meimei> I also have put some of my thoughs in etherpad
14:21:37 <meimei> Could we have a further disscussion at this meeting?
14:21:40 <fdegir> yes
14:21:46 <meimei> the scope and concept of E2E
14:21:46 <meimei> 1th End:
14:21:46 <meimei> E2E CI will still be triggered by timing (because lack of resource)
14:21:46 <meimei> and then if we can run E2E CI sequentially(reconfiguring LF lab) , we will run E2E CI after merge and it will be sequential
14:21:46 <meimei> After more official labs are functional, E2E CI will be triggered by each code change or test case change.
14:21:46 <meimei> 2ed End:
14:21:46 <meimei> run build/develop/test sequentially
14:21:47 <meimei> collect all the outputs(report/log) of build/develop/test
14:21:47 <meimei> show a uniform report of full chain(build/develop/test)
14:22:08 <fdegir> meimei: can we paste the link instead please?
14:22:19 <meimei> ok:P
14:22:23 <fdegir> pasting 10s of lines wouldn't help but make irc harder to follow
14:22:37 <meimei> sorry
14:22:39 <fdegir> np
14:23:05 <fdegir> #info as meimei points out on etherpad and I quite agree the CI should start with a change
14:23:36 <fdegir> #info and different jobs should be triggered based on the nature of the change, realizing our loops in CI
14:24:18 <fdegir> #info all the changes that are sent for review should travel our CI, creating feedback to developer and the wider community regarding the quality of the change
14:24:52 <fdegir> #info and if any change that fails to pass certain loop should not be allowed to merge to master
14:25:21 <fdegir> #info when it comes to longer loops such as our daily loops and perhaps later on weekly
14:25:59 <fdegir> #info we should perhaps employ some kind of promotion mechanism to carry artifacts known to have better quality to longer loops
14:26:23 <fdegir> and this is pretty high level definition of CI for me
14:26:40 <fdegir> meaning that we always try to do things when things happen; triggered by change
14:27:00 <fdegir> and test them as much and as quick as possible in shorter loops
14:27:32 <fdegir> increasing the scope of testing while we move towards to longer/more extensive loops
14:27:59 <fdegir> anyone else wants to share his/her thoughts?
14:28:43 <fdegir> it seems not
14:29:08 <meimei> yes , very high level
14:29:18 <fdegir> #info please go ahead and share your thoughts on etherpad under the heading of "the scope and concept of E2E CI"
14:29:26 <fdegir> #link https://etherpad.opnfv.org/p/octopusR2
14:29:53 <fdegir> moving on to the next topic if noone objects
14:30:19 <fdegir> #topic Jira Issues and B-release CI Work
14:30:43 <fdegir> I haven't been able to check the Jira yet
14:30:58 <fdegir> anyone created any stories/tasks in the backlog for B-release work?
14:31:48 <fdegir> #info We need to start cleaning up the backlog and populating the new one on Jira for B-Release
14:32:34 <aricg> here you go fdegir -> https://jira.opnfv.org/browse/RELENG/
14:32:45 <fdegir> #info Please have a look at Jira and close/cancel the Jira issues that you fixed already but haven't closed yet
14:32:54 * fdegir thanks aricg
14:33:24 <fdegir> trozet aricg: it would perhaps good to have a quick status update regarding LF Lab Reconfiguration
14:33:34 <fdegir> since CI needs to do some work
14:33:48 <fdegir> #topic LF Lab Reconfiguration Status
14:34:06 <trozet> #info the lab reconfig works for Foreman, and there were some updates made for Fuel.  Fuel still needs to finish a few changes and still test before we take down POD1
14:34:24 <fdegir> thx trozet
14:34:25 <trozet> #info szliard_ is working on it from the FUel side
14:35:03 <fdegir> #info fuel verification/adjustments are needed in order to be able to maintain/support Arno release for both Foreman and Fuel
14:35:28 <fdegir> anyone wants to know more can join bgs meeting right after this one
14:35:55 <fdegir> #topic AoB
14:36:02 <fdegir> anyone wants to bring anything?
14:36:45 <fdegir> then I thank you all for joining
14:36:51 <trozet> thanks fdegir
14:36:52 <fdegir> and have a nice day
14:36:56 <fdegir> #endmeeting