15:00:10 <frankbrockners> #startmeeting OPNFV BGS/Genesis weekly meeting
15:00:10 <collabot> Meeting started Mon Aug 24 15:00:10 2015 UTC.  The chair is frankbrockners. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:10 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:00:10 <collabot> The meeting name has been set to 'opnfv_bgs_genesis_weekly_meeting'
15:00:19 <frankbrockners> #topic roll call
15:00:26 <frankbrockners> #info Frank Brockners
15:00:27 <trozet> #info Tim Rozet
15:00:38 <pbandzi_> #info peter Bandzi
15:00:40 <chenshuai> #info chenshuai
15:00:58 <dduffey> #David Duffey
15:01:01 <[1]JonasB> #info Jonas Bjurel
15:01:05 <chigang> #chigang
15:01:09 <lmcdasm> #info Daniel Smith
15:01:12 <chigang> #info chigang
15:01:39 <[1]JonasB> I unfortunatly have very spoty connectivity from my hotel:-(
15:02:01 * frankbrockners hopes that it is good enough for IRC :-)
15:02:19 <frankbrockners> Looks like we already have a quorum
15:02:27 <frankbrockners> let's get started...
15:03:02 <frankbrockners> #info agenda: https://wiki.opnfv.org/meetings/bgs#aug242015
15:03:08 <frankbrockners> anything else to add?
15:03:44 <frankbrockners> I have one additional minor topic - doesn't really need an agenda item
15:03:47 <chenshuai> frankbrockners: shall we need to talk about genesis tickets?
15:03:58 <chenshuai> i mean jira
15:04:11 <frankbrockners> chenshuai: Yes this is the plan as part of the Genesis agenda topic
15:04:39 <frankbrockners> back on my minor ticket: I won't be able to host the next two Monday meetings
15:05:06 <frankbrockners> looking for a volunteer from the Genesis committer team to fill in for me and host the meeting....
15:05:44 <fdegir> #info Fatih Degirmenci
15:06:22 <frankbrockners> anyone willing to drive the meetings on Aug/31 and Sept/7?
15:07:06 <pbandzi_> frankbrockners: I can , i am  not commiter however :)
15:07:13 <lmcdasm> i can as well if need be
15:07:26 <frankbrockners> trozet, [1]JonasB?
15:07:45 <trozet> frankbrockners: OK
15:07:53 <trozet> frankbrockners: I can
15:08:01 <frankbrockners> thanks trozet
15:08:26 <frankbrockners> #info trozet will host BGS/Genesis weekly meetings on Aug/31 and Sept/7
15:08:35 <frankbrockners> ok - now on to the agenda
15:08:47 <frankbrockners> #topic LF lab reconfig status
15:09:14 <trozet> #info POD2 can now deploy fuel and foreman
15:09:22 <frankbrockners> pbandzi_, trozet  could you give us an update? I believe we're all good now, right?
15:09:33 <trozet> #info there is one issue that creeps up every so often where there jenkins slave disconnects during deploy:
15:09:41 <trozet> #link https://build.opnfv.org/ci/job/genesis-foreman-deploy-master/52/console
15:10:08 <trozet> #info not sure why this happens, something with timing during start up is my guess
15:10:23 <fdegir> trozet: we might need to put some more sleep
15:10:35 <fdegir> and can do more magic if necessary - wait for slave to come up
15:11:01 <trozet> #info POD1 is also able to run foreman virtual deploy (3/3 passes).  I have submitted a patch to enable it for jenkins/gerrit verification
15:11:17 <trozet> fdegir: yeah we can try adding more sleep
15:12:18 <frankbrockners> thanks trozet and fdegir
15:12:30 <fdegir> before you switch subject frankbrockners
15:12:45 <fdegir> can I ask to both trozet and pbandzi_: does this mean we can enable daily runs triggered via timer?
15:12:56 <fdegir> starting tonight?
15:13:18 <trozet> fdegir: I believe so
15:13:26 <pbandzi_> i have no problem also it if everything works now
15:13:30 <fdegir> good, thx
15:13:35 <fdegir> then we're back to business
15:14:24 <frankbrockners> #info daily deploys re-activated from tonight onwards
15:14:41 <frankbrockners> #topic Arno SR1 - status
15:14:59 <frankbrockners> #info TSC decided Arno SR1 release date as Sept/29
15:15:22 <frankbrockners> are we still on track from a Fuel and Foreman/Quickstack perspective?
15:15:53 <[1]JonasB> #info rebasing for Fuel SR1 ongoing - should be fine for CF mid sep and release end Sep.
15:16:16 <[1]JonasB> Did yo get that, manual Ack needed :-)
15:17:08 <trozet> [1]JonasB: I see your info message
15:17:26 <[1]JonasB> trozet: thx
15:17:44 <trozet> #info Now that CI and jenkins verification are ready to go again.  Will be working on fixing SR1 bugs this week.  Still on track for release
15:18:14 <frankbrockners> thanks trozet, [1]JonasB
15:18:20 <lmcdasm> frank - are there planned content lists for SR1 available yet?
15:18:23 <frankbrockners> anything else on SR1?
15:19:15 <frankbrockners> lmcdasm - what are "planned content lists"?
15:19:48 <lmcdasm> so we have an idea of the deliverables - or is that simply going to be in the readme on what is cut at code freeze - just wondering since people have asked me "what will be in it - sr1"?
15:21:09 <[1]JonasB> lmcdasm: largely critical bug-fixes for respective installer
15:21:18 <frankbrockners> hmm .. my current understanding is that it is a "service release" - so officially no new features, but bug fixes. If there are additional enhancements, then we'd just release and document them as additional benefits
15:21:54 <lmcdasm> thank you
15:23:09 <frankbrockners> ok - let's move on
15:23:11 <frankbrockners> #topic Genesis: Work procedures
15:23:49 <frankbrockners> in our past meetings we already discussed the topic of "how to interface with Genesis" a bit
15:23:52 <trozet> i plan on putting bug fixes/enhancements in release notes for SR1
15:24:26 <frankbrockners> #info https://wiki.opnfv.org/genesis/genesis_work_procedures provides a few updates
15:24:56 <frankbrockners> #info i.e. outlines of "how other teams could interface with Genesis"
15:25:31 <frankbrockners> #info part of the update is to include a recipe for "how to insert your requirement into Jira"
15:26:00 <frankbrockners> would be great if you could review and evolve
15:26:13 <frankbrockners> any immediate thoughts on the wiki as it is right now?
15:27:00 <[1]JonasB> I need to come back with comments tomorrow
15:27:11 <frankbrockners> thanks [1]JonasB
15:27:31 <chenshuai> so anyone could create genesis jira for requirement?
15:27:56 <frankbrockners> chenshuai - yes, that would be the plan
15:28:01 <chenshuai> great
15:28:37 <fdegir> a question frankbrockners
15:28:52 <fdegir> the type of the jira issues is "ticket" there
15:29:02 <fdegir> how do you plan to follow up requirements?
15:29:07 <fdegir> via tasks or stories?
15:30:03 <[1]JonasB> One thing I think wee urgently need to do is to request B-projects to report their needs/requirements on installers: deps, way they intend to deliver (manifests, scripts, etc.)
15:30:10 <frankbrockners> would we need a follow-up here? IMHO the ticket should be sufficient to create an associated patch
15:30:35 <frankbrockners> at least for "requirements written in English language"
15:30:51 <frankbrockners> for code - it could be either a task or a story - but more likely a story
15:30:58 <fdegir> not the follow up but settling the way right in the beginning would be better
15:31:21 <trozet> so then, would a JIRA ticket that is "Resolved" mean it was accepted?
15:32:02 <frankbrockners> IMHO resolved would mean that someone created a patch - which could either be accepted/merged or disagreed/abandoned
15:33:03 <frankbrockners> fdegir - makes sense - so we should be more selective about matching the type of requirement to the type of the jira issue
15:34:07 <frankbrockners> trozet - my understanding so far was to use Jira as a "better sandbox" to allow requirements to be submitted in a structured way. Ultimate truth is in git - not in Jira
15:34:19 <fdegir> the reason I ask this is that if a requirement comes in via story, subtasks per installer to have installer specific work/discussion/analysis can be created
15:35:03 <frankbrockners> fdegir - do you want to switch to story as default? We can of course do this
15:35:04 <fdegir> and then overall story can be tracked &  closed impelemented/rejected depending on the status of subtasks
15:35:13 <trozet> fdegir +1
15:35:15 <fdegir> frankbrockners: just a feedbacj
15:35:25 <fdegir> I would've done it like that myself
15:36:04 <trozet> i think the tracking should be done in JIRA and as we normally do git commits use JIRA ID to coordinate reqs to patches
15:36:17 <trozet> Resolved state sounds good for when a patch is in for every sub-task for installers
15:36:21 <[1]JonasB> trozet +1
15:37:03 <frankbrockners> I like the idea
15:37:11 <frankbrockners> makes better use of Jira
15:39:52 <frankbrockners> I'll try to update the wiki accordingly and also changes the current Jira issues from "features" to "stories". Description is not necessarily always "story" style - but we probably need to live with this for now...
15:41:08 <frankbrockners> #action frankbrockners to change wiki to reflect: Genesis Jira requirements input as stories. Jira ticket would be "resolved" if all installers implemented it.
15:42:01 <frankbrockners> given that we're already on the Jira topic.. let's switch topic...
15:42:36 <frankbrockners> #topic Initial set of Jira tickets for requirements definition - and document templates in Git
15:43:17 <frankbrockners> #info frankbrockners took the requirements we had in the sandbox document and created associated Jira tickets (which will become stories)
15:43:56 <[1]JonasB> I think we should avoid having directories specific to releases
15:44:09 <frankbrockners> #info there is also a proposed template format for "requirements in English language": https://gerrit.opnfv.org/gerrit/#/c/1278/
15:44:55 <frankbrockners> [1]JonasB - per what I said over email, I'm also on the fence for that one...
15:46:11 <frankbrockners> should we avoid release specific directories for requirements in English language? I mainly proposed this to make things more obvious for a general audience:
15:46:40 <frankbrockners> You browse to http://git.opnfv and read what is in a certain release..
15:46:52 <frankbrockners> Thoughts? I'm fine either way
15:47:23 <[1]JonasB> I think we better stick to use git as version, tagging control and have release artifacts catalouged per release in artifactory
15:47:44 <frankbrockners> any other views?
15:48:33 <lmcdasm> i am in line with Tim's commenti nthe ticket
15:48:39 <frankbrockners> trozet? wshao?
15:48:47 <lmcdasm> sorry.. trozet
15:49:14 <trozet> I agree with [1]JonasB.  The genesis requirements should show up here for users interested: https://www.opnfv.org/software/download
15:49:36 <fdegir> or artifacts.opnfv.org
15:49:42 <trozet> those are just links to artifacts
15:49:43 <trozet> but yeah
15:49:50 <fdegir> since we generate docs after change gets merged
15:50:17 <lmcdasm> the availability group has done a Req' subfolder in their artifacts
15:50:38 <frankbrockners> cool - looks like consensus - I'll get rid of the brahmaputra dir
15:51:47 <frankbrockners> #info https://gerrit.opnfv.org/gerrit/#/c/1278/ - will change to not include release specific directories.
15:52:22 <fdegir> frankbrockners: since directory structure mentioned
15:52:23 <frankbrockners> Any other comments?
15:52:35 <fdegir> I hope you can take a look at that releng ticket to see the proposed dir structure
15:52:47 <fdegir> and comment if you have any objection
15:52:54 <fdegir> obviously everyone can comment there
15:53:05 <fdegir> https://jira.opnfv.org/browse/RELENG-15
15:53:06 <frankbrockners> fdegir - do you have a link?
15:53:08 <frankbrockners> thanks
15:53:35 <frankbrockners> #info https://jira.opnfv.org/browse/RELENG-15 - proposed dir structure by releng. Everyone please comment
15:54:02 <lmcdasm> im for it
15:55:26 <frankbrockners> fdegir - thanks for sharing - we'll comment in Jira
15:55:39 <fdegir> np
15:56:47 <chenshuai> frankbrockners: I have checked out genesis jira tickets(39 totally) and I do not understand for some jira, I think also same for other installers, do we have some channel (IRC?) to clarify these tickets?
15:58:25 <frankbrockners> chenshuai - good point. You can put questions / comments into Jira. But the larger question you raise: Do we want a Genesis IRC channel, or should we use opnfv-bgs for now?
15:59:25 <chenshuai> frankbrockners: sorry, I just mean can we clarify via this IRC channel?
15:59:36 <frankbrockners> IMHO we could stay with opnfv-bgs for now
15:59:44 <chenshuai> frankbrockners: :P
16:00:15 <frankbrockners> any other opinions?
16:01:13 <frankbrockners> does not seem to be the case - and we're at the top of the hr.
16:01:25 <frankbrockners> so let's use opnfv-bgs for both BGS and Genesis discussions for now
16:01:43 <[1]JonasB> frankbrockners +1
16:01:52 <frankbrockners> #info BGS and Genesis teams will use #opnfv-bgs IRC channel for discussions moving forward
16:02:05 <frankbrockners> ok...
16:02:13 <frankbrockners> looks like we're done for today...
16:02:22 <frankbrockners> thank you everyone!
16:02:29 <frankbrockners> #endmeeting