#opnfv-meeting: LSOAPI

Meeting started by KLuehrs at 16:00:05 UTC (full logs).

Meeting summary

  1. Status Update (KLuehrs, 16:04:33)
    1. CableLabs was asked by MEF to help organize the MEF LSO Hackathon in November in Dallas, TX (KLuehrs, 16:09:58)
    2. CableLabs shared proposed development road map leading up to the MEF LSO Hackathon (KLuehrs, 16:16:29)
    3. Lance H suggested for the first phase, implement IP transport network with GRE tunnel overlay for EVC implementation. Currently ability to provide Layer 2 service is not in place in all service provider networks (business services over DOCSIS), leveraging IP makes more sense. (KLuehrs, 16:18:11)
    4. Group was queried: can anyone provide access to a NetConf enabled MEF compliant device? No response. (KLuehrs, 16:21:57)
    5. James Kim from CableLabs shared MEF plans for the LSO Hackathon. MEF currently plans two sub-projects during the Hackathon: one based on OPNFV Connectivity Services LSO project work and one based on MEF Service Configuration and Activation project. (KLuehrs, 16:27:51)
    6. ACTION: James Kim to send Hesham El Bakoury from Huawei information about the MEF Hackathon (KLuehrs, 16:29:54)
    7. MEF LSO Hackathon goals (1) Contribute API development back to MEF specifications, (2) Contribute API development back to outside projects including OPNFV Connectivity Services LSO. (KLuehrs, 16:36:07)
    8. Question: Can another controller be used, e.g., ONOS? James Kim responded that for the Hackathon time is limited for preparation and planning so we need to focus on OpenDaylight for now. Kevin Luehrs added that the APIs being developed within LSOAPI will eventually be able to interface via REST to other controllers (KLuehrs, 16:44:24)
    9. Kevin Luehrs shared the LSOAPI software architecture documentation wiki page. (KLuehrs, 16:44:52)
    10. Steve Saunders shared the API documentation being developed using RAML. When complete this will be posted to the LSOAPI /documents wiki page. (KLuehrs, 16:45:29)

  2. LSOAPI Requirements (KLuehrs, 16:51:03)
    1. Concern: How does architecture of the software map to an orchestrator? The APIs northbound to OpenDaylight likely belongs in an orchestrator. The focus is on the APIs and we need to find a home for the APIs, e.g., in OpenStack. (KLuehrs, 16:56:19)
    2. LSOAPI project seeks people with OpenStack expertise to help define where the northbound APIs belong. (KLuehrs, 16:57:51)
    3. Comment: While the proof of concept focuses on Ethernet eventually the APIs may need to support other transport. (KLuehrs, 16:58:54)


Meeting ended at 17:01:30 UTC (full logs).

Action items

  1. James Kim to send Hesham El Bakoury from Huawei information about the MEF Hackathon


People present (lines said)

  1. KLuehrs (19)
  2. collabot (4)


Generated by MeetBot 0.1.4.