#opnfv-meeting: Octopus and Releng Weekly Meeting

Meeting started by fdegir at 14:00:04 UTC (full logs).

Meeting summary

    1. David Duffey (dduffey, 14:00:24)

  1. Rollcall (fdegir, 14:00:24)
    1. Fatih Degirmenci (fdegir, 14:00:34)
    2. meimei (meimei, 14:00:37)
    3. chenshuai (chenshuai, 14:00:38)
    4. Ryota Mibu (IRC only) (r-mibu, 14:00:40)
    5. Uli Kleber (uli-k, 14:00:40)
    6. Morgan Richomme (morgan_orange, 14:00:54)
    7. Bryan Sullivan (bryan_att, 14:01:48)
    8. Please note that this is an IRC-only meeting (fdegir, 14:01:58)

  2. Agenda Bashin (fdegir, 14:02:10)
    1. Octopus: Action Item Review / Lab Compliancy / B-Release Work (fdegir, 14:02:27)
    2. Dan Radez (radez, 14:02:28)
    3. Releng: LF Lab Configuration Status Update / Releng Backlog (fdegir, 14:02:34)
    4. AoB (fdegir, 14:02:41)

  3. Action Item Review (fdegir, 14:03:04)
    1. uli-k trozet ChrisPriceAB: clarify the need of doing Brahmaputra release on LF Lab (fdegir, 14:03:29)
    2. ACTION: uli-k trozet ChrisPriceAB: clarify the need of doing Brahmaputra release on LF Lab (fdegir, 14:04:13)
    3. meimei fdegir Follow-up Octopus Requirements with Pharos (fdegir, 14:04:30)
    4. No progress with the Octopus requirements on Pharos (fdegir, 14:05:18)
    5. ACTION: meimei fdegir: Follow-up Octopus Requirements with Pharos (fdegir, 14:05:27)
    6. ACTION: trevor_intel to propose way forward with community labs (fdegir, 14:12:37)
    7. meimei to apply naming scheme for Huawei slaves: huawei-build-[1-4], huawei-deploy-1 (fdegir, 14:14:06)
    8. meimei applied the new naming schement for Huawei Slaves (fdegir, 14:14:49)
    9. https://build.opnfv.org/ci/computer/ (fdegir, 14:14:58)
    10. uli-k Clean up the Octopus committer list (fdegir, 14:15:35)
    11. uli-k contacted all inactive committers (fdegir, 14:16:14)
    12. ACTION: uli-k Clean up the Octopus committer list (fdegir, 14:17:18)

  4. Lab Compliancy (fdegir, 14:17:52)
    1. As we discussed above just minutes ago (fdegir, 14:18:02)
    2. meimei documented the requirements and we had the discussion on Etherpad (fdegir, 14:18:22)
    3. But not much happened with compliancy (fdegir, 14:18:44)
    4. since Pharos doesn't have place to discuss these things and generally downprioritized against testing stuff ion Thursdays (fdegir, 14:19:15)
    5. ACTION: uli-k to bring slow progress with Pharos to TSC (fdegir, 14:20:29)
    6. There was a discussion regarding Pharos during hackfest (fdegir, 14:23:18)
    7. morgan_orange states that it was strongly suggested to create a weekly meeting for Pharos and that each community lab provides a contributor to the project (fdegir, 14:23:32)

  5. B-Release Work (fdegir, 14:26:48)
    1. There have been some questions regarding how to be integrated to CI (fdegir, 14:27:01)
    2. some of the projects are trying to figure out how to get their stuff integrated to CI (fdegir, 14:27:40)
    3. kvmfornfv and ovsnfv have asked some questions (fdegir, 14:28:33)
    4. Some information and links have been provided to those projects (fdegir, 14:28:43)
    5. https://etherpad.opnfv.org/p/octopusR2 (fdegir, 14:30:15)
    6. kvmfornfv started working with their build script which will be integrated to verify jobs (fdegir, 14:30:47)
    7. ovsnfv is in the process of identifying what they need (fdegir, 14:31:02)
    8. Apart from new projects, we have some good updates in CI (fdegir, 14:32:55)
    9. Thanks to trozet, we can now run virtual deployment for foreman patches (fdegir, 14:33:20)
    10. Due to lack of resources, this is only available for foreman but will be made available to other installer(s) (fdegir, 14:33:56)
    11. ACTION: aricg to help kvmfornfv with regards to keeping their patches in the repo, and to apply them as part of the build step. (fdegir, 14:35:02)

  6. Releng LF Lab Reconfiguration Status (fdegir, 14:37:48)
    1. pbandzi, trozet, and aricg finished the reconfiguration of LF POD2 (fdegir, 14:38:09)
    2. We are now able to run both installers on a single POD (fdegir, 14:38:31)
    3. We have a script now that rolls back the POD2 to original state (fdegir, 14:39:02)
    4. And then foreman/fuel build and deployment scripts get executed depending on which installer job is running (fdegir, 14:39:27)
    5. https://build.opnfv.org/ci/job/genesis-foreman-deploy-master/58/console (morgan_orange, 14:42:38)
    6. The script that does the configuration is located in releng repo (fdegir, 14:44:58)
    7. https://gerrit.opnfv.org/gerrit/gitweb?p=releng.git;a=tree;f=utils/lab-reconfiguration (fdegir, 14:45:06)
    8. There are installer specific configuration files there (fdegir, 14:45:20)
    9. http://sinawiki/wiki/images/8/8f/Archi_reseau.svg (arnaud_orange, 14:45:39)
    10. So please feel free to look at it if you want to configure a specific installer for it (fdegir, 14:45:53)
    11. It is still pending to restructure LF POD1 in order to provide build, virt deploy, and other testing resources (fdegir, 14:47:27)
    12. There is an action on LF Admins to adjust the networking (fdegir, 14:47:46)
    13. More info will follow coming days/weeks once the work progresses (fdegir, 14:48:14)
    14. The suggestion from Konstantin to push the change to September 13 (fdegir, 14:50:44)

  7. Releng Backlog (fdegir, 14:51:29)
    1. Releng Stories are collected under 4-epics (fdegir, 14:51:41)
    2. Automation and Development of Test Result Reporting/Dashboard/Analytics (fdegir, 14:51:51)
    3. Improvements in Automation/Toolchain/CI (fdegir, 14:51:58)
    4. Automation for Pharos Lab Infrastructure (fdegir, 14:52:06)
    5. Release Process Support (fdegir, 14:52:14)
    6. https://jira.opnfv.org/browse/RELENG (fdegir, 14:52:23)
    7. Stories from all epics but release process have been progressing (fdegir, 14:52:42)
    8. morgan_orange is driving testing related epic (fdegir, 14:52:59)
    9. aricg is working with documentation toolchain and DB for test reporting (fdegir, 14:53:12)
    10. pbandzi with Lab stuff (fdegir, 14:53:22)
    11. Anyone is free to take items from the backlog (fdegir, 14:53:46)
    12. Or come up with suggestions (fdegir, 14:54:00)

  8. AoB (fdegir, 14:54:48)
    1. uli-k reminds the discussion regarding where the Arno SR1 will come out from (fdegir, 14:55:40)
    2. There is a documented process for stable branch handling (fdegir, 14:55:55)
    3. https://wiki.opnfv.org/releases/stablebranch?s[]=stable (fdegir, 14:56:26)
    4. The release will come out from stable/arno branch (fdegir, 14:56:51)
    5. The process is: do the work/bugfixing on master, cherrypick to stable/arno accordingly (fdegir, 14:57:20)


Meeting ended at 14:59:23 UTC (full logs).

Action items

  1. uli-k trozet ChrisPriceAB: clarify the need of doing Brahmaputra release on LF Lab
  2. meimei fdegir: Follow-up Octopus Requirements with Pharos
  3. trevor_intel to propose way forward with community labs
  4. uli-k Clean up the Octopus committer list
  5. uli-k to bring slow progress with Pharos to TSC
  6. aricg to help kvmfornfv with regards to keeping their patches in the repo, and to apply them as part of the build step.


Action items, by person

  1. aricg
    1. aricg to help kvmfornfv with regards to keeping their patches in the repo, and to apply them as part of the build step.
  2. fdegir
    1. meimei fdegir: Follow-up Octopus Requirements with Pharos
  3. meimei
    1. meimei fdegir: Follow-up Octopus Requirements with Pharos
  4. trozet
    1. uli-k trozet ChrisPriceAB: clarify the need of doing Brahmaputra release on LF Lab
  5. uli-k
    1. uli-k trozet ChrisPriceAB: clarify the need of doing Brahmaputra release on LF Lab
    2. uli-k Clean up the Octopus committer list
    3. uli-k to bring slow progress with Pharos to TSC


People present (lines said)

  1. fdegir (182)
  2. uli-k (50)
  3. bryan_att (17)
  4. morgan_orange (17)
  5. trozet (14)
  6. meimei (7)
  7. aricg (7)
  8. chenshuai (7)
  9. r-mibu (5)
  10. collabot (4)
  11. arnaud_orange (2)
  12. dduffey (1)
  13. radez (1)


Generated by MeetBot 0.1.4.