15:00:46 <trozet> #startmeeting BGS/Genesis Weekly Meeting
15:00:46 <collabot> Meeting started Mon Aug 31 15:00:46 2015 UTC.  The chair is trozet. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:46 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:00:46 <collabot> The meeting name has been set to 'bgs_genesis_weekly_meeting'
15:01:05 <[1]JonasB> #info Jonas Bjurel
15:01:15 <uli-k> #info Uli Kleber
15:01:26 <chenshuai> #info chenshuai
15:01:37 <radez> #info Dan Radez
15:01:40 <dduffey> #info David Duffey
15:01:45 <arnaud_orange> #info arnaud morin
15:01:51 <fdegir> #info Fatih Degirmenci
15:01:54 <RandyLevensalor> #info Randy Levensalor
15:02:17 <trozet> #topic Arno SR1 status
15:02:22 <hongbotian> #info hongbo tian
15:02:50 <David_Orange> #info David_Orange
15:02:56 <trozet> #info Any status updates from Fuel/Foreman for SR1?
15:03:04 <trozet> [1]JonasB: you want to go?
15:03:26 <[1]JonasB> #info is still on track for SR1, plan is to release it through the stable/arno branch. We're constantly cherry-picking from master
15:03:38 <lmcdasm> #info daniel Smith
15:03:39 <[1]JonasB> Thats all:-)
15:03:48 <trozet> #info Foreman is the same.  Need to cherry pick from master to stable/arno
15:04:19 <trozet> #info  Fuel/Foreman need to have release-notes updated with Fixes for SR1
15:04:29 <[1]JonasB> What about functest for sr1?
15:04:51 <trozet> you mean functest status? or cherry picking commits?
15:05:29 <trozet> [1]JonasB:^
15:05:42 <[1]JonasB> <trozet>: Two things, I think functest was broke at some point, and that functest should define a stable/arno branch.
15:06:03 <morgan_orange> yes functest is not properly working
15:06:06 <trozet> [1]JonasB: yeah I think morgan_orange is fixing it/ waiting on me to fix Foreman deploy
15:06:11 <morgan_orange> I created a page to track it on the wiki
15:06:12 <morgan_orange> https://wiki.opnfv.org/functest_release_1
15:06:21 <morgan_orange> see Arno SR1 section
15:06:51 <morgan_orange> we have bugs in Functest (we will be able to solve hopefully) but it also seems that there are some issues with rally
15:06:56 <morgan_orange> bug reported to rally
15:06:58 <[1]JonasB> morgan_orange: Thx
15:06:59 <trozet> #info functest currently being fixed to verify SR1 stability
15:07:03 <morgan_orange> work in progress...
15:07:06 <trozet> #link https://wiki.opnfv.org/functest_release_1
15:08:00 <trozet> [1]JonasB: when do you think Fuel will have a draft of release notes ready, including a list of fixes+improvements?
15:08:45 <trozet> code freeze will be in a about 2-3 weeks so was thinking we should get moving on docs
15:09:05 <[1]JonasB> trozet: In two weeks - about
15:09:25 <trozet> ok lets say in 2 weeks then we will have drafts of release notes ready for SR1?
15:09:31 <[1]JonasB> trozet: Its a matter of an hour of work
15:09:34 <trozet> [1]JonasB: is that OK with you?
15:09:41 <trozet> yeah just want to have some dates
15:09:42 <[1]JonasB> troze: OK!
15:09:51 <uli-k> I saw some mention of a new repo genesis2. Does that affect SR1?
15:10:07 <trozet> #action trozet, [1]JonasB: drafts of release notes for SR1, updated install instructions, etc ready in 2 weeks
15:10:08 <[1]JonasB> uli-k: No that is for the B-release
15:10:32 <uli-k> so it will just work on the installer requirements?
15:11:00 <[1]JonasB> uli-k: Lets wait with those questions till we start discussing B-
15:11:11 <uli-k> ok
15:11:30 <trozet> #topic Genesis - JIRA Requirements
15:11:33 <RandyLevensalor> trozet, What is going on with the Foremen neutron provider networking change that you were working on at OPDL
15:11:55 <RandyLevensalor> too late...I'll followup late
15:12:04 <trozet> RandyLevensalor: yeah ping me after the meeting
15:12:22 <trozet> #info any updates on new requirements or current ones that were added in JIRA?
15:12:32 <[1]JonasB> I have reviewed the genesis Jira requests and commented on them
15:13:01 <trozet> #info I have a couple of requirements that I was thinking about adding.  Wanted to see what people thought int his meeting first
15:13:50 <[1]JonasB> In general, I dont think genesis should state functionality on the deployed stack, functionality comes from upstream or other OPNFV projects preferably funneled through upstream.
15:14:03 <trozet> #info We currently have most openstack services in HA, including neutron-dhcp-agent.  However we create neutron networks, we dont actually do multiple dhcp servers per tenant in HA.  Is that something we shoudl add a requirement for?
15:14:44 <[1]JonasB> <trozet>: That makes sense to me.
15:14:59 <[1]JonasB> #info +1
15:15:21 <trozet> #action trozet will add requirement for multiple dhcp servers in HA per tenant for review
15:16:08 <chenshuai> do installers need to support deployment offline?
15:16:09 <trozet> #info another requirement proposal: For helium, we used neutron L3 agent to do forwarding.  However in Lithium, ODL introduced L3 forwarding and also distributed virtual routing (DVR).  Should we add a requirement to do L3 inside of the SDN controller, and if so, use DVR?
15:16:34 <trozet> (meaning we would no longer use neutron L3 agent)
15:17:03 <[1]JonasB> #info: I would like to remove the requirement on hitless software upgrade, that is the task of Escalator, if they deliver we will have hitless upgrade, if not we will not have it.
15:17:24 <trozet> chenshuai: can you please info that?
15:18:24 <chenshuai> trozet: I mean installers deploy without internet access, like github or wget and download packages or iso
15:18:31 <chenshuai> just my question
15:19:06 <trozet> #info [1]JonasB: proposes removing Genesis-15.
15:19:11 <[1]JonasB> chenshuai: My personal preference is that it should be possible to deploy withon network access
15:19:42 <trozet> #info <chenshuai> do installers need to support deployment offline?
15:20:08 <chenshuai> maybe i create a Jira, and let the 5 committers to vote
15:20:17 <trozet> #info I don't see a current requirement in JIRA. chenshuai: can you please add one
15:20:17 <trozet> yes
15:20:36 <trozet> #action chenshuai: propose JIRA requirement to require offline deployment option
15:21:52 <[1]JonasB> #info I would also like to remove genesis-41. An ONOS project should take care that requirement (ask Genesis to integrate it) it should not be a Genesis Jira issue.
15:22:03 <trozet> #info Genesis team please review Genesis-15 and provide feedback to [1]JonasB comment in the JIRA issue
15:22:42 <trozet> [1]JonasB: hmm shouldnt we track it in Genesis somehow though?
15:23:13 <chenshuai> [1]JonasB: do you mean ONOS should raise a discussion before create a jira?
15:23:38 <[1]JonasB> trozet: Yes once we have reviewed the request, with needed dependences, deliverables, dates etc. But not self generate it.
15:24:03 <[1]JonasB> chenshuai: Yes
15:24:10 <chenshuai> [1]JonasB:  email to genesis group?
15:24:11 <trozet> [1]JonasB: so only genesis team members should create JIRA reqs for Genesis?
15:24:20 <[1]JonasB> Jus my humble oppinion.
15:24:48 <trozet> [1]JonasB: hmm it may be better so that we can make sure an issue has all the necessary info
15:25:14 <trozet> i guess we really dont have a structure to how other projects communicate yet
15:25:46 <trozet> chenshuai: its ok to leave the JIRA issue for now, but please send out an email to the genesis team stating the request, estimated work load to integrate with O/S, and dates
15:25:55 <[1]JonasB> trozet: I dont realy care wh creates the request, but prior to creating it there should be a negotiation around deps, kernel versions, delivery dates etc. Similar to the proposal that was sent out to project leads last week.
15:26:10 <chenshuai> trozet: ok
15:26:45 <trozet> [1]JonasB do you have a link to that proposal?
15:27:02 <[1]JonasB> Yes - hang-on...
15:27:48 <[1]JonasB> #link https://etherpad.opnfv.org/p/artifact_handling
15:28:11 <trozet> #action chenshuai to email Genesis team with ONOS requirement information and start the discussion for Genesis-41
15:28:55 <trozet> [1]JonasB: so we should come up with similar guidelines for integrating with Genesis
15:29:29 <[1]JonasB> trozet: Yes - but why not use ONOS as a pipe-cleaner.
15:29:33 <trozet> [1]JonasB: shall we propose an email to start hte discussion (with certain key info), then creation of JIRA issue, then voting by Genesis team, followed updating git repo?
15:29:53 <[1]JonasB> trozet: A good start - shoot!
15:30:23 <trozet> #info General integrating with genesis guidelines: mail to start hte discussion (with certain key info), then creation of JIRA issue, then voting by Genesis team, followed updating git rep
15:30:47 <trozet> #action trozet come up with a wiki draft of these guidelines to follow
15:30:58 <[1]JonasB> trozet: That is a good process!
15:31:11 <trozet> ok cool
15:31:55 <trozet> #action trozet to create requirement for SDN Controller L3 forwarding (instead of neutron).  Will also include comments about distributed virtual routing (DVR)
15:32:15 <trozet> #info any other JIRA requirements to bring up?
15:32:51 <[1]JonasB> #info All committers to review and comments on the Jira requests
15:33:10 <chenshuai> I have one
15:33:42 <trozet> shoudl we also move some of the requirements to gerrit, and start voting?
15:34:11 <[1]JonasB> trozet: Makes sense
15:34:29 <chenshuai> ok
15:34:55 <trozet> #action trozet will create some gerrit reviews for 5 or so JIRA reqs to get the ball rolling
15:35:47 <trozet> any one else have anything to bring up for genesis reqs?
15:35:52 <trozet> chenshuai?
15:36:02 <chenshuai> yes
15:36:21 <[1]JonasB> I have a question regarding repos, in this or another topic?
15:36:32 <chenshuai> for B release, during B release, openstack will have issued 2 version, kilo and libvert, need installers provide 2 openstack version?
15:37:21 <[1]JonasB> chenshuai: I think that is a requirement we should vote on!
15:37:43 <trozet> afaik we will only support 1, and it will be kilo
15:37:45 <trozet> but yes
15:37:48 <trozet> it should be ar eq
15:37:48 <chenshuai> so maybe I create a Jira, do you think so?
15:38:03 <trozet> #action chenshuai please propose a req for required openstack version
15:38:16 <trozet> we should get htat one into gerrit asap
15:38:26 <[1]JonasB> trozet: That is already a Jira req.
15:38:47 <trozet> [1]JonasB: then update it there?
15:38:57 <chenshuai> https://jira.opnfv.org/browse/GENESIS-7 ?
15:39:13 <[1]JonasB> trozet: Lets bring that to gerrit and vote!
15:39:31 <trozet> #undo
15:39:31 <collabot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x295f210>
15:39:49 <trozet> #action trozet add GENESIS-7 to vote in gerrit
15:40:37 <trozet> ok lets move onto AOB
15:40:45 <trozet> #topic AOB
15:41:01 <trozet> [1]JonasB: you had a question?
15:41:35 <[1]JonasB> How do we handle the repos in B-release, where do we carry common? The new repo name kind of indicate that it only carries code.
15:42:01 <[1]JonasB> How do we handle the repos in B-release, where do we carry common? The new repo name kind of indicate that it only carries requirements - IT SHOULD BE
15:43:15 * lmcdasm raises hand
15:43:15 <trozet> [1]JonasB: from what I understand the current repo is temporary and will be moved to "genesis"
15:43:30 <trozet> [1]JonasB: everything in current genesis repo will be removed except for common/
15:43:47 <trozet> lmcdasm: speak it!
15:44:05 <uli-k> What means "moved"? How will we do the SR1 things?
15:44:09 <[1]JonasB> trozet: Ahh, so we scratch master (except common) and keep stable/arno?
15:44:27 <trozet> [1]JonasB: that was my understanding from talking to frankborkcners
15:44:31 <trozet> frankbrockners*
15:44:47 <lmcdasm> further to the use of common, are we going to have some guidelines, etc on what should be in and not in there?  do we intend to enforce commonailies (and if not - then should we have it at all now - since each project seems to be subfolder / independant delivery??)
15:44:47 <[1]JonasB> trozet: Works for me I guess?
15:44:53 <trozet> uli-k: the move will happen after SR1 is released and tagged
15:45:21 * fdegir remembers the same discussion: remove everything but common from master branch after SR1
15:45:32 * fdegir but don't touch stable/arno
15:45:43 <uli-k> So we decide that there will be never SR2?
15:45:44 <[1]JonasB> daniel: I dont think we can enforce use of common, it is more like best practice.
15:46:16 <trozet> #info [1]JonasB: asks what is the procedure for repo changes with regards to B-release
15:47:03 <[1]JonasB> uli-k: I guess there will not be, but in case we need to do a fix we can always work on stable/arno or create another branch
15:47:07 <trozet> #info he current repo is temporary and will be moved to "genesis" master after SR1.  Only common directory will be kept in current genesis repo (everything else removed).  stable/arno will remain untouched
15:47:42 <trozet> uli-k: there won't be an SR2 I don't think, and as [1]JonasB: said any critical fixes for SR1 can go into arno/stable branch
15:48:22 <uli-k> Let's hope so. But maybe the TSC should confirm something like this.
15:48:48 <trozet> well if we do SR1 at the end of September, and B release is Feb
15:49:03 <uli-k> After a move any SR would create some additional work, since we cannot just cherrypick anymore or can we?
15:49:09 <[1]JonasB> uli-k: These details shouldnt need TSC aproval.
15:50:11 <uli-k> details affecting the possibility of an SR2 need TSC approval.
15:50:26 <uli-k> An SR2 might be needed even after B is released.
15:50:33 <trozet> uli-k: can you ask in the TSC meeting to confirm there will be no SR2?
15:51:01 <[1]JonasB> uli-k: As said, we could deliver SR2, SR3, SR4, etc. Just not progress those from master.
15:51:14 <uli-k> I can ask, but I think SR2 might be needed and we cannot decide today.
15:51:48 <trozet> uli-k: ok then as [1]JonasB mentioned, can we not just do that on stable/arno?
15:52:19 <uli-k> Of course SR2 would be done also on stable/arno
15:52:23 <trozet> maybe we should info that stable/arno will be used for any future patches to Arno SR releases
15:52:26 <trozet> does that work?
15:52:41 <uli-k> I think so. But what about the repo-move?
15:53:00 <trozet> uli-k: repo move is only for master
15:53:35 <uli-k> We want to cherrypick from master to stable/arno. Does that work from one repo to another?
15:54:09 <[1]JonasB> uli-k: Progresion of SR1 happens on old repo master
15:54:19 <radez> uli-k: yes, you just have to add one as remote to the other
15:54:29 <radez> and reference the hash of what you want to pick
15:54:58 <radez> uli-k: ping me when you get ready to do it and I'm happy to help with it
15:55:08 <uli-k> OK. Then I'm fine. That was the background of my question
15:55:38 <uli-k> Probably we need to provide some guideline when we are there.....
15:56:05 <uli-k> Thanks for your patience
15:56:07 <trozet> #info SR1 release and future SRs to take place on stable/arno branch.  This branch will remain untouched when we migrate genesis_req to genesis master
15:56:33 <trozet> #info any other items to be discussed?
15:56:57 <fdegir> last question
15:57:11 <fdegir> I suppose we will stop CI stuff once SR1 is out the door?
15:57:23 <fdegir> I meant stopping CI on stable/arno
15:57:35 <fdegir> this can free up some resources
15:57:36 <[1]JonasB> fdegir: I supose we can
15:57:51 <trozet> fdegir: I think its ok to disable it and focus on B-release
15:57:56 <fdegir> good then
15:58:00 <trozet> fdegir: maybe dont remove it from JJB, just disable
15:58:06 <fdegir> trozet: yep
15:58:11 <trozet> ok cool
15:58:18 <trozet> thanks everyone for attending
15:58:22 <trozet> #endmeeting