#opnfv-meeting: Octopus & Releng weekly meeting

Meeting started by uli-k at 14:00:33 UTC (full logs).

Meeting summary

    1. kaipule (kaipule, 14:00:55)

  1. roll-call (uli-k, 14:01:03)
    1. Fatih Degirmenci (fdegir, 14:01:04)
    2. chigang (chigang, 14:01:33)
    3. meimei (May-meimei1, 14:01:45)
    4. Tim Rozet (trozet, 14:01:50)
    5. David Duffey (dduffey, 14:02:00)

  2. agenda bashing (uli-k, 14:02:28)
    1. Morgan richomme (morgan_orange, 14:02:52)
    2. chenshuai (chenshuai, 14:02:54)

  3. Action Items (uli-k, 14:04:07)
    1. First AI uli-k trozet ChrisPriceAB: clarify the need of doing Brahmaputra release on LF Lab (uli-k, 14:04:39)
    2. Dan Radez (radez, 14:05:08)
    3. If Pharos could create Lab compliance and validate lab(s) for their compliance (fdegir, 14:05:13)
    4. It should be possible to do B release from those labs (fdegir, 14:05:23)
    5. I still don't think we have an answer on this yet (trozet, 14:05:55)
    6. so let's keep it open.... (uli-k, 14:06:51)
    7. ACTION: uli-k trozet ChrisPriceAB: clarify the need of doing Brahmaputra release on LF Lab (uli-k, 14:07:10)
    8. next AI uli-k talk to Huawei lab guys to support Pharos (uli-k, 14:07:27)
    9. Bryan Sullivan (bryan_att, 14:07:37)
    10. ACTION: uli-k talk to Huawei lab guys to support Pharos (uli-k, 14:07:56)
    11. next AI uli-k to trigger other lab reps according to community lab overview wiki (uli-k, 14:08:24)
    12. ACTION: uli-k to trigger other lab reps according to community lab overview wiki (uli-k, 14:09:05)
    13. next: uli-k Clean up the Octopus committer list (uli-k, 14:09:30)
    14. ACTION: uli-k Clean up the Octopus committer list (uli-k, 14:19:28)
    15. Next AI chigang, chenshuai clarify kvm4nfv workflow and how to use their kernel (uli-k, 14:19:53)
    16. overall build/deploy still needs to be designed. Octopus will waitfor genesis and others to work this out and then adjust. (uli-k, 14:31:31)
    17. verify jobs can be created independently from genesis/installers (fdegir, 14:31:54)
    18. last remaning AI: fdegir to update Wiki for Arno SR1 release (uli-k, 14:32:13)
    19. Arno SR1 release will be done in same way as Arno (fdegir, 14:32:39)
    20. https://wiki.opnfv.org/octopus/releasepipeline#arno_sr1_release (fdegir, 14:32:44)
    21. closed. (uli-k, 14:35:18)

  4. lab compliancy (uli-k, 14:35:51)
  5. Status C-milestone for B-Release (uli-k, 14:37:23)
    1. Initial Octopus R2 backlog has been created in Jira and available on below link (fdegir, 14:40:23)
    2. http://bit.ly/1NrG0PK (fdegir, 14:40:25)
    3. ACTION: uli-k to raise the issue in project meeting so projects come forward with their dependency on octopus to setup their pipeline (uli-k, 14:46:11)

  6. AoB (uli-k, 14:47:21)
  7. (Re)Claiming servers from LF POD1 (fdegir, 14:48:01)
    1. We got 3 VLAs as requested by pbandzi (fdegir, 14:48:34)
    2. So the work with reclaiming servers from POD1 and using them for CI can start (fdegir, 14:48:52)
    3. The plan is to have 2 ubuntu 14.04 as build servers and 4 Centos 7 as virt deploy/testing purposes (fdegir, 14:49:20)

  8. Test Result Reporting API (fdegir, 14:50:07)
    1. morgan_orange did the demo last week (fdegir, 14:50:18)
    2. Work with it continues (fdegir, 14:50:26)
    3. The API is available except the move to target DB which is located in LF (fdegir, 14:52:22)
    4. the test projects are free to start aligning their reporting accordingly ti have common base for a dashboard (fdegir, 14:52:50)
    5. dashboard portal proof of concept to be initiated with LF team (morgan_orange, 14:53:15)

  9. Automatic Doc Generation (fdegir, 14:53:49)
    1. With the help from aricg and r-mibu, we are switching to sphinx for doc generation for all projects (fdegir, 14:54:23)
    2. We will have 1 script and 1 job for all OPNFV projects to produce documentation (fdegir, 14:54:49)
    3. The updates have been sent to all projects for review (fdegir, 14:55:12)

  10. AoB (uli-k, 14:57:15)


Meeting ended at 14:59:04 UTC (full logs).

Action items

  1. uli-k trozet ChrisPriceAB: clarify the need of doing Brahmaputra release on LF Lab
  2. uli-k talk to Huawei lab guys to support Pharos
  3. uli-k to trigger other lab reps according to community lab overview wiki
  4. uli-k Clean up the Octopus committer list
  5. uli-k to raise the issue in project meeting so projects come forward with their dependency on octopus to setup their pipeline


Action items, by person

  1. trozet
    1. uli-k trozet ChrisPriceAB: clarify the need of doing Brahmaputra release on LF Lab
  2. uli-k
    1. uli-k trozet ChrisPriceAB: clarify the need of doing Brahmaputra release on LF Lab
    2. uli-k talk to Huawei lab guys to support Pharos
    3. uli-k to trigger other lab reps according to community lab overview wiki
    4. uli-k Clean up the Octopus committer list
    5. uli-k to raise the issue in project meeting so projects come forward with their dependency on octopus to setup their pipeline


People present (lines said)

  1. fdegir (107)
  2. uli-k (90)
  3. morgan_orange (12)
  4. bryan_att (8)
  5. chenshuai (7)
  6. trozet (4)
  7. collabot (4)
  8. chigang_ (3)
  9. chigang (2)
  10. May-meimei1 (2)
  11. dduffey (1)
  12. radez (1)
  13. kaipule (1)


Generated by MeetBot 0.1.4.