15:00:13 <frankbrockners> #startmeeting Arno SR1 synch
15:00:13 <collabot> Meeting started Fri Sep 18 15:00:13 2015 UTC.  The chair is frankbrockners. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:13 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:00:13 <collabot> The meeting name has been set to 'arno_sr1_synch'
15:00:19 <frankbrockners> #info Frank Brockners
15:00:28 <radez> #info Dan Radez
15:00:34 <[1]JonasB> #info Jonas Bjurel
15:00:47 <s_berg> #info Stefan Berg
15:00:49 <RandyLevensalor> #info Randy Levensalor
15:00:53 <trozet> #info Tim Rozet
15:00:56 <jose_lausuch> #info Jose Lausuch
15:00:59 <morgan_orange> #info Morgan Richomme
15:01:06 * trozet goes to grab more coffee brb
15:01:21 <jose_lausuch> what time is it there trozet?
15:01:32 <radez> jose_lausuch: it's 11am for us
15:01:47 <jose_lausuch> ah, not so early :)
15:01:53 <frankbrockners> #info draft agenda for today: https://wiki.opnfv.org/releases/arno/stablerelease_1#meetings
15:01:59 <radez> but trozet's family has decided to stop sleeping on account of his daughter's sickness so it always early for him
15:02:13 <fdegir> #info Fatih Degirmenci
15:02:21 <frankbrockners> #info this is the standing agenda plus the set of open issues we identified on Wednesday
15:02:30 <frankbrockners> let's get rolling
15:02:40 <frankbrockners> #topic BGS - updates on Fuel
15:02:43 <jose_lausuch> ammmh...
15:02:47 <[1]JonasB> Ok
15:03:07 <frankbrockners> [1]JonasB - any updates on Fuel (especially the deploy failure you saw)?
15:03:20 <jose_lausuch> we are currently working on it
15:03:20 <[1]JonasB> #info Local repo mirror work ongoing, should have it done early/mid next week
15:03:24 <jose_lausuch> well, szilard_ is
15:03:29 <jose_lausuch> Im just being there :)
15:03:46 <trozet> back
15:04:02 <[1]JonasB> #info We have (most likely) a solution to the cache problem, finishing that up over the week-end
15:04:54 <[1]JonasB> #Szilard is working on the remaining deployment issues, he would need the access rights to kick off Jenkins deployment runs as he will work over week-end
15:05:10 <[1]JonasB> #info Szilard is working on the remaining deployment issues, he would need the access rights to kick off Jenkins deployment runs as he will work over week-end
15:05:27 <[1]JonasB> #info Documentation will finish next week.
15:05:40 <[1]JonasB> Thats all I had on top of my head.
15:06:03 <[1]JonasB> Note the thing about szilard needing access rights for Jenkins
15:06:13 <[1]JonasB> Who can help on that?
15:06:14 <jose_lausuch> who can provide that?
15:06:34 <fdegir> aricg can
15:06:36 <jose_lausuch> I would help to run the jobs, but I will be on the road the whole weekend
15:06:38 <trozet> so do we need to delay the release by like a week, to make sure we have enough time with functest as well?
15:06:59 <jose_lausuch> morgan_orange: what do you think?
15:07:05 <jose_lausuch> if we get fuel up and running on monday
15:07:11 <fdegir> another thing to mention yet again; resource outage is also slowing down this work
15:07:12 <jose_lausuch> maybe we could finish functest on fuel
15:07:16 <jose_lausuch> with some effort
15:07:22 <jose_lausuch> ?
15:07:32 <morgan_orange> yes
15:07:34 <fdegir> we can't start fuel deployment now since foreman will be triggered
15:07:54 <morgan_orange> I think we will get the same error that we have on foreman (experienced on the last successful fuel run)
15:08:01 <morgan_orange> so for functest we have 1 issue to solve
15:08:03 <jose_lausuch> but at 17:00UTC
15:08:05 <jose_lausuch> 2 hours to go
15:08:18 <fdegir> but build + deployment will take more than that
15:08:24 <jose_lausuch> hmmm
15:08:33 <fdegir> and also as trozet found out last night, we might have a problem with job blocking logic in jenkins
15:08:34 <jose_lausuch> then I can trigger it later tonight
15:08:39 <jose_lausuch> and see the results tomorrow
15:08:55 <fdegir> if you want to stay awake to click the button; be my guest :D
15:09:08 <fdegir> anyway
15:09:13 <[1]JonasB> fdegir: Can you ask aric to give Szilard access?
15:09:13 <jose_lausuch> if its just about clicking  its fine :p
15:09:14 <fdegir> I complained about this more than necessary
15:09:15 <fdegir> shutting up
15:09:16 <frankbrockners> sounds like jose_lausuch wants to do this...
15:09:26 <trozet> I can also push a button during your PM
15:09:30 <fdegir> [1]JonasB: Can't reach aricg on IRC
15:09:35 <fdegir> will send an email to helpdesk
15:09:42 <frankbrockners> thanks fdegir
15:09:44 <jose_lausuch> ok, maybe thats the best
15:09:45 <[1]JonasB> fdegir: Thanks
15:09:49 <szilard_> thanks Fatih
15:10:14 <frankbrockners> on the release decision... let's see how far jose_lausuch gets over the weekend and we can decide in our meeting on Monday
15:10:31 <frankbrockners> ok?
15:10:32 <jose_lausuch> well, I didnt say over the weekend
15:10:33 <morgan_orange> ok
15:10:36 <jose_lausuch> just clicking tonight
15:10:48 <jose_lausuch> I'll be driving during saturday and sunday :)
15:10:51 <frankbrockners> tonight == weekend for me :-)
15:10:55 <jose_lausuch> haha ok
15:11:13 <frankbrockners> ok - let's move to foreman
15:11:14 <jose_lausuch> but someone from bgs will have to merge that patch
15:11:15 <[1]JonasB> frankbrockners: Cant we wait until Wed to make a decision, I dont think the expectations are as high as for Arno/SR0
15:11:28 <frankbrockners> sure - we can also wait till Wednesday
15:11:35 * fdegir sent the mail
15:11:38 <frankbrockners> I just did not want to make a decision today
15:11:49 <frankbrockners> let's see where we are on Monday
15:11:51 <[1]JonasB> frankbrockners :-)
15:12:02 <frankbrockners> can we move to Foreman?
15:12:17 <frankbrockners> #topic BGS - Foreman status/updates
15:12:51 <morgan_orange> I have to drop out but jose_lausuch is working even the week end ..
15:12:56 <frankbrockners> there were 4 open topics identified on Wednesday
15:13:01 <trozet> #info  we are passing in CI on stable/arno.  There are 2 outstanding items.  1 opendaylight is being built by dfarrell07 as helium SR4 now and put into CBS repo, we will need to patch to point to that version
15:13:07 <frankbrockners> (from Wednesday): patch to migrate ODL helium SR3 build to SR4 and repo location to CBS
15:13:07 <frankbrockners> (from Wednesday): one patch remaining from randylevensalor to fix default route bug
15:13:07 <frankbrockners> (from Wednesday): Foreman doc patch SR1 in gerrit
15:13:07 <frankbrockners> (from Wednesday): .iso image builing and testing for SR1
15:13:31 <trozet> #info patch from RandyLevensalor to fix default route is good and merged
15:14:03 <trozet> #info Foreman doc is basically done, holding off on merge due to one last minute feature request to provision baremetal over a single interface from bryan_att.  Going to see if I can get that merged today
15:14:23 <trozet> #info If that patch doesnt work, we can just not include it into stable/arno, just thought it would be nice for users to have
15:14:34 <radez> #info .iso build looks good, still testing, I'm ona slow connection this week and had a bit of hangup getting the testing done
15:15:05 <trozet> #info so we are aiming to be done today
15:15:06 <frankbrockners> thanks for the updates trozet, radez
15:15:07 * s_berg needs to leave - have a nice weekend.
15:15:27 * ChrisPriceAB feels bad for being late...
15:15:29 <frankbrockners> anything else on Foreman/Quickstack?
15:16:01 <frankbrockners> if not, we can quickly move to Functest..
15:16:01 <trozet> thats it
15:16:07 <frankbrockners> thanks trozet
15:16:07 <bryan_att> #info Bryan Sullivan
15:16:19 <frankbrockners> #topic Functest - status/updates
15:16:43 <frankbrockners> morgan_orange - could you give us a brief update? any news on ODL testing?
15:16:48 <jose_lausuch> he just left
15:16:54 <jose_lausuch> I'll give the update
15:16:58 <frankbrockners> but you're still here :-)
15:17:06 <frankbrockners> thanks jose_lausuch
15:17:09 <jose_lausuch> #info no updates in the ODL problem
15:17:23 <fdegir> to everyone; please hold off before you merge your doc updates
15:17:30 <jose_lausuch> #info this will start on Monday by pbanzi and myself to trobuleshoot the issue
15:17:35 <jose_lausuch> #info this happens in both installers
15:17:46 <trozet> jose_lausuch: what is the issue?
15:17:52 <jose_lausuch> #info hopefully will be fixed next week
15:18:04 <jose_lausuch> some configuration file in the robot framework
15:18:11 <jose_lausuch> to be honest, I dont know the source of the issue yet
15:18:16 <jose_lausuch> need time to look into it still
15:18:28 <jose_lausuch> as soon as we get something stable to work on :)
15:18:37 <trozet> jose_lausuch: do you mind linking the table again with latest status
15:18:38 <frankbrockners> let's info that - from what pbandzi told me, some configs changed with the new release, and would need to be adapted
15:18:40 <[1]JonasB> jose_lausuch: Does functest now have a stable/arno branch?
15:18:41 <trozet> or morgan_orange:^
15:18:44 <jose_lausuch> #info besides that issue, nothing urgent for SR1
15:19:03 <jose_lausuch> #link https://wiki.opnfv.org/releases/arno/stablerelease_1
15:19:16 <jose_lausuch> yes, Jonas2
15:19:28 <[1]JonasB> jose_lausuch: Great/thx
15:19:45 <jose_lausuch> thats it, withouth extending :)
15:20:00 <frankbrockners> #topic Releng/Docs updates
15:20:18 <frankbrockners> #info fdegir asks everyone: please hold off before you merge your doc updates
15:20:26 <[1]JonasB> We're much better of than for SR0, I mean there is 1.5 weeks to go, oceans of time
15:20:43 <fdegir> #info The reason for this is that the doc-build script for genesis-docs jenkins job is disabled
15:20:46 <jose_lausuch> hahah sure, we said that also in SR0 :p
15:20:49 <trozet> jose_lausuch: what is the functest test case pass rate for Fuel/Foreman? can we put that in the table?
15:21:07 <trozet> jose_lausuch: and how does it compare to Arno?
15:21:09 <jose_lausuch> trozet: rate ?
15:21:09 <fdegir> #info Will work on it and send a notification once it is done
15:21:19 <fdegir> frankbrockners: that's all
15:21:24 <frankbrockners> let's action jose_lausuch...
15:21:35 <jose_lausuch> the comparison is that we should get the same result as for SR0
15:21:43 <jose_lausuch> plus ODL test working on Fuel
15:21:47 <jose_lausuch> that would be the idea
15:22:21 <frankbrockners> #action jose_lausuch: put up a functest pass/fail table - similar to what we did for Arno R1 - and compare to Arno R1 results
15:22:40 <frankbrockners> with this, looks like we're done for today
15:22:51 <jose_lausuch> ok
15:22:54 <trozet> jose_lausuch: im just thinking it would be useful to see the results.  Especially with foreman about to make a change from helium SR3 to SR4
15:22:54 <frankbrockners> next checkin is on Monday 1500 UTC = 8am PT
15:23:03 <trozet> jose_lausuch:  i would expect an improvement :)
15:23:17 <frankbrockners> yep - we hope that you can not only create but also remove networks....
15:23:19 <jose_lausuch> yes, hopefully me too :)
15:23:32 <frankbrockners> or is this too much of a hope?
15:23:47 <jose_lausuch> removing networks is what failed, so hopefully works now with SR4 helium
15:24:06 <jose_lausuch> cannot answer taht!
15:24:08 <jose_lausuch> need to test!
15:24:13 <jose_lausuch> hehehe
15:24:15 <frankbrockners> :-)
15:24:23 <frankbrockners> ok ... let's wait for the tests
15:24:38 <jose_lausuch> but most urgent is to get fuel deployment working
15:24:46 * trozet thinks frankbrockners may be dreaming
15:24:54 <jose_lausuch> lol
15:25:02 * frankbrockners has the same feeling...
15:25:09 <frankbrockners> with this... everyone enjoy your weekend!
15:25:16 <trozet> LOL
15:25:16 <jose_lausuch> thanks frankbrockners
15:25:28 <frankbrockners> #endmeeting