15:00:01 <frankbrockners> #startmeeting BGS/Genesis weekly meeting - and Arno SR1 synch
15:00:01 <collabot> Meeting started Mon Sep 21 15:00:01 2015 UTC.  The chair is frankbrockners. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:01 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:00:01 <collabot> The meeting name has been set to 'bgs_genesis_weekly_meeting___and_arno_sr1_synch'
15:00:07 <frankbrockners> #info Frank Brockners
15:00:28 <morgan_orange> #info Morgan Richomme
15:00:49 <chenshuai1> #info chenshuai
15:00:53 <dduffey> #info David Duffey
15:00:57 <dduffey> is this an irc only meeting?
15:01:02 <davidmichaelkarr> #info David Karr
15:01:11 <RandyLevensalor> #info Randy Levensalor
15:01:22 <frankbrockners> dduffey - so far yes
15:01:32 <jose_lausuch> #info Jose Lausuch
15:01:53 <trozet> #info Tim Rozet
15:02:01 <ashyoung> #info Ashlee Young
15:02:02 <wshao> #info Weidong Shao
15:02:43 <[1]JonasB> 3info Jonas Bjurel
15:02:50 <[1]JonasB> #info Jonas Bjurel
15:03:04 <frankbrockners> agenda for today is 2-fold: 1st half of the meeting is Arno SR1 synch, second half is Genesis
15:03:13 <frankbrockners> #info draft agenda: https://wiki.opnfv.org/meetings/bgs#sep212015
15:03:32 <frankbrockners> #topic Arno SR1 synch
15:03:43 <frankbrockners> #info detailed agenda is found here: https://wiki.opnfv.org/releases/arno/stablerelease_1#monday_sept212015
15:03:51 <wshao> are we on goto-meeting?
15:04:06 <frankbrockners> wshao: IRC only
15:04:21 <frankbrockners> BGS status/updates
15:04:21 <frankbrockners> Fuel status
15:04:21 <frankbrockners> (from Wednesday):Fuel deployment failure (cache corruption) resolution
15:04:21 <frankbrockners> Foreman/Quickstack status
15:04:21 <frankbrockners> (from Wednesday): patch to migrate ODL helium SR3 build to SR4 and repo location to CBS
15:04:22 <frankbrockners> (from Wednesday): one patch remaining from randylevensalor to fix default route bug
15:04:22 <frankbrockners> (from Wednesday): Foreman doc patch SR1 in gerrit
15:04:23 <frankbrockners> (from Wednesday): .iso image builing and testing for SR1
15:04:23 <frankbrockners> Testing – Functest status (tests, documentation)
15:04:24 <frankbrockners> (from Wednesday): Robot/ODL testing failures
15:04:24 <frankbrockners> CI/RELENG - status/updates
15:04:25 <frankbrockners> OPNFV docs - status/updates
15:04:38 <frankbrockners> that was a cut and paste from the agenda
15:04:47 <radez> #info Dan Radez
15:04:59 <frankbrockners> #topic Update on LF lab
15:05:02 <s_berg> #info Stefan Berg
15:05:28 <frankbrockners> anyone can give a quick update? trozet, pbandzi? Jumphost of LF Pod1 seems to be down
15:05:40 <trozet> #info POD1 had some problems - pbandzi fixed it
15:05:49 <frankbrockners> cool - thanks pbandzi
15:05:55 <bryan_att> #info Bryan Sullivan
15:05:56 <frankbrockners> anything else on the LF lab?
15:06:00 <trozet> #info pod2 - pbandzi is modifying it so that it doesn't need lab reconfig anymore
15:06:14 <frankbrockners> great
15:06:17 <pbandzi> #info pbandzi
15:06:30 <trozet> #info pod2 will use a static ucs/linux networking config - changes have been made and szilard is modifying Fuel now
15:07:20 <narindergupta> #info Narinder Gupta
15:07:27 <frankbrockners> done with LF lab?
15:07:55 <frankbrockners> #topic Fuel status
15:08:05 <[1]JonasB> #info Cache coruption fixed, Szilard has been working the week-end to get deploy working (Just got the message that it seems to be working now - Great work done by Szilard). Stefan got the package mirror working. Documentation will finish this week.
15:08:27 <[1]JonasB> #info - So status looks pretty promising for fuel.
15:08:31 <frankbrockners> Great news... - # of issues is trending down :-)
15:08:54 <[1]JonasB> One issue though (not related to any specific installer)
15:09:49 <wshao> sorry, my IRC connections is flaky today. is today's Agenda posted elsewhere?
15:09:53 <[1]JonasB> When you touch a common file - Jenkins triggers a whole lot of build and deploy jobs (4 all 5 installers). That takes 4ever to finish
15:09:56 <frankbrockners> [1]JonasB: What about the local mirror work you were planning to complete?
15:10:31 <frankbrockners> wshao: https://wiki.opnfv.org/meetings/bgs#sep212015
15:10:32 <[1]JonasB> frankbrockners: It is working now, just final touching on it.
15:10:39 <fdegir> today's issue was due to having pod1 jumpstart down
15:10:43 <frankbrockners> let's info that briefly
15:10:49 <fdegir> which blocked foreman virt deploy
15:11:05 <fdegir> that blocked verification of changes touching common stuff
15:11:20 <fdegir> I see pod1 js is up now
15:11:26 <[1]JonasB> frankbrockners: Already infoed the mirror stuff.
15:11:30 <fdegir> so things should move on
15:11:41 <frankbrockners> fdegir - please read through the earlier log - pbandzi fixed things
15:12:36 <fdegir> frankbrockners: this is not about pod2
15:12:36 <frankbrockners> #info (from [1]JonasB - common issue: When you touch a common file - Jenkins triggers a whole lot of build and deploy jobs (4 all 5 installers). Takes quite a long time to finish
15:12:56 <frankbrockners> fdegir: he fixed pod1
15:13:00 <fdegir> this is about what [1]JonasB says
15:13:24 <fdegir> so I shouldn't give details about the problem?
15:14:02 <frankbrockners> #info (from [1]JonasB): Work on creating a local mirror for Fuel installer is about to finish
15:14:21 <frankbrockners> fdegir - sorry - I thought this was a repeat of the earlier discussion on LF lab status
15:14:37 <frankbrockners> anything else on Fuel?
15:14:48 <[1]JonasB> frankbrockners: Nope
15:14:53 <frankbrockners> thanks.
15:15:02 <frankbrockners> #topic Foreman/Quickstack status
15:15:30 <trozet> #info patch to migrate ODL helium SR3 build to SR4 and repo location to CBS - Done
15:15:42 <trozet> #info  one patch remaining from randylevensalor to fix default route bug - Done
15:15:48 <frankbrockners> trozet - any updates on the "last min feature for Bryan" and the iso built?
15:16:01 <trozet> #info tested ISO - looks good - Done
15:16:07 <frankbrockners> (I noticed I cut&pasted the wrong agenda above)
15:16:43 <trozet> #info Bryan tested out the patch locally and it worked for him - has not made it through the CI gauntlet yet due to issues with POD1, going to try to get it through today
15:17:36 <frankbrockners> sounds good - so we're close to "done" for Foreman as well
15:17:45 <frankbrockners> anything else on Foreman?
15:18:14 <trozet> no thats it
15:18:21 <frankbrockners> thanks
15:18:23 <frankbrockners> #topic Functest status update
15:18:38 <frankbrockners> from Friday we had:
15:18:42 <frankbrockners> (from Friday): Robot/ODL testing failures
15:18:42 <frankbrockners> (from Friday): Table summarizing Arno SR1 status and delta to Arno R1.
15:19:00 <jose_lausuch> table planned to have it for tomorrow
15:19:16 <jose_lausuch> robot odl failures under investigation still
15:19:21 <jose_lausuch> we need a stable deploy also
15:19:22 <morgan_orange> #info jose_lausuch table planned tomorrow
15:19:35 <frankbrockners> #action jose_lausuch will supply a Table summarizing Arno SR1 status and delta to Arno R1 to Sept/22
15:20:07 <frankbrockners> #info obot odl failures under investigation still (per jose_lausuch)
15:20:08 <morgan_orange> #info ODL issue still pending, waiting for a stable test env
15:20:24 <frankbrockners> anything else on Functest?
15:20:27 <jose_lausuch> and pbandzi also :) he is everywhere
15:20:30 <morgan_orange> #action morgan_orange finalize doc update before the end of the week
15:20:44 <morgan_orange> maybe just a remark
15:21:00 <morgan_orange> when tests were running vPing lasts 80s on fuel and 120s on foreman
15:21:25 <morgan_orange> not an issue (vPing is properly received in both cases but delta time is surprising)
15:21:49 <morgan_orange> that is all for functest
15:21:55 <frankbrockners> what does "last" mean - not sure I follow
15:22:33 <trozet> frankbrockners, morgan_orange: does that mean like the test execution time is 80s/120s?
15:22:43 <morgan_orange> in average the same test (vPing)  takes 80s with fuel installer and 120s with foreman
15:22:44 <jose_lausuch> the test case takes 80 seconds on fuel and 120s on foreman
15:22:47 <morgan_orange> reproducible
15:22:50 <jose_lausuch> to bring up the VMs and ping each other
15:23:03 <frankbrockners> how many pings do you run?
15:23:18 <jose_lausuch> forever until it pings or timesout
15:23:45 <frankbrockners> then I really don't understand the 80s value...
15:23:50 <[1]JonasB> So it is the VM bring up time that differs?
15:24:23 <morgan_orange> probably
15:24:30 <jose_lausuch> not to extend the meeting, lets say that the test as such takes 80s
15:24:41 <morgan_orange> it was just a remark...
15:24:42 <jose_lausuch> maybe its about bringing the VM or the metadata server
15:24:44 <jose_lausuch> not sure
15:24:56 <jose_lausuch> but not super important now, since it still works
15:25:35 <frankbrockners> ok - would still like to understand the scenario a bit better.. anyone would write a quick email with background info?
15:25:50 <[1]JonasB> Question: Is there any other non BGS related documentation that needs touching/cleaning for SR1?
15:25:51 <jose_lausuch> yes, we can take it offline :_
15:25:56 <jose_lausuch> :)
15:26:15 <frankbrockners> [1]JonasB - let's move to Docs
15:26:24 <frankbrockners> #topic OPNFVdocs updates
15:26:46 <frankbrockners> any thoughts on Jonas' question?
15:27:00 <[1]JonasB> #info Fuel hopes to finish related docs this week
15:27:15 <morgan_orange> #info Functest tambien
15:27:37 <jose_lausuch> tambien? :)
15:27:47 <morgan_orange> #undo
15:28:08 <[1]JonasB> Dont undo :-)
15:28:16 <morgan_orange> i cannot anyway
15:28:28 <trozet> :)
15:28:36 <frankbrockners> #info tambien == as well
15:28:58 <jose_lausuch> in french? also in spanish
15:28:59 <jose_lausuch> hehe
15:29:49 <frankbrockners> apart from the Foremand / Fuel / Functest guides there is only the automated deployment guide as a candidate for updates
15:30:09 <frankbrockners> fdegir - are you planning to change the automated deployment guide?
15:30:41 <fdegir> frankbrockners: I don't know what that is
15:30:59 <fdegir> I haven't written anything to that guide
15:31:04 <fdegir> so nothing feom me
15:31:14 <frankbrockners> "Connecting Labs to OPNFV Jenkins"
15:31:21 <frankbrockners> on https://www.opnfv.org/software/download
15:31:36 <fdegir> I will check that one
15:31:42 <frankbrockners> perfect - thanks
15:31:43 <fdegir> towards the weekend
15:31:52 <[1]JonasB> Any comunity PR/Marketing/Download web pages that needs update?
15:32:09 <frankbrockners> Ray already asked that question
15:32:30 <frankbrockners> current assumption is that we'll simply update the current page with pointers to the new SR1 docs
15:32:47 <frankbrockners> the old ones will still be accessible via artifacts.opnfv.org
15:33:19 <frankbrockners> I expect that marketing will take care of the updates on www.opnfv. org
15:33:29 <frankbrockners> but they'll need pointers from us of course
15:33:48 <frankbrockners> let's close on status... CI/Releng is missing
15:33:55 <frankbrockners> #topic CI/Releng updates?
15:34:18 <frankbrockners> fdegir - any updates? You disabled building docs. Plans for re-enablement?
15:34:23 <fdegir> #info Doc generation updates have been submitted to master
15:34:33 <fdegir> #info The jobs should produce docs now
15:34:51 <fdegir> please report any problems
15:35:03 <frankbrockners> that means that folks can start to put new docs patches in, correct?
15:35:12 <fdegir> that's correct
15:35:20 <frankbrockners> thanks fatih
15:35:24 <fdegir> np
15:35:49 <frankbrockners> overall... looks like we're on track towards releasing on Sep/29 - or does someone believe otherwise?
15:36:08 <[1]JonasB> So where do we collect our SR1 hoodies :-)
15:36:18 <morgan_orange> it would be good to see at least 2 days of CI without issues....
15:36:40 <frankbrockners> agree morgan_orange
15:36:55 <frankbrockners> let's hope that by Wednesday it's all clean
15:37:16 <frankbrockners> ok - let's switch topics
15:37:32 <frankbrockners> I have a quick heads up on the release artifacts discussion:
15:37:36 <jose_lausuch> maybe we dont have weekend work :)
15:37:42 <frankbrockners> #topic OPNFV release artifacts discussion
15:38:09 <frankbrockners> #info earlier today I sent an email on the topic with a wiki link
15:38:36 <frankbrockners> #link https://wiki.opnfv.org/releases/brahmaputra/release_artifacts_discussion
15:38:51 <frankbrockners> #info people already started to update and modify - which is good
15:39:10 <frankbrockners> #info plan is for the TSC to discuss tomorrow and voice some preference for options
15:39:27 <frankbrockners> #info hence the ask to everyone here: please review and evolve... - thanks!
15:39:52 <frankbrockners> Don't want to spend more time here - but wanted to give everyone a heads up
15:39:57 <frankbrockners> now on to Genesis
15:40:03 <frankbrockners> #topic Genesis
15:40:42 <frankbrockners> from the topics on the agenda - it is probably better to discuss things live...
15:40:54 <trozet> ok
15:41:00 <[1]JonasB> Yes
15:41:05 <frankbrockners> if you're ok - we can use my personal webex room: https://cisco.webex.com/meet/fbrockne
15:41:19 <[1]JonasB> 7 minutes bio?
15:41:42 <[1]JonasB> If we plan to go to 7 PM
15:42:13 <frankbrockners> sorry - I have a hard stop at 6pm = 9am PDT
15:42:27 <frankbrockners> but I scheduled another call for tomorrow 9am PDT
15:42:42 <[1]JonasB> Ok, then we go
15:42:50 <frankbrockners> thanks [1]JonasB
15:46:11 <wshao> fyi - I am unable to join webex for some reason.
15:57:54 <dduffey> frankbrockners, I would be available for a call same time tomorrow (8am PDT)
16:00:53 <dduffey> frankbrockners, I would recommend suggesting that everyone try to put comments into jira before the call so that there is some thought, etc... since going one-by-one through the issues will be pretty time consuming
16:01:32 <[1]JonasB> Frankbrockners: Dont forget endmeeting
16:01:44 <frankbrockners> dduffey - 8am is taken by Debra
16:02:08 <dduffey> frankbrockners, okay, I won't be able to join ... but I'll add comments and maybe narinder can join
16:02:10 <frankbrockners> dduffey - everyone put their thoughts in Jira: YES PLEASE
16:02:23 <dduffey> thanks frankbrockners
16:02:27 <narindergupta> dduffey: yes i am joining
16:02:28 <frankbrockners> thanks everyone for joining
16:02:32 <frankbrockners> #endmeeting