14:00:20 <uli-k> #startmeeting Octopus weekly meeting
14:00:20 <collabot> Meeting started Mon Sep 28 14:00:20 2015 UTC.  The chair is uli-k. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:20 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:00:20 <collabot> The meeting name has been set to 'octopus_weekly_meeting'
14:00:32 <uli-k> Hi everybody!
14:00:37 <uli-k> #topic roll-call
14:00:47 <uli-k> please type #info
14:00:48 <chenshuai1> hi Uli
14:00:54 <chenshuai1> #info chenshuai
14:01:00 <narindergupta> #info Narinder Gupta
14:01:20 <fdegir> #info Fatih Degirmenci
14:01:51 <May-meimei> #info meimei
14:02:17 <pbandzi> #info Peter Bandzi
14:02:26 <uli-k> Did anyone from you participate last week? I didn't have a chance to ask trozet about the meeting
14:03:27 <fdegir> it seems not much happened last week
14:03:27 <fdegir> http://ircbot.wl.linuxfoundation.org/meetings/opnfv-meeting/2015/opnfv-meeting.2015-09-21-14.01.html
14:03:30 <fdegir> due to SR1 work
14:03:36 <May-meimei> sorry, I had the bad network last week
14:03:38 <fdegir> and due to lack of people
14:03:49 <uli-k> I feared so.....
14:04:05 <uli-k> I put a few things on the agenda for today:
14:04:09 <uli-k> #topic agenda bashing
14:04:14 <trozet> #info Tim Rozet
14:04:19 <radez> #info Dan Radez
14:04:28 <uli-k> #info Action item review - Milestone C for B-Release - Arno SR1 work - some Current sorking topics
14:04:44 <uli-k> Anything we should add?
14:04:54 <trozet> uli-k: it was mostly pbandzi and I chatting in the meeting about current CI issues nothing really to report
14:05:07 <uli-k> OK. Thanks, trozet!
14:05:28 <uli-k> OK let's start with AIs then.
14:05:35 <uli-k> #topic Action Item review
14:05:53 <uli-k> #info first AI: uli-k trozet ChrisPriceAB: clarify the need of doing Brahmaputra release on LF Lab
14:06:05 <ChrisPriceAB> :D
14:06:09 <uli-k> I think we don't have progress there?
14:06:19 <ChrisPriceAB> Nope.
14:06:25 <uli-k> So keep open.....
14:06:28 <uli-k> #action uli-k trozet ChrisPriceAB: clarify the need of doing Brahmaputra release on LF Lab
14:06:39 <ChrisPriceAB> SR1 and MSC have been a little heavy...
14:07:03 <uli-k> yes.....
14:07:07 <uli-k> #info next two AIs on me about Pharos lab support.
14:07:27 <uli-k> I also don't have much progress there - at least no results.
14:07:38 <uli-k> So let me repeat them ....
14:07:50 <uli-k> #action uli-k talk to Huawei lab guys to support Pharos
14:08:00 <uli-k> #action uli-k to trigger other lab reps according to community lab overview wiki
14:08:16 <uli-k> #info next one about clean-up of committer list.
14:08:32 <uli-k> #info three committers agreed to be removed from the octopus committer list:
14:08:53 <uli-k> #info Zhangyu, Huqiqi, Wes Hayutin agreed to be removed.
14:09:01 <uli-k> Do we need to vote?
14:09:25 <ChrisPriceAB> Committers just need to send you a mail to stand down.
14:09:43 <uli-k> I have that. So I will update the INFO file.
14:09:55 <ChrisPriceAB> The TSC should be informed with the relevant information and reasons (TSC still oversee's committer removal)
14:10:05 <uli-k> #action uli-k to remove 3 committers from INFO file and inform TSC
14:10:13 <ChrisPriceAB> (A mail to the mailing list should do.)
14:10:37 <ChrisPriceAB> I will raise it tomorrow I think for a discussion as we have not be super clear on the process at the TSC yet.
14:11:11 <uli-k> I fully agree. There was a lot of traffic promoting committers before the election :D
14:11:24 <uli-k> I tried to contact three more committers, but didn't get answers:
14:11:55 <uli-k> #info Palani, Chengappa and Sudha Kumari were contacted by uli-k, but no answer
14:12:14 <uli-k> #info Chengappa had answered in July, but didn't start working.
14:12:36 <uli-k> #info Frank didn't confirm to me that we can remove Palani.
14:12:53 <uli-k> Should we raise this to the TSC?
14:13:48 <uli-k> I can also take the action to talk again to Frank and to Dave Lenrow.
14:13:55 <uli-k> What do you think?
14:14:13 <fdegir> I think you can ask TSC
14:14:18 <fdegir> what is the process if the committers don't answer/want to stand down and do nothing?
14:14:33 <fdegir> any "expiry date"? :)
14:14:58 <uli-k> Since these committers haven't been active more than 6 month, according to the TSC charter, the TSC can remove them. Right ChrisPriceAB?
14:16:31 <uli-k> OK. Since ChrisPriceAB said he will raise discussion on committers tomorrow, we can push that to TSC.
14:16:46 <uli-k> #action uli-k to bring discussion on these 3 to TSC.
14:17:08 <uli-k> OK. Sorry too much time for such issue.....
14:17:31 <uli-k> #info Next AI: uli-k to raise the issue in project meeting so projects come forward with their dependency on octopus to setup their pipeline
14:17:55 <uli-k> We did that (fdegir and me).
14:18:11 <uli-k> We received requests from IPv6 and from armband.
14:18:22 <uli-k> I created Jira for those.
14:18:32 <uli-k> Suggest to close the AI.
14:18:53 <uli-k> moving on.....
14:19:14 <uli-k> #topic Milestone C for B-Release
14:19:25 <uli-k> I have sent milestone C report.
14:19:52 <uli-k> So that should be fine. However, there still needs to be added some more details in the Jira.
14:20:06 <uli-k> comments?
14:20:29 <uli-k> #topic Arno SR1 work
14:20:55 <uli-k> any news / problems / Successes?
14:21:19 <fdegir> BGS and FuncTest guys are doing the heavylifting
14:21:33 <fdegir> so I stop and let pbandzi trozet to comment on it
14:21:45 <trozet> or jose_lausuch
14:22:21 <trozet> #info I think we are waiting on a foreman run right now, to make sure odl tests pass with the help of jose_lausuch and pbandzi
14:22:35 <trozet> not sure about Fuel status, Jonas1, do you want to comment?
14:23:43 <uli-k> I think he is not here
14:24:06 <fdegir> #info Not much to report for Arno SR1 from CI point of view
14:24:26 <ChrisPriceAB> sorry uli-k, doing multiple things :)
14:25:16 <uli-k> let's move on to the three current working topics, I noticed in the mails....
14:25:33 <uli-k> #topic Current issues: Connecting ZTE lab
14:25:50 <uli-k> I think MatthewLi, you are helping them, right?
14:25:55 <ChrisPriceAB> At this time (pending TSC discussion) the process should be.  Try to get in touch with inactive committers.  Talk to them about stepping down if they will not be active in the project.  If they send a mail stating they will step down they can be removed.   (Then send a mail to the TSC and remove them form the INFO)
14:26:00 <uli-k> Any issues? progress?
14:26:15 * ChrisPriceAB thinks the TSC should only really need to vote on "non voluntary removals"
14:27:01 <uli-k> ChrisPriceAB, we have 3 voluntarily stepping down, and 3 we cannot get in touch.
14:27:09 <uli-k> We have moved on.....
14:27:41 <uli-k> and it looks like also MatthewLi is doing multiple things..... :D
14:27:57 <uli-k> Let's go to the next one....
14:28:01 <May-meimei> zte slave have been online
14:28:02 <fdegir> we need to find out what we can run on zte lab
14:28:20 <fdegir> it seems they can't upload/download isos due to low bandwidth
14:28:29 <uli-k> hmmmm
14:28:32 <fdegir> we can perhaps run some test framework validation on it
14:28:47 <fdegir> or an installer that doesn't require iso
14:29:04 <fdegir> but we can move on and take this offline
14:29:29 <uli-k> yes.
14:29:48 <uli-k> #topic current issues: CI for armband
14:30:32 <fdegir> this is a tricky topic and it really depends on the ambition level of the armband project
14:30:49 <fdegir> do they want to mirror all CI stuff runs on Intel
14:30:59 <uli-k> I think they have ambitions for that.
14:31:02 <fdegir> meaning validating all installers
14:31:12 <fdegir> good
14:31:32 <fdegir> then we need arm labs setup asap assuming they want to be part of B-release
14:31:48 <uli-k> I think I saw the C-report.
14:32:10 <uli-k> And durign creation review they told us the ambitions....
14:32:27 <uli-k> I don't know about *all* installers.
14:32:42 <uli-k> But I am sure, there will be more than on.
14:32:45 <uli-k> one.
14:33:20 <fdegir> when is the next milestone?
14:33:54 <uli-k> I think that is something like feature complete. So there will be some time - and work to do until then.
14:33:57 <fdegir> dec 1
14:34:09 <fdegir> so we have about 2 months
14:35:06 <fdegir> anyway, if they bring their first lab up and running
14:35:12 <uli-k> Maybe we should schedule a separate meeting with them - after they are approved they passed Milestone C.
14:35:37 <aricg-> arm lab? arm will provide that this yes?
14:35:38 <fdegir> it would help everyone since it is genesis, installers, test, infra projects
14:35:50 <uli-k> aricg: yes.
14:35:57 <fdegir> everyone will need to get feedback from there
14:36:03 <fdegir> so it is not actually 2 months
14:36:15 <fdegir> if some issues are found in some projects
14:36:24 <fdegir> they need time to fix them if they agreed arm requirements
14:36:49 <uli-k> Fully agree.
14:37:11 <uli-k> So I suggest, we wait, whether they get Milestone C approval.
14:37:30 <fdegir> ok
14:37:31 <uli-k> Then we call for a meeting to understand their thinking.
14:38:07 <uli-k> #agree to meet with armband as soon as we have decision whether they are in B release
14:38:19 <uli-k> #topic AoB
14:38:29 <uli-k> (and then releng!)
14:39:00 <uli-k> #chair fdegir
14:39:00 <collabot> Current chairs: fdegir uli-k
14:39:19 <uli-k> #info moving on to releng.
14:39:48 <fdegir> #topic Releng Brahmaputra Milestone-C Status
14:40:06 <fdegir> #info Milestone-C status report has been sent out
14:40:31 <fdegir> #info There are definitely invisible/secondary dependencies which will surface later on
14:40:53 <fdegir> #info Combinations of things will also make things interesting
14:41:13 <fdegir> #topic Releng AOB
14:41:29 <fdegir> aricg morgan_orange trozet jose_lausuch MatthewLi: do you want to add anything?
14:42:10 <fdegir> most of the people are busy with SR1 so not much to report I assume
14:42:36 <fdegir> nothing more for releng
14:42:50 <trozet> no
14:42:55 <aricg-> no
14:42:55 <trozet> nothing from me
14:43:19 <jose_lausuch> sorry, didnt follow much
14:43:25 <jose_lausuch> we are testing currently odl on foreman
14:43:47 <fdegir> jose_lausuch: thx
14:43:56 <morgan_orange> nothing from me
14:44:22 <fdegir> thx to all
14:44:43 <fdegir> back to you uli-k
14:45:12 <uli-k> OK. Thanks everybody then for the meeting!
14:45:22 <uli-k> Talk to you next week!
14:45:38 <uli-k> #endmeeting