14:00:35 <uli-k> #startmeeting OPNFV-Octopus Weekly Meeting
14:00:35 <collabot> Meeting started Mon Oct 19 14:00:35 2015 UTC.  The chair is uli-k. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:35 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:00:35 <collabot> The meeting name has been set to 'opnfv_octopus_weekly_meeting'
14:00:46 <uli-k> Hello everybody!
14:00:53 <chenshuai1> Hi Uli
14:00:55 <May-meimei1> hi, Uli
14:01:15 <uli-k> Let's have next octopus meeting after we skipped last week
14:01:23 <uli-k> #topic roll-call
14:01:31 <sudha> Hello Uli
14:01:33 <uli-k> please type info
14:01:42 <uli-k> Welcome sudha!
14:02:18 <dduffey> #info David Duffey
14:02:25 <chenshuai1> #info chenshuai
14:02:25 <uli-k> #info Uli Kleber
14:02:31 <r-mibu> #info Ryota Mibu
14:02:32 <May-meimei1> #info meimei
14:02:32 <fdegir> #info Fatih Degirmenci
14:02:45 <narindergupta> #info Narinder Gupt
14:03:04 <uli-k> So we are a good group! Let's get rolling.
14:03:12 <uli-k> #topic agenda bashing
14:04:02 <uli-k> #info I have put on wiki: AI-review, Meeting time (daylight saving stops), Pharos questionnair, B-release work.
14:04:08 <uli-k> Anything else?
14:04:26 <trozet> #info Tim Rozet
14:04:58 <uli-k> #info I like to add committer maintenance again, since sudha joined (we just wanted to remove her from list)
14:06:02 <uli-k> OK. So let's go.
14:06:16 <uli-k> #topic Action items
14:06:25 <fdegir> kind of a bit late
14:07:01 <uli-k> agree.....
14:07:18 <uli-k> #info First Action uli-k trozet ChrisPriceAB: clarify the need of doing Brahmaputra release on LF Lab - put high priority on TSC agenda
14:08:03 <uli-k> we still didn't have a discussion in TSC on this.
14:08:20 <uli-k> So let's keep open.
14:08:43 <uli-k> #info Next AI: uli-k talk to Huawei lab guys to support Pharos
14:09:02 <uli-k> Done. The answer to Pharos questionnaire should be here.
14:09:09 <uli-k> fdegir, is it in?
14:09:17 <fdegir> uli-k: yes
14:09:30 <uli-k> #info AI closed.
14:09:54 <uli-k> #info Next AI: uli-k to talk to Huawei lab guys to increase the bandwidth, check the network, etc. to make sure they're up at all times
14:10:11 <uli-k> Done. We are working on it.....
14:10:58 <May-meimei1> yes, I will support pharos, and we are improving the networking
14:11:09 <uli-k> #info AI closed.
14:11:39 <uli-k> #info Next AI: uli-k to trigger other lab reps according to community lab overview wiki
14:11:54 <uli-k> I think fdegir has closed this AI for me. Thanks fdegir :D
14:11:59 <fdegir> np
14:12:07 <uli-k> #info AI closed.
14:12:21 <uli-k> #info last one: trozet to connect intel pod 2 to OPNFV CI
14:12:48 <trozet> yeah
14:12:51 <trozet> still need to do that
14:13:01 <trozet> #info will work on that this week
14:13:20 <uli-k> OK. I re-action, so we track it....
14:13:26 <uli-k> #action trozet to connect intel pod 2 to OPNFV CI
14:13:32 <trozet> thanks
14:14:06 <uli-k> #topic meeting times
14:14:25 <kaipule> #info kaipule
14:14:30 <uli-k> #info Europe stops daylight saving next sunday, US will be one week later.
14:15:19 <uli-k> So if we stay with UTC 1400, the meeting will be one hour later next week.
14:15:33 <uli-k> But some people will be in Tokyo and not able to participate.
14:15:44 <uli-k> Should we have meeting next week?
14:16:33 <fdegir> I wouldn't mind not having the meeting next week
14:17:10 <uli-k> I would also prefer to skip (in Tokyo it starts at midnight)
14:17:22 <uli-k> Anybody disagree?
14:17:26 <May-meimei1> agree
14:17:40 <uli-k> #agree to skip next week's meeting
14:18:36 <uli-k> #info for meeting time in two weeks, I suggest to follow a general guidance, which I requested from TSC, to avoid new overlapping meetings.
14:18:54 <uli-k> At least I want us to move in the same way as genesis
14:19:25 <uli-k> Anybody having strong feelings?
14:20:16 <uli-k> no. Then I action myself.
14:20:39 <uli-k> #action uli-k to clarify meeting times after switching back from daylight saving
14:21:08 <uli-k> Please everybody be aware, that the time may shift on November 2.
14:21:43 <uli-k> #topic Committer maintenance
14:22:11 <uli-k> #info we have successfully voted to start removal process for two committers whom we could not reach.
14:22:42 <uli-k> #info now finally sudha got some notification on her new email address.
14:23:18 <uli-k> I would have difficulty now telling the TSC that I still couldn't get any contact.
14:23:22 <sudha> :) .... i had emailed long back to update my id
14:24:01 <uli-k> We need to fix the email thing consistently.
14:25:14 <uli-k> Please register the new email address with LF and your LF id.... I will update INFO file.
14:25:26 <uli-k> ... :D and start contributing :D
14:25:34 <sudha> LF?
14:25:43 <uli-k> Linux Foundation.
14:25:56 <sudha> Sure
14:26:31 <uli-k> I hope everybody is fine with that.
14:27:00 <uli-k> I will still ask TSC to remove Palani.
14:27:13 <uli-k> (that is I will update my request ....)
14:27:19 * fdegir prefers not to talk
14:28:37 <uli-k> #topic Results of Pharos questionnaire
14:28:59 <uli-k> fdegir, how many labs do we have "today"?
14:29:43 <fdegir> 8
14:29:57 <fdegir> not counting the ones having more than a lab
14:30:15 <fdegir> if we do that, it goes up to 10 I think
14:30:57 <uli-k> how many can run jenkins jobs that *we* would create?
14:31:10 <fdegir> 2 to start with
14:31:15 <fdegir> the rest needs to be validated
14:31:35 <fdegir> I have hopes for Huawei, ZTE, China Mobile, Orange, Dell
14:31:38 <fdegir> based on the answers
14:31:53 <fdegir> Spirent also offers resources
14:32:21 <fdegir> with VMs and whatnot
14:32:30 <uli-k> I guess these 6 (7) labs have different time schedule when they are ready for such validation?
14:32:53 <uli-k> Do you know who will be available first?
14:33:08 <fdegir> interestingly, all those labs became online on jenkins after we sent the survey
14:33:15 <uli-k> :D
14:33:28 <fdegir> so I'm writing a script to do connection check continuously
14:33:35 <uli-k> So they all want to be validated tomorrow?
14:33:37 <fdegir> and also will try to download large files
14:33:49 <fdegir> validation should be run more than a day
14:33:54 <fdegir> not just a day
14:34:00 <fdegir> a week or something
14:34:19 <uli-k> (I meant starting tomorrow)
14:34:31 <fdegir> will see if I make it for tomorrow
14:34:40 <May-meimei1> good
14:34:56 <fdegir> apart from usual connectivity stuff
14:34:57 <fdegir> I
14:34:58 <kaipule> zte-lab can provide the vm
14:35:03 <uli-k> didn't want to put pressure on you, but meaning they are really ready.
14:35:14 <fdegir> ll also check when was a job run on any of the slaves/labs
14:35:21 <fdegir> last time
14:35:55 <fdegir> the thing is
14:36:03 <fdegir> some of the labs are shared between dev and CI work
14:36:11 <fdegir> I think China Mobile and ZTE are 2 of them
14:36:26 <fdegir> so the developers need to do booking on wiki
14:36:36 <fdegir> and CI times will be there as well
14:36:48 <fdegir> anyway, this is the update I have
14:37:02 <uli-k> But this is really good news!
14:37:23 <fdegir> don't believe it until I see it :)
14:37:52 <uli-k> In Dusseldorf, we had a very short discussion whether we should have a common solution for big file transfers into China.
14:38:15 <uli-k> Should we have a short discussion on that?
14:38:51 <uli-k> kaipule, do you know how to do it for ZTE?
14:39:03 <kaipule> yes
14:39:05 <ChrisPriceAB> Just coming back quickly on my action point.  I would like to hear from others as well, but I believe we need the current Pharos investigation to come to a conclusion before we can make a decision on the ability to use community labs (and under what conditions) for release activities.
14:39:21 <ChrisPriceAB> I doubt adding it to the TSC agenda this week will not result in an outcome.
14:39:33 * ChrisPriceAB uses not when he should not
14:39:42 <kaipule> we lab can test the yardsick and functest.
14:40:10 <uli-k> ChrisPriceAB: Understand. But we are on connectivity issue at the moment....
14:40:31 <ChrisPriceAB> I know, apologies for ambushing.  Just putting it out there
14:40:37 <kaipule> but our lab can not auto configure
14:40:58 <zhifeng> ZTE can try to download the big file from server in HOKONG.
14:41:30 <fdegir> the thing is
14:41:31 <uli-k> I think that is similar to our (Huawei) solution.
14:41:40 <fdegir> the download needs to be done on a jenkins connected slave
14:41:43 <fdegir> the problem we
14:41:48 <fdegir> ve experienced is that
14:42:00 <fdegir> all the bandwidth gets eaten by the download operation
14:42:06 <fdegir> and jenkins loses connectivity to slave
14:42:13 <fdegir> so manual download might work
14:42:19 <fdegir> but not from jenkins
14:42:58 <fdegir> of course you can try manual download as well for other purposes
14:43:04 <uli-k> ChrisPriceAB in Dusseldorf talked about a mirror in China.
14:43:09 <zhifeng> I agree. the manual download is better.
14:43:15 <uli-k> A mirror all China labs could use.
14:43:26 <fdegir> but it is not about having a mirror there
14:43:35 <kaipule> I agree too.
14:43:37 <fdegir> it is through jenkins
14:43:59 <fdegir> you can download it from mirror
14:44:23 <fdegir> but isn't that bandwidth shared between jenkins slave connection and download operation?
14:44:54 <fdegir> and btw, manual stuff has no place in CI
14:45:43 <May-meimei1> the problem is "offline from jenkins master", yes?
14:45:51 <fdegir> yes
14:46:33 <fdegir> I remember mentioning playing with wget download limits
14:46:40 <fdegir> but don't know if anyone tried that
14:48:47 <zhifeng> ZTE can try and give the result with wget download limits.
14:49:36 <uli-k_> .. sorry, my slave PC lost connection to the master IRC :D
14:50:18 <uli-k_> I wanted to say: the idea of the mirror is:
14:50:41 <uli-k_> the slave connection to jenkins master will go different way than the download.
14:50:48 <zhifeng> The command is  like "wget http://some.server.com/file --limit-rate=20k"
14:51:10 <fdegir> uli-k_: it is already like that if I
14:51:13 <fdegir> m not mistaken
14:51:23 <fdegir> slave connection goes to LF
14:51:28 <fdegir> download goes to google
14:51:38 <uli-k_> But both are in US
14:52:05 <fdegir> if you say so
14:52:47 <uli-k_> Does CMCC also have a idea for solution already?
14:53:58 <uli-k_> Looks like we don't know.
14:54:06 <May-meimei1> I think chinese users have lots network problem , not just bandwide
14:54:58 <uli-k> OK. Let's move on.
14:55:06 <uli-k> Anything for AoB?
14:55:42 <uli-k> Anything for releng? - fdegir, we took too long again...
14:55:50 <fdegir> releng is fine
14:56:30 <uli-k> OK.
14:56:49 <kaipule> I want to ask a question about releng
14:57:04 <fdegir> kaipule: go ahead
14:57:12 <uli-k> let's continue to discuss the connection issue on #opnfv-octopus whenever necessary.
14:57:19 <uli-k> #chair fdegir
14:57:19 <collabot> Current chairs: fdegir uli-k
14:57:33 <uli-k> #chair May-meimei1
14:57:33 <collabot> Current chairs: May-meimei1 fdegir uli-k
14:58:09 <kaipule> how to del with escala 's documention about releng
14:58:51 <fdegir> kaipule: aricg already pushed common doc generation to all project repos
14:58:58 <fdegir> and it is available for escalator as well
14:59:00 <fdegir> https://gerrit.opnfv.org/gerrit/gitweb?p=escalator.git;a=tree;f=docs;h=5c6b48a619260b23220eebe730b08e19f81299dc;hb=HEAD
14:59:29 <fdegir> please take a look at how-to-use-docs there
14:59:57 <kaipule> fdegir :OK,thank you
15:00:02 <fdegir> np
15:00:24 <uli-k> Anything else?
15:00:40 <uli-k> We have to close, so Genesis can start.....
15:01:02 <uli-k> Just move to #opnfv-octopus if there are questions
15:01:08 <uli-k> #endmeeting