#opnfv-meeting: OPNFV B Release CI Planning Pharos Test and Perf

Meeting started by iben at 15:04:45 UTC (full logs).

Meeting summary

    1. Jonas Bjurel ([1]JonasB, 15:04:57)
    2. Morgan Richomme (morgan_orange, 15:04:58)
    3. Ana Cunha (anac1, 15:04:59)
    4. Fatih Degirmenci (fdegir, 15:05:04)
    5. Iben Rodriguez (iben, 15:05:12)
    6. agenda https://wiki.opnfv.org/meetings/test (morgan_orange, 15:06:19)
    7. Stefan Berg (s_berg, 15:06:20)
    8. trevor_intel (Pharos) (trevor_intel, 15:06:58)

  1. Logistics and Weekly Agenda: https://wiki.opnfv.org/meetings/test (iben, 15:06:58)
    1. Bin Hu (IPv6) (bin_, 15:07:06)
    2. Narinder Gupta (narindergupta, 15:07:10)
    3. discussion on possible combinations for B-Release (morgan_orange, 15:07:28)

  2. CI needs to know which configuration to run and which tests to execute (iben, 15:08:01)
    1. Need common configuration files for build, deploy, pod, test setup, test execution, test data collection (iben, 15:08:50)
    2. list of projects that declared testcases: (morgan_orange, 15:10:25)
    3. http://213.77.62.197/test_projects (morgan_orange, 15:10:27)
    4. 88 testcases have been declared (morgan_orange, 15:11:37)
    5. This is the page propose for keeping track of combinations (fdegir, 15:13:06)
    6. https://etherpad.opnfv.org/p/brahmaputra_release_testing (fdegir, 15:13:08)
    7. https://wiki.opnfv.org/brahmaputra_testing_page (morgan_orange, 15:32:29)
    8. https://wiki.opnfv.org/genesis/configuration-files-discussion (frankbrockners, 15:34:21)
    9. https://git.opnfv.org/cgit/yardstick/tree/etc/yardstick/nodes/pod.yaml.sample (anac1, 15:35:08)
    10. https://wiki.opnfv.org/brahmaputra_testing_page (morgan_orange, 15:37:33)
    11. but we were not able to run against all the labs (morgan_orange, 15:46:10)
    12. first run functest & yardstick with all the installers (on the 4 identified labs) then integrate feature projects tests, generalize test framework in any lab (morgan_orange, 15:47:47)
    13. all pods listed on Morgan's page must be connected to Jenkins (fdegir, 15:53:52)
    14. all installers must come to jenkins and then automatic installations must be enabled (fdegir, 15:53:58)
    15. once the automatic installations work fine, testing must be enabled (fdegir, 15:54:18)
    16. ACTION: morgan_orange create a matrix: installer feature supported, possible to deploy through jenkins (morgan_orange, 15:58:45)
    17. add information on what can be deployed today (morgan_orange, 15:58:58)
    18. what is possible, on which lab is it possible (morgan_orange, 15:59:17)
    19. needs synchro meetings on this topic => reuse existing meetings release meeting (Tuesday) test (Thursday) (morgan_orange, 16:06:16)


Meeting ended at 16:07:03 UTC (full logs).

Action items

  1. morgan_orange create a matrix: installer feature supported, possible to deploy through jenkins


Action items, by person

  1. morgan_orange
    1. morgan_orange create a matrix: installer feature supported, possible to deploy through jenkins


People present (lines said)

  1. fdegir (35)
  2. iben (22)
  3. morgan_orange (21)
  4. trevor_intel (7)
  5. [1]JonasB (4)
  6. collabot (4)
  7. iben_ (4)
  8. narindergupta (3)
  9. trozet (3)
  10. s_berg (2)
  11. anac1 (2)
  12. frankbrockners (1)
  13. bin_ (1)


Generated by MeetBot 0.1.4.