16:01:56 <debrascott> #startmeeting Brahmaputra Release
16:01:56 <collabot`> Meeting started Tue Dec 22 16:01:56 2015 UTC.  The chair is debrascott. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:56 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
16:01:56 <collabot`> The meeting name has been set to 'brahmaputra_release'
16:03:15 <debrascott> #info agenda today is to continue CI pipeline and lab resources for development discussion
16:04:01 <ashyoung> #info Ashlee Young (onosfw)
16:04:10 <ChrisPriceAB> #info Chris Price (opnfvdocs)
16:04:26 <frankbrockners> #info Frank Brockners (genesis)
16:04:27 <StuartMackie> #info Stuart Mackie - OpenContrail
16:04:34 <uli-k_> #info #info Uli (octopus)
16:04:40 <mdgray> #info Mark Gray (ovsnfv)
16:05:02 <anac1_> #info Ana Cunha (Yardstick)
16:06:25 <debrascott> #info Branch prerequisite is to have environment that would support test & dev, 8 pods ideally but minimum 5 pods
16:07:26 <ljlamers> #info Larry Lamers
16:08:04 <debrascott> #plan B proposal reduce test scope (what we do on master branch) after branching
16:08:39 <debrascott> #info plan B proposal reduce test scope (what we do on master branch) after branching
16:09:21 <fdegir> it is not reducing the test scope
16:09:28 <fdegir> we do not reduce the test scope
16:09:39 <fdegir> we do not run as much verification activities against master
16:10:03 <debrascott> #info impact reducing verification activities based on resources = stable is less stable, less
16:10:05 <fdegir> so the test scope is same but we won't run the testing against master  perhaps
16:10:54 <anac1_> fdegir: platform testing on stable primarily?
16:11:03 <fdegir> the proposal suggests to use all the available PODs for stable branch
16:11:15 <fdegir> and do limited verification against master, either build, virtual deployment and so on
16:11:29 <fdegir> once more resources become available, use these PODs against master branch
16:11:38 <fdegir> anac1_: that's right
16:12:10 <debrascott> #info other option is to not branch which creates significant risk of breaking release so not desired
16:13:28 <debrascott> #info concept is to do as much verification on master as possible, depending on lab resources, if more resources become available then increase verification
16:14:20 <debrascott> #info it is critical that we know what scenarios to run; need projects to submit scenarios they want to see
16:15:27 <debrascott> #info by scenario we mean deployed set of components in a certain configurations (hardware, installer, os, etc)
16:17:14 <debrascott> #info need this scenario information from every feature project that intends to be part of the CI/CD test pipeline
16:18:14 <ashyoung> Where do we convey these scenarios?
16:18:29 <ashyoung> I apparently have no voice capability
16:18:59 <ChrisPriceAB> #link https://wiki.opnfv.org/brahmaputra_testing_page#test_scenarios_for_brahmaputra deployment scenario list
16:19:02 <ashyoung> Can you type in the link to the wiki?
16:19:06 <ashyoung> Thanks!
16:19:42 <ashyoung> Do we just put our info into that matrix?
16:20:02 <frankbrockners> yes - with owners please :-)
16:20:26 <mdgray> OVSNFV will update the wiki in the next day or two
16:20:37 <frankbrockners> mdgray - many thanks
16:20:55 <debrascott> #Action: resend communication to all project leads to add scenarios for their projects to the link above
16:21:05 <ashyoung> Got it. Will include an owner
16:21:06 <mdgray> Sorry about the delay .. We had other problems up until now but I think we can answer this now
16:21:11 <ashyoung> Thanks!
16:21:34 <billyoma> Hi Chris Billy here from OVSNFV. My audio is very poor. But we are aware of the need for us to start our CI tasks asap.
16:23:03 <debrascott> #info which projects have not deployed on Pharos yet? which can use Jenkins now to deploy?
16:24:08 <mdgray> #info OVSNFV can deploy on Pharos. However there are some issues. We aren't using Jenkins yet.
16:24:31 <debrascott> #action on test scenario page add a status for each project on deploying with Pharos in which scenarios
16:25:16 <debrascott> #info need visibility on status of test case coding
16:26:25 <debrascott> #info many of the test cases in the repo are skeleton frameworks without details, especially difficult for those that are not in Jenkins
16:28:23 <ashyoung> Can you type in the link to the Jenkins jobs here too?
16:28:34 <ChrisPriceAB> #info looks like we should be targetting Jenkins integration for projects by Milestone D (c+release) for tracking leading up to code freeze.
16:28:47 <debrascott> #info projects need to create put scripts into a CI folder in Jenkins job
16:29:03 <fdegir> this link is very early version of the jenkins dashboard for brahmaputra
16:29:06 <fdegir> #link https://build.opnfv.org/ci/view/Brahmaputra%20CI/
16:29:30 <ashyoung> Thanks!
16:33:38 <ashyoung> Is there a specific format for that CI folder?
16:33:55 <fdegir> #info In order for projects to run specific Jenkins jobs for the project, they must create what script they want to execute via Jenkins in their repo under ci folder
16:34:06 <fdegir> ashyoung: no format
16:34:15 <fdegir> just a folder named ci so we know where to look
16:34:16 <ashyoung> At the top level or root?
16:34:20 <ashyoung> Okay
16:34:22 <fdegir> repo root
16:34:22 <ashyoung> Thanks!
16:34:25 <fdegir> np
16:34:43 <ashyoung> Can the script be in bash?
16:35:00 <ibenrodriguez> #info Iben Rodriguez
16:35:09 <fdegir> ashyoung: any language
16:35:16 <fdegir> we just need to know what dependencies you have
16:35:25 <fdegir> so we install them on the jenkins slave
16:35:49 <ashyoung> Is this to test build, or deployment?
16:35:59 <ashyoung> Or both?
16:36:38 <fdegir> ashyoung: if you want to run virtual stuff
16:36:48 <fdegir> then it can be for deployment as well
16:36:53 <debrascott> #info Jack Morgan at Intel is contact for jump host issues, time for having the labs up and running is unknown at this time. Was supposed to be ready last week
16:36:59 <fdegir> but if your stuff gets integrated into any installer
16:37:09 <fdegir> then you sort that part together with the installer teams
16:37:16 <ashyoung> Okay
16:37:19 <fdegir> they need to do adjustments on their side
16:37:57 <ashyoung> I think I have a good idea for what we need to do here
16:38:05 <fdegir> #info One the projects create scripts in <project_repo_root>/ci folder, corresponding jenkins jobs will be created or updated if already exist
16:39:22 <ashyoung> We are still struggling with Joid installer work-- big time.
16:39:30 <ashyoung> But other installers are looking pretty decent
16:39:48 <fdegir> #link http://lists.opnfv.org/pipermail/opnfv-tech-discuss/2015-December/006893.html
16:40:02 <frankbrockners> https://git.opnfv.org/cgit/?s=idle
16:40:05 <fdegir> ashyoung: you can take a look at above link for why the ci stuff is set this way
16:40:35 <ashyoung> Just pulled it up
16:40:54 <mdgray> OVSNFV have being working on another temporary repo
16:41:19 <ashyoung> frankbrockners: Some of us have been working on the installers, which is why we've been idle on repo checking
16:42:21 <debrascott> #Action why is everything idle on projects repo for 2 weeks? Are they working in private repo or doing other work? Debra to check on status
16:42:24 <ibenrodriguez> ashyoung: what issues with JOID are you having?  where can we see the list?
16:43:40 <ashyoung> ibenrodriguez: I have a list of items and will share. Do I just use the JOID tag on the OPNFV tech discuss list?
16:45:42 <anac1_> Yardstick work for Apex and Joid is on-going
16:45:55 <fdegir> #info The status for installers on CI
16:46:16 <fdegir> #info Apex virtual deploys work fine on Jenkins, bare metal work is ongoing
16:46:37 <ashyoung> ibenrodriguez: I am not sure what issues have actually been shared already with JOID team. I just got a list over the weekend from that developer. The others have communicated broadly with relevant installer tag.
16:46:49 <fdegir> #info Compass bare metal deploys work on Jenkins and some functest execution done manually against it
16:47:04 <fdegir> #info Fuel bare metal and virtual deploys work on Jenkins, functest and yardstick work
16:47:50 <fdegir> #info Joid bare metal work on Jenkins but due to lack of jumphost on Intel POD5, only 3 controllers and 1 compute deployed, functest runs as well but fails
16:48:06 <ibenrodriguez> anac1_: can we expect to see jenkins jobs here for apex and JOID soon? https://build.opnfv.org/ci/view/yardstick/
16:48:15 <fdegir> #link https://build.opnfv.org/ci/view/Brahmaputra%20CI/job/fuel-nosdn-opnfv-jump-2-daily-master/
16:48:25 <fdegir> #link https://build.opnfv.org/ci/view/Brahmaputra%20CI/job/joid-odl-intel-pod5-daily-master/
16:48:30 <ashyoung> Thanks for that added clarification Frank!
16:48:42 <fdegir> #link https://build.opnfv.org/ci/view/Brahmaputra%20CI/job/apex-daily-master/
16:48:44 <anac1_> ibenrodriguez: yes, on-going
16:48:52 <fdegir> #link https://build.opnfv.org/ci/view/Brahmaputra%20CI/job/compass-daily-master/
16:49:43 <ibenrodriguez> ashyoung: you mean I can see the JOID issues by seaching email? what project is having trouble integrating with JOID?
16:50:47 <ashyoung> ibenrodriguez: No. Not your email :) They were internal emails to me. I am still not certain what has already been conveyed to the JOID team. So, I will re-post these onto the opnfv Mail list
16:51:42 <ibenrodriguez> ashyoung - err - I thought I was part of the JOID team - I guess not now then.  Hum.  What to do?  Thanks for helping communicate this.
16:51:56 <ashyoung> ibenrodriguez: not what I'm saying
16:52:10 <debrascott> #info Frank reiterates that projects will not be excluded simply because they “miss” having something finished in the milestone E report. Milestone E is primarily reporting. We are trying to include everyone as best we can in the release. Milestone E gives us a chance to see where there are gaps and to know what must be documented. Exlusion from the release would be based on having critical issues such as can’t build
16:52:11 <debrascott> with the project included, or basic Arno scenarios break with project included. In most cases this would be self gating.
16:52:36 <ashyoung> ibenrodriguez: I don't know if I have a shy developer. That's what I have been trying to determine and overcome.
16:52:48 <debrascott> #topic Documentation
16:53:05 <debrascott> #info focusing on central docs right now
16:53:24 <debrascott> #info patches are being pushed for templates now
16:53:39 <ashyoung> ibenrodriguez: But I'm glad I now know someone on the team :) I want to make sure we support 100% of the installers.
16:53:42 <debrascott> #info documentaition processes are updated on the wiki
16:53:59 <ChrisPriceAB> #link https://wiki.opnfv.org/documentation documentation overview
16:54:20 <ChrisPriceAB> #link https://wiki.opnfv.org/documentation/configguide configuration guide instructions
16:56:25 <ChrisPriceAB> #info need to finalize the scenarioäs in order to close the document structures fully.
17:02:37 <debrascott> #action IRC standup reporting to begin after Milestone E
17:04:10 <debrascott> #endmeeting