15:00:29 <ChrisPriceAB> #startmeeting OPNFV TSC
15:00:29 <collabot> Meeting started Tue Jan 26 15:00:29 2016 UTC.  The chair is ChrisPriceAB. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:29 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:00:29 <collabot> The meeting name has been set to 'opnfv_tsc'
15:00:32 <ChrisPriceAB> #topic roll call
15:00:36 <dku> #info Dirk Kutscher
15:00:39 <ChrisPriceAB> #info Chris Price
15:00:46 <frankbrockners> #info Frank Brockners
15:00:50 <bin_> #info Bin Hu
15:01:06 <Julien-zte> #info Julien
15:01:07 <ttallgren> #info Tapio Tallgren
15:01:16 <edgarstp> #info Edgar StPierre
15:01:17 <uli-k_> #info Uli Kleber
15:01:44 <ChrisPriceAB> #chair rpaik
15:01:44 <collabot> Current chairs: ChrisPriceAB rpaik
15:01:50 <ChrisPriceAB> #chair uli-k_
15:01:50 <collabot> Current chairs: ChrisPriceAB rpaik uli-k_
15:02:03 <ChrisPriceAB> #chair GeraldK
15:02:03 <collabot> Current chairs: ChrisPriceAB GeraldK rpaik uli-k_
15:02:03 <GeraldK> #info Gerald Kunzmann
15:02:11 <Parviz> #info Parviz Yegani
15:02:21 <ChrisPriceAB> #topic approval of previous minutes of meeting
15:02:23 <morgan_orange> #info Morgan Richomme
15:02:31 <ChrisPriceAB> #info no comments received, previous minutes approved
15:02:39 <ChrisPriceAB> #topic Agenda Bashing
15:02:51 <ChrisPriceAB> #link https://wiki.opnfv.org/wiki/tsc current agenda
15:04:14 <ChrisPriceAB> #info postponing the policy document update as Brian is not able to join the call.
15:04:32 <ChrisPriceAB> #topic Brahmaputra status update
15:04:40 <rpaik> we now have a quorum
15:05:00 <ChrisPriceAB> thanks ray
15:05:36 <ChrisPriceAB> #info Currently we have 24 scenario's planned.  Of those we have 15 scenario's installing successfully
15:06:09 <ChrisPriceAB> #info some scenario's have not yet been deployed, some are pending solutions to known issues.
15:06:45 <ChrisPriceAB> #info it may be necessary to delay the release to include the pending functionality.
15:07:56 <trevor_intel> #info Trevor Cooper
15:08:41 <ChrisPriceAB> #info Of the test projects, YardStick has some pending issues, functest also has some pending issues.
15:09:13 <ChrisPriceAB> #info GeraldK asks about other pending issues including vPing.
15:10:48 <ChrisPriceAB> #info morgan_orange provides an update that functest is working on some scenario's although work is ongoing to stabilise functest for all scenario's
15:11:56 <ChrisPriceAB> #info vIMS is not possible unless it is proven that vPing works on the deployment.  Some progress is being made on vIMS to secure it's stability.
15:12:11 <dneary> #info Dave Neary
15:12:53 <ChrisPriceAB> #info morgan adds that we do not yet have a scenario that is able to be run according to the release requirement of four successful runs.
15:13:43 <ChrisPriceAB> #info Compass provides the closest set of scenario's that approach release readiness.
15:14:09 <ChrisPriceAB> #info rnugent asks what level of confidence there is that three weeks will provide the needed stabilisy.
15:14:14 <ChrisPriceAB> with a t
15:14:31 <morgan_orange> I would not say that Functest was unstable...
15:14:44 <ChrisPriceAB> #info debra responds that a three week delay would make her 80% confident that we would make the release.
15:15:03 <anac1> yardstick wasn't running on ODL
15:15:32 <ChrisPriceAB> #info GeraldK adds that we are currently three weeks late on meeting milestone E requirements and that a three week delay would help bring stability.
15:16:08 <ChrisPriceAB> #info uli-k_ adds that we should look to reducing content for Brahmaputra to achieve our dates.
15:16:47 <morgan_orange> we were already 3 weeks late on Milestone D if we consider that the CI Labs should have been ready beginning of December
15:17:13 <morgan_orange> we are still lacking a second POD for Apex
15:17:56 <anac1> we don't have one scenario succesfully tested  4 consecutive times
15:18:27 <ChrisPriceAB> #info The teams report that we do not have a release candidate today that fulfills our release requirements.
15:18:48 <fdegir> it takes 4 to 6 hours for a scenario to be deployed/tested depending on installer/scenario
15:19:47 <rpaik> #info we also do not have code freeze on many cases
15:20:09 <GeraldK> reducing content for Brahmaputra can be an additional measure to achieve release readiness, but this will not compensate for the delay that has already piled up and given no scenario is meeting the release requirements
15:21:54 <ChrisPriceAB> I agree GeraldK, if we choose to set our target date later in February there should be a strict freeze on features and reduction based on results.
15:22:43 <ildikov> GeraldK: +1
15:22:52 <rpaik> #info morgan_orange adds that there was also delay in testing projects for some of the milestone D items
15:25:02 <GeraldK> #info ChrisPriceAB is asking testing teams about their view/confidence towards stability given a 3 weeks delay for Brahmaputra
15:26:19 <GeraldK> #info morgan_orange: vIMS is a bit more complex; we still get surprises every day; for internal test cases they are quite confident
15:27:42 <GeraldK> #info morgan_orange: we should REALLY freeze end of this week
15:27:54 <fdegir> code freeze and start release verification on stable/brahmaputra
15:29:28 <morgan_orange> #info rpaik just to mention that CI labs were supposed to be ready beginning of January to perform the first tests, they were only available beginning of January
15:29:42 <GeraldK> #info uli-k: we need to make sure that everybody understands what code freeze means and what is still allowed after the code freeze
15:33:30 <ChrisPriceAB> #info GeraldK states that we need to have clear activities, plans and targets in place for the time between now and a target release date.
15:34:14 <ChrisPriceAB> #info ffrankbrockners outlines this would involve knowing the steps clearly, and having concise plans in place.  The challenge frank outlines is that we may not know enough to establish accurate milestones.
15:34:32 <uli-k_> #link https://wiki.opnfv.org/releases/stablebranch stable branch policy -  the rules for our code freeze
15:35:10 <ChrisPriceAB> #info frankbrockners states another approach would be to work toward a target of scenario's and base the release date on achieving those targets
15:39:22 <rpaik> #info GeraldK suggests still defining gate/schedule even if we take a “content-based” approach
15:40:12 <rpaik> #info dneary suggests reducing scenarios to avoid scope creep
15:49:54 <rpaik> #info frankbrockners discussed creating a schedule (need reasonable milestones) with a new target release date
15:51:44 <rpaik> #info community learned in the past few weeks that testing required more time than anticipated
15:52:35 <GeraldK> do we want to vote on code freeze end of this week?
15:53:10 <rpaik> #info uli-k suggests setting up a separate meeting this week to discuss the new schedule
15:55:44 <trevor_intel1> #info Trevor Cooper voting for Brian Skerry
15:55:57 <ChrisPriceAB> #startvote Does the TSC agree that it is necessary to move the target release out from February 2nd? (-1, 0, +1)
15:55:57 <collabot> Begin voting on: Does the TSC agree that it is necessary to move the target release out from February 2nd? Valid vote options are , -1, 0, +1, .
15:55:57 <collabot> Vote using '#vote OPTION'. Only your last vote counts.
15:56:11 <dneary> #vote +1
15:56:12 <GeraldK> #vote +1
15:56:13 <dku> #vote +1
15:56:14 <ChrisPriceAB> #vote +1
15:56:14 <edgarstp> #vote 0
15:56:15 <tnadeau_> #vote +1
15:56:16 <uli-k_> #vote +1
15:56:16 <frankbrockners> #vote +1
15:56:16 <trevor_intel1> #vote +1
15:56:17 <ttallgren> #vote +1
15:56:19 <Julien-zte> #vote +1
15:56:21 <rpaik> #vote +1
15:56:30 <ChrisPriceAB> #endvote
15:56:30 <collabot> Voted on "Does the TSC agree that it is necessary to move the target release out from February 2nd?" Results are
15:56:30 <collabot> 0 (1): edgarstp
15:56:30 <collabot> +1 (11): dneary, Julien-zte, dku, GeraldK, uli-k_, ChrisPriceAB, ttallgren, tnadeau_, frankbrockners, trevor_intel1, rpaik
15:56:31 <rpaik> #info proxy for Parviz
15:57:01 <ChrisPriceAB> #info Chinese new year is on February 8th with vacation from our Chinese participants.
15:58:00 <uli-k_> #link https://wiki.opnfv.org/releases/stablebranch stable branch policy -  the rules for our code freeze
15:58:58 <rpaik> code freeze: deployments need to be running for the scenarios
15:59:05 <ChrisPriceAB> #startvote Does the TSC agree to code freeze by the end of this week? (-1, 0 +1)
15:59:05 <collabot> Begin voting on: Does the TSC agree to code freeze by the end of this week? Valid vote options are , -1, 0, +1, .
15:59:05 <collabot> Vote using '#vote OPTION'. Only your last vote counts.
15:59:11 <uli-k_> #vote +1
15:59:37 <tnadeau_> we need a clear definition of "code freeze"
15:59:47 <tnadeau_> what level of patches are allowed - be specific please
15:59:50 <dneary> tnadeau_, Also, a process for freeze exceptions
16:00:02 <ChrisPriceAB> #endvote
16:00:02 <collabot> Voted on "Does the TSC agree to code freeze by the end of this week?" Results are
16:00:02 <collabot> +1 (1): uli-k_
16:00:17 <ChrisPriceAB> #info cancelling vote due to lack of clarity on the meaning of code freeze.
16:00:19 <ttallgren> #vote +1
16:01:27 <ChrisPriceAB> #action chrispriceab to send a definition of code freeze for review and eventual voting on the mailiing lists.
16:01:28 <tnadeau_> +1 voting on mailing list
16:01:31 <tnadeau_> good idea
16:02:06 <ChrisPriceAB> #endmeeting