15:00:03 <ChrisPriceAB> #startmeeting OPNFV TSC
15:00:03 <collabot`> Meeting started Tue Feb 23 15:00:03 2016 UTC.  The chair is ChrisPriceAB. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:03 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:00:03 <collabot`> The meeting name has been set to 'opnfv_tsc'
15:00:12 <ChrisPriceAB> #topic Roll Call
15:00:19 <ChrisPriceAB> #info Chris Price
15:00:37 <ChrisPriceAB> #chair rpaik
15:00:37 <collabot`> Current chairs: ChrisPriceAB rpaik
15:00:39 <dku> #info Dirk Kutscher
15:00:59 <JuhaOravainen> #info Juha Oravainen (proxy for Tapio Tallgren)
15:01:21 <morgan_orange> #info Morgan Richomme (IRC)
15:01:29 <uli-k_> #info Uli
15:01:48 <Parviz> #info Parviz Yegani
15:01:48 <bjskerry> #info Brian Skerry
15:02:18 <narindergupta> #info Narinder Gupta
15:02:42 <ChrisPriceAB> #topic Approval of previous minutes of meeting
15:02:48 <ChrisPriceAB> #link https://wiki.opnfv.org/wiki/tsc#february_16_2016 previous TSC minutes
15:03:08 <ChrisPriceAB> #info no feedback was received minutes approved.
15:03:18 <ChrisPriceAB> #topic Agenda Bashing
15:03:18 <GeraldK> #info Gerald Kunzmann
15:03:19 <bryan_att> #info bryan sullivan
15:03:29 <frankbrockners> #info Frank Brockners
15:03:39 <ChrisPriceAB> #link https://wiki.opnfv.org/wiki/tsc#february_23_2016 current agenda for today
15:03:45 <rpaik> we now have a quorum
15:05:11 <ChrisPriceAB> #info rpaik raises the need to discuss release artifacts and release pages
15:05:26 <ChrisPriceAB> #info geraldk would like to discus projects that did not make the release.
15:06:13 <ChrisPriceAB> #info these topics will be captured in the Brahmaputra discussion
15:06:21 <Julien-zte> #info Julien
15:06:24 <ChrisPriceAB> #topic Brahmaputra release update
15:06:40 <debrascott> #link https://wiki.opnfv.org/releases/brahmaputra/daily_status
15:07:09 <ChrisPriceAB> #info the following scenario's are ready for release:   apex/odl_l2 - compass/odl_l2 - compass/onos - compass-nosdn - fuel/nosdn - fuel/old_l2 - fuel/onos
15:08:15 <ChrisPriceAB> #info projects that do not yet have a stable scenario include:  NFVOVS, KVM4NFV, SFC, BGP-VPN, Doctor
15:08:15 <ebrjohn> #info ebrjohn Brady Johnson, SFC
15:08:46 <[1]JonasB> #info Jonas Bjurel
15:09:24 <ChrisPriceAB> #info Joid deploy has achieved stability for odl_l2 and nosdn
15:09:40 <ChrisPriceAB> #info stability runs are ongoing in preparation for release on Thursday
15:09:49 <dneary> #info dneary
15:10:10 <ghall> #info ghall ( proxy Tom Nadeau )
15:10:34 <trevor_intel_> #info trevor_intel
15:12:14 <ChrisPriceAB> #info Doctor is being deployed on apex/odl_l2
15:12:33 <ChrisPriceAB> #info as of et there have not been 4 successful runs verifying the doctor functionality.
15:22:39 <rpaik> #info discussion that scenarios like Apex/ONOS and Apex/ODL-L3 are deploying successfully but have known limitations
15:24:28 <rpaik> #info concensus that these scenarios could be released with issues documented
15:24:53 <ChrisPriceAB> oops lost audio back soon
15:30:32 <ChrisPriceAB> #link http://artifacts.opnfv.org/opnfvdocs/review/10487/configguide/configoptions.html#opnfv-scenario-s scenario matrix patch
15:43:19 <jose_lausuch> for functest, the sunshine means +4 successful runs, the "few-clouds" icon means 0<X<4., the "clouds" mean that there are problems but it runs... the storm icon means it has never worked
15:46:02 <GeraldK> chrispriceAB: maybe share it first without #agree so that we can see you proposal
15:46:38 <ChrisPriceAB> #agree the TSC agree that scenario's which have known limitations can be released with the limitations documented for Thursday.  The scenario's need to be stable and reproducable.
15:46:45 <ChrisPriceAB> can undo it
15:53:39 <ChrisPriceAB> #action ChrisPriceAB and opnfvdocs team to work with the deploy and test teams to clarify and fully document the state of each scenario according to the above agreement.
15:59:10 <ChrisPriceAB> #action debra, aricg and the octopus team to ensure the release tagging process is well understood for the project leads.  Tagging must be done by Wednesday for all projects.
15:59:53 <ChrisPriceAB> #topic Brahmaputra release and artifact handling
15:59:53 <[1]JonasB> For tagging process, see https://wiki.opnfv.org/octopus/releasepipeline
16:00:06 <rpaik> #link https://www.opnfv.org/software/download current software downloads page
16:00:13 <ChrisPriceAB> #info updates will be made to the software downloads page
16:00:21 <debrascott> If you are joining for Brahmaputra Release Meeting: please join the extended TSC meeting https://global.gotomeeting.com/join/798898261
16:00:35 <debrascott> [1]JonasB: thank you!
16:01:24 <ChrisPriceAB> #info on the main dowwnloads page there will be links to each deploy tool
16:01:42 <ChrisPriceAB> #info the link will take users to the download page including documentations for each deploy tool.
16:01:51 <rpaik> #link https://wiki.opnfv.org/releases/brahmaputra/releasedocs docs wiki
16:02:35 <ChrisPriceAB> #info the main downloads page will also contain direct links the composite docs and a link to the release documentation page which will contain all project documentation.
16:04:02 <ChrisPriceAB> #topic AoB Brahmaputra
16:04:39 <ChrisPriceAB> #info Heather asks what terminology we would want to use for our release iterations.
16:05:49 <ChrisPriceAB> #info frankbrockers indicates "release additions" would be a good convention
16:12:36 <RayNugent_> #info Feature Release?
16:12:50 <ChrisPriceAB> #topic C Release planning and discussion.
16:15:51 <rpaik> #action rpaik to start a mailing list coversation on the C-release naming
16:16:48 <fdegir> listed some points on etherpad - some are pretty obvious
16:16:49 <fdegir> https://etherpad.opnfv.org/p/c-release-brainstorming
16:17:13 <ChrisPriceAB> #link https://etherpad.opnfv.org/p/c-release-brainstorming c release brainstorming etherpad
16:17:22 <DanSmithEricsson> im confused about how we will be doing the double track (for the installer support point of view) for SR1 (with the phased release approach for  B) and start with C release?
16:17:47 <DanSmithEricsson> there seems to me to be alot of planning tasks that we are going ahead with wihtout necessarily planning time for our current (b-release)
16:20:32 <Julien-zte> #info agree with Daniel, I suggest to reduce the test cases which cost too much resources including CI hardware resources
16:20:37 <rpaik> #info debrascott notes back-end resource issues (e.g. for testing, documentation, CI, etc.)
16:22:58 <Julien-zte> #info currently there are 23 scenarios, but only fewer can be released in B
16:27:33 <DanSmithEricsson> With this approach - then we give up homogeny across all installers?
16:32:06 <ChrisPriceAB> blessed silence.  I unfirtunately can't unmute myself
16:32:26 <ChrisPriceAB> #info dan outlines that pharos and reosurce management is a key area to improve for C-Release
16:32:51 <rpaik> #info discussion on resource issues for Pharos, install teams, etc.
16:34:37 <ChrisPriceAB> #info Debra identifies that we need to identify how many new projects will be involved and what impact this will have on integration, test & infra
16:36:30 <Julien-zte> #info Debra suggest trade-off between scope and more resources. the challenge is that there are several types of installers which will cost each project team more resources to be integrated
16:39:50 <[1]JonasB> Is the hacfest really the right place for the retrospect?
16:39:53 <[1]JonasB> https://etherpad.opnfv.org/p/Q1'2016_Hackfest
16:40:08 <RayNugent_> #info +1 on Dan's idea that we identify content early on so we can do reasonable resource mapping and communicate to installers and test what the workload will be.
16:40:20 <[1]JonasB> At most 10 developers out of the 180 in the comunity will be there
16:41:54 <rpaik> #info radez adds that shifting requirements late in the Brahmaputra release cycle was also a challenge
16:42:01 <DanSmithEricsson> i really think Dan Radez said it best
16:42:29 <DanSmithEricsson> we need to have (since we are in an environment of co-optition) a better understanding from project at the start of what the common goal of the OPNFV release XYZ is
16:42:39 <radez> #info inparticular, scheduling a requirements freeze of some sort early on in the release cycle
16:43:21 <DanSmithEricsson> or if we change our release process, then we need to see some common "cadance" guidelines where by each "year" our common goals are things that projects (things = areas) that installers / projects go towards.
16:45:07 <rpaik> #info dneary agrees with DanSmithEricsson that the community is setup to provide adequate support
16:45:36 <ildikov> In my opinion we also need to clearly clarify what applies to features and what for scenarios regarding milestones
16:46:23 <debrascott> completely agrees with support concerns. This is another area of our processes that I’ve been concerned about for some time. It is another area of “the runway” that needs to be built out
16:46:29 <ildikov> and what we mean by agreeing on content? Either of them or both?
16:50:07 <dneary> rpaik, Correction: I agree that we are *not* set up to provide support and new development in parallel
16:50:40 <rpaik> dneary good catch (and important detail :-))
16:51:57 <dneary> rpaik, :-)
16:52:03 <dneary> #undo
16:52:35 <dneary> #info dneary agrees with DanSmithEricsson that the community is not set up to provide adequate support across multiple versions of upstream projects
16:52:39 <dneary> #info dneary agrees with DanSmithEricsson that the community is not set up to provide adequate support across multiple versions of upstream projects
16:52:53 <dneary> I don't think I'm a chair...
16:54:01 <DanSmithEricsson> +1 Uli
16:54:27 <[1]JonasB> Ulik: +1
16:54:31 <DanSmithEricsson> i think it should be more of a team effort.
16:54:46 <ildikov> uli-k: +1
16:54:49 <DanSmithEricsson> however, i think that we need to say there needs to be a seperate approach - he installers need time to release and make their features
16:55:41 <RayNugent_> +1 Bryan Sullivan we should look at making installer integration easier.
17:01:12 * bryan_att sorry had to drop
17:01:21 <Julien-zte> #info +1 with ildikov for reference platform
17:02:03 <bryan_att> I'd be happy to join in a discussion about how to simplify feature integration into installers.
17:02:04 <ashyoung_> I don't think the installers are the issue
17:02:36 <[1]JonasB> ashyoung_: +1
17:02:39 <ashyoung_> The installer guys went out of their way to help ONOSFW
17:02:42 <ChrisPriceAB> #endmeeting