13:59:33 <ChrisPriceAB> #startmeeting OPNFV TSC
13:59:33 <collabot`> Meeting started Tue Mar 15 13:59:33 2016 UTC.  The chair is ChrisPriceAB. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:59:33 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
13:59:33 <collabot`> The meeting name has been set to 'opnfv_tsc'
13:59:39 <ChrisPriceAB> #topic roll call
13:59:44 <ChrisPriceAB> #info Chris Price
13:59:46 <uli-k_> #info Uli Kleber
13:59:46 <GeraldK> #info Gerald Kunzmann
14:00:15 <JonasArndt> #info Jonas Arndt
14:00:30 <ChrisPriceAB> working through some local audio issues
14:00:52 <rpaik> can anyone hear us?
14:01:00 <frankbrockners> #info Frank Brockners
14:01:03 <TomNadeau> yes i can hear
14:02:01 <GeraldK> Ray, I cannot hear you
14:02:01 <uli-k_> we still cannot hear.
14:02:22 <GeraldK> can you hear us?
14:02:27 <ChrisPriceAB> no we cannot
14:02:48 <TomNadeau> HackFest folks have audio issues
14:02:55 <bjskerry> #info Brian Skerry
14:04:03 <edgarstp> #info Edgar StPierre
14:04:08 <ttallgren> #info Tapio Tallgren
14:05:01 <rpaik> we have  a quorum
14:05:02 <ChrisPriceAB> #topic Approval of previous minutes
14:05:08 <ChrisPriceAB> #link https://wiki.opnfv.org/wiki/tsc#march_8_2016 previous meeting minutes
14:05:13 <ChrisPriceAB> #info minutes approved
14:05:18 <ChrisPriceAB> #topic Agenda Bashing
14:05:33 <ChrisPriceAB> #link https://wiki.opnfv.org/wiki/tsc#march_15_2016 current agenda
14:05:52 <timirnich> #info Tim Irnich
14:06:55 <ChrisPriceAB> #info chris proposes some agenda shuffling, to do the creation reviews first, followed by the IETF update and then follow the rest of the agenda
14:07:01 <dku> #info Dirk Kutscher
14:07:22 <GeraldK> #info proposal to timebox both project creation reviews
14:07:24 <ChrisPriceAB> #topic Project creation review - OpenSAF
14:07:51 <dneary> Dave Neary is here
14:07:53 <ChrisPriceAB> #link https://wiki.opnfv.org/opensaf opensaf project proposal
14:08:05 <ChrisPriceAB> welcome mister dneary
14:08:13 <uli-k_> welcome!
14:08:27 <dneary> was not on IRC until just now
14:08:36 <bryan_att> #info Bryan Sullivan
14:08:49 <dneary> #info dneary
14:09:02 <Julien-zte> #info Julien
14:09:17 <r-mibu_> #info Ryota Mibu (proxy Dirk)
14:09:30 <ChrisPriceAB> #info Jonas outlines the history of the opensaf project
14:09:43 <ChrisPriceAB> #info has been focused on implementing the SAF specification
14:10:14 <ChrisPriceAB> #info has more recently turned to investingating and implementing requirements for virtual environemtns
14:10:45 <ChrisPriceAB> #info the availability project focus is to help applications achieve 5x9 availbility
14:10:56 <ChrisPriceAB> #undo
14:10:56 <collabot`> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2deead0>
14:11:02 <ChrisPriceAB> #info the opensaf project focus is to help applications achieve 5x9 availbility
14:11:53 <ChrisPriceAB> #info edgar asks if opensaf supports other environments other than carrier/telco communities
14:12:25 <ChrisPriceAB> #info JOnas answers that the focus is on carrier networking, however the project also addresses military applications as well
14:13:00 <ChrisPriceAB> #info edgar assk if opensaf would exclusively address OPNFV environments
14:13:33 <ChrisPriceAB> #info jonas answers that they will continue to support existing users while working with OPNFV for virtual environments
14:14:10 <ChrisPriceAB> #info bryan assk is OpenSAF will exist as a foundation outisde of OPNFV.
14:14:56 <ChrisPriceAB> #info Jonas answers that the upstream foundation will dissolve
14:16:29 <ChrisPriceAB> #info Jonas describes that the license will switch from LGPL to Apache after the April release
14:17:12 <ChrisPriceAB> #info frankbrockners asks how the license will be changed.
14:17:54 <ChrisPriceAB> #info Jonas answered that the OpenSAF foundation is the sole owner of the copywright and has the right o change the license.
14:18:03 <TomNadeau> note that licenses change requires agreement of ALL contributors to the code base
14:20:29 <dneary> This is not a topic for the TSC
14:20:43 <dneary> Frustrating to spend time on this rather than the substantive issue at hand
14:20:53 <TomNadeau> this is something the LF Legal needs to sort out but the rules are the rules around licensing transfer
14:21:13 <TomNadeau> Brian is right: many of us have dealt with this before. its not necessarily clear.
14:21:28 <edgarstp> #info I would think legal concerns need to be addressed by Linux Foundation lawyers and opinion communicated clearly back to us.
14:22:36 <bryan_att> #info A key question is to the governance of the foundation, and whether the agreement of the contributors survives the foundation. We have not had a chance to review the governance.
14:23:28 <bryan_att> #info Chris, we need to also provide our legal opinion so need time for our legal staff to review this as well.
14:23:44 <rpaik> #action rpaik to discuss licensing question with the LF legal team
14:23:50 <edgarstp> It is not appropriate for OPNFV to host code for non-NFV related markets and applications.
14:25:08 <bryan_att> #info The primary concern I have is whether OPNFV is designed to support "owning" platform code rather than integrating it. If the code base remains in some upstream community, then integrating the code in OPNFV is similar to other projects.
14:25:40 <TomNadeau> its a question even if its for OPNFV-related markets and applications
14:25:41 <rpaik> #action dneary to start the discussion on the mailing list on hosting code development project in OPNFV
14:25:48 <bryan_att> #info The thread on the appropriateness has already occurred.
14:25:50 <TomNadeau> lets carry onto the mailing list
14:26:21 <B_Smith_> can we get a link to the thread?
14:26:37 <ChrisPriceAB> #action rpaik to get a statement from the LinuxFoundation legal team on the license issue identified.
14:26:49 <ChrisPriceAB> #info review postponed until next week
14:27:06 <ChrisPriceAB> #topic Project creation review NFV readiness
14:27:21 <ChrisPriceAB> #link https://wiki.opnfv.org/project_proposals/nfvreadyness project proposal
14:27:22 <bryan_att> #info There has been substantial discussion on that point, and even if we did integrate this project in OPNFV the license issue, including provenance of the code prior to relicensing, and the obligations to anyone other than the OpenSAF Foundation, would be key remaining concerns if the code was "owned" by OPNFV.
14:27:44 <ChrisPriceAB> #chair rpaik
14:27:44 <collabot`> Current chairs: ChrisPriceAB rpaik
14:28:19 <ChrisPriceAB> #info Georg outlines the intention of this project is to work with upstream communities to evaluate NFV use cases in the context of cloud networking.
14:28:22 * bryan_att wants the points I raised for the minutes.
14:29:14 <bryan_att> #info We also need copies/links to the OpenSAF governance documents so we can do a proper legal review ("we" meaning AT&T legal staff)
14:29:18 <ChrisPriceAB> #info the project intends to focus on requirements and deployment validation and will perform coding activities in the context of the existing upstream communities.
14:30:04 <ChrisPriceAB> bryan_att can you reach out to rpaik to make sure your legal team is involved in the response
14:30:52 <bryan_att> rpaik: please emsure that our legal team is included in the review and response
14:31:18 <ChrisPriceAB> #info the project will ensure the work of the project fits into the openstack environment.
14:31:41 <GeraldK> w.r.t OpenSAF, an interesting fact that came up during today's call is that if the project becomes part of OPNFV, we would be hosting code that is also used outside NFV context and support for those existing users is expected.
14:31:44 <rpaik> bryan_att, can you send me the names/emails of your legal contacts at ATT?
14:32:00 <ChrisPriceAB> #info the proposal has been on the community review meeting on two occasions with good discussion and feedback.
14:32:24 <ChrisPriceAB> #info dnaery asks if there is any reason the project cannot exist in other projects
14:33:00 <ChrisPriceAB> #info Georg answers that the first phase of the project is on use cases analysis, not focused on existing project scopes.
14:33:40 <ChrisPriceAB> #info Georg also answers that this project may propose new solutions to some use cases that deviates from other projects
14:34:39 <ChrisPriceAB> #info GeraldK asks if the wide scope of the project makes it unclear on what the project might actually do in OPNFV.
14:35:46 <ChrisPriceAB> #info Georg outlines the goal is to look at future needs and opportunities.
14:37:07 <ChrisPriceAB> #info dneary asks where the limits are for the project, for the TSC to approve an understandable scope.
14:37:48 <ChrisPriceAB> #info prakash answers that the projects intends to look at networking requirements in a variety of use cases.
14:38:51 <TomNadeau> if there are future plans that might expand the scope of this "project" lets create a specific project then. I agree with dave neary that we should try to have this absorbed in an existing project
14:40:08 <TomNadeau> a project needs a clear scope and mission, or we're just added overhead for the organization to manage with no identifiable purpose
14:46:52 <Julien-zte> #info dneary do you mean to focus the scope to gap analysis between opnfv and openstack neutron and collect requirements for neutron?
14:47:07 <ChrisPriceAB> #info the TSC feeds back that name change would be helpful to better define the project.
14:47:19 <ChrisPriceAB> #action georg to propose on the TSC mailng list
14:47:27 <dneary> Julien-zte, Yes, that is my proposal
14:48:10 <Julien-zte> #info I miss the final decisions for the network issue.
14:49:06 <ChrisPriceAB> #info dneary requests that the vote be postponed until the name and scope have been discussed further.
14:49:07 <GeraldK> we should keep having project discussions at the END of the TSC meetings as otherwise we have hard time to go through the other important topics. timeboxing did not work so well today.
14:49:23 <ChrisPriceAB> #topic IETF 95 - Hackfest
14:50:01 <ChrisPriceAB> GeraldK the TSC MUST be more involved in the community discussions that occur rather than providing feedback on the creation reviews.
14:50:31 <GeraldK> ChrisPriceAB, I agree to this.
14:50:43 <rpaik> #info Charles Eckel gives an oveview of IETF and their new focus on code via Hackathons
14:50:48 <ChrisPriceAB> #info Charles outlines the mission of the IETF to be more involved with OpenSource communities
14:51:27 <ChrisPriceAB> #info Charles has been running Hack-Fest activities at the IETF to bring developers and standards engineers together
14:51:50 <ChrisPriceAB> #info Charles invites the OPNFV community to join the Hackathon at IETF in Buenes Aires
14:52:15 <ChrisPriceAB> #info the hackathon is free for community members to attend.
14:52:22 <rpaik> #info OPNFV is also sponsoring Bit’sNBites at the upcoming IETF
14:54:44 <B_Smith_> Can we get the links being shown
14:55:01 <GeraldK> #link http://www.ietf.org/hackathon/
14:55:12 <dneary> ChrisPriceAB, Thanks
14:55:45 <ChrisPriceAB> for the action point?  :D
14:56:08 <dneary> For the postponement
14:56:15 <dneary> ChrisPriceAB, In this case, the feedback on the TSC call was given verbatim during the technical review meeting, but the proposal was not revised to take the feedback into account
14:56:44 <dneary> ChrisPriceAB, That's another issue - what action is expected of project proposers based on tech meeting feedback
14:56:54 <ChrisPriceAB> #info in addition there will be hackathons at the IETF in Berlin in July
14:58:20 <ChrisPriceAB> #topic Marketing update - Brandon
14:58:49 <ChrisPriceAB> #info Brandon outlines there is OPNFV content at the ONS that can be found on the web site
14:59:05 <ChrisPriceAB> #info the Plugfest site is now available on the web as well including registration
14:59:30 <ChrisPriceAB> #info CFP for the OPNFV Summit in Berlin is open and urges the community get proposals in for the event.
14:59:48 <rpaik> #link http://www.meetup.com/pro/opnfv/ OPNFV Meetup page
14:59:56 <ChrisPriceAB> #info there was recently an OPNFV meet-up in Shanghai
15:00:18 <ChrisPriceAB> #info an account has been made where OPNFV members can create local meet-up's for their community for OPNFV.
15:00:34 <ChrisPriceAB> #info the meet-up tool is available to all our community members
15:01:19 <rpaik> #info If you have interest or questions in IETF hackathon, contant Charles Eckel eckelcu@cisco.com
15:01:43 <uli-k_> Thanks!
15:01:48 <ChrisPriceAB> #endmeeting