13:59:14 <ChrisPriceAB> #startmeeting OPNFV TSC
13:59:14 <collabot> Meeting started Tue Apr 12 13:59:14 2016 UTC.  The chair is ChrisPriceAB. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:59:14 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
13:59:14 <collabot> The meeting name has been set to 'opnfv_tsc'
13:59:19 <ChrisPriceAB> #topic Roll Call
13:59:28 <ChrisPriceAB> #info Chris Price
13:59:30 <frankbrockners> #info Frank Brockners
13:59:48 <edgarstp> #info Edgar StPierre
13:59:49 <uli-k> #info Uli Kleber
14:00:27 <bryan_att> #info Bryan Sullivan
14:00:48 <ttallgren> #info Tapio Tallgren
14:01:04 <bramwelt> #info Trevor Bramwell
14:01:43 <cgoncalves> #info Carlos Goncalves (proxying for Dirk Kutscher)
14:02:04 <GeraldK> #info Gerald Kunzmann (DOCOMO)
14:02:20 <ChrisPriceAB> #topic Approval of previous minutes of meeting
14:02:29 <ChrisPriceAB> #link https://wiki.opnfv.org/display/meetings/TSC#TSC-April5,2016 previous minutes of meeting
14:02:42 <rpaik> #info no feedback on minutes
14:02:44 <ChrisPriceAB> any comments received on previous minutes rpaik?
14:02:47 <dneary> #info dneary
14:02:47 <rprakash> #info rprakash
14:02:56 <ChrisPriceAB> #info previous minutes approved
14:03:03 <ChrisPriceAB> #topic Agenda Bashing
14:03:15 <ChrisPriceAB> #link https://wiki.opnfv.org/display/meetings/TSC#TSC-April12,2016 todays agenda
14:04:13 <trevor_intel1> #info Trevor Cooper
14:04:26 <rpaik> we now have a quorum
14:04:37 <trevor_intel1> #info Trevor standing in for Brian Skerry
14:04:49 <dneary> ChrisPriceAB: Can we have community metrics be an AOB again this week? Sounds like we will not have time, but...
14:05:25 <dneary> Thanks (that was my suggestion)
14:05:32 <ChrisPriceAB> #info chrispriceab proposes o skip the 3.0 update
14:05:43 <rpaik> #info also want to introduce bramwelt additional sys admin resource helping Aric
14:06:04 <Julien-zte> #info Julien
14:06:46 <ChrisPriceAB> #info trevor bramwelt introduces himself as an LF infrastructure resource working with our community
14:07:00 <ChrisPriceAB> #topic Wiki post-mortem
14:07:26 <ChrisPriceAB> #link https://wiki.opnfv.org/pages/viewpage.action?pageId=6817397 post morten link
14:09:19 <ChrisPriceAB> #info GeraldK adds that few people have added feedback on the wiki postmortem, more feedback could be valuable
14:09:30 <ChrisPriceAB> #info dneary agrees
14:09:41 <mbeierl> There have been 4 different contributors to the page: https://wiki.opnfv.org/pages/viewpreviousversions.action?pageId=6817397
14:10:01 <bryan_att> let those who feel strongly convey their feelings, and consider those in the next time this happens (if ever). but I would not spend a lot of cycles on it.
14:10:10 <rpaik> #info how long should we open the feedback for?  another few weeks?
14:10:17 <ChrisPriceAB> #action rpaik to send a reminder to the list to provide input on the wiki migration activity.
14:10:54 <ChrisPriceAB> #info dneary proposes a real time call to discuss the wiki migration debrief
14:12:04 <edgarstp> #info +1 bryan_att
14:12:35 <rpaik> finding a timeslot will always be a challenge
14:12:44 <rpaik> esp. between 6-9am PT
14:12:45 <ChrisPriceAB> #action dneary to set up a call for wiki post mortem activities.
14:13:15 <ChrisPriceAB> #topic Colorado planning and activities
14:13:27 <dneary> bryan_att, My concerns with wiki only are you end up with things like "we need to plan better" which are non-specific, and non-actionnable
14:13:37 <ChrisPriceAB> #link https://wiki.opnfv.org/display/SWREL/Colorado colorado planning page
14:13:41 <dneary> At some point you need to dig down to root cause analysis
14:13:55 <ChrisPriceAB> #info MS2 passed last friday and David has been woring with PTL's to secure planning for Colorado
14:14:04 <dneary> And doing it on a wiki page doesn't het keep the tone non-accusatory
14:14:04 <ChrisPriceAB> #undo
14:14:04 <collabot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x309a850>
14:14:21 <ChrisPriceAB> #info MS2 passed last friday and David has been working with PTL's to secure planning for Colorado
14:14:34 <mbeierl> dneary, bryan_att: as an aside, I think there will be future infrastructure changes, and also agree we need to action this into a general process for change
14:14:54 <ChrisPriceAB> #info David reported that where most projects were red on colrado planning that is now reduced to around 20-30% of projects.
14:14:55 <bryan_att> dneary: I don't feel responsible to tease out actionable ideas from unspecific concerns; those who have the concerns should follow thru with useful concrete ideas to address them; same as blueprints vs code
14:15:05 <ChrisPriceAB> #info input continues to come in from projects who are working on planning
14:15:44 <GeraldK> where can we see the project matrix with the color code?
14:16:06 <ChrisPriceAB> #info Colorado timelines are under discussion, many projects assume feature freeze leading up to june/july
14:16:09 <edgarstp> dneary: the next time a similar activity is required, we look back at the wiki and plan accordingly.
14:16:30 <ChrisPriceAB> #info the testing project indicate we need between 12-16 weeks post freeze (including integration/test/docs) to complete the release.
14:16:57 <dneary> Anyone know if Bin is planning on running the tech discuss meeting this week? I see he is on vacation
14:17:44 <dneary> bryan_att, The whole point of post mortems is that the people who feel the pain don't necessarily have insight into how to relieve it - you need both sides
14:17:52 <ChrisPriceAB> #action dmcbride to send an updated matrix to the tech discuss list once published.
14:18:04 <dneary> If either the people who did the migration or the people who had issues with it are not engaged, it goes nowhere
14:19:14 <ChrisPriceAB> #topic Colorado test coordination and planning
14:19:34 <ChrisPriceAB> #link https://wiki.opnfv.org/display/SWREL/Colorado+Testing+-+Discussion+and+Proposals test project and activity analysis wiki
14:20:00 <bryan_att> dneary: I don't mean to devalue post mortems, just in my scheme of priority they don't match progress on R3 - but feel free to drive it
14:20:17 <ChrisPriceAB> #info trevor_intel outlines the expansion of test project and scenario growth creates a challenge for the testing teams to coordinate criteria across a release activity.
14:20:32 <dneary> bryan_att, No point in driving an empty bus...
14:20:49 <ChrisPriceAB> #info trevor_cooper adds that projects should look to contribute to the test projects which would be reported and documented in a common and consistent manner.
14:21:14 <dneary> bryan_att, My main concern is that we don't let old woulds fester until next time. "it's past, we can ignore it now" doesn't work.
14:21:34 <ChrisPriceAB> #info this provides a clearer method for projects to understand how to participate as part of a release, rather than as seperate project test activities
14:22:22 <ChrisPriceAB> #info fdegir adds that there is a need to reduce overlap and focus our efforts to maximise the effectiveness of our efforts to validate and prove the platform.
14:23:21 <bryan_att> so are the overall issues that are being expressed for testing documented somewhere, so we can address the concerns over value, reasonableness, resources, etc?
14:24:20 <ChrisPriceAB> #info fdegir adds that we should focus on what we are testing rather than the seperate testing projects in order to better facilitate a coordinated effort
14:24:45 <ChrisPriceAB> bryan_att U htink that is what trevor_intel and team are working on
14:24:54 <ChrisPriceAB> s/U/I
14:25:08 <bryan_att> can the specific issues with the diversity of test focus in QTIP and Yardstick be explained as well?
14:26:02 <ChrisPriceAB> #info frankbrockners asks how to move forward with this, fdegir answers that the test project PTL's should drive this forward.
14:27:50 <bryan_att> perhaps if it's not clear (it should be), add a note prior to the table "Matrix of Features versus Test Projects" on the nature/focus of the test project. Then the feature project can determine if there is some value in targeting the test project (but I would this this would already be done as R3 planning...).
14:28:14 <bryan_att> s/this this/think this/
14:30:52 <ChrisPriceAB> #topic Dedicated mailing lists and dedicated GTM accounts for projects
14:31:27 <ChrisPriceAB> #info frankbrockners indicates the fast data project needs a dedicated mailing list for it's project team.
14:31:49 <rpaik> #info do we need similar mailing list for other upstream communites?
14:31:54 <rpaik> #undo
14:32:01 <rpaik> do we need similar mailing list for other upstream communites?
14:32:27 <rpaik> or should we even re-think our mailing lists in general?
14:32:57 <dneary> I can tell you that there has been very little enthusiasm in the ODL community to joining opnfv-tech-discuss and tagging with opendaylight
14:33:19 <GeraldK> we should per se not have separate mailing lists for projects
14:33:24 <dneary> It has not been an effective way to get to people - I end up cross-posting to upstream lists, which kind of defeats the purpose
14:33:38 <GeraldK> only for specific needs like requested here
14:34:35 <dneary> There has been no single place where OPNFV and ODL developers who care about NFV have been able to talk
14:34:59 <bryan_att> +1 to specific exceptions
14:35:47 <bryan_att> having multiple mailing lists is a bad idea generally. mail tools provide plenty of control to avoid what you don't care about
14:36:27 <bryan_att> but in this case a separate list, if needed, would be OK to me.
14:37:05 <lhinds> one point on the security-list, we need this for gerrit code reviews..please don't take it away :-/
14:37:18 <bryan_att> but the basic question I have is if this is an OPNFV project, why can't it use the OPNFV list exclusively? Because the people on the list might get bothered by the OPNFV traffic?
14:37:20 <lhinds> or rather not reviews, tags
14:37:28 <tnadeau__> how about slack channels?
14:37:48 <bryan_att> lhinds: not my intent - there are valid use cases for separate lists, I agree
14:38:18 <lhinds> bryan_att, thanks
14:39:00 <ChrisPriceAB> #startvote Does the TSC approve as an exception a dedicated email list for the FDS project. (+1, 0, -1)
14:39:00 <collabot> Unable to parse vote topic and options.
14:39:06 <bryan_att> #vote 0
14:39:09 <tnadeau__> #vote 0
14:39:12 <frankbrockners> #vote +1
14:39:13 <edgarstp> #vote 0
14:39:16 <ChrisPriceAB> #vote +1
14:39:17 <cgoncalves> #vote 0
14:39:18 <tnadeau__> BTW I'm frankly kind of confused why we need to vote on this
14:39:19 <uli-k> #vote 0
14:39:32 <ChrisPriceAB> #startvote Does the TSC approve as an exception a dedicated email list for the FDS project? (+1, 0, -1)
14:39:32 <collabot> Begin voting on: Does the TSC approve as an exception a dedicated email list for the FDS project? Valid vote options are , +1, 0, -1, .
14:39:32 <collabot> Vote using '#vote OPTION'. Only your last vote counts.
14:39:34 <dneary> #vote +1
14:39:39 <bryan_att> #vote 0
14:39:41 <ChrisPriceAB> #vote +1
14:39:42 <uli-k> #vote 0
14:39:43 <cgoncalves> #vote 0
14:39:44 <edgarstp> #vote 0
14:39:44 <tnadeau__> #vote 0
14:39:46 <GeraldK> #vote 0
14:39:47 <TapioT> #vote 0
14:39:47 <frankbrockners> #vote +1
14:39:50 <dneary> tnadeau__, Me too - air cover, I guess
14:39:55 <ChrisPriceAB> (I am ok as an evaluation to see how it goes)
14:39:57 <Julien-z_> #vote 0
14:40:17 <ChrisPriceAB> #endvote
14:40:17 <collabot> Voted on "Does the TSC approve as an exception a dedicated email list for the FDS project?" Results are
14:40:17 <collabot> 0 (8): GeraldK, TapioT, cgoncalves, tnadeau__, bryan_att, Julien-z_, uli-k, edgarstp
14:40:17 <collabot> +1 (3): dneary, ChrisPriceAB, frankbrockners
14:40:25 <tnadeau__> again, why are we voting for this?  the abstention is a good indication of that. :P
14:40:25 <trevor_intel1> #vote +1
14:40:32 <trevor_intel1> Trevor voting for Brian
14:40:41 <dneary> And avoiding a dangerous precedent where the TSC doesn't vote on things like this
14:41:02 * bryan_att wonders where robert is when you need him
14:41:07 <tnadeau__> 0 == abstain
14:41:27 <ChrisPriceAB> #agree the TSC agrees to create the mailing list
14:42:13 <rpaik> should we try getting a couple more GTM accounts?
14:42:21 <aricg-> gchat for any smaller meeting?
14:42:42 <aricg-> works for up to ten ppl or so if video is turned off
14:42:48 <lhinds> aricg-, block in some places :(
14:42:59 <bryan_att> we need a scheduling meeting, in which we figure out: how many parallel meetings we want; who can go when; document this on the wiki for clarity
14:43:09 <ChrisPriceAB> #info frankcbrockers outline issues with coordinating GTM sessions across the project
14:43:09 <lhinds> *blocked
14:43:23 <jmorgan1> why not one account for official topics (tsc, planning, etc) and second one for projects
14:43:40 <ChrisPriceAB> #info rpaik outlines that he has budgeted for more GTM accounts.
14:43:48 <bryan_att> we have a meetings page where we could make sure that this is documented
14:44:15 <aricg-> https://wiki.opnfv.org/display/meetings/Meetings
14:44:29 <aricg-> Some events were not shown in the calendars below because there were too many of them :(
14:44:52 <GeraldK> we need to have consistent reminders for organizers to not start meetings prior to the expected starting times.
14:45:05 <bryan_att> aricg-: we need to fix that - the table is largely unusable as a result. we can format it better.
14:45:06 <mbeierl> aricg-: that means there are too many in the future to display all meetings months in advance
14:45:24 <aricg-> mbeierl: ahh,
14:45:26 <bryan_att> we don't need calendar integration if that feature obscures the real data
14:45:36 <Julien-z_> #info can we use static calendar just like before. everytime I open the Meeting page, it cause my browser down
14:45:38 <mbeierl> it does not mean that the current week or month is lacking info
14:46:03 <lhinds> Not webex please
14:46:07 <lhinds> No linux support
14:46:24 <lhinds> Nothing personal, just I can't use it
14:47:03 <lhinds> bluejeans?
14:47:15 <lhinds> x-platform, and works well
14:47:19 <dneary> We should ask the Chinese government to stop blocking Google so that we can use Google hangouts.
14:47:26 <ChrisPriceAB> #action rpaik to propose a solution to the conference infrastructure on the list and invest in additional accounts as needed
14:47:28 <bryan_att> yes, whatever we use has to be cross-platform and accessible in all countries, and if possible inside corp proxies
14:47:37 <Julien-z_> # +1 dneary
14:48:00 <GeraldK> meeting cutoff at the full hour I don't see the major problem, but organizers starting the meeting 10minutes early are a problem
14:48:06 <dneary> lhinds, It works sometimes on Android
14:48:10 <ChrisPriceAB> #topic Board dialogs from the Collaboration Summit
14:48:13 <dneary> Which, I hear, is Linux
14:48:58 <bryan_att> mbeierl: the meetings page used to have a table - that's what I was referring to. I thought there was one in the new wiki but I see now there's list a list. That's OK, but I think we need a quick tabular overview of the week so projects can consider where they might fit in for scheduling.
14:49:01 <GeraldK> https://www.webex.de/support/support-system-requirements.html works with Linux + FF
14:50:05 <bryan_att> otherwise some meeting scheduling tool that allows projects to reserve timeslots, and block reservations as needed
14:50:10 <lhinds> GeraldK, dneary , it was the my rooms / jabber client stuff I had issues with. Must be that plain webex is ok
14:50:27 * bryan_att generally though does not prefer new tools
14:50:29 <mbeierl> bryan_att: The table is still at the bottom, just fed from live calendar.  I see ChrisPriceAB added the test list to the sidebar
14:50:44 <lhinds> another possible is we host a mumble server, create as many channels as we like, and you can bind dial in numbers
14:50:47 <mbeierl> bryan_att: btw, the table was horribly out of date in the old wiki too
14:50:50 <lhinds> open source too
14:50:52 <tnadeau__> stackanalytics?
14:51:01 <GeraldK> bryan_att: https://wiki.opnfv.org/display/meetings/calendar/8d315bbd-158a-42c1-83e2-dea8b27a6c4f?calendarName=OPNFV%20Team%20Meetings
14:51:11 <tnadeau__> i will mention that ODL has spectrometer 2.0 underway. we're rewriting it so its portable and could be consumed by opnfv
14:51:25 <GeraldK> bryan_att: is this is what you where looking for?
14:51:43 <bryan_att> mbeierl: agreed - one of the issues with this. no easy solution. the table at the bottom doesn't show all the meetings thus it's marginally useful to me.
14:52:02 <dneary> ChrisPriceAB: So I guess we are going to talk community metrics
14:52:13 <mbeierl> bryan_att: what meetings are missing?  I added all of them from the text of the page
14:52:37 <mbeierl> if people aren't maintaining that, then that is the root cause
14:52:49 <ljlamers_> The link gives a message "Some events were not shown in the calendars below because there were too many of them"
14:53:19 <Julien-z_> #info mbeierl, the live table cause my browser down again and again, can we use static table ?
14:53:32 <GeraldK> ljlamers, i also noticed that. i fully agree, we have too many meetings
14:53:34 <ChrisPriceAB> #topic Upcoming board meeting TSC report
14:53:45 <mbeierl> ljlamers_: was just discussed - the calendar does not show the events months and months in advance.  The current month does not hide any meetings
14:53:47 <bryan_att> ok, it looks like they are there in the page GeraldK linked. maybe it's just the amount of info listed for each project meeting, that fills the table content too much; more brief info/links would be more useful (to me)
14:53:50 <ChrisPriceAB> #link https://wiki.opnfv.org/download/attachments/2925933/opnfv_board_meeting_tsc_april_2016.pptx?version=1&modificationDate=1460460438439&api=v2 proposed preliminary board deck
14:54:26 <GeraldK> Julien-z_, let me propose not to use the INFO tag for offline discussions like this.
14:54:58 <Julien-z_> #GeraldK good
14:55:08 <dneary> ChrisPriceAB: The only additional thing I wanted to raise on this call was what questions we want metrics to answer, and what actions we want to incent. My preference is task/blueprint/patch level measurements rather than measuring the entirity of activity of individuals, but that's just because I think it provides better data.
14:55:20 <dneary> (that is, re metrics)
14:55:38 <mbeierl> Julien-z_: I did not put the live text on the side, so it's not my place to remove it.
14:56:14 <mbeierl> Julien-z_: does this page bog down your browser? https://wiki.opnfv.org/display/meetings/calendar/8d315bbd-158a-42c1-83e2-dea8b27a6c4f?calendarName=OPNFV%20Team%20Meetings
14:56:27 <Julien-z_> #info yea, actually
14:56:56 <Julien-z_> #info I hope this use the old style as a static table
14:56:59 <bryan_att> on the lab-aas, I am continuing to develop on Ravello. It may not be workable for CI/CD but it certainly is workable for testing based upon a snapshotted deploy. And until other options arise, it's the only one in town.
14:57:11 <B_Smith_> where is the Lab as a service wiki
14:57:13 <fdegir> bryan_att: we basically ticked off ravello
14:57:27 <fdegir> it does not work
14:58:00 <Julien-z_> #info link https://wiki.opnfv.org/display/pharos/Pharos+Laas
14:58:02 <fdegir> evaluated options are: google compute engine, amazon ec2, microsoft azure, ravello, rackspace
14:58:29 <fdegir> all but rackspace have been evaluated and deemed as not viable
14:58:38 <fdegir> rackspace evaluation is starting up
14:58:44 <bryan_att> fdegir: ok, that's their problem. If they can't support a use case then boohoo. But I still plan to challenge them to be a useful cloud-based lab tool (for some purposes) until they fail me, or some better option arises.
14:58:57 <fdegir> they failed us :)
14:59:04 <fdegir> they haven't been able to answer
14:59:07 <ChrisPriceAB> #Topic AoB
14:59:14 <fdegir> their hvm does not work
14:59:29 <ChrisPriceAB> #endmeeting