14:01:17 <ChrisPriceAB> #startmeeting OPNFV TSC
14:01:17 <collabot> Meeting started Tue Apr 19 14:01:17 2016 UTC.  The chair is ChrisPriceAB. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:17 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:01:17 <collabot> The meeting name has been set to 'opnfv_tsc'
14:01:25 <ChrisPriceAB> #topic Roll Call
14:01:30 <ChrisPriceAB> #info Chris Price
14:01:36 <Julien-zte> #info Julien
14:01:44 <JonasArndt> #info Jonas Arndt
14:01:45 <GeraldK> #info Gerald Kunzmann (DOCOMO)
14:01:47 <uli-k> #info Uli Kleber
14:01:54 <dku> #info Dirk Kutscher
14:02:11 <bryan_att> #info Bryan Sullivan
14:02:33 <mbeierl> #info Mark Beierl - proxy for Edgar StPierre
14:02:40 <dneary> #info Dave Neary
14:02:50 <dneary> (proxy for Chris Wright)
14:02:59 <ChrisPriceAB> #topic Approval of previous minutes of meeting
14:03:00 <rpaik> we now have a quorum
14:03:03 <frankbrockners> #info Frank Brockners
14:03:10 <ChrisPriceAB> #link https://wiki.opnfv.org/display/meetings/TSC#TSC-April12,2016 previous minutes
14:03:22 <ChrisPriceAB> #info no comments received minutes approved.
14:03:27 <ChrisPriceAB> #topic Agenda Bashing
14:03:43 <ChrisPriceAB> #link https://wiki.opnfv.org/display/meetings/TSC current agenda
14:04:49 <ChrisPriceAB> #info no topics added
14:05:14 <bjskerry> #info Brian Skerry
14:05:35 <ChrisPriceAB> #topic Board meeting report out
14:07:18 <rprakash> #info rprakash
14:09:35 <ChrisPriceAB> #info chris outlines the content of the board call according to the e-mail provided by anthony
14:10:08 <ChrisPriceAB> #info Prodeep provides and update on discussions at the board around our technical goverenance and area for potential improvement.
14:10:21 <ChrisPriceAB> #link https://wiki.opnfv.org/download/attachments/2925933/OPNFV%20technical%20governance%20proposal%20April2016.pdf?version=2&modificationDate=1461072621038&api=v2 slides outlining areas for improvement
14:10:32 <ChrisPriceAB> #undo
14:10:32 <collabot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x2e45dd0>
14:10:40 <TapioT> #info Tapio Tallgren
14:10:46 <ChrisPriceAB> #link https://wiki.opnfv.org/download/attachments/2925933/OPNFV%20technical%20governance%20proposal%20April2016.pdf?version=2&modificationDate=1461072621038&api=v2 slides outlining areas for discussion and potential improvement
14:12:09 <ChrisPriceAB> #info Prodip outlines some of the areas where OPNFV is unique in the industry and areas where OPNFV may be suited to take a leadership role across some areas of NFV.
14:12:50 <ChrisPriceAB> #info He proposes the question of if we are doing as much as we could, or should, and is our structure helping us achieve those goals.
14:13:57 <ChrisPriceAB> #info Prodip also outlines a desire to have a merit based approach to OPNFV and if we are doing as much as we can to reward and promote those who are contributing strongly to our community.
14:14:59 <ChrisPriceAB> #info Prodip also states that the TSC and community has outperfomed many peoples expectations and the rational for change is to promote improvements in the community rather than question if our community is functional as it stands.
14:16:01 <ChrisPriceAB> #info Prodip shows a slide that outlines some feedback received on our community structure as it is structured.
14:18:20 <ChrisPriceAB> #info Prodip asks for feedback form the TSC and community on the topics raised and if we can improve our technical structure and governance.
14:19:00 <ChrisPriceAB> #info the intention is to gather feedback from the community and identify if any improvements can be made according to the needs of our constituency.
14:19:55 <ChrisPriceAB> #info Bryan asks what process has been used for gathering feedback, Prodip responds that the feedback has been provided independantly.  Thus the intention to get a broader set of feedback on these topics.
14:21:57 <ChrisPriceAB> #info Bryan asks if industry leadership can be better defined.  Prodip outlines the breadth of activities in MANO and Forwarding etc where the Board believes OPNFV can play a role in resolving/coordinating industry activities of this nature.  OPNFV may be able to be better structured to broker these types of discussions.
14:22:31 <rpaik> #info Prodip notes that NFV industry leadership is desired to broker architectural discussions within OPNFV
14:23:55 <ChrisPriceAB> #info Bryan also asks about the issues with the meritocratic nature of OPNFV.  The answer is that many open source communities have elected committee's rather than elected committee's which may include a transitional phase or establishment as elected committee's.
14:26:16 <rpaik> #info Margaret also added that having merit-based TSC could also attract more developers
14:26:39 <ChrisPriceAB> #info Bray adds that even if we move toward a meritocratic structure there needs to be a clear plan and migration activity toward such a structure.
14:26:45 <ChrisPriceAB> #undo
14:26:45 <collabot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2be9590>
14:26:50 <ChrisPriceAB> autocorrect...
14:26:56 <ChrisPriceAB> #info Bryan adds that even if we move toward a meritocratic structure there needs to be a clear plan and migration activity toward such a structure.
14:28:17 * ChrisPriceAB loves his ppt compileer
14:28:40 <bryan_att> Powerpointers?
14:29:21 <ChrisPriceAB> not sure anyone means you bryan  :D
14:29:34 * ChrisPriceAB points at self...
14:30:01 <rpaik> #info The presentation will also be sent out to mailing lists
14:30:28 <dneary> The most interesting question for me is how change happens, and whether we should be looking to the board to lead change, or whether we should be leading change from the TSC
14:30:29 <rpaik> #info will also continue the conversations in future calls
14:30:34 <ChrisPriceAB> #topic brahmaputra.3.0 update
14:30:58 <bryan_att> My main point about the transition if/when it occurs is that it needs to be meritocratic itself, and that the nature of *merit* as a concept needs to be commonly agreed. Vision and action come in many forms, not just code commits.
14:31:07 <ChrisPriceAB> #info B.3.0 is on track for labelling at the end of this month.
14:31:21 <ChrisPriceAB> #info scenario freeze is due this week accroding to the timeplan.
14:33:01 <rpaik> #info Frankbrockners asks if there’s a plan for another dot release in May.  ChrisPriceAB notes that it looks like most scenarios will make the 3.0 release but can have nother conversation next week
14:33:04 <ChrisPriceAB> #topic Colorado planning and activities
14:33:19 <ChrisPriceAB> not too quick
14:33:54 <ChrisPriceAB> #info Milestone discussions continue in the community capturing the feedback from Brahmaputra
14:34:14 <ChrisPriceAB> #info the intention is to have more granular milestones that better capture the development flow toward the release.
14:34:44 <ChrisPriceAB> #info scenario discussions and planning is another key topic of discussion across the community in some seperate meetings focused on those items
14:35:13 <ChrisPriceAB> #info the community has agreed to roll the scenario and release planning project discussions back into the weekly release meetings
14:35:48 <ChrisPriceAB> #info scernario's and scenario owners have been captured on the wiki
14:36:03 <frankbrockners> #link *draft* view of scenario inventory: https://wiki.opnfv.org/display/SWREL/Colorado+scenario+inventory+and+dependencies
14:36:06 * ChrisPriceAB stares wildly around for someone to link in that wiki refernce...
14:36:15 * ChrisPriceAB applaudes frank :)
14:36:30 * frankbrockners saw ChrisPriceAB starring around
14:36:55 <ChrisPriceAB> #info we are behind on some of our early milestones although catching up and bringing our activities into alignment for Colorado overall.
14:38:11 <ChrisPriceAB> #info GeraldK asks if there is an updated timeline available, dmcbride answers that we are close to producing an updated schedule.
14:39:16 * bryan_att fears a one-year cycle would doom OPNFV to irrelevance
14:40:03 * dneary is resisting the urge to ask once again why we are wasting so much effort in a release process, when the release is not the main value of OPNFV.
14:40:36 <rpaik> #info There was also a discussion on release candence/interval amongst Board members in Beijing (as there was a lot of stress on the community to meet the 6-month cadence)
14:41:55 <ChrisPriceAB> #info Brian adds that the cadence in his view is not the issue, our processes and activities should maybe be evaluated to limit the effort of addressing the release activity.
14:42:29 <ChrisPriceAB> #info dneary adds that he thinks the value of the community is not in the releases we produce
14:43:29 <bryan_att> Dneary: We need to have a community product, that adds value to the market and that promotes our work here. Projects need these periodic demonstrations of some tangible output.
14:45:16 <dneary> bryan_att, I understand that perspective. I think that the upstream releases provide that already.
14:45:25 <bryan_att> Integration of upstream projects is one of the key goals of our work; whether vendors pick up that and use it (I.e. Leverage the work we do here directly), they benefit from that work.
14:45:31 <rpaik> #info Margaret encourages the technical community to provide feedback/recommendation to the Board on release cadence
14:46:43 <dneary> bryan_att, Agreed. We do that in our testing projects.
14:48:50 <rpaik> #action ChrisPriceAB will start a discussion on the mailing reg. release cadence
14:49:12 <bryan_att> Dneary: if we did not release a packaged/integrated/usable product, the market would have a hard time seeing any tangible value from what OPNFV does. our scenario concept is founded on a specific set of upstream released components, as thewhat we test.
14:49:30 <rpaik> #info process discussion can take place during dmcbride’s weekly Colorado releace meetings
14:50:07 <bryan_att> Thus we naturally get to the point of needing to cap that work and release it as a tested reference, however often we do it.
14:50:08 <dneary> bryan_att, Yes - like I said, the value of the release is the ability to have a periodical press release and milestone for things we have done in OPNFV
14:50:17 <rpaik> #action dneary to start a email conversation on whether we do releases
14:50:24 <dneary> bryan_att, It is about market perception of our tangible value
14:50:27 <GeraldK> we should introduce timeboxes for TSC topics, in order to avoid every meeting we have to go quick/drop some of the later agenda items
14:50:32 <ChrisPriceAB> #topic Upcoming Events and planning
14:50:48 <rpaik> #link https://wiki.opnfv.org/display/EVNT list of technical community events
14:51:58 <ChrisPriceAB> #info an e-mail will be sent out to the community outlining our OPNFV rleated activities at OpenStack
14:51:58 <bryan_att> This week at NFV World Congress I will be representing OPNFV in an IM Workshop panel.
14:52:15 <rpaik> #info there will be a Telco track on Wed-Thu during OpenStack Summit next week
14:53:02 <ChrisPriceAB> #info Highlights include, booth crawl Monday night at the OPNFV booth, Tuersday night "stack city" includes OPNFV as a premier sponsor and a sponsored location on the street.,
14:53:36 <ChrisPriceAB> #info The plugfest is planned for the second week or May.
14:54:02 <ChrisPriceAB> #info OPNFV Summit in Berlin is being planned, our design summit planning will kick off next week.
14:54:21 <ChrisPriceAB> #info rpaik will update the H2, 2016 events page shortly.
14:55:02 <bryan_att> See http://wiki.opnfv.org/models/Events
14:55:36 <rpaik> #info OPNFV Summit code for member companies: OPNFVMEM16
14:56:41 <rpaik> #info looking for volunteers to help program the Design Summit in Berlin
14:56:57 <ChrisPriceAB> #topic Community metrics
14:58:03 <ChrisPriceAB> #info dneary outlines the community metrics initiative should be driven by a set of outcomes and wanted answers/questions that can help define the metrics we would propose.
14:58:41 <bryan_att> Can a wiki page be created where the goal of this activity is expressed and developed?
14:59:22 <rpaik> #link http://lists.opnfv.org/pipermail/opnfv-tsc/2016-April/002494.html Dave’s discussion on the topic
14:59:25 <ChrisPriceAB> #info There is an interest from openstack to capture NFV metrics which we could leverage to achieve our own goals.
14:59:53 <bryan_att> I.e. What is the goal of tracking metrics, what metrics are relevant per those goals, etc.
15:00:43 <bryan_att> I can help develop this as needed, but we need to socialize the goals of it first. I imagine that within our companies we are already doing this.
15:01:30 <ChrisPriceAB> #action dneary to see if it is possible to set up a meeting with the openstack community next week at the summit
15:01:38 <ChrisPriceAB> #endmeeting