#opnfv-meeting: Test&performance weekly meeting May 5th

Meeting started by morgan_orange at 14:00:05 UTC (full logs).

Meeting summary

  1. call roll (morgan_orange, 14:00:13)
    1. Morgan Richomme (morgan_orange, 14:00:17)
    2. Jose Lausuch (jose_lausuch, 14:02:02)
    3. qiliang (ql, 14:02:36)
    4. Frank Brockners (frankbrockners, 14:02:45)
    5. zhifeng (zhifeng, 14:02:54)
    6. Mark Beierl (mbeierl, 14:03:10)
    7. topic Test Criteria (morgan_orange, 14:05:27)
    8. Maryam Tahhan (mtahhan, 14:05:52)
    9. https://wiki.opnfv.org/display/PROJ/Daisy+Nfv (mbeierl, 14:09:53)
    10. release criteria applies to scenarios individually (jose_lausuch, 14:10:02)
    11. as the test group, we have the mission to validate a release and each of the scenarios (jose_lausuch, 14:10:26)
    12. the number of features might increase significantly, since the idea is to test everything, this will cause time concerns (jose_lausuch, 14:13:24)
    13. to validate a scenario (functest case): 4 consecutive runs + smoke tests passing + scenario specific test (~1h testing time) (jose_lausuch, 14:14:10)
    14. Frank suggests the benefit of pulling the definitions of scenarios out of Jenkins and into scenario definition files that scenario owners can manage (mbeierl, 14:17:48)
    15. Suggestion understood, but probably not doable in C time (mbeierl, 14:19:45)
    16. https://wiki.opnfv.org/display/SWREL/Test+Release+Criteria (mbeierl, 14:26:23)
    17. https://wiki.opnfv.org/display/SWREL/Colorado+scenario+inventory+and+dependencies - List of scenarios (frankbrockners, 14:32:38)
    18. ACTION: morgan_orange review Colorado scenario and conbtact scenario owner to list scenario specific test list (morgan_orange, 14:34:17)

  2. roadmap (morgan_orange, 14:34:26)
    1. more resources allocation roadmap (morgan_orange, 14:34:38)
    2. to be sync with david karr (action from Infra group to setup CI Intra resources) (morgan_orange, 14:38:04)

  3. plugfest (morgan_orange, 14:39:54)
    1. presentations on Functest, Yardstick, StorPerf well received (morgan_orange, 14:40:24)
    2. several integrations done, Yardstick and Functest launched successfully (morgan_orange, 14:41:36)
    3. all the installers represented (morgan_orange, 14:42:02)
    4. first tests collected (morgan_orange, 14:42:45)
    5. http://plugfest.opnfv.org/testapi/results (morgan_orange, 14:42:47)

  4. Approach to testing (morgan_orange, 14:47:29)
    1. consolidation on OPNFV testing in progress (morgan_orange, 14:47:49)
    2. one goal = create a white paper to clarify what is testing in OPNFV (morgan_orange, 14:48:04)
    3. some wiki pages have to be updated (morgan_orange, 14:49:11)
    4. ACTION: all review testing main page and re-share first attempt on domain coverage (morgan_orange, 14:50:09)
    5. https://wiki.opnfv.org/display/functest/Testing (morgan_orange, 14:50:39)
    6. Clarification on the test results: The above link shows only results of OPNFV test projects. It is simple pass/fail and basic information on the criteria. This database does *not* contain any propriety test results such as VNF performance, etc. (mbeierl, 14:50:43)
    7. https://wiki.opnfv.org/display/functest/Testing+Coverage (morgan_orange, 14:51:02)
    8. presentation of Alan's Draft on Testing approach (morgan_orange, 14:52:13)


Meeting ended at 15:04:32 UTC (full logs).

Action items

  1. morgan_orange review Colorado scenario and conbtact scenario owner to list scenario specific test list
  2. all review testing main page and re-share first attempt on domain coverage


Action items, by person

  1. morgan_orange
    1. morgan_orange review Colorado scenario and conbtact scenario owner to list scenario specific test list


People present (lines said)

  1. morgan_orange (27)
  2. jose_lausuch (8)
  3. mbeierl (8)
  4. collabot` (5)
  5. frankbrockners (3)
  6. mtahhan (3)
  7. zhifeng (1)
  8. ql (1)
  9. QiLiang (0)


Generated by MeetBot 0.1.4.