14:00:51 <morgan_orange> #startmeeting Test subgroup weekly meeting June 2nd
14:00:51 <collabot`> Meeting started Thu Jun  2 14:00:51 2016 UTC.  The chair is morgan_orange. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:51 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:00:51 <collabot`> The meeting name has been set to 'test_subgroup_weekly_meeting_june_2nd'
14:00:57 <morgan_orange> #topic call role
14:00:59 <mbeierl> GTM is busy?
14:01:06 <mbeierl> #info Mark Beierl (StorPerf)
14:01:07 <kubi> #info kubi
14:01:11 <jose_lausuch> waiting for opnfv project?
14:01:14 <jose_lausuch> #info Jose Lausuch
14:01:36 <mbeierl> When I launched (as PTL), it told me another meeting was still running
14:01:58 <mbeierl> So I am given the option of terminating the other meeting or logging out
14:03:04 <morgan_orange> #info Morgan
14:03:10 <mtahhan> #info Maryam Tahhan
14:05:25 <morgan_orange> #topic Action point follow up
14:05:30 <morgan_orange> #info nothing this week
14:05:35 <morgan_orange> #topic Colorado Status
14:05:55 <morgan_orange> #chair jose_lausuch MatthewLi
14:05:55 <collabot`> Current chairs: MatthewLi jose_lausuch morgan_orange
14:06:02 <morgan_orange> #chair mbeierl
14:06:02 <collabot`> Current chairs: MatthewLi jose_lausuch mbeierl morgan_orange
14:07:30 <mtahhan> #info vsperf started integration with yardstick, moongen integration is well underway and outstanding item for C release is the update to use the new results API
14:07:42 <morgan_orange> #info storperf relatively quiet (part time job, really??), new Cengn contributor joined, discussion with Yardstick (initiated during the plugfest)
14:10:47 <kubi002> morgan
14:11:06 <morgan_orange> #action morgan_orange presentation of refactored test API next week, Senera will be in Berlin for the Summit
14:11:19 <kubi002> i'm on line
14:11:24 <kubi002> but no audio
14:11:31 <kubi002> wait a moment
14:11:46 <morgan_orange> #info Functest stable (first blue balls in CI)
14:11:51 <trevor_intel_> #info Trevor Cooper
14:12:03 <morgan_orange> #info first Apex results collected this week
14:12:56 <jose_lausuch> #info new testcases about security scanning
14:13:38 <jose_lausuch> #link http://testresults.opnfv.org/reporting/functest/release/master/index-status-apex.html
14:15:27 <mbeierl> #info yardstick new plugin made available for sub projects: vsperf, storperf, etc.
14:15:38 <morgan_orange> #info meeting yardstick / ha
14:16:20 <mbeierl> kubi002: where is the gerrit review?
14:17:47 <kubi002> mbeierl: #link https://gerrit.opnfv.org/gerrit/#/c/14823/
14:18:41 <kubi002> jose_lausuch: yardstick team also provide some sample for mutli-VMs in Ping scenario.
14:19:27 <kubi002> jose_lausuch: #link https://gerrit.opnfv.org/gerrit/#/c/15041/
14:19:48 <jose_lausuch> kubi002: yes, they are treated as nodes, not at host/target :)
14:19:49 <jose_lausuch> thanks
14:22:23 <mbeierl> #link https://gerrit.opnfv.org/gerrit/#/c/15087/2
14:22:25 <dfarrell07> +1/w00t @ "upstream, upstream, upstream" morgan_orange :)
14:22:48 <mbeierl> #info Gerrit review for the Presentation ^
14:23:32 <mbeierl> #link https://gerrit.opnfv.org/gerrit/#/c/15087
14:23:42 <mbeierl> in case there are more patches.... oops
14:29:43 <jose_lausuch> #info In Brahmaputra feature projects had 2 choices to place tests cases, functest and yardstick
14:30:22 <jose_lausuch> #info the allocation was decided according to the idea of sharing the load between them, without thinking much the nature of the test case (functional, performance,.... )
14:31:09 <jose_lausuch> #info Morgan suggests to rethink the way we use the umbrella projects for testing
14:32:06 <ebrjohn> #info ebrjohn, Brady Johnson SFC PTL
14:33:53 <jose_lausuch> #info when selecting a test project, there are some steps to follow like declaring the test in the DB, provide a success criteria of the test cases, create JIRA for integration and work together with the test project members and collaborate with documentation
14:35:24 <jose_lausuch> #info Morgan proposes a if-else diagram about the nature of the test cases to make clear where to place the tests
14:36:46 <jose_lausuch> #info question: where to find information about the different testing frameworks in OPNFV --> also needed when deciding where to place the tests
14:39:22 <jose_lausuch> ebrjohn: you have a similar situation ...
14:39:37 <ebrjohn> yes, Im waiting for Tim to finish to ask my question
14:42:57 <morgan_orange> question on how difficult it is to migrate a testcase from Yardstick to Functest? Does it make sense for tests that already exist
14:43:25 <mbeierl> or functest to yardstick
14:43:31 <morgan_orange> yes
14:43:54 <morgan_orange> and as said prjects may use both..depending on the nature of the tests
14:44:02 <morgan_orange> the 2 frameworks are complementary
14:44:05 <mbeierl> I think the plugin framework that is being proposed in yardstick may help to answer that from the yardstick side
14:44:29 <mbeierl> if I understood kubi002's comment on what the review is
14:51:25 <mbeierl> #chair dfarrell07
14:51:25 <collabot`> Current chairs: MatthewLi dfarrell07 jose_lausuch mbeierl morgan_orange
14:51:37 <dfarrell07> working on it
14:51:47 <ebrjohn> Dan saves the day again...
14:52:01 <dfarrell07> #startvote Shall the test projects adopt the layout of Yardstick/Functest as described by morgan_orange? -1,0,+1
14:52:01 <collabot`> Begin voting on: Shall the test projects adopt the layout of Yardstick/Functest as described by morgan_orange? Valid vote options are -1, 0, +1.
14:52:01 <collabot`> Vote using '#vote OPTION'. Only your last vote counts.
14:52:07 <dfarrell07> #vote +1
14:52:11 <mbeierl> #vote +1
14:52:13 <jose_lausuch> #vote +1
14:52:13 <morgan_orange> #vote +1
14:52:15 <trevor_intel_> #vote +1
14:52:18 <mtahhan> #vote +1
14:52:19 <timirnich> #vote +1
14:52:20 <kubi002> #vote +1
14:52:22 * ebrjohn who gets to vote??
14:52:28 * ebrjohn committers only
14:52:38 * ebrjohn :)
14:52:44 <ebrjohn> #vote +1
14:52:48 <dfarrell07> anyone else?
14:52:53 <ebrjohn> #vote +1
14:52:58 <dfarrell07> #endvote
14:52:58 <collabot`> Voted on "Shall the test projects adopt the layout of Yardstick/Functest as described by morgan_orange?" Results are
14:52:58 <collabot`> +1 (9): ebrjohn, mtahhan, timirnich, morgan_orange, dfarrell07, kubi002, trevor_intel_, jose_lausuch, mbeierl
14:53:13 <jose_lausuch> ebrjohn: you voted twice!
14:53:15 <jose_lausuch> :)
14:53:16 <mbeierl> kubi002: where are you located?  What time is it?
14:54:27 * ebrjohn has to leave to pick the kids up from school
14:54:48 * ebrjohn putting on my taxi hat now :)
14:56:35 <kubi002> mbeierl: shanghai, 22:57
14:56:59 <mbeierl> kubi002: it is late evening for you then!  Thanks for joining!
14:58:49 <morgan_orange> #action PTL => provide input on test slicing
14:59:36 <kubi002> mbeierl: It's my pleasure.
14:59:52 <mbeierl> morgan_orange: where do we provide the feedback?  Are you putting that up on the wiki and we can comment there?
15:00:03 <morgan_orange> #topic AoB
15:00:24 <morgan_orange> #action morgan_orange create wiki page to reflect discussion on test tiering
15:00:43 <mtahhan> got to drop. Thanks folks
15:01:13 <kubi002> bye
15:01:13 <morgan_orange> #endmeeting