#opnfv-meeting: Test and Performance Weekly Meeting

Meeting started by mbeierl at 14:05:04 UTC (full logs).

Meeting summary

  1. Roll Call (mbeierl, 14:05:27)
    1. kubi (kubi001, 14:05:29)
    2. Mark Beierl (StorPerf) (mbeierl, 14:05:31)
    3. Yujun Zhang (yujunz, 14:05:38)
    4. Morgan Richomme (Functest) (morgan_orange, 14:05:39)
    5. Julien (Julien-zte, 14:06:51)

  2. QTIP Presentation (mbeierl, 14:07:24)
    1. HELP: (mbeierl, 14:08:05)
    2. Maryam Tahhan (mtahhan, 14:08:08)
    3. https://wiki.opnfv.org/display/qtip (yujunz, 14:08:31)
    4. QTIP being discussed (mbeierl, 14:08:35)
    5. discussion of QTIP scope (mbeierl, 14:10:15)
    6. open question after last demo: is QTIP going to continue independently or should it roll up into Functest and Yardstick (mbeierl, 14:11:14)
    7. morgan_orange mentioned what's the overlap between qtip and other projects such as bottleneck (Julien-zte, 14:11:37)
    8. yujunz discussed QTIP internally and is proposing a roadmap. (mbeierl, 14:12:09)
    9. https://gerrit.opnfv.org/gerrit/#/c/15681/4/docs/roadmap.rst,unified (yujunz, 14:13:02)
    10. new PTL, new members, so new roadmap is proposed, please comment on the roadmap (mbeierl, 14:13:06)
    11. morgan_orange asked if QTIP tests *before* the OPNFV installation? (mbeierl, 14:13:50)
    12. yardstick has now confirmed as being umbrella for all performance testing - the ones built in, and well as the interface to CPerf, StorPerf, and VSPerf (mbeierl, 14:14:57)
    13. Functest is umbrella for all functional tests (mbeierl, 14:15:21)
    14. During Colorado planning, there has been a discussion of test projects to attempt to clear the overlap. It comes down to all projects should be affiliated with one of the two umbrellas: performance (Yardstick) or functional (Functest) (mbeierl, 14:18:02)
    15. that does not mean that individual projects go away. VSPerf is very much independent, but it's OPNFV reporting and CI pipeline are going to be driven from Yardstick integration (mbeierl, 14:19:04)
    16. agreed that this conversation will continue in Berlin: "How does QTIP fit in now that there is the plan to have the two major umbrella projects" (mbeierl, 14:20:39)
    17. https://wiki.opnfv.org/display/functest/testing (mbeierl, 14:21:59)
    18. https://wiki.opnfv.org/download/attachments/2926690/Testing.png?version=1&modificationDate=1463478046000&api=v2 (mbeierl, 14:23:31)
    19. https://wiki.opnfv.org/download/attachments/2926690/how_to_testing.png?version=1&modificationDate=1464962177000&api=v2 "How to interact with other projects" (mbeierl, 14:24:20)

  3. "Conversations with the test teams" (mbeierl, 14:24:32)
    1. to introduce ourselves to attendees - perhaps upstream contributors (mbeierl, 14:25:01)
    2. to discuss our goals and ambitions (collective and individual) for the testing projects (mbeierl, 14:25:24)
    3. discussion about the https://wiki.opnfv.org/download/attachments/2926690/Testing.png?version=1&modificationDate=1463478046000&api=v2 picture (mbeierl, 14:31:16)
    4. it's a way of looking at the testing framework (mbeierl, 14:32:02)
    5. Presentation is in git, team leads to add content (mbeierl, 14:32:24)
    6. Goal is to emphasize Functest is upstream focused (mbeierl, 14:32:50)
    7. , and that it's time to give back :) (mbeierl, 14:33:45)
    8. Open the discussion about defining Telco KPIs (mbeierl, 14:34:04)
    9. Daniel clarified that the diagrams do not constitute formal organization, but rather a mutual agreement on presentation of how things fit together (mbeierl, 14:38:41)
    10. ACTION: : morgan_orange to create a page for Berlin summit test group planning (mbeierl, 14:55:41)
    11. Will discuss during the summit how to have rolling organization of this weekly meeting so that it becomes more collaborative (mbeierl, 14:59:15)
    12. Project leads, etc, encouraged to fill in details in the presentation (mbeierl, 14:59:48)


Meeting ended at 15:00:10 UTC (full logs).

Action items

  1. : morgan_orange to create a page for Berlin summit test group planning


Action items, by person

  1. morgan_orange
    1. : morgan_orange to create a page for Berlin summit test group planning


People present (lines said)

  1. mbeierl (55)
  2. Julien-zte (13)
  3. kubi001 (11)
  4. morgan_orange (7)
  5. mtahhan (6)
  6. frankbrockners (6)
  7. yujunz (6)
  8. collabot` (4)
  9. dneary (1)
  10. dfarrell07 (1)


Generated by MeetBot 0.1.4.