06:00:15 <rpaik> #startmeeting OPNFV TSC
06:00:15 <collabot> Meeting started Tue Jun 21 06:00:15 2016 UTC.  The chair is rpaik. Information about MeetBot at http://wiki.debian.org/MeetBot.
06:00:15 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
06:00:15 <collabot> The meeting name has been set to 'opnfv_tsc'
06:01:06 <Ashiq_Khan> #info Ashiq Khan
06:01:17 <csatari> #info Gergely Csatari
06:01:22 <ChrisPriceAB> #topic Roll Call
06:01:29 <ChrisPriceAB> #info Chris Price
06:02:11 <rpaik> #chair ChrisPriceAB
06:02:11 <collabot> Current chairs: ChrisPriceAB rpaik
06:02:15 <ChrisPriceAB> #topic Roll Call
06:02:17 <rpaik> we have a quorum
06:02:20 <ChrisPriceAB> #info Chris Price
06:02:31 <ttallgren> #info Tapio Tallgren
06:02:52 <ChrisPriceAB> #topic Approval of the previous minutes of meeting
06:02:52 <edgarstp> #info Edgar StPierre
06:03:02 <csatari> Can you share the GTM link?
06:03:03 <bryan_att> #info Bryan Sullivan
06:03:06 <Ashiq_Khan> #info Ashiq Khan
06:03:20 <ChrisPriceAB> #link https://wiki.opnfv.org/display/meetings/TSC#TSC-June14,2016 previous minutes of meeting
06:03:28 <frankbrockners> #info Frank Brockners
06:03:32 <ChrisPriceAB> #info no comments received minutes approved
06:03:40 <StuartMackie> #info Stuart Mackie
06:03:41 <ChrisPriceAB> #topic Agenda Bashing
06:03:47 <JonasArndt> #info Jonas Arndt
06:04:11 <csatari> https://global.gotomeeting.com/join/798898261
06:05:01 <ChrisPriceAB> #topic Update on the TSC Charter to reflect the OPNFV Code of Conduct
06:05:22 <ChrisPriceAB> #info rpaik outlines the code of conduct updated proposed to the board have been approved.
06:05:35 <ChrisPriceAB> #link https://wiki.opnfv.org/download/attachments/2925933/TSC%20Charter%20May%2031-2016%20v2.pdf?version=1&modificationDate=1466094997000&api=v2
06:05:47 <ChrisPriceAB> #agree rpaik will update the www.opnfv.org page accodingly
06:06:02 <ChrisPriceAB> #topic Report out from the Design Summit
06:06:21 <ulik> #info Uli Kleber
06:06:36 <ChrisPriceAB> #info rpaik outlines that our design summit included over 300 people on day 1.
06:06:58 <ChrisPriceAB> #info today there will be a number of colocated events during the day with other communities
06:07:07 <Julien-zte> #info Julien
06:09:31 <ChrisPriceAB> #topic Q3 hackfest planning
06:10:09 <ChrisPriceAB> #info rpaik now that the second plugfest date has been determined in december our planning for hackfests is coalescing to a needed decision around our Q3 event
06:10:34 <ChrisPriceAB> #info two good options are the LinuxCon north america or OpenDaylight summit
06:11:13 <ChrisPriceAB> #info rpaik indicates LinuxCon would be a good option for the hackfest, where we would potentially run a meetup at the OpenDaylight summit
06:12:23 <trevor_intel_> #info Trevor Cooper
06:13:47 <rpaik> #info bjskerry notes that LinxuCon NA is about a month before the scheduled Colorado release date
06:14:17 <ChrisPriceAB> #agree the TSC agrees to pursue the Q3 hackfest at LinuxCon Toronto.
06:14:35 <ChrisPriceAB> #topic Colorado planning and activities
06:15:17 <ChrisPriceAB> #info dmcbride has been working with the infrastructure team at the summit to work thorugh release considerations.
06:16:14 <ChrisPriceAB> #info the team has identified challenges related to support of the armband project however in general infra is looking good for Colorado.
06:17:32 <ChrisPriceAB> #info An ARM POD will be established during August to support ArmBand.
06:17:44 <ChrisPriceAB> #topic MANO working group discussion
06:19:38 <rpaik> #info ChrisPriceAB notes that the MANO working group could be looking at things like common interfaces
06:20:09 <rpaik> #info the working group can also work on cross coordination
06:21:19 <ttallgren> We already have the security working group, so there is a precedent
06:21:50 <ChrisPriceAB> #info prakash outlines the discussion around MANO in relation to the project focusing on the integration of Open-O.
06:22:11 <ulik> @ttallgren: there is also test and infra wg
06:22:11 <collabot> ulik: Error: "ttallgren:" is not a valid command.
06:22:41 <ChrisPriceAB> #info prakash reflects on the challenge of achieving standards compliance across interfaces in open source projects.
06:23:57 <bryan_att> IMO we need to work this in two directions; what is already implemented in open source; a roadmap for *potential* covergence with MANO APIs to the extent they ever get stage 3 defined.
06:24:16 <ChrisPriceAB> #agree the TSC agrees that the establishment of a MANO working group is a good idea and supports it.
06:24:39 <bryan_att> IMO also the key part of the existing open source focus should be content (NSD/VNFD) portability
06:25:48 <bryan_att> I also don't think we should limit the focus to any specific set of open source projects in the conceptual MANO stack space
06:26:39 <rpaik> #info disccussion that existing working groups (e.g. security, infra, testing) in OPNFV do not have formal charters
06:26:42 <bryan_att> I agree we need to keep any such WG very light in organization and procedures; no formal charter etc.
06:27:15 <bryan_att> this is mostly a discussion forum to facilitate cross-project collaboration
06:27:45 <dneary> Joining IRC late...
06:27:49 <dneary> #info dneary
06:28:43 <dneary> bryan_att, I tend to think that common infrastructure and information model are the most important things to agree on across MANO projects
06:29:02 <ChrisPriceAB> #action prakash to raise the working group for discussion on the TWS and a time shall be set for the calls.
06:29:10 <dneary> NSD, VNFFGD, VNFD, and similar
06:29:15 <bryan_att> not sure what you mean by common infra
06:29:16 <ChrisPriceAB> #topic Joint TSC Board meeting preparation
06:29:28 <bryan_att> I agree on the info model
06:29:36 <dneary> ChrisPriceAB, That was to me
06:30:33 <dneary> bryan_att, I would add a shared message queue, app catalog, BPMS...
06:30:43 <ChrisPriceAB> #info dmcbride has prepared material for the meeting.
06:31:09 <ChrisPriceAB> #action dmcbride to distribute the material and TSC members to comment.
06:31:54 <bryan_att> dneary: OK, I agree there should be a common ground, e.g. what the MODM determined i.e. parsers, app catalog, multi-IaaS plugin frameworks - the other things you mention are good examples too
06:32:54 <ChrisPriceAB> #info uli-k outlines the SPC joint session is being discussed, the SPC goals will be shared openly now prior to the call.
06:33:28 <rpaik> #action rpaik to complete the Bitergia roadmap slides with dneary and also send out to the TSC mailing list
06:34:28 <bryan_att> Items Uli mentioned: NFV reference platform; NFV reference methodology; evolvability; scalability; global utility
06:34:37 <ChrisPriceAB> #info the SPC has an interest to form a working group to address long term planning and community themes
06:34:51 <ChrisPriceAB> #info to be discussed further at the Board/TSC f2f
06:35:02 <bryan_att> We will have to interpret those concepts with details to be sure we are all on the same page
06:35:08 <dneary> ulik, Is this related to this afternoon's "OPNFV strategy and roadmap" session?
06:35:23 <ChrisPriceAB> #topic TSC Governance discussion for the joint Board-TSC meeting
06:37:56 <rpaik> #info ChrisPriceAB discusses feedback on the TSC composition (e.g. improve the meritocratic nature of the TSC)
06:39:33 <rpaik> #info TSC constitution discussion includes maintain the current setup (with committer at large); migrate to an elected TSC; migrate to a fullt merit-based TSC
06:40:28 <dneary> ChrisPriceAB, "Best suits our needs" - can you summarise what those are, please?
06:41:44 <bryan_att> clarification: per the earlier comment, the TSC has "no qualified members" only because we have no agreed qualification method. We need to first agree upon such a method if we are to move toward a meritocratic TSC.
06:44:26 <bryan_att> Perhaps someone should put up a wiki page where what "best suits our needs" can be commented on by the existing TSC and membership. We need to get to know what the community thinks is needed.
06:44:47 <bryan_att> Not hearing the speaker well.
06:46:05 <dneary> bryan_att, Sorry - that was me. I asked the question I asked in channel - what are the trade-offs I don't see if we move away from designate TSC members?
06:47:27 <dneary> bryan_att, The first question was whether this was a board-driven discussion, whether we needed board approval, or whether the TSC was letting the board know what we wanted to do (ie not asking permission).
06:48:06 <rpaik> #info frankbrockners notes that there maybe a potentential tradeoff that we need to consider when Platinum members do not automatically get a TSC seat
06:48:25 <dneary> #info dneary asked whether this discussion was the board asking the TSC to change, the TSC asking the board to recommend a structure change, or the TSC informing the board of how we decide to change
06:48:33 <bryan_att> dneary: OK, that comes back to what "best suits our needs" input from the existing TSC and membership. It could be that what suits our needs is that we have TSC members with specific types of skillsets/focus, i.e. how you define merit is key, if you focus on merit at all.
06:49:05 <dneary> #info ChrisPriceAB says it could be any of the three, right now the board has flagged the concern that the TSC (and project) is perceived as pay-to-play
06:49:49 <dneary> #info dneary asked what "suits our needs" means, and what were the trade-offs which would prevent us going to a fully elected-from-community TSC
06:51:18 <bryan_att> ChrisPriceAB: we need to get the board to clarify what other types of ways to get to "play" are preferred vs "paying".
06:51:19 <dneary> #info Several replies - a TSC seat is one of the carrots we "sell" when getting Platinum members to pay; it has been useful to have designates to ensure that there is a communication channel from the community (TSC and projects) into the members
06:51:50 <dneary> #info ulik asks how it would work in practice - who would vote/choose TSC members?
06:53:04 <bryan_att> "What should be done" is at least to understand better the concerns that the Board is responding to. At this point we have a fairly vague concern over "pay to play". So I don't agree that anything needs to be done, other than 1st clarify the Board's concerns and get those who stimulated it to come forward and speak plainly about their concerns.
06:55:54 <dneary> #info Is there a concern about TSC size? The main issue is achieving quorum.
06:57:18 <dneary> #info If we have elected membership delegates, we should ensure other membership classes are represented.
06:58:04 <dneary> #info The by-laws allow the TSC to have committers elected to the TSC
07:00:00 <rpaik> #info if we can get a breakout room, we could have further discussions prior to the Board meeting
07:00:13 <rpaik> #endmeeting