13:59:34 <ChrisPriceAB> #startmeeting OPNFV TSC Meeting
13:59:34 <collabot`> Meeting started Tue Jul  5 13:59:34 2016 UTC.  The chair is ChrisPriceAB. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:59:34 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
13:59:34 <collabot`> The meeting name has been set to 'opnfv_tsc_meeting'
13:59:40 <ChrisPriceAB> #topic roll call
13:59:44 <dneary> Hi all
13:59:47 <dneary> #info dneary
13:59:50 <ChrisPriceAB> morning my neary
13:59:55 <ChrisPriceAB> #info Chris Price
14:00:02 <dneary> your neary?
14:00:03 <ChrisPriceAB> s/my/mr
14:00:08 <ChrisPriceAB> :)
14:00:14 <dneary> Rather familiar...
14:00:20 <Ceciliacorbi> #info Cecilia Corbi
14:00:26 <juhao> #info Juha Oravainen (proxy for Tapio Tallgren)
14:00:29 <Julien-zte> #info Julien
14:00:32 <ChrisPriceAB> #info Uli Kleiber (on the phone)
14:00:40 <jmorgan1> #info Jack Morgan (proxy for Brian Skerry)
14:01:13 <frankbrockners> #info Frank Brockners
14:01:56 <mdgray_> #info Mark Gray
14:02:06 <rprakash> #info rprakash
14:02:07 <ChrisPriceAB> #topic Previous meeting minutes
14:02:28 <ChrisPriceAB> #info to be postponed until next TSC call.
14:02:34 <StuartMackie> #info Stuart Mackie
14:02:36 <ChrisPriceAB> #topic Agenda Bashing
14:02:46 <ChrisPriceAB> #link https://wiki.opnfv.org/display/meetings/TSC current agenda
14:04:57 <ChrisPriceAB> #info uli-k would like to add the topic of the OpenStack operators NFV working group.
14:05:28 <ChrisPriceAB> #info GeraldK would like to raise the Colorado test freeze date as a topic to discuss
14:05:29 <GeraldK> #info Gerald Kunzmann
14:06:45 <ChrisPriceAB> #topic OPNFV CI development/evolution
14:07:08 <ChrisPriceAB> #link https://wiki.opnfv.org/display/INF/CI+Evolution plans to update our methodology for CI
14:07:14 <fdegir> https://wiki.opnfv.org/display/INF/CI+Evolution#CIEvolution-HowtheThingsFitTogether
14:07:48 <ChrisPriceAB> #link https://wiki.opnfv.org/display/INF/CI+Evolution#CIEvolution-HowtheThingsFitTogether a diagram of reference for Fatih's discussion.
14:08:54 <ChrisPriceAB> #info fdegir outlines the challenge of scale when handling multiple scenarios and multiple labs in our CI pipeline.  Our activities continue to grow release over release and some adjustment is needed in CI to accomodate that growth.
14:09:11 <mbeierl> #info Mark Beierl (Proxy for Edgar Stpierre)
14:09:55 <ChrisPriceAB> #info fdegir outlines the challenge of resource allocation and the opportunities we have to validate scenario's on virtual environments prior to utilising bare metal labs
14:10:03 <bryan_att> #info Bryan Sullivan
14:11:23 <ChrisPriceAB> #info fdegir outlines the challenges we have with test case stability, troubleshooting, and system stability with our current methodology.  Indicating a staged approach to validation of scenario's can aid in identifying where faults may occur.
14:12:04 <ChrisPriceAB> #info the main purpose of these changes is to increase the speed with which the CI system can provide feedback to designers on their work.
14:14:39 <cgoncalves> #info Carlos Goncalves
14:14:50 <cgoncalves> (proxy for Dirk K.)
14:17:10 <Julien-zte> #info it's different for a developer to set the scenarios affected and installers
14:17:22 <ChrisPriceAB> #info fdegir outlines that it should be possible that a committer can request to deploy or not to deploy the scenario based on the commit message.
14:17:58 * ChrisPriceAB is having trouble hearing fatih
14:18:09 <Julien-zte> hard to hear
14:18:19 <fdegir> I'll call in again
14:18:20 <fdegir> sorry
14:19:17 <ChrisPriceAB> #info GeraldK outlines the challenges involved in delaying some test cases for one week after a patch is pushed
14:19:42 <Julien-zte> as to support  the verify/gate job, projects must support UT and enough UT test cases.
14:22:11 <ChrisPriceAB> #info fdegir and geraldk both think pushing significant changes on our development environment during the least months of Colorado could be risky, and that the majority of impacting changes should be done earl in the D-River cycle.
14:22:26 <ChrisPriceAB> #info the current target is to get commit gating in place during Colorado
14:23:23 <ChrisPriceAB> #info uli-k asks that the commit message changes be well communicated to the community
14:24:14 <ChrisPriceAB> #info uli-k and fdegir forsee little to no risk to Colorado by introducing the commit gating process and commit messaging
14:25:12 <jmorgan1> ChrisPriceAB: can you add comment about implentation schedule (phase1is in progress and phase2 post release)?
14:26:16 <ChrisPriceAB> #info The current plan by the infra team is to implement phase 1 (commit gating) prior to the Colorado release, and the further scenario staging and testing processes after the Colorado release.
14:26:25 <mdgray_> It seems like the lower risk for colorado is an "opt-in" strategy.
14:28:36 <ChrisPriceAB> #info julien outlines the potential challenge of resource scheduling with this approach.
14:30:01 <mdgray_> fdegir: Is the intention that the virtual deploy becomes mandatory post Colorado?
14:30:06 <ChrisPriceAB> #topic Committer at large (CAL) elections to the TSC
14:32:41 <fdegir> mdgray_: if virtual deployment is applicable for given change, it should be mandatory - in my opinion
14:32:42 <mdgray_> fdegir: So on a per-scenario basis, it could be disabled?
14:32:44 <ChrisPriceAB> #info GeraldK asks about the use of the term committer at large in the context of the joining the TSC.
14:32:53 <fdegir> mdgray_: that's right
14:33:07 <fdegir> mdgray_: there will be cases a change might not impact the deployment itself
14:33:11 <mdgray_> fdegir: Thanks
14:33:30 <fdegir> mdgray_: but there 'are lots of questions and we will find the answers while we move on
14:34:50 <GeraldK> "If a member of a board of directors is said to be “at large”, that means that he/she does not have very specific duties like the other members of the board of directors might have. "
14:35:01 <GeraldK> source: http://www.programmerinterview.com/index.php/american-vocabulary/at-large-meaning/
14:36:24 <Julien-zte> #+1 for committer at least
14:38:22 <bryan_att> A contributor should be defined as those who make technical contributions by submitting  to a repo.
14:39:00 <ChrisPriceAB> #info in the discussion on whom should be able to run for a TSC position, there seems to be agreement among TSC members that the nominee's be restricted to committers.
14:39:12 <bryan_att> Editing a wiki, attending meetings, etc is not enough skin in the game. We need active contributors in concrete terms.
14:39:32 <mbeierl> bryan_att: agreed
14:39:42 <persia> I will recommend against the "committer" word, unless one is using something like SVN or CVS.  "Technical Contributor" or similar runs into less ACL issues with distributed workflows (e.g. bzr, git)
14:39:44 <bryan_att> The technical work is what moves this community forward.
14:40:06 <jmorgan1> bryan_att: how does a contributer commit to a repo? Isn't that what a commiter is?
14:40:14 <mbeierl> committer is a specific term only when used in conjunction with Gerrit
14:40:47 <mbeierl> "Contributor" can submit patches to code.  Committers are the only ones with the authority to merge those patches into the code base using Gerrit
14:40:50 <bryan_att> No, a committer merges patches. A contributor can submit anything for review.ma contributor does not have commit (merge) privilege.
14:41:14 <jmorgan1> mbeierl: bryan_att ah, ok. thanks
14:41:27 <persia> That's precisely the class of ACL issue that makes "Contributor" useful for anything outside gerrit :)
14:42:30 <bryan_att> We will obviously be sensitive to gaming the system. That's what the voting process is for,
14:43:23 <bryan_att> Existing TSC members should be voting.
14:43:31 <dneary> #info One potential concern is that committer status might not be a good proxy for activity - there are committers who are not active, and potentially very active non-committers
14:44:00 <dneary> #info frankbrockners states that it's theoretical, that an active contributor can easily becoime a committer
14:44:10 <mbeierl> #info but would the committer removal process that care of that, dneary ?
14:44:39 <Julien-zte> dneary, there is also the stepdown merchanizm in opnfv
14:45:10 <dneary> Julien-zte, There is, and we have seen some committer removals
14:45:33 <dneary> Julien-zte, It has been inconsistently applied by projects - the cost of leaving inactive committers in place is low
14:45:45 <ChrisPriceAB> #info at this time there is no concensus on whom would vote for the nominees
14:45:58 <ChrisPriceAB> #action rpaik to poll for more information
14:46:00 <dneary> bryan_att, Is there a way to draw a line around all contributors?
14:46:09 <Julien-zte> non active committer does affects the work in the project,either votes for new committers, new features, discussions
14:46:31 <bryan_att> Dreary: Yes, by Gerrit records.
14:46:40 <persia> dneary: The cost of leaving inactive committers in place is largely 1) people occasionally committing something without current code context, and 2) enlargening the pool of "committers", which can increase the bar for contributors to become committers.
14:46:47 <bryan_att> (Spell check)
14:47:03 <dneary> bryan_att, Gerrit reviews being the measurement for activity/contribution?
14:47:20 <persia> One can also get all contributors from git: just because someone submitted something for review isn't interesting, unless it was ultimately merged.
14:48:07 <bryan_att> Yes, review requests primarily, but also review comments etc.
14:48:14 <ChrisPriceAB> #info discussion on how many at large members we would want to have on our TSC.
14:49:14 <ChrisPriceAB> #info an option is to set a percentage of elected members as opposed to a given number.  dneary adds that the committer at large member number should not be coupled to the number of platinum member seats.
14:49:42 <dneary> 5 is a good number
14:50:12 <ChrisPriceAB> #info frankbrockners proposes 5 community members be added for the coming term.
14:51:19 <Julien-zte> #info frankbrockners suggested that we can evaluate this, including seats, long every year.
14:51:32 <ChrisPriceAB> #startvote Does the TSC agree to include 5 committer TSC seats for the 2016/2017 term?  (-1, 0, +1)
14:51:32 <collabot`> Begin voting on: Does the TSC agree to include 5 committer TSC seats for the 2016/2017 term? Valid vote options are , -1, 0, +1, .
14:51:32 <collabot`> Vote using '#vote OPTION'. Only your last vote counts.
14:51:36 <dneary> #vote +1
14:51:39 <ChrisPriceAB> #vote +1
14:51:40 <frankbrockners> #vote +1
14:51:42 <GeraldK> #vote 0
14:51:45 <juhao> #vote +1
14:51:46 <uli-k_> #vote +1
14:51:47 <bryan_att> #vote +1
14:51:47 <mbeierl> #vote +1
14:51:50 <StuartMackie> #vote +1
14:51:55 <mbeierl> #info Proxy for Edgar Stpierre
14:51:57 <cgoncalves> #vote 0
14:51:58 <Julien-zte> #vote +1
14:52:00 <jmorgan1> #vote +1 (proxy for Brian Skerry)
14:52:00 <collabot`> jmorgan1: +1 (proxy for Brian Skerry) is not a valid option. Valid options are , -1, 0, +1, .
14:52:08 <jmorgan1> #vote +1
14:52:14 <ChrisPriceAB> #endvote
14:52:14 <collabot`> Voted on "Does the TSC agree to include 5 committer TSC seats for the 2016/2017 term?" Results are
14:52:14 <collabot`> 0 (2): GeraldK, cgoncalves
14:52:14 <collabot`> +1 (10): dneary, Julien-zte, juhao, frankbrockners, bryan_att, uli-k_, ChrisPriceAB, StuartMackie, mbeierl, jmorgan1
14:52:24 <jmorgan1> #info proxy for Brian Skerry
14:52:52 <ChrisPriceAB> #startvote Does the TSC agree to start the committer election process on the 8th of August?  (-1, 0, +1)
14:52:52 <collabot`> Begin voting on: Does the TSC agree to start the committer election process on the 8th of August? Valid vote options are , -1, 0, +1, .
14:52:52 <collabot`> Vote using '#vote OPTION'. Only your last vote counts.
14:53:21 <frankbrockners> #vote +1
14:53:22 <bryan_att> #vote +1
14:53:23 <StuartMackie> #vote +1
14:53:23 <ChrisPriceAB> #vote +1
14:53:24 <dneary> #vote +1
14:53:26 <mbeierl> #vote +1
14:53:31 <juhao> #vote +1
14:53:33 <mbeierl> #info Proxy for Edgar Stpierre
14:53:40 <uli-k_> #vote +1
14:53:41 <Ceciliacorbi> #vote +1
14:53:42 <cgoncalves> #vote +1
14:53:42 <jmorgan1> #vote 0
14:53:44 <Julien-zte> #vote 0
14:53:46 <GeraldK> #vote 0
14:53:47 <jmorgan1> #info proxy for Brian Skerry
14:53:53 <ChrisPriceAB> #endvote
14:53:53 <collabot`> Voted on "Does the TSC agree to start the committer election process on the 8th of August?" Results are
14:53:53 <collabot`> 0 (3): GeraldK, Julien-zte, jmorgan1
14:53:53 <collabot`> +1 (10): frankbrockners, juhao, cgoncalves, dneary, bryan_att, ChrisPriceAB, uli-k_, StuartMackie, Ceciliacorbi, mbeierl
14:54:29 <ChrisPriceAB> #topic Colorado planning and activities
14:55:04 <ChrisPriceAB> #info dcmcbride outlines that the feature freeze milestone was last friday, david has been in contact with the PTL's around status for this milestone
14:55:46 <ChrisPriceAB> #info the compass team is pending a merge for the installer freeze, this is being followed up regularly by david
14:56:22 <dneary> Ja
14:56:30 <dneary> (sorry, wrong channel)
14:56:50 <ChrisPriceAB> #info a number of projects that had expressed intent to participate in Colorado will not longer participate.
14:57:19 <ChrisPriceAB> #info  These projects have withdrawn from Colorado;  escalator, resource scheduler and policy test
14:58:03 <ChrisPriceAB> #info dmcbride outlines that some process should be put in place to better track projects participation and status
14:58:52 <ChrisPriceAB> #info geralk outlines some concerns with the test freeze date of this thursday as there are some test case development activities that may not make the date.
14:59:26 <ChrisPriceAB> #info dmcbride outlines the freeze date is for implementation it is not gating on test case success.
15:00:29 <jmorgan1> thanks
15:00:38 <ChrisPriceAB> #action dmcbride to follow up on the colorado call
15:00:43 <ChrisPriceAB> #endmeeting