07:04:44 <joehuang> #startmeeting multisite
07:04:44 <collabot`> Meeting started Thu Jul  7 07:04:44 2016 UTC.  The chair is joehuang. Information about MeetBot at http://wiki.debian.org/MeetBot.
07:04:44 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
07:04:44 <collabot`> The meeting name has been set to 'multisite'
07:04:46 <margaret> more of which one is going into the 'C' release and which openstack release. As you know for carriers multi-site is important
07:05:40 <joehuang> wait few minutes, Meimei is coming
07:05:49 <May-meimei> #info meimei
07:06:02 <joehuang> #info joehuang
07:06:13 <SAshish> #info Ashish
07:06:24 <sorantis> #info dimitri
07:06:29 <margaret> #info margaret
07:07:22 <joehuang> yes, had long discussion with Gluon and Bin in Berlin summit
07:08:42 <joehuang> We just had a meeting together with NetReady this Tuesday about L2 networking and underlay networking
07:08:58 <joehuang> do you have more to discuss in this meeting
07:09:23 <margaret> go over the topics you were originally planning on doing and i can add my questions after then
07:10:08 <joehuang> ok
07:10:43 <joehuang> #topic Functest, CI integration of Kingbird
07:10:50 <joehuang> hello, Meimei
07:11:15 <May-meimei> joehuang: hi
07:11:22 <May-meimei> Ihave run all the step manually
07:11:36 <May-meimei> just the testing part
07:11:47 <joehuang> does it work?
07:11:54 <SAshish> Did you take the latest code
07:12:14 <May-meimei> latest tempest ?
07:12:18 <SAshish> Kingbird
07:12:44 <May-meimei> Ithink I pulled the latest one
07:12:49 <SAshish> okay
07:13:24 <May-meimei> we don't have automatic deployment of multisite, but we need a automatic functest first?
07:13:28 <May-meimei> yes?
07:13:47 <sorantis> yes
07:13:53 <joehuang> yes, CI/Functest on pre-configured multi-site test bed
07:14:05 <sorantis> there will be a jenkins job that will trigger update on the target node
07:14:07 <joehuang> #link https://jira.opnfv.org/browse/FUNCTEST-179
07:14:33 <May-meimei> ok,I will make a detail plan today
07:15:12 <joehuang> #link https://docs.google.com/presentation/d/12Svp-mv9ROHDxE7ifrrBGEm1IBM6DPzniISX2OiXBWc/edit#slide=id.p
07:15:46 <joehuang> and Dimitri, could you provide the detail environment setting to connect to kingbird service in intel pod 4
07:16:27 <SAshish> the Jumpserver IP is changed
07:16:29 <joehuang> and publish it in the wiki page in https://wiki.opnfv.org/display/multisite/Kingbird+integration
07:17:30 <joehuang> for example, adminrc, openstack endpoint list
07:17:31 <sorantis> integration or environment settings?
07:17:37 <sorantis> these are two different things
07:18:13 <joehuang> in tempest, there are several configuration is related to the SUT( system under test)
07:18:28 <sorantis> https://review.openstack.org/#/c/330473/
07:19:19 <sorantis> I will update the page with relevant info
07:20:14 <joehuang> good
07:20:36 <joehuang> I'll update what's the information is needed in tempest.conf
07:21:09 <SAshish> also Joe: Do you remember we were not able to generate kb specific new configurations in tempest.conf
07:21:17 <joehuang> #action update wiki page for the relevant info for tempest test in intel pod4
07:21:22 <SAshish> and you told you will talk to tempest guys
07:21:28 <SAshish> Did you talk?
07:21:41 <SAshish> configurations such as: kb_url
07:21:44 <joehuang> the bug is fixed it could be now, for this patch has been merged
07:22:47 <SAshish> it adds new value for existing group
07:23:01 <SAshish> Eg: for [service_available] it adds kingbird = true
07:23:03 <joehuang> https://review.openstack.org/#/c/328683/
07:23:10 <joehuang> yes
07:23:38 <SAshish> but I am telling about new configuration section
07:23:39 <joehuang> the kingbird plugin configuration now could be generated in tempest.conf.samle
07:24:10 <SAshish> KBGroup = [     cfg.StrOpt(name='endpoint_type',                default='publicURL',                help="Endpoint type of Kingbird service."),     cfg.IntOpt(name='TIME_TO_SYNC',                default=30,                help="Maximum time to wait for a sync call to complete."),     cfg.StrOpt(name='endpoint_url',                default='http://127.0.0.1:8118/',                help="Endpoint URL of Kingbird service."),     cfg
07:24:29 <SAshish> these values should come in tempest.conf
07:24:30 <joehuang> https://review.openstack.org/#/c/328683/4/kingbird/tests/tempest/scenario/config.py
07:24:35 <joehuang> sure
07:24:50 <SAshish> Does it come now?
07:25:15 <joehuang> I tested, it could be generated together with tempest conf, if you run tox -egenconfig under tempest root folder after the plugin is discovered by tempest
07:25:23 <joehuang> yes, it comes
07:25:44 <SAshish> it creates a new [kingbird] section??
07:26:07 <joehuang> of course, a new [kingbird] section
07:26:15 <SAshish> I tested it yestreday, It didnt come. will try again
07:26:28 <joehuang> and one more configuration to enable kingbird service test or not
07:27:50 <SAshish> okay
07:29:07 <joehuang> under [service_available] section
07:29:23 <SAshish> yeah. that is fine
07:29:33 <SAshish> I am worried about new section [kingbrid]
07:30:09 <joehuang> don't worry, if something not working, ping me please
07:30:26 <SAshish> sure
07:30:30 <joehuang> #topic Integration test
07:30:55 <joehuang> hi Ahish, how about the test after the rpc refactoring?
07:31:44 <SAshish> yeah. I am able to run tempests manually
07:31:49 <SAshish> all passed
07:32:02 <joehuang> great news
07:32:10 <SAshish> Joe: Please have a look at new section [kingbrid] in tempest.conf
07:32:15 <SAshish> it is not getting generated
07:32:21 <SAshish> I have tested just now
07:32:47 <SAshish> only kingbird = True under [service_available]  is generated
07:33:04 <joehuang> was the kingbird tempest test cases discovered by tempest
07:33:28 <joehuang> with no error in discovering
07:36:07 <SAshish> yes, yesterday I tried. it discovered but no kb section in conf
07:36:38 <SAshish> downloading fresh tempest. will mail you
07:37:00 <joehuang> you can use following command to debug endpoint discovering
07:37:37 <SAshish> testr list-tests | grep quota-management
07:37:52 <SAshish> to list testcases for kb
07:38:13 <joehuang> sudo pip install entry_point_inspector  epi group list  epi group show tempest.test_plugins  epi ep show tempest.test_plugins kingbird_tests
07:38:23 <joehuang> sorry one by one
07:38:36 <joehuang> sudo pip install entry_point_inspector
07:38:42 <joehuang> epi group list
07:38:49 <joehuang> epi group show tempest.test_plugins
07:39:29 <SAshish> yes it shows
07:39:29 <joehuang> when you find kingbird in the result, then run
07:39:46 <joehuang> epi ep show tempest.test_plugins kingbird_tests
07:40:20 <joehuang> 'kingbird_tests' need to be replaced with the info you see in the epi group show tempest.test_plugins for kingbird
07:40:55 <joehuang> ok, I'll try it again after the meeting for the latest code
07:41:02 <SAshish> yeah. plese
07:42:05 <joehuang> if error occured in the result after run above commands, need to fix it before generate tempest.conf.sample
07:43:05 <joehuang> the generated tempest.conf.sample is under the sub-folder of tempest: in the tempest root folder, cd etc/
07:43:18 <joehuang> then you will find the tempest.conf.sample
07:44:14 <SAshish> yeah. I have tried and let us continue this over mail.
07:44:25 <joehuang> ok
07:44:46 <joehuang> other topics?
07:44:50 <SAshish> please try to generate at your and see
07:44:56 <SAshish> at your end*
07:45:06 <sorantis> just one announcement
07:45:08 <margaret> yes i have question on which use cases are getting pulled into tempest ?
07:45:43 <joehuang> currently in release C only kingbird test cases
07:46:16 <joehuang> to Dimitri, please
07:46:19 <sorantis> registering python-kingbirdclient for D release
07:46:19 <margaret> and what is the kingbird test cases?
07:46:21 <sorantis> https://review.openstack.org/#/c/337254/
07:46:47 <joehuang> quota control over multisite
07:47:09 <joehuang> more exactly, centralized quota management
07:47:18 <SAshish> Dimitri: Cool
07:47:22 <margaret> are you going to add the gluon requirements as another set of use cases?
07:47:49 <margaret> sorry since i am new to this - what is quota management?
07:48:01 <joehuang> cool
07:48:30 <sorantis> syncrhonization of quota limits across muliple openstack regions
07:48:45 <joehuang> A dedicated project gluon was just opened in OpenStack
07:48:45 <margaret> quota of what?
07:49:06 <margaret> ok i need to talk with bin thanks on the gluon
07:49:32 <sorantis> virtual resource quota
07:49:49 <margaret> ok thanks
07:49:49 <sorantis> e.g. the number of instances a user is allowed to run
07:49:53 <joehuang> I don't know whether there is a project in OPNFV about Gluon
07:49:56 <SAshish> nova/cinder/neutron
07:50:08 <margaret> project netready is technically gluon project
07:50:18 <joehuang> ok, understand
07:51:28 <joehuang> not sure NetReady will integrate Gluon into release C or not
07:52:22 <margaret> well goal was to figure out what gluon should do based on the use case and then decide if we needed a new openstack project or fold into the L3VPN openstack project - i guess they decided to have new
07:52:55 <joehuang> yes, a new project started by Bin
07:53:23 <joehuang> https://wiki.openstack.org/wiki/Gluon
07:53:33 <margaret> multi-site lists 3 use cases - are any of these implemented fully yet?
07:53:38 <joehuang> I helped him a little on the project preparation
07:54:06 <joehuang> use case 1 already in trunk
07:54:25 <joehuang> use case2/3 are still in developing in community
07:54:37 <margaret> great
07:54:50 <joehuang> kingbird/tricircle is mainly for use case 4/5
07:54:58 <margaret> when do you see use case 2/3 to be 'completed' - ie which openstack release
07:55:14 <joehuang> and tricircle will deal with cross site overlay L2 networking
07:56:07 <joehuang> hopefully in N, but may be delayed to O, for L2GW is not active project, no enough core reviewer in L2GW
07:56:46 <joehuang> I mentioned in the meeting log in the mail to mail-list for netready/multisite
07:57:11 <margaret> ok ill just talk with bin
07:57:16 <joehuang> for tenant level volume replication, community may introduce this feature in N release
07:58:30 <joehuang> more topics?
07:59:28 <SAshish> not from my side
07:59:35 <margaret> i'm fine
07:59:48 <joehuang> ok, think you for attending meeting, especially Margaret, it's late into night in USA/
07:59:52 <sorantis> i’m good
07:59:57 <joehuang> let's conclude the meeting
08:00:04 <joehuang> #endmeeting