13:58:58 <mbeierl> #startmeeting Test and Performance Weekly Meeting
13:58:58 <collabot> Meeting started Thu Jul 14 13:58:58 2016 UTC.  The chair is mbeierl. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:58:58 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
13:58:58 <collabot> The meeting name has been set to 'test_and_performance_weekly_meeting'
13:59:04 <steveg> mbeierl: it is not specific to openstack, but I want to know how generally building VNF happens
13:59:09 <mbeierl> #topic Roll Call
13:59:13 <steveg> mbeierl: thanks for the pointers :)
13:59:25 <acm> #info Al Morton
13:59:34 <mbeierl> steveg: you're welcome and I hope that helps...
13:59:46 <mbeierl> #info Mark Beierl
14:00:06 <mbeierl> hmm... we're not getting feedback from callabot on #topic again...
14:00:16 <Mingjiang5> #info Mingjiang
14:00:24 <mbeierl> Launching GTM now
14:01:00 <yujunz> #info Yujun Zhang
14:01:20 <dmcbride> #info David McBride
14:01:25 <kubi001> #info kubi
14:02:20 <mbeierl> Oh dear... new laptop and my GTM login is not stored
14:02:27 <dmcbride> which GTM?
14:02:31 <mbeierl> I forgot my password :( so I cannot start it at the moment
14:02:41 <dmcbride> I have this:  https://global.gotomeeting.com/join/305553637
14:02:46 <mbeierl> https://global.gotomeeting.com/join/305553637
14:02:50 <mbeierl> Yes, that's the one
14:03:04 <mbeierl> wait... is that Trevor's Intel one?
14:03:08 <dmcbride> But I'm not the organizer
14:03:35 <dmcbride> Do you want me to start a different one?
14:03:48 <mbeierl> I'm not an organizer either apparently
14:04:01 <mbeierl> Yes, let's start a new one and I'll send out an email to the list
14:04:18 <kubi001> mbeierl:  tech-projects2@opnfv.org/4opnfv-projs2
14:04:27 <makullbe> mbeierl: Can you paste the link here as well?
14:05:42 <Mingjiang5> you can use the account mentioned by kubi001, i think we're using the same one.
14:05:47 <mbeierl> kubi001: "You don't have organizer access to this meeting"
14:05:52 <mbeierl> Let me try the other one
14:06:22 <kubi001> mbeierl: yes, you are right
14:06:25 <dmcbride> We can use this for today
14:06:27 <dmcbride> https://www.gotomeet.me/DavidMcBride
14:06:43 <dmcbride> I'm on GTM now
14:07:16 <mtahhan> sorry, i've joined late is https://www.gotomeet.me/DavidMcBride for the testing subgroup call or for whatever is clashing right now ?
14:07:33 <dmcbride> testing
14:07:39 <dmcbride> this is just for today
14:07:45 <mbeierl> #chair dfarrell07
14:07:45 <collabot> Current chairs: dfarrell07 mbeierl
14:08:01 <Mingjiang5> https://global.gotomeeting.com/join/853047565
14:08:24 <acm> #chair acm
14:08:43 <mtahhan> #info Maryam Tahhan
14:08:46 <mbeierl> #chair acm
14:08:46 <collabot> Current chairs: acm dfarrell07 mbeierl
14:08:53 <mtahhan> I have to drop at half past
14:09:12 <mbeierl> Mingjiang5: we are in David's room: https://www.gotomeet.me/DavidMcBride
14:09:38 <Mingjiang5> mbeierl: i'm in
14:09:52 <acm> #topic agenda
14:10:59 <dfarrell07> ah, great "we apologize, but an error occurred while connecting to computer audio. Please call in from a telephone."
14:11:00 <acm> defer Alan Sardella' test paper to a future meeting
14:11:16 <acm> #action mark send time change e-mail
14:11:30 <dfarrell07> #info defer Alan Sardella' test paper to a future meeting
14:11:52 <acm> #action mark send new GTM URL for future meetings while Trevor out
14:12:38 <acm> #topic Yardstick test Scenarios
14:12:57 <dfarrell07> yay, finally have working audio
14:13:32 <mbeierl> dfarrell07: yay!
14:14:19 <acm> Yardstick slides show new test organization based on scenario deployed
14:14:24 <dfarrell07> #info Yardstick talks about proposals for how we trigger tests from scenarios
14:14:39 <dfarrell07> acm, use #info to take normal notes
14:14:48 <acm> some agreement expressed with scenario-oriented test suites
14:15:04 <acm> every time?  ok
14:15:13 <dfarrell07> #info Proposal would kick off more specific tests per-scenario
14:15:32 <dfarrell07> acm: yeah, to get it in the minutes (vs just log)
14:16:05 <dfarrell07> #info Info about how to change JJB to do this new way of kicking off smaller sets of tests
14:16:41 <mbeierl> dfarrell07: not sure that this is JJB yaml.  I think it is Yardstick specific ua,;
14:16:43 <mbeierl> yaml
14:16:49 <dfarrell07> #undo
14:16:49 <collabot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x27a0990>
14:17:02 <dfarrell07> #info Info about how to change yardstick yaml config to do this new way of kicking off smaller sets of tests
14:17:07 <mbeierl> :)
14:17:20 <dfarrell07> mbeierl: was just starting to think "humm, this syntax is different"
14:17:23 <dfarrell07> mbeierl: thanks :)
14:19:31 <acm> #info this organization adds constraints on the test files (yaml)
14:20:00 <acm> #info planned for Colorado, work in progress.
14:20:19 <dfarrell07> #info examples of constraints include which installer is being run
14:20:34 <dfarrell07> #info Dave points out that we're past some relevant milestones for C, maybe should do in D
14:20:42 <acm> #info Dave, we are past the infra milestone for Colorado, consider for release D
14:20:52 <dfarrell07> acm: it's okay to have dups like that, FYI
14:21:41 <dfarrell07> #info Feedback that proposal is helpful, some +1s that it may be more approprate for D
14:22:51 <dfarrell07> #info Dave points out that we're in the stabilization phase, past infra update milestone, so changing infra this late in release is concern
14:23:00 <acm> #info Maryam, is this not more relevant to the test milestone?
14:23:42 <dfarrell07> #info Maryam points out that the milestone Dave was referencing is more about hardware infra, not tests
14:23:49 <acm> #info Dave, I take the point  Kubi, change can take place in one week, not a big change
14:24:34 <acm> #info Mark, who takes responsibility to modify current test cases?
14:25:05 <dfarrell07> #info Kubi points out that existing tests are mostly generic, not specific to pods, so these constraint changes wouldn't touch them
14:25:08 * dfarrell07 has audio lag
14:25:34 <dfarrell07> yujunz: yeah, we can't hear you
14:25:45 <yujunz> I'll try to type
14:26:00 <mbeierl> thanks!
14:26:20 <yujunz> So, are we going to leave constraint implementation to next release and implement only the convertion part?
14:26:39 <yujunz> Since constraint is not defined yet and something is unpredictable
14:27:54 <mbeierl> #info Mingjiang5: Constraints are not implemented as part of this change
14:27:56 <acm> #info Maryam, will commit gate be able to detect if this fails?
14:28:36 <dmcbride> This change should be limited to what yujunz cam complete in the next week
14:29:02 <dfarrell07> dmcbride:  you can #info that
14:29:05 <mbeierl> #info question from yujunz: are we going to leave constraint implementation to next release and implement only the convertion part? Since constraint is not defined yet and something is unpredictable
14:29:24 <dmcbride> #info This change should be limited to what yujunz cam complete in the next week
14:29:50 <dmcbride> #info Should not require any effort from project teams for release C
14:29:51 <kubi001> dmcbride: not yunjunz, It's Mingjiang
14:29:59 <dmcbride> ah - sorry
14:30:15 <kubi001> dmcbride: yes, not more require from other teams
14:30:20 <mbeierl> Mingjiang5: the question from mtahhan is "will commit gate be able to detect if this fails?"
14:30:47 <dmcbride> #info #info This change should be limited to what Mingjiang5 cam complete in the next week
14:32:02 <dfarrell07> #info Kubi answers Meryam that team wants to enhance commit gate to run real tests in virtual pod
14:32:33 <dfarrell07> #info Mark clarifies that question is "is there code level test for constraints, to see if they work before merge"
14:32:49 <dmcbride> #info we should action Mingjiang5 to provide status at this meeting until change is completed
14:33:08 <acm> #info Mark clarifies: is there a test on the constaint code, before it will be merged?
14:33:33 <dfarrell07> #info Yardstick Gerrit changes undergo unit tests, implication is that this would be covered
14:33:52 <acm> #info Kubi, yes we will test it , of course
14:34:45 <dfarrell07> #info Summery seems to be that this should go ahead, as long as it doesn't take a long time (week), doesn't require big changes from test projects, and status reported here until complete
14:35:42 <dfarrell07> #info Testing white paper topic deferred until next week
14:35:48 <dfarrell07> #topic Time of meeting
14:35:58 <dfarrell07> #info Do we want to keep this time and add one? Move slot?
14:36:50 <dfarrell07> #info Kubi points out that there's a Asia/Eu testing meeting on Wed
14:38:19 <dfarrell07> #info Bi-weekly Wed 830UTC is the Asia/Eu meeting Kubi was talking about, it's on the wiki but apparently not many were actually attending
14:38:45 <dfarrell07> #info Do we want to restart that meeting? Yardstick gives +1, asks for feedback from others
14:39:30 <yujunz> I think weekly meeting is already enough
14:39:49 <mbeierl> 8:30 AM Thursday, Coordinated Universal Time (UTC) is
14:39:50 <mbeierl> 4:30 AM Thursday, Eastern Time (ET)
14:42:08 <mbeierl> #info suggestion from dfarrell07: have 1 meeting a month that is APAC friendly
14:42:27 <mbeierl> #info that is, to change the time for that one meeting
14:42:49 <mbeierl> #info would that be helpful for APAC members?
14:42:53 <acm> #info Al Morton
14:43:07 <dfarrell07> #info dfarrell07 (Eastern Time) says he can suck it up and do one meeting a month at 4:30AM
14:43:17 <dfarrell07> #info dfarrell07 asks if there are people in APAC for which this would be helpful
14:43:32 <mbeierl> yujunz: sorry we have lost your audio again
14:43:44 <dfarrell07> #info meeting continues to be plagued with audio issues :(
14:44:25 <dfarrell07> yujunz: are you in APAC? would this be helpful for you?
14:44:40 <yujunz> Yes, I'm in Shanghai
14:44:59 <yujunz> But I'm OK with current slot.
14:45:28 <yujunz> If we starts a new APAC meeting, who will not be able to join?
14:45:35 <mbeierl> #info dfarrell07 asks if there is anyone who wants a time change?
14:46:14 <acm> #action Mark to ask about meeting times in the summary e-mail
14:46:22 <dfarrell07> #info mbeierl to send email to group asking if an APAC-friendly timezone meeting would be helpful, since of course the people here can make this time work
14:46:26 <dfarrell07> #undo
14:46:26 <collabot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2c97a90>
14:46:29 <kubi001> sounds good
14:46:32 <dfarrell07> #action mbeierl to send email to group asking if an APAC-friendly timezone meeting would be helpful, since of course the people here can make this time work
14:47:03 <mbeierl> #topic AoB?
14:47:13 <mbeierl> feel free to type here if there is anything else
14:47:39 <yujunz> Where can I find the table of meeting host?
14:47:47 <yujunz> It seems I didn't get that mail
14:47:50 <mbeierl> I will add that to the wiki
14:48:01 <dfarrell07> #info yujunz asks "Where can I find the table of meeting host?", mbeierl will add it to wiki
14:48:04 <mbeierl> It was in an email from July 1,
14:48:12 <mbeierl> so I will update the wiki with it
14:48:21 <yujunz> OK. Thansk
14:48:34 <dfarrell07> #action mbeierl to add meeting chair/minutes info to wiki
14:50:04 <dfarrell07> #endmeeting