07:04:22 <joehuang> #startmeeting multisite
07:04:22 <collabot> Meeting started Thu Jul 28 07:04:22 2016 UTC.  The chair is joehuang. Information about MeetBot at http://wiki.debian.org/MeetBot.
07:04:22 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
07:04:22 <collabot> The meeting name has been set to 'multisite'
07:04:28 <joehuang> hi Dimitri
07:04:30 <SAshish_> okay, Can you update patch?
07:04:33 <SAshish_> Hi Dimitri
07:04:47 <sorantis> morning
07:04:51 <joehuang> I can update a patch, but may be more than one place
07:05:17 <joehuang> we just talked about that the configure generation still not successfully
07:05:43 <joehuang> one bug in kingbird_lock.py, one bug in the tox.ini
07:05:44 <SAshish_> Dimitri, Can you share todays jenkins link?
07:06:08 <sorantis> hang on
07:07:38 <sorantis> https://build.opnfv.org/ci/view/functest/job/functest-fuel-virtual-suite-master/
07:08:21 <sorantis> you mean this one?
07:08:30 <sorantis> “Found more than one valid endpoint. Use a more restrictive filter”
07:08:39 <sorantis> there’s no filtering based on region
07:09:11 <SAshish_> what about our daily build?
07:09:51 <sorantis> https://build.opnfv.org/ci/view/multisite/job/multisite-kingbird-daily-master/
07:12:14 <joehuang> can figure out installation successful or not, and the test successful or not
07:12:34 <joehuang> how to check that
07:13:05 <SAshish_> so we have jobs and subjobs
07:13:59 <SAshish_> daily master has three subjobs: 1 build, 2 functest health check & 3 functest tempest
07:14:46 <joehuang> the second one is same as the third one?
07:16:07 <SAshish_> no both are differenct, 2 == heathchecks & 3 == multisite tempest
07:16:19 <SAshish_> that is what Meimei has told me yesterday
07:16:23 <SAshish_> is she around?
07:16:41 <joehuang> she said she will be online, but not find her here
07:17:13 <SAshish_> okay, so there is some issue with deploy right now. will have to run deploy manually once and check
07:17:48 <joehuang> do you know where to find the tempest test result
07:19:04 <SAshish_> yeah, it comes on console when we run that
07:19:12 <SAshish_> inside docker
07:19:14 <joehuang> Meimei said the tempest test cases could be executed through the job against kingbird, isn't it
07:19:26 <SAshish_> yes
07:19:49 <joehuang> I wonder to know where to find the result in the daily job
07:20:33 <May-meimei> hi
07:20:34 <joehuang> OPNFV output is quite different from that in OpenStack
07:20:38 <joehuang> hi Meimei
07:20:58 <joehuang> where to find the functest result in the daily job
07:20:59 <SAshish_> Hi Meimei
07:21:31 <May-meimei> https://build.opnfv.org/ci/view/multisite/job/multisite-kingbird-daily-master/14/
07:21:41 <May-meimei> we failed in the first step
07:22:11 <joehuang> console output?
07:22:28 <May-meimei> api_pid=dead
07:22:57 <May-meimei> but if you can confirm that api-server is working,we can trigger it now
07:23:39 <SAshish_> yeah, you can trigger. I dnt have access from here.
07:23:52 <May-meimei> SAshish_: ok!
07:23:53 <SAshish_> Dimitri can you check if services are up
07:24:08 <SAshish_> I have connected from home
07:24:13 <sorantis> I’m looking at it right now
07:24:36 <SAshish_> I am sure we will get "“Found more than one valid endpoint. Use a more restrictive filter”"
07:24:56 <SAshish_> which we got when we ran manully from Functest container
07:25:07 <sorantis> the services are up
07:25:27 <SAshish_> okay, can trigger now
07:25:28 <May-meimei> https://build.opnfv.org/ci/view/functest/job/functest-fuel-virtual-suite-master/11/console
07:26:45 <SAshish_> endpoints needs to be filtered
07:28:39 <joehuang> still in building functest container image
07:29:37 <joehuang> Command "git read-tree -mu HEAD" returned status code 128:
07:29:37 <joehuang> stdout:
07:29:39 <joehuang> stderr: fatal: Not a valid object name HEAD
07:30:03 <joehuang> what's this error, does it affect the job
07:30:41 <SAshish_> I suspect one issue
07:30:49 <SAshish_> kinbgird endpoint url
07:30:56 <SAshish_> let us see
07:34:24 <joehuang> service url should include {project-id}
07:34:55 <joehuang> like this one: http://127.0.0.1:877 |
07:34:57 <joehuang> | c43a8f28321f8       |           |              |                | 74/v2.1/$(tenant_id | 74/v2.1/$(tenant_id | 4/v2.1/$(tenant_id)s
07:35:06 <joehuang> sorry , wrong format
07:35:53 <joehuang> http://127.0.0.1:8774/v2.1/$(tenant_id)s
07:36:05 <joehuang> the endpoint is registered with wrong format
07:36:46 <joehuang> this one http://192.168.0.2:8774/v2.1 is incorrect
07:37:09 <joehuang> dimitri/ashish/meimei, can you see my message
07:37:55 <joehuang> nova/cinder url needs to include /$(tenant_id)s after the version in the url
07:38:15 <SAshish_> are these for regionOne or regiontwo?
07:38:22 <joehuang> both
07:38:45 <joehuang> both return wrong url format, no /$(tenant_id)s included
07:39:03 <SAshish_> I guess we did not modify the service url
07:39:10 <SAshish_> Dimitri: Have we?
07:39:21 <joehuang> I saw that in installation script
07:39:51 <sorantis> the endpoints are registered by Fuel
07:39:56 <SAshish_> yes
07:40:03 <sorantis> I don’t think there’s anything wrong with them
07:40:11 <sorantis> this is not the issue anyway
07:40:31 <sorantis> the issue is that the code in functest cannot distinguis endpoints in different regions
07:41:35 <joehuang> do you have specifed the region=RegionOne in compute and volume tempest configuration?
07:41:42 <joehuang> this must be configured
07:42:37 <joehuang> there is one option for region in compute and volume configuration section
07:42:47 <SAshish_> we did not add anything in tempest configuration except kingbrid section, services available for kingbird service
07:42:53 <joehuang> but I think the format fuel registered is incorrect
07:43:08 <sorantis> Joe it cannot be, because everything works
07:43:25 <SAshish_> functest has to adhere fuel based setup
07:43:29 <sorantis> the issue is that functest code is not optimizied to account for multiple regions
07:43:45 <joehuang> no, in the past only one region is tested, not multiple region returned, you have to configure the "region" option now
07:44:09 <sorantis> yes, but this is not for us to decide
07:44:21 <sorantis> we can register a bug in functest
07:44:34 <SAshish_> yes, a issue in jira
07:44:36 <sorantis> and whoever works in functest should respond
07:44:46 <joehuang> great
07:45:21 <SAshish_> #action we can register a bug in functest
07:46:20 <joehuang> can't disable one region in the environment, to make the flow work first?
07:46:31 <joehuang> sorry, wrong type
07:46:46 <joehuang> can we disable one region in the environment, to make the flow work first?
07:48:51 <joehuang> dimitri, could you help to check whether the endpoint url in other fuel environment like this can pass the tempest test
07:49:13 <sorantis> I don’t see the point. If there’s an issue in functest it should be fixed
07:49:40 <SAshish_> Its too much of reconfiguration
07:50:37 <joehuang> ok
07:51:14 <SAshish_> I see Jose has joined the meeting, Can he help with the issue?
07:51:24 <joehuang> Hello, Jose?
07:53:16 <joehuang> no response from Jose
07:54:33 <joehuang> hello, Ashish, is there any one of tempest test case of kingbird passed in the functest in the past
07:55:04 <SAshish_> No it did not trigger any
07:55:40 <joehuang> ok thank you
07:55:41 <SAshish_> it generated the conf properly, then it listed all kb testcases properly
07:55:58 <SAshish_> but no triggering of testcase
07:56:25 <joehuang> in functest container in the daily job?
07:56:30 <SAshish_> yes
07:56:45 <SAshish_> yesterday, me and Meimei checked that
07:57:39 <joehuang> is this get_instances(nova_client) a test cases of Functest>
07:59:00 <joehuang> no need to run other test cases, only run kingbird test cases is enough
07:59:07 <SAshish_> I am not sure, which testcase is this
08:01:29 <joehuang> before Found more than one valid endpoint. Use a more restrictive filter
08:03:23 <joehuang> ok, so please contact functest guys to configure the tempest with one specified region name after the meeting
08:03:48 <joehuang> let's end the meeting, and you are hungry now :)
08:03:59 <SAshish_> yeah :)
08:04:09 <joehuang> #endmeeting