#opnfv-meeting: Dovetail

Meeting started by rprakash at 14:25:17 UTC (full logs).

Meeting summary

    1. Jun Li (matthewli_, 14:25:39)
    2. yuyang (yuyang, 14:25:53)
    3. Dave Neary (intermitten network access) (dneary, 14:26:08)
    4. Dave Neary (intermittent network access) (dneary, 14:26:18)
    5. Chris (ChrisPriceAB, 14:26:41)
    6. rprakash (rprakash, 14:26:48)
    7. Dave had some questions on this and lets start with his inputs (rprakash, 14:28:06)

  1. Continuing discussions on L3VPN, SFC use-cases (dneary, 14:29:51)
    1. Chris Donley attended the Dovetail meeting on behalf of the C&C Committee 2 weeks ago (dneary, 14:30:25)
    2. His input to the Dovetail discussion was that the C&C Committee wanted L3VPN, IPv6 overlay, and SFC to be part of the scope for Dovetail testing (dneary, 14:30:58)
    3. There were significant concerns expressed about the feasibility of including any of those features in scope for conformance testing in a Colorado timeframe (dneary, Bryan Sullivan, David McBride) (dneary, 14:32:04)
    4. There was discussions on API vs. Use case Approach (rprakash, 14:32:56)
    5. The main concerns were that Dovetail tests should pass at least with multiple installers, controllers, and scenarios inside OPNFV before we consider including them in a test suite which should apply to other VIMs, SDN controllers, etc (dneary, 14:34:03)
    6. using ETSI NFV TST APIs vs Blackbox approach where we use cases as stated (rprakash, 14:34:10)
    7. and SFC does not have a method-independent test yet (there are VNFFG tests and SFC tests), IPv6 overlay does not work end to end yet, and L3VPN is still in development (dneary, 14:34:46)
    8. It was minuted from the last meeting that there was agreement on including these features in scope, and dneary noted in an email that it was not agreed. (dneary, 14:35:27)
    9. IPv6 overlay is almost ready, while with some hardcoded not fixed, however, it's the C release time, code freezed, (matthewli_, 14:36:16)
    10. I am not saying use cases is agreed but at a broader level C&C said that in essence of time to satrt testing on release C we must start with use cases instead of APIs like tempest like suite' (rprakash, 14:37:04)
    11. Chris agreed that's what Dave had concerns and we were to discuss that (rprakash, 14:38:08)
    12. http://lists.opnfv.org/pipermail/opnfv-tech-discuss/2016-July/011725.html e-mail form chris proposing establishing test case criteria (ChrisPriceAB, 14:38:27)
    13. • Since API from OPNFV projects are yet to be compiled and gap assessed with respect to ETSI TS APIs for many projects that have MANO implications, the baseline currently appears to be OPENSTACK + SDNC and NB APIs are going to take time to settle. (rprakash, 14:38:41)
    14. the Functest and Yardstic tests do that and C&C suggested adding or stressing on IPv6 (Overlay) , SFC and L3VPN (rprakash, 14:40:26)
    15. ChrisPriceAB states that the starting point should be basic test about the state of the platform - "are the lights on?" - and L3VPN is out of scope for that (dneary, 14:40:35)
    16. I also think that we can leverage test cases from other test project ONLY AFTER we have defined the requirements of a dovetail test case. (ChrisPriceAB, 14:41:28)
    17. OK let us agee that the start point is Functest and Yardstick and lets select out of it what can we use as harness for Dovetail (rprakash, 14:42:20)
    18. Chris I agree this for Compliance Verifciation Program and not Dvelopment testing (rprakash, 14:45:23)
    19. ltes talk published standards (rprakash, 14:46:00)
    20. Maybe we can spin up a wiki page under dovetail to walk through our test case requiremenents. Happy to start that. (ChrisPriceAB, 14:46:54)
    21. #opnfv-dovtail needs meetbot update once that is done recording will be easier (rprakash, 14:47:03)
    22. ChrisPriceAB and dneary proposed criteria for consideration of test cases as part of Dovetail (dneary, 14:47:12)
    23. until then we use this channel (rprakash, 14:47:22)
    24. AGREED: test case need, structure, requirements wiki to identify "how" we will test? (rprakash, 15:01:27)
    25. https://wiki.opnfv.org/display/dovetail - a reminder of Dovetail scope (dneary, 15:03:29)
    26. we agree to follow on defining what we have on record here and close the meeting now and meet next week (rprakash, 15:06:18)


Meeting ended at 15:06:31 UTC (full logs).

Action items

  1. (none)


People present (lines said)

  1. dneary (55)
  2. ChrisPriceAB (49)
  3. rprakash (36)
  4. matthewli_ (7)
  5. collabot (6)
  6. yuyang (1)


Generated by MeetBot 0.1.4.