13:59:44 <ChrisPriceAB> #startmeeting TSC Meeting
13:59:44 <collabot> Meeting started Tue Aug  2 13:59:44 2016 UTC.  The chair is ChrisPriceAB. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:59:44 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
13:59:44 <collabot> The meeting name has been set to 'tsc_meeting'
13:59:50 <ChrisPriceAB> #topic Roll Call
13:59:55 <ChrisPriceAB> #info Chris Price
13:59:58 <ulik> #info Uli Kleber
13:59:59 <tapio_> #info Tapio Tallgren
14:00:00 <frankbrockners> #info Frank Brockners
14:00:04 <bjskerry> #info Brian Skerry
14:00:12 <edgarstp> #info Edgar StPierre
14:00:26 <Ceciliacorbi> Cecili
14:01:38 <ulik> Cecilia, you should type "#info Cecilia" so you get logged.
14:02:09 <dku> #info Dirk Kutscher
14:02:11 <JonasArndt> #info JonasArndt
14:02:16 <ChrisPriceAB> #topic Approval of previous minutes of meeting
14:02:17 <Ceciliacorbi> #info Ceciliacorbi
14:02:30 <ChrisPriceAB> #link https://wiki.opnfv.org/display/meetings/TSC#TSC-July26,2016 previous minutes of meeting for approval
14:02:43 <ChrisPriceAB> #info no comments were received the minutes are approved
14:02:53 <ChrisPriceAB> #topic Agenda Bashing
14:03:01 <GeraldK> #info Gerald Kunzmann
14:03:03 <ChrisPriceAB> #link https://wiki.opnfv.org/display/meetings/TSC
14:03:06 <bin_> #info Bin Hu (for Bryan Sullivan)
14:03:12 <JonasArndt> sorry, on mute now
14:03:12 <rpaik> we now have a quorum
14:04:22 <ChrisPriceAB> #info no additional topics
14:04:58 <dneary> #info Dave Neary
14:05:02 <dneary> Forgot that bit
14:05:04 <ChrisPriceAB> #topic TSC update to the board 4th of August
14:05:14 <ChrisPriceAB> #link https://wiki.opnfv.org/download/attachments/2925933/OPNFV%20TSC%20Board%20update%204%20August%202016%20v1.pptx?version=1&modificationDate=1470141017976&api=v2 prepared material
14:07:52 <bryan_att> #info Bryan Sullivan
14:08:06 <rpaik> #info Chris will discuss Colorado update, Committer-at-Large election, and Community Events during the Board meeting on Aug. 4th
14:08:14 <rpaik> #undo
14:08:35 <rpaik> #info ChrisPriceAB will discuss Colorado update, Committer-at-Large election, and Community Events during the Board meeting on Aug. 4th
14:09:32 <dku> looks very good to me
14:09:38 <rpaik> #info ChrisPriceAB asks for feedback on the material via email/IRC/etc.
14:13:07 <dneary> Interesting topic...
14:13:24 <dneary> Needs a proposal & discussion on the list, I think
14:13:55 <ChrisPriceAB> #info bjskerry asks how we will achieve quorum and how delegates for nominated TSC representatives will be handled.
14:14:20 <dneary> #info Brian Skerry asks what the new quorum will be for the TSC meetings, and whether elected TSC members can name alternates
14:14:25 <ChrisPriceAB> #info this is not so clear at this time and further discussion will be required and to be captured on the wiki page .
14:14:26 <dneary> #undo
14:14:30 <dneary> Sorry
14:14:33 <dneary> Can't undo
14:14:42 <ChrisPriceAB> #info this is not so clear at this time and further discussion will be required and to be captured on the wiki page.
14:14:49 <ChrisPriceAB> #undo
14:14:49 <collabot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2b59e50>
14:14:51 <ChrisPriceAB> lol
14:16:36 <Julien-zte> #info Julien
14:16:49 <ChrisPriceAB> #info the process for how the community election will be run in the context of limiting TSC seats to 2 per company needs to be clearly documented.
14:17:33 <ChrisPriceAB> #action chrispriceab to amend the wiki for the next TSC for clarififcation prior to the elections progressing that far.
14:18:36 <ChrisPriceAB> #action bjskerry to start a mail thread on how we handle delegates for elected TSC members
14:18:55 <ChrisPriceAB> #topic October-January budget amendment and activities
14:19:34 <rpaik> #link https://wiki.opnfv.org/display/meetings/Budget budget proposal for Q4'2016
14:20:03 <rpaik> #info OPNFV's fiscal calendar will move to January - December (vs. Oct - Sep today)
14:22:58 <ChrisPriceAB> #info rpaik outlines the bullet list of budget items for the october-january budget.
14:23:48 <ChrisPriceAB> #info in addition to additional IT support staff we will in addition need to acquire a new switch in the lab to accommodate newly donated hardware.
14:24:56 <ChrisPriceAB> #topic Committer Promotions
14:25:12 <ChrisPriceAB> #link https://wiki.opnfv.org/display/DEV/Committer+Promotions committer promotion process
14:27:17 <aricg> fwiw I've never seen a minus wrt a committer vote.
14:30:29 <ChrisPriceAB> #startvote Does the TSC approve the use of gerrit for committer promotion as described on the Committer Promotions wiki? (-1, 0, +1)
14:30:29 <collabot> Begin voting on: Does the TSC approve the use of gerrit for committer promotion as described on the Committer Promotions wiki? Valid vote options are , -1, 0, +1, .
14:30:29 <collabot> Vote using '#vote OPTION'. Only your last vote counts.
14:30:32 <ulik> #vote +1
14:30:33 <dku> #vote +1
14:30:36 <ChrisPriceAB> #vote +1
14:30:37 <bin_> #vote +1
14:30:38 <edgarstp> #vote +1
14:30:39 <frankbrockners> #vote +14
14:30:39 <collabot> frankbrockners: +14 is not a valid option. Valid options are , -1, 0, +1, .
14:30:40 <bjskerry> #vote +1
14:30:41 <JonasArndt> #vote +1
14:30:46 <Ceciliacorbi> #vote +1
14:30:47 <frankbrockners> #vote +1
14:30:50 <Julien-zte> #vote +1
14:30:50 <tapio_> #vote +1
14:30:59 <dneary> #vote +1
14:31:00 <GeraldK> #vote +1
14:31:07 <ChrisPriceAB> #endvote
14:31:07 <collabot> Voted on "Does the TSC approve the use of gerrit for committer promotion as described on the Committer Promotions wiki?" Results are
14:31:07 <collabot> +1 (12): frankbrockners, dku, dneary, tapio_, ChrisPriceAB, Julien-zte, bin_, JonasArndt, bjskerry, GeraldK, edgarstp, ulik
14:31:26 <ChrisPriceAB> #agree the TSC agrees to adopt the updated committer promotion process.
14:31:50 <ChrisPriceAB> #topic Colorado planning and activities
14:32:19 <ChrisPriceAB> #info dmcbride outlines that reporting has increased significantly since the focus on getting it done.
14:32:28 <ChrisPriceAB> #undo
14:32:28 <collabot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x278c6d0>
14:32:36 <ChrisPriceAB> #info dmcbride outlines that Colorado project reporting has increased significantly since the focus on getting it done.
14:33:19 <ChrisPriceAB> #info dmcbride explains the % values in the material provided to the TSC last week
14:36:09 <rpaik> #info dmcbride notes that the scenario table is sortable by different columns
14:36:42 <ChrisPriceAB> #link https://wiki.opnfv.org/display/octopus/Finalizing+OPNFV+Releases release process CI flow for Colorado
14:37:19 <ChrisPriceAB> #info uli-k explains that the steps to Colorado release will be the same as for Brahmaputra and that he has updated the process and described it for Colorado miletsones.
14:40:07 <ChrisPriceAB> #info uli-k outlines that after code freeze all Colorado development will follow stable branch handling.
14:42:54 <trozet> if you leave it to projects to police their own cherry picks as only bug fixes, why not trust them to only submit bug fixes to master?
14:44:38 <jmorgan1> why not have those projects who do master only work with David on this
14:45:40 <trozet> jmorgan1: agree
14:48:46 <trozet> just say code freeze means only bug fixes...doesnt matter what branch it's in
14:52:14 <bramwelt> I think 'feature freeze' maybe a better term to use here
14:52:22 <bramwelt> or 'scenario freeze'
14:52:30 <trozet> bramwelt: yeah
14:53:51 <trozet> aricg: that helps to eliminate CI resource contention
14:54:23 <aricg> trozet: yes, I think that will please everyone.
14:54:33 <Julien-zte> agree
14:55:18 <trozet> aricg: only problem is order of cherry-picks
14:55:24 <trozet> aricg: without any ci validation
14:59:19 <trozet> dneary: takes 2.5 hours
14:59:22 <trozet> dneary: for a verify job
14:59:34 <trozet> at least on apex..
14:59:38 <dneary> trozet, Today? Or post MS9?
14:59:45 <trozet> dneary: well post it will be double
14:59:54 <trozet> dneary: for doing the cherry pick
15:00:07 <dneary> OK
15:00:10 <dneary> Thanks
15:00:16 <ChrisPriceAB> #info there was a lot of discussion around the final milestones for Colorado, where some projects feel they should not branch to stable at this time.
15:00:29 <rpaik> #info discussion on testing resource requirements  on master vs. stable
15:00:58 <ChrisPriceAB> #action dmcbride to follow up on this discussion and understand the impacts of changing the Colorado milestones, or allowing exemptions.
15:01:14 <jmorgan1> thanks
15:01:15 <ChrisPriceAB> #endmeeting