#opnfv-meeting: testperf

Meeting started by dfarrell07 at 14:01:43 UTC (full logs).

Meeting summary

    1. CPerf (dfarrell07) is chairing today, VSPerf is taking notes (dfarrell07, 14:02:26)
    2. Morgan Richomme (morgan_orange, 14:02:36)
    3. Mark Beierl (mbeierl, 14:02:41)
    4. kubi (kubi002, 14:02:46)
    5. Dave Urschatz (durschatz, 14:02:50)
    6. Jun Li (matthewli_, 14:02:59)
    7. Yujun Zhang (IRC only) (yujunz, 14:03:45)
    8. Maryam Tahhan (mtahhan__, 14:05:07)
    9. dfarrell07 (dfarrell07, 14:05:15)

  1. APAC-friendly Meeting Time (dfarrell07, 14:06:13)
    1. We did a vote in this meeting (noting sampling bias) and tool a poll over email (to avoid sampling bias) about best time slots (dfarrell07, 14:06:21)
    2. http://lists.opnfv.org/pipermail/opnfv-tech-discuss/2016-August/011902.html Email with link to poll (dfarrell07, 14:06:28)
    3. http://doodle.com/poll/fa4nspdf4ta2u7pb Poll about APAC-friendly meeting times (dfarrell07, 14:06:32)
    4. Second Wednesday of the month at 0800 UTC is currently winning with 6-yes, 1-if-need-be, 0-no (dfarrell07, 14:06:39)
    5. Others should go vote (dfarrell07, 14:06:51)
    6. Second Wed. was yesterday, so if we agree we'd start next month (dfarrell07, 14:07:05)

  2. Meeting Minutes (dfarrell07, 14:08:34)
    1. In the last month or so started taking minutes via collabot in #opnfv-meetings (dfarrell07, 14:08:46)
    2. http://ircbot.wl.linuxfoundation.org/meetings/opnfv-meeting/2016/ All #opnfv-meeting minutes in one big dir (dfarrell07, 14:08:56)
    3. Up until 7-14-16, we took meeting minutes in #opnfv-testperf, which gave us a dir for all notes (dfarrell07, 14:09:05)
    4. http://ircbot.wl.linuxfoundation.org/meetings/opnfv-testperf/2016/ Meeting minutes in dir for #opnfv-testperf chan only (dfarrell07, 14:09:12)
    5. This is a problem because all meeting minutes get stored in the same dir and there's not a good way to find testperf ones (dfarrell07, 14:09:17)
    6. Al Morton (acm, 14:09:18)
    7. ODL's meetbot breaks minutes up into <channel>/<meeting title> dirs, which would make #opnfv-meeting work (dfarrell07, 14:09:22)
    8. https://meetings.opendaylight.org/opendaylight-integration/2016/ (dfarrell07, 14:09:32)
    9. dfarrell07 thinks we need a) collabot to start splitting up meetings into dirs based on title 2) start using #opnfv-testperf to org notes (dfarrell07, 14:09:36)
    10. We'll need to update meeting wiki (dfarrell07, 14:09:42)
    11. this can be proposed to be update by an a-mail to the help-desk (ChrisPriceAB, 14:11:41)
    12. this can be proposed to be update by an e-mail to the help-desk (ChrisPriceAB, 14:11:57)
    13. Finding minutes -- hard to do. (acm, 14:12:21)
    14. morgan_orange reports that #opnfv-testperf chan was functest, but they have moved, so we could use it (dfarrell07, 14:12:22)
    15. morgan_orange had been linking to minutes from wiki to make finding later possible (dfarrell07, 14:13:07)
    16. lots of projects send URLs to minutes in e-mail (acm, 14:13:17)
    17. https://wiki.opnfv.org/display/meetings/TestPerf (morgan_orange, 14:13:19)
    18. ACTION: dfarrell07 to raise helpdesk ticket about meetbot update to get title dirs (dfarrell07, 14:14:24)
    19. AGREED: for testperf, we'll use #opnfv-testperf channel in future, as well as fix meetbot to give dirs for other projects (dfarrell07, 14:15:26)
    20. ACTION: dfarrell07 to update the wiki with info about chan (dfarrell07, 14:15:47)
    21. only +3 for our title directories (acm, 14:15:51)
    22. TSC moving to election of comitters system (?) and voting system? (acm, 14:17:11)
    23. TSC structure was not well recognizing the meritocracy of the community (acm, 14:18:00)
    24. morgan_orange gives background on TSC elections. There was feedback that there wasn't the merit in elections, so adding way to elect non-platinum members (dfarrell07, 14:18:30)
    25. There's a self-nomination phase open currently (dfarrell07, 14:18:43)
    26. so, elect some committers to the TSC - nominations in progress for 5 seats. (acm, 14:18:50)
    27. morgan_orange was nominated by fatih (cool) (dfarrell07, 14:19:20)
    28. nominations end Friday, Aug 12 (acm, 14:19:26)
    29. TestPerf is kinda a big part of OPNFV, so would make sense to have that voice on TSC (dfarrell07, 14:19:35)
    30. mbeierl has been attending TSC's, morgan_orange says, and would be good rep (dfarrell07, 14:21:26)
    31. Mark's question: Is Morgan on TSC? -- no, just platinum companies (acm, 14:21:52)
    32. morgan_orange clarifies that there's no formal overlap between commiters, PTLs and TSC members (dfarrell07, 14:22:46)
    33. morgan_orange was elected as dev rep to Board, which is different than TSC seats (dfarrell07, 14:23:12)
    34. Morgan "we need test reps on TSC" -- this is not the same as the OPNFV Board (acm, 14:23:14)
    35. Committer term for TSC is one year (acm, 14:23:56)
    36. mbeierl if morgan_orange wants to be test rep, or if has too much on plate (dfarrell07, 14:24:15)
    37. Fatih has been nominated for infra, good connections with TestPerf (dfarrell07, 14:24:55)
    38. reps from INFRA, Doctor with good connection to OpenStack (Ryota) (acm, 14:25:08)
    39. mbeierl has been following TSC closely since started in OPNFV last sep. (dfarrell07, 14:25:42)
    40. Marck feeld he could be a good rep (acm, 14:25:43)
    41. ACTION: acm to send email nominating mbeierl for TSC (dfarrell07, 14:26:14)
    42. yes Al (acm, 14:27:46)
    43. I see Uli's mail, I'll reply mentioning our discussion here today. (acm, 14:28:47)

  3. Tests against Scenarios (dfarrell07, 14:29:26)
    1. Discussion about which tests are run for scenarios, that scenario owner may only run tests that pass/are easy, that TestPerf may want to mandate some tests are run (dfarrell07, 14:29:28)
    2. Some func projects have very light test coverage, installers can't manage all (dfarrell07, 14:29:55)
    3. Many more scenarios in C, so more important (dfarrell07, 14:30:12)
    4. acm asks if there is evidence people are trying to make tests easier in context of some scenarios (dfarrell07, 14:30:47)
    5. acm thinks could be good to have core set of tests all should pass (dfarrell07, 14:30:55)
    6. acm thinks we don't need to address too badly until we know it's a problem, people are trying to avoid failing tests (dfarrell07, 14:31:15)
    7. morgan_orange thinks there should be a min set of tests compatible with scenario, asks yardstick/kubi002 about input (dfarrell07, 14:32:15)
    8. Morgan's recommendation: minimum tests are the same set as Brahmaputra (acm, 14:33:06)
    9. kubi002 points out that yardstick has smoke tests that could be used (dfarrell07, 14:33:23)
    10. having a min set, like smoke tests from functest and yardstick, would give lots of confidence (dfarrell07, 14:34:15)
    11. another recommendation would be pass both of those smoketest suites (dfarrell07, 14:34:31)
    12. Mark B. - we discussed categories of tests about a montho ago, why not use that? (acm, 14:35:08)
    13. mbeierl asks about categories/levels of tests we discussed in past, having some low level be min (dfarrell07, 14:35:20)
    14. dfarrell07 wonders if there's a diff b/t smoketests and these levels of tests (dfarrell07, 14:35:34)
    15. Morgan still need the functests and smoke tests (acm, 14:35:42)
    16. projects can add smoke tests if they have feature-focused ones (dfarrell07, 14:35:51)
    17. can run all relevant smoketests (dfarrell07, 14:36:01)
    18. Each test project should define different levels of testing - include in teh scenario (or not) (MR) (acm, 14:36:48)
    19. Recommendation is for projects to define smoke tests, and all relevant smoke tests run for compatible scenarios (dfarrell07, 14:36:59)
    20. Mark B connection to certification and dovetail? Morgan: next we we have an update (acm, 14:37:20)
    21. OPNFV Cert discussion is relevant, will tie this in next week (dfarrell07, 14:37:23)

  4. Docs (dfarrell07, 14:38:54)
    1. ... not clear what will be the final view of testing for Colorado (morgan) (acm, 14:39:06)
    2. morgan_orange points out there's a mail asking us to do combined docs for TestPerf group (dfarrell07, 14:39:26)
    3. we're close to the docs deadline, so if we want docs that ref all test projects we need this ASAP (dfarrell07, 14:39:43)
    4. ACTION: morgan_orange to contact Sophia about which docs we need, any updates for TestPerf docs (dfarrell07, 14:40:32)
    5. Morgan: e-amil form Sofia - do we need to creat documentation for the testperf?? no further input (acm, 14:40:38)

  5. APAC Poll Results (dfarrell07, 14:41:45)
    1. AGREED: New APAC meeting will be at 800 UTC first Wed of every month (dfarrell07, 14:42:41)
    2. Will run this as experiment, but if no one shows up we'll reevaluate (dfarrell07, 14:43:30)
    3. Morgan: this time was tried, and not very successful (acm, 14:43:50)
    4. This will be best for EU and APAC people, maybe want one later for APAC and US (dfarrell07, 14:43:53)
    5. taking good minutes for this call is important, to allow async people to follow (dfarrell07, 14:44:09)
    6. AGREED: Actually second Wed, not first, sorry (dfarrell07, 14:44:29)
    7. ACTION: dfarrell07 to update wiki with APAC meeting (dfarrell07, 14:44:54)
    8. Functest is chair next week, with Bottleknecks taking notes (dfarrell07, 14:45:29)


Meeting ended at 14:45:36 UTC (full logs).

Action items

  1. dfarrell07 to raise helpdesk ticket about meetbot update to get title dirs
  2. dfarrell07 to update the wiki with info about chan
  3. acm to send email nominating mbeierl for TSC
  4. morgan_orange to contact Sophia about which docs we need, any updates for TestPerf docs
  5. dfarrell07 to update wiki with APAC meeting


Action items, by person

  1. acm
    1. acm to send email nominating mbeierl for TSC
  2. dfarrell07
    1. dfarrell07 to raise helpdesk ticket about meetbot update to get title dirs
    2. dfarrell07 to update the wiki with info about chan
    3. dfarrell07 to update wiki with APAC meeting
  3. mbeierl
    1. acm to send email nominating mbeierl for TSC
  4. morgan_orange
    1. morgan_orange to contact Sophia about which docs we need, any updates for TestPerf docs


People present (lines said)

  1. dfarrell07 (75)
  2. acm (23)
  3. morgan_orange (6)
  4. mbeierl (6)
  5. collabot (6)
  6. mtahhan__ (5)
  7. ChrisPriceAB (4)
  8. kubi002 (4)
  9. yujunz (4)
  10. matthewli_ (3)
  11. durschatz (1)


Generated by MeetBot 0.1.4.