13:59:38 <ChrisPriceAB> #startmeeting OPNFV TSC
13:59:38 <collabot> Meeting started Tue Sep  6 13:59:38 2016 UTC.  The chair is ChrisPriceAB. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:59:38 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
13:59:38 <collabot> The meeting name has been set to 'opnfv_tsc'
13:59:42 <ChrisPriceAB> #topic Roll Call
13:59:47 <ChrisPriceAB> #info Chris Price
13:59:47 <dneary> #info Dave Neary
13:59:53 <hongbo1> #info hongbo
14:00:00 <edgarstp> #info Edgar StPierre
14:00:04 <morgan_orange> #info Morgan Richomme
14:00:05 <frankbrockners> #info Frank Brockners
14:00:16 <rossella_s> #info Rossella Sblendido
14:00:17 <jmorgan1> #info Jack Morgan
14:01:22 <bjskerry> #info Brian Skerry
14:01:46 <ChrisPriceAB> #topic Approval of previous minutes of meeting
14:01:52 <ChrisPriceAB> #link https://wiki.opnfv.org/display/meetings/TSC#TSC-August30,2016 previous minutes
14:02:02 <fdegir> #info Fatih Degirmenci
14:02:05 <ChrisPriceAB> #info No comments received minutes approved.
14:02:33 <ChrisPriceAB> #topic Agenda Bashing
14:02:38 <ChrisPriceAB> #link https://wiki.opnfv.org/display/meetings/TSC#TSC-September6,2016 todays agenda
14:03:22 <ashyoung> #info Ash Young (for Uli)
14:03:27 <rprakash> #info rprakash
14:04:08 <rpaik> we now have a quorum
14:04:12 <bryan_att> #info Bryan Sullivan
14:04:18 <StuartMackie> #info Stuart Mackie
14:04:41 <cgoncalves> rpaik: Dirk seems to be out today. can I proxy for him?
14:04:48 <bin_> #info Bin Hu
14:04:49 <Steven_> #info Steven Wright
14:05:06 <rpaik> cgoncalves, yes :-)
14:05:08 <frankbrockners> #link http://lists.opnfv.org/pipermail/opnfv-tsc/2016-September/002860.html
14:05:12 <cgoncalves> rpaik: tks
14:05:12 <Julien-zte> #info Julien
14:05:21 <ChrisPriceAB> #info there was a request for the TSC to discuss config files for Doctor, we will address that in the Colorado section
14:05:23 <tallgren> #info Tapio Tallgren
14:05:23 <cgoncalves> #info Carlos Goncalves (for Dirk K.)
14:06:08 <ChrisPriceAB> #topic Introduction/welcome for new TSC members
14:06:32 <dneary> rossella_s, Welcome!
14:06:45 <rossella_s> dneary, thanks!
14:06:58 <rpaik> #link http://lists.opnfv.org/pipermail/opnfv-tech-discuss/2016-September/012438.html email on CAL TSC members
14:07:01 <ChrisPriceAB> #info the five new TSC members were voted in and started today
14:07:03 <Julien-zte> welcome !
14:08:08 <ChrisPriceAB> #topic License scan update
14:08:36 <ChrisPriceAB> #info Scott and Ray have been sending questions to OPNFV projects where our license scan has turned up issues.
14:09:06 <ChrisPriceAB> #info if you have not received questions from them no issues have been identified.
14:09:29 <ChrisPriceAB> #info Scott addresses the TSC, outlining he is not acting as a legal council but to discuss process with us.
14:09:48 <morgan_orange> rpaik: for information for Functest we remove the directory including the problematic license (fonts were not used anyway)  https://gerrit.opnfv.org/gerrit/#/c/20453/
14:10:09 <ChrisPriceAB> #chair rpaik
14:10:09 <collabot> Current chairs: ChrisPriceAB rpaik
14:11:00 <jmorgan1> ChrisPriceAB: can we add another topic for today or next week on common configuraiton files
14:11:02 <ChrisPriceAB> #chair morgan_orange
14:11:02 <collabot> Current chairs: ChrisPriceAB morgan_orange rpaik
14:11:04 <jmorgan1> ChrisPriceAB: http://lists.opnfv.org/pipermail/opnfv-tech-discuss/2016-September/012426.html
14:11:43 <ChrisPriceAB> yes jackmorgan1, that topic will be discussed during the Colorado section.
14:11:55 <ChrisPriceAB> yes jmorgan1, that topic will be discussed during the Colorado section.
14:11:57 <rpaik> #info Scott notes that there's room for improvement in including license information at the file-level ( not just on directories)
14:11:57 <ChrisPriceAB> :)
14:12:04 <jmorgan1> ChrisPriceAB: thanks
14:12:19 <jmorgan1> Julien-zte: ^^
14:13:01 <ashyoung> rpaik: Can't always do it for leveraged source files that don't already include it.
14:13:22 <Julien-zte> welcome jmorgan1
14:14:45 <ashyoung> rpaik: We ran into this with ONOS, which was also Apache, but didn't have the preamble in all files. Copyright holder had to do the mods to the existing source files' licensing.
14:14:55 <rpaik> #info Scott Nicholas notes that  license files should have a .txt extension
14:14:55 <jmorgan1> Julien-zte: thanks
14:15:02 <ChrisPriceAB> #link https://wiki.opnfv.org/display/DEV/Contribution+Guidelines licence references on the contributor guidelines wiki
14:16:45 <rpaik> #info Scott also noted that projects should also avoid using private repo's (e.g. personal GitHub)
14:17:03 <bryan_att> where is the line between a private repo and an upstream repo?
14:17:30 * ChrisPriceAB oops sorry is losing audio
14:20:45 <ChrisPriceAB> I am having some trouble with Audio, let's not rat-hole here we have a lot to get through.
14:21:15 <ChrisPriceAB> We can start a dialog on this topic along with other community members outside the TSC call
14:22:12 <ashyoung> ChrisPriceAB: We have an issue here. And I think we need a separate discussion on this.
14:22:24 <bryan_att> sounds like what is needed is an inventory of all upstream/external code that is pulled as part of OPNFV install or test, since there may be some concern about the license of code that is put into the reference platform, but we have to balance that with the actual practice of how the system is built
14:22:24 <ashyoung> Maybe next week
14:22:37 <ChrisPriceAB> ashyoung OK, we can set aside time for this.
14:22:42 <ashyoung> bryan_att: That's it in a nutshell
14:23:03 <ashyoung> ChrisPriceAB: Thanks!
14:23:27 <bryan_att> there is a lot of GPL code in the built OPNFV platform, pulled from upstream. the important thing is that code created/changed for OPNFV must (by default) be Apache licensed.
14:23:31 <ChrisPriceAB> #topic Confluence/wiki tracking on Bitergia
14:24:07 <ChrisPriceAB> #info raik updates the TSC on work to track community activity on bitergia.
14:24:14 <ashyoung> bryan_att: Can't change the license of a modified file. That's up to the copyright holder according to Apache.
14:24:29 <ashyoung> bryan_att: Certainly true for new ones.
14:24:42 <ChrisPriceAB> #info rpaik asks if we can spend 3K out of the TSC initiatives to fill the need on bitergia
14:25:12 <Julien-zte> too many informations in the dashboard to be got confused of Bitegia, not simple to use
14:25:27 * dneary is in favour
14:25:35 <bryan_att> ashyoung: of course, I didn't mean to imply that. New files and files that the author/originator agrees to relicense, only
14:26:26 <ashyoung> bryan_att: Totally agree
14:26:29 <ChrisPriceAB> #info Julien asks if we should track more things as there is already a lot on the dashboard.
14:27:02 <ChrisPriceAB> #info rpaik the wiki tracking has been a pending point to be done for a long time
14:27:12 <ashyoung> bryan_att: We also have discussed this issue as it pertains to security and to CII badging. We have a CI process that doesn't mean much if the things we're installing are coming from external sites.
14:27:48 <ashyoung> bryan_att: I think we can bring all of this under control as an integrity check
14:28:33 <ChrisPriceAB> #startvote Does the  TSC agree to spend 3K USD on adding wiki tracking to bitergia from the TSC initiatives budget? (-1, 0, +1)
14:28:33 <collabot> Begin voting on: Does the  TSC agree to spend 3K USD on adding wiki tracking to bitergia from the TSC initiatives budget? Valid vote options are , -1, 0, +1, .
14:28:33 <collabot> Vote using '#vote OPTION'. Only your last vote counts.
14:28:39 <bjskerry> #vote +1
14:28:40 <frankbrockners> #vote +1
14:28:41 <ChrisPriceAB> #vote +1
14:28:43 <jmorgan1> #vote +1
14:28:43 <StuartMackie> #vote +1
14:28:43 <tallgren> #vote +1
14:28:44 <Julien-zte> #vote +0
14:28:44 <collabot> Julien-zte: +0 is not a valid option. Valid options are , -1, 0, +1, .
14:28:45 <cgoncalves> #vote +1
14:28:45 <edgarstp> #vote +1
14:28:46 <fdegir> #vote +1
14:28:47 <hongbo1> #vote +1
14:28:48 <morgan_orange> +1
14:28:48 <rossella_s> #vote +1
14:28:48 <ashyoung> #vote +1
14:28:53 <morgan_orange> #vote +1
14:28:57 <Julien-zte> #vote 0
14:29:02 <dneary> #vote +1
14:29:07 <ashyoung> Wow! What a close vote
14:29:13 <ChrisPriceAB> #endvote
14:29:13 <collabot> Voted on "Does the  TSC agree to spend 3K USD on adding wiki tracking to bitergia from the TSC initiatives budget?" Results are
14:29:13 <collabot> 0 (1): Julien-zte
14:29:13 <collabot> +1 (14): frankbrockners, cgoncalves, dneary, ashyoung, fdegir, hongbo1, morgan_orange, ChrisPriceAB, tallgren, StuartMackie, rossella_s, bjskerry, edgarstp, jmorgan1
14:29:24 <ChrisPriceAB> #agree the TSC agree to update bitergia
14:29:28 <ChrisPriceAB> #topic September OPNFV Board meeting
14:29:47 <dneary> rpaik, Out of curiosity, with the bigger TSC, what is the new quorum?
14:29:48 <ChrisPriceAB> #link https://wiki.opnfv.org/download/attachments/2925933/TSC%20update%20to%20the%20board%20September%202016.pptx?version=1&modificationDate=1473169988020&api=v2 current draft material for the board meeting
14:30:04 <rpaik> dneary, it's now 13
14:31:25 <morgan_orange> "I am not supersticious, it can cause bad luck"... :)
14:31:46 <rpaik> :-)
14:33:04 <ChrisPriceAB> #topic Technical community elections
14:33:41 <ChrisPriceAB> Committer Board (Announcement: Sep. 6/Nomination Sep 13 - 23/Election Sep 26 - 30/Result: Oct. 3)
14:33:46 <ChrisPriceAB> #info Committer Board (Announcement: Sep. 6/Nomination Sep 13 - 23/Election Sep 26 - 30/Result: Oct. 3)
14:34:23 <ChrisPriceAB> #info TSC Chair (Announcement: Sep. 12/Nomination Sep 19 - 30/Election Oct. 3 - 7/Result: Oct. 10)
14:34:52 <ChrisPriceAB> #topic OPNFV intern program update
14:35:09 <rpaik> #link https://wiki.opnfv.org/display/DEV/First+year+internship+program+observations learning from the intern program
14:36:12 <ChrisPriceAB> #info rpaik states he is happy with the interns we have had and the work they have been doing for the project.
14:36:34 <ChrisPriceAB> #info interns have even helped out with answering inquiries on the opnfv-users support page.
14:37:03 <ChrisPriceAB> #info rpaik states that mentors have also stated they have been happy with the process.
14:37:33 <ChrisPriceAB> #info rpaik also states that while a "part time" option for intenship was available it was not used by the community or potential interns
14:38:01 <ChrisPriceAB> #info rpaik asks if there would be concerns with removing the "part time intern" program.
14:38:45 <jmorgan1> i'd like to see the longer term iternship option keep especially for infrastructure related projects
14:39:10 <jmorgan1> perhaps doing more to promote the program will generate demand
14:39:17 <ChrisPriceAB> #info rpaik also states that most interns have been run during the summer
14:39:22 <Julien-zte> agree jmorgan1
14:39:55 <ChrisPriceAB> My gut tells me to keep it as well jmorgan1, if it is not costing us anything it feels like something that might come in handy at some stage.
14:40:07 <cgoncalves> +1 to keep. it could be useful to capture BsC and MsC students, for example
14:40:47 <cgoncalves> usually their projects/theses last for 1-2 semesters
14:41:10 <jmorgan1> rpaik: sounds good, thanks
14:41:30 <lylavoie> I think Ray covered all the points well
14:42:18 <lylavoie> As a side note, our intern (Todd) will be staying on at the UNH-IOL and will still be participating in the project, working on Pharos LaaS and the plugfest.
14:42:39 <ChrisPriceAB> #topic Colorado planning and activities
14:43:17 <ChrisPriceAB> #info dmcbride outlines that the planned release date for Colorado 1.0 is September 22nd and it is coming very close now.
14:43:35 <ChrisPriceAB> #info the functest dashboard shows a very small number of green scenario's compared to the number being tracked.
14:44:02 <ChrisPriceAB> #info the scenario status wiki is also showing 6/7 scenario's that are not showing release ready at this stage.
14:44:37 <ChrisPriceAB> #info dmcbride also describes that while we are improving on Jira status there are still untracked issues.
14:48:31 <ChrisPriceAB> #info frankbrockners outlines that while tests are failing on some scenario's it maye be only one use case that is failing.  These scenario's can release with documented limitations capturing the issues.
14:51:30 <ChrisPriceAB> #action dmcbride to report back to the TSC next week with scenario release status for Colorado 1.0
14:51:48 <ChrisPriceAB> #topic Common OPNFV configurations
14:52:02 <cgoncalves> #link http://lists.opnfv.org/pipermail/opnfv-tsc/2016-September/002860.html
14:52:42 <ChrisPriceAB> #info cgonclaves describes that the doctor project requires certain platform configurations to function.
14:53:18 <ChrisPriceAB> #info it has found to not be possible to be done in the Colorado project across all installers
14:53:51 <ChrisPriceAB> #info for some projects the feature set is intended to be compatible across all scenarios not intended to define a scenario of their own.
14:54:51 <ChrisPriceAB> #info this establishes a need for a common set of behaviours that allow features to be deployed on all scenarios
14:56:33 <dneary> Are there any projects which require conflicting configuration options?
14:56:45 <ChrisPriceAB> #info julien-zte outlines that we should be able to articulate common capabilities for the installers to provide in any releasel
14:56:47 <dneary> As in, one project needs an option on, and another needs it off, for example?
14:56:56 <cgoncalves> dneary: from doctor side, I am unaware of any
14:57:31 <dneary> My understanding was that scenarios (and specifically the goal of scenario consolidation) were the right place to do deployment-specific configuration
14:57:35 <ChrisPriceAB> #info info julien-zte indicates genesis should be a vehicle to achieve common configurations across installers.
14:58:12 <ChrisPriceAB> #info jmorgan1 adds that while this is not possible to achieve in Colorado, we should be looking at defining our needs for this heading into the D release.
14:59:01 <ChrisPriceAB> #info frankbrockners adds that there was limited participation in genesis to harmonize these items and as such genesis stood down from Colorado.
14:59:04 <cgoncalves> dneary: deployment-specific configuration but only when needed. in this case (doctor/fuel/ceilometer) if there's no configuration conflict, we could have it across all scenarios without creating yet another one
14:59:53 <ashyoung> I agree with what Frank just said. I think we need to try again.
15:00:00 <morgan_orange> +1
15:00:06 <dneary> cgoncalves, Right - so there are 2 things: configuration files needed by some projects awhich don't affect others (could become the default option for an installer)
15:00:08 <hongbo1> +1
15:00:26 <dneary> And then scenario-specific configuration (which needs to be done per-scenario)
15:00:32 <ChrisPriceAB> #info jmorgan1 adds that the infra WG and pharos are working on this issue from the physical infra perspective that can lead to alignment on installers .
15:00:40 <cgoncalves> dneary: +1
15:01:01 <ChrisPriceAB> #action jmorgan1 to work with this topic and report back to the TSC regularly with progress and for guidance.
15:01:05 <morgan_orange> we may distinguish generic (nosdn, odl_l2,..) and specific scenario, if for a feature project config divergence is too big => it shall be a specific scenario
15:01:10 <cgoncalves> I think the default should be to try to make it the default option for an installer and then check if there's any conflict to resolve
15:01:15 <morgan_orange> difficulty is to know what too big means
15:01:33 <jmorgan1> cgoncalves: good points, and let's discuss it in future Infra wg meetings
15:01:38 <ChrisPriceAB> #endmeeting