15:00:17 <fdegir> #startmeeting Infra WG Weekly Meeting
15:00:17 <collabot> Meeting started Wed Sep  7 15:00:17 2016 UTC.  The chair is fdegir. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:17 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:00:17 <collabot> The meeting name has been set to 'infra_wg_weekly_meeting'
15:00:31 <fdegir> #topic Roll Call
15:00:46 <rpaik> #info Ray Paik
15:00:51 <lylavoie> #info Lincoln Lavoie
15:00:59 <jmorgan1> #info Jack Morgan (Pharos)
15:01:05 <lylavoie> We can hear you
15:01:09 <yujunz-zte> #info Yujun Zhang
15:01:19 <fdegir> #topic Agenda
15:01:27 <fdegir> #link https://wiki.opnfv.org/display/INF/Infra+Working+Group#InfraWorkingGroup-Agenda
15:01:58 <fdegir> #topic Adding Huawei POD2 to CI PODs
15:03:13 <fdegir> #info How can a resource can be declared as CI Resource
15:03:15 <fdegir> #link https://wiki.opnfv.org/display/INF/Continuous+Integration#ContinuousIntegration-HardwareResources
15:05:10 <jmorgan1> i'm suggest sticking to plan (2 weeks to monitor)
15:08:59 <fdegir> #info Intel POD8 is not connected to Jenkins at the moment
15:09:45 <Julien-zte> #info Julien
15:09:54 <fdegir> #info Because of this, Compass requests addition of Huawei POD2 as CI POD
15:10:15 <fdegir> #action aricg and May-meimei to fix Intel POD8 Jenkins connection
15:10:54 <fdegir> #info Infra WG will monitor Huawei POD2 for 2 weeks and then take action
15:11:19 <aricg> May-meimei: Sending connection string via pm
15:11:23 <fdegir> #topic Upcoming migration of Ericsson lab
15:11:40 <fdegir> #link http://lists.opnfv.org/pipermail/opnfv-tech-discuss/2016-September/012466.html
15:12:36 <fdegir> #action fdegir and Daniel Smith to follow this up
15:13:32 <fdegir> #info The biggest impact will be on Fuel
15:13:57 <fdegir> #info The builds might be impacted as well
15:14:30 <Julien-zte> Doctor + Fuel + KVM not work for now
15:14:44 <Julien-zte> for a week in our pods
15:15:45 <fdegir> #chair jmorgan1
15:15:45 <collabot> Current chairs: fdegir jmorgan1
15:16:21 <fdegir> #topic Discussion regarding any release blockers
15:16:34 <fdegir> #info frankbrockners asks if we have top 10 type of list of blockers
15:18:03 <fdegir> #info It is important for community to be disciplined to use JIRA to track issues with different severity/criticality
15:21:51 <fdegir> #info Installers PTLs might need to be contacted in order to find out if and which scenarios are under risk
15:21:57 <aricg> May-meimei: Did you get my pm? Your key is expired so I can't send it via email
15:22:05 <fdegir> #info What can be done in order to sort remaining issues out
15:24:57 <fdegir> #action dmcbride to send mail to installer, test, infra PTLs and suggest having daily status meetings
15:26:05 <fdegir> #topic Infra/CI status update and plans for D-release
15:27:41 <fdegir> #info The main concern during Colorado release was CI Evolution
15:27:42 <jmorgan1> CI Evolution, phase #1/2 for example
15:27:59 <jmorgan1> CI evolution, phase #3/4 post Colorado 1.0 release
15:28:27 <jmorgan1> David is asking about phase #3/4, i think
15:31:06 <fdegir> #info The main issue for not having CI Evolution not being ready is lack of human resources
15:33:40 <fdegir> #info MS for Infra updates complete December 15th
15:35:37 <fdegir> #info The work with CI Evolution will be done on sandbox first
15:36:12 <fdegir> #link https://wiki.opnfv.org/display/INF/CI+Evolution
15:42:27 <fdegir> #info Separating builds from the rest of the chain and enabling/aligning commit gating/smoke test are the first steps towards CI Evolution
15:42:49 <fdegir> #info Once we have an alignment on these, work with scenario promotion can start
15:43:58 <fdegir> #action Put more detailed plan for CI Evolution including any prerequisites
15:44:02 <fdegir> #undo
15:44:02 <collabot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x2fe47d0>
15:44:07 <fdegir> #action fdegir Put more detailed plan for CI Evolution including any prerequisites
15:44:35 <fdegir> #topic Tracking OPNFV contributions in OpenStack
15:44:38 <aricg> https://wiki.opnfv.org/display/COM/Tracking+OPNFV+contributions+in+OpenStack
15:44:51 <fdegir> #link https://wiki.opnfv.org/display/COM/Tracking+OPNFV+contributions+in+OpenStack
15:47:41 <fdegir> #info One question is if we are able to do this for other upstream projects?
15:48:09 <fdegir> #info OpenStack is first candidate to start with and try to design a mechanism which is applicable to other communities as well
15:49:28 <fdegir> #action aricg to propose this in releng and then send it to tech-discuss for further discussion
15:49:49 <fdegir> #action aricg to check how apex is doing this
15:50:26 <fdegir> #link https://wiki.opnfv.org/display/apex/Upstream+Tracking
15:51:20 <fdegir> #topic New Lab CI Process Discussion
15:51:49 <fdegir> #info There is a discrepancy between wiki and pharos repo regarding labs
15:52:41 <aricg> #info we are now doing gerrit replication to improve clone speeds. If your DC would like a local copy of all opnfv repos send request to helpdesk.
15:52:45 <fdegir> #info One option could be to have all the lab information on gerrit and include generated documents on Wiki
15:52:49 <fdegir> thx aricg
15:53:14 <fdegir> #info The question is: what is the primary source for lab information
15:54:10 <fdegir> #info jmorgan1 says the labs will document information in Pharos repo by Colorado.3.0
15:55:22 <Julien-zte> #info morgan1, I will help you update some of the labs from the rst files
15:55:42 <Julien-zte> #info jmorgan1, I will help you update some of the labs from the rst files
15:57:46 <fdegir> #info We need to have an onboarding document for new labs/pods/resources coming online
15:58:37 <fdegir> #action jmorgan1 to start up a wiki page for resource onboarding
15:58:54 <fdegir> #topic Bitergia Jenkins Dashboard
15:59:09 <rpaik> #link https://opnfv.biterg.io proto-type page
15:59:33 <rpaik> click on Jenkins all the way on the right at the top
15:59:38 <fdegir> #info What information we want to display on Bitergia Dashboard when it comes to Jenkins?
16:00:14 <jmorgan1> thanks, Julien-zte
16:00:56 <fdegir> #info Please put ideas on etherpad linked below
16:00:58 <fdegir> #link https://etherpad.opnfv.org/p/jenkins-bitergia-dashboard
16:00:59 <jmorgan1> Julien-zte: i'll be updating the JIRA tasks today and we can work on them
16:01:12 <Julien-zte> OK jmorgan1
16:01:29 <Julien-zte> I can use ZTE for test for demo
16:01:40 <lylavoie> That's fine with me.  :)
16:02:11 <fdegir> #info This activity aims to collect job, scenario, slave statistics
16:02:15 <fdegir> #endmeeting