13:59:29 <ChrisPriceAB> #startmeeting OPNFV TSC
13:59:29 <collabot`> Meeting started Tue Sep 13 13:59:29 2016 UTC.  The chair is ChrisPriceAB. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:59:29 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
13:59:29 <collabot`> The meeting name has been set to 'opnfv_tsc'
13:59:38 <ChrisPriceAB> #topic Roll Call
13:59:45 <Julien-zte> #info Julien
13:59:46 <ChrisPriceAB> #info Chris Price
13:59:48 <Ceciliacorbi> #info ceciliacorbi
13:59:49 <jmorgan1> #info Jack Morgan (Pharos)
13:59:50 <hongbo2> #info hongbo
13:59:51 <Julien-zte> m
13:59:53 <ulik> #info Uli Kleber
14:00:53 <fdegir> #info Fatih Degirmenci
14:01:17 <frankbrockners> #info Frank Brockners
14:01:24 <JonasArndt> #info JonasArndt
14:01:30 <ChrisPriceAB> #topic Approval of previous minutes of meeting
14:01:35 <ChrisPriceAB> #link https://wiki.opnfv.org/display/meetings/TSC#TSC-September6,2016 previous minutes
14:01:38 <rpaik> we now have a quorum
14:01:44 <StuartMackie> #info Stuart Mackie
14:01:48 <ChrisPriceAB> #info No comments or feedback received, minutes approved
14:01:51 <trevc> #info Trevor Cooper representing Brian Skerry
14:01:52 <ChrisPriceAB> #topic Agenda Bashing
14:01:52 <morgan_orange> #info Morgan Richomme
14:01:53 <dneary> #info Dave Neary
14:02:03 <edgarstp> #info Edgar StPierre
14:02:06 <ChrisPriceAB> #link https://wiki.opnfv.org/display/meetings/TSC#TSC-September13,2016 todays agenda
14:02:08 <rpaik> welcome back trevorc!
14:02:10 <tallgren> #info Tapio Tallgren
14:02:17 <rossella_> #info Rossella Sblendido
14:02:20 <trevc> thanks Ray
14:02:24 <bin_> #info Bin Hu
14:02:43 <rprakash> #info rprakash
14:03:02 <ChrisPriceAB> #info no further agenda items
14:03:43 <ChrisPriceAB> #info frankbrockners asks about federation of Jira, may be good to couple to the "external repo's" discussion
14:03:50 <dku> #info Dirk Kutscher
14:04:09 <ChrisPriceAB> #topic Update from the September OPNFV Board meeting
14:04:23 <rpaik> #link http://lists.opnfv.org/pipermail/opnfv-tech-discuss/2016-September/012584.html Board meeting summary
14:07:09 <rpaik> #info the next TSC Chair will have a chance to review/work on the 2017 Technical Community budget in Q4'16
14:08:49 <rpaik> #action rpaik to provide update on the Q4 budget
14:08:51 <ChrisPriceAB> #topic Technical community elections
14:10:39 <ChrisPriceAB> #topic Meetup at OpenDaylight Summit
14:10:50 <rpaik> #link https://wiki.opnfv.org/display/EVNT/Meetup+at+OpenDaylight+Developer+Design+Forum ODL meet-up planning page
14:11:47 <ChrisPriceAB> #info rpaik outlines that there will be a metup at the ODL design summit on the Thursday of that week.
14:12:00 <ChrisPriceAB> #info the first set of topics will be around OpenDaylight carbon
14:12:23 <ChrisPriceAB> #info the second set of topics include compliance testing and VNF onboarding
14:12:48 <ChrisPriceAB> #info rpaik urges community members to add their names to the wiki as participants of the meetup
14:13:33 <ChrisPriceAB> #info rpaik asks if during the first hour when we meet with the ODL team whom we should invite specifically for that discussion please inform him
14:14:44 <ChrisPriceAB> #info bryan_att adds that having Yang design experts at the conference they would be very helpful to have onboard
14:16:30 <ChrisPriceAB> #topic Colorado planning and activities
14:17:07 <ChrisPriceAB> #info dmcbride states that he has updated the D-release schedule
14:17:38 <rprakash> #kink https://wiki.opnfv.org/display/SWREL/D-Release'
14:17:50 <ChrisPriceAB> #link #link https://wiki.opnfv.org/display/SWREL/D-Release?preview=/6827418/7767196/OPNFV%20Release%20%2522D%2522%20r2.pdf d release schedule
14:18:54 <ChrisPriceAB> #info dmcbride adds that there is some consensus on maintaining the stable branch cutting window that was applied in the Colorado release.
14:19:30 <ChrisPriceAB> #info dmcbride adds that we will use Jira gating for the D release.
14:21:03 <ChrisPriceAB> #info frankbrockners adds that there is discussion around the processes ongoing on the mailing lists
14:21:06 <dneary> You're welcome! I live to serve
14:21:48 <ChrisPriceAB> #action  -> d-release is from now to be referred to as Danube!
14:22:08 <ChrisPriceAB> #info 14 scenario's are now release ready.
14:22:25 <ChrisPriceAB> #info a further 10 scenario's are approahcing the stability milestone
14:22:41 <ChrisPriceAB> #info we are approaching around 70% readiness across scenario's.
14:23:49 <ChrisPriceAB> #info Jira status still has some work remaining to be in a resonlved state, around 20% of the items are unresolved.
14:24:55 <ChrisPriceAB> #info rpaik asks if there are going to be different artifacts for different architectures ARM/x86 for instance
14:25:26 <ChrisPriceAB> #info jmorgan1 describes that the Pharos spec for instance will accomodate multiple architectures in the same document
14:25:41 <fdegir> armband builds fuel iso and they need to be named accordingly
14:26:02 <fdegir> since we release installer based artifacts as well
14:26:25 <fdegir> https://www.opnfv.org/software/download
14:26:41 <fdegir> under install tools so if arm artifacts will go under fuel link
14:26:49 <fdegir> they need to be named explicitly
14:27:09 <ChrisPriceAB> #info bin_ confirms that ARM does build it's own ISO and this should accomdated in the release artifacts
14:27:37 <ChrisPriceAB> #action rpaik to work with brandon and aric to identify how to manage the artifacts for the release.
14:27:55 <ChrisPriceAB> #topic Project Health Metrics Discussion
14:28:21 <ChrisPriceAB> #link https://wiki.opnfv.org/display/PROJ/Project+Health+Metrics+Discussion wiki with metrics prposal
14:31:22 <frankbrockners> #link https://www.opnfv.org/developers/technical-project-governance/project-lifecycle
14:32:02 <rpaik> #info ChrisPriceAB notes that the metrics could be a tool to evaluate project's activity
14:32:37 <rpaik> #into tallgren notes that one of the goal is to identifier "outliers"
14:32:56 <ChrisPriceAB> #link http://lists.opnfv.org/pipermail/opnfv-tech-discuss/2016-September/012532.html mail thread on project metrics
14:34:22 <ChrisPriceAB> #info frankbrockners asks what problem we are trying to solve
14:35:06 <ChrisPriceAB> #info dneary states that we can use these metrics to help identify projects that may need community guidance and assistance to be successful
14:36:03 <ChrisPriceAB> #info franks adds that he would like to see the project lifecycle be used for project evaluation
14:36:24 <ChrisPriceAB> #info ttalgren adds that we need to start working on the project lifecycle in some way and this would be one input to that
14:36:55 <ChrisPriceAB> #info dneary adds that these metrics may be useful for more than just the TSC and project lifecycle
14:39:27 <ChrisPriceAB> #topic OPNFV External repo's
14:43:28 <rpaik> #info Scott Nicholas will be coming to Technical Community call early/mid October for an extended discussion on licensing
14:43:45 <bryan_att> my comments were put on onto the email list. Basically we should allow "non-governed" repos as short-term holding places for what we are working on, e.g. upstream project forks, as needed. e.g. we should not restrict the use of github for this purpose - it's an essential path to getting changes upstreamed.
14:44:37 <bryan_att> Every repo should have a license, and the contribution to it is governed by that license. As long as that license is compatible with OPNFV there should be no problem.
14:45:03 <ChrisPriceAB> # info chrispriceab outlines that the community should discuss and agree on how we would like to include external repositories in part of our development processes.
14:45:29 <bryan_att> We should encourage code to be maintained in the OPNFV repos, but not mandate that esp where need to engage with upstream more directly, and reference that work in OPNFV projects.
14:46:09 <tallgren> There was a case in B-release where a release candidate for B-release pulled in the latest branch rom Github
14:46:33 <ChrisPriceAB> #info bryan_att adds: my comments were put on onto the email list. Basically we should allow "non-governed" repos as short-term holding places for what we are working on, e.g. upstream project forks, as needed. e.g. we should not restrict the use of github for this purpose - it's an essential path to getting changes upstreamed.
14:46:45 <ChrisPriceAB> #info brya_att adds: Every repo should have a license, and the contribution to it is governed by that license. As long as that license is compatible with OPNFV there should be no problem.
14:46:46 <frankbrockners> #info external repo discussion should qualify (may be scott can do this) what categories of external repos are there, i.e. some repos are closely reviewed and make sure that license info is always there, others (e.g. personal githubs) handle license info potentially more loosely
14:48:06 <ChrisPriceAB> #info ashlee adds that incorporating upstream repositories should ensure that any upstream code repo's should accommodate OPNFV processes and governance.
14:50:28 <ChrisPriceAB> #info dneary asks if OPNFV should maintain a clone of upstream repositories that we could branch off locally.
14:51:00 <ChrisPriceAB> #info rpaik outlines that such processes are being looked into for some projects
14:52:56 <rprakash> #info rprakash
14:52:57 <ChrisPriceAB> #action rpaik to plan for further discussions on the tech calls and to incorporate the questions and items raised on this call.
14:53:16 <ChrisPriceAB> #topic Mailing list discussions
14:53:23 <rpaik> #link http://lists.opnfv.org/pipermail/opnfv-tech-discuss/2016-August/012279.html mailing list discussion
14:53:45 <ChrisPriceAB> #info rpaik outlines that there has been some discussion around the potential creation of new mailing lists
14:54:05 <ChrisPriceAB> #info the tech-discuss list has become very congested and can be difficult to follow.
14:55:05 <ChrisPriceAB> #info rpaik outlines that the proposal includes mailing lists per working groups and some discussion on mailing lists for upstream discussion on request.
14:55:38 <ChrisPriceAB> #info bryan_att asks about the "upstream" component of the proposal
14:56:14 <ChrisPriceAB> #info rpaik outlines that these would be for active upstream communities to be able to subscribe to focused lists in our communities
14:57:55 <ChrisPriceAB> #info ashlee adds that having open and shareable discussion forums are verty useful and he will send an informational e-mail about this shortly.
15:00:35 <ChrisPriceAB> #info rpaik proposes that we get started with the working group mailing lists.
15:00:35 <bryan_att> we need to be careful of adding additional overhead; threaded discussions are great but mail tools should be all you need for that. any more specific web service (Jira, Slack, etc) turn out to be another place that you have to watch, in addition to email and IRC.
15:01:17 <hongbo2> bryan_att: I agree with you
15:01:33 <ChrisPriceAB> #agree the TSC agrees to set up the new mailing lists as described.
15:01:48 <ChrisPriceAB> #action to report back to the TSC on the list after 3 months
15:01:52 <ChrisPriceAB> #undo
15:01:52 <collabot`> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x2b57490>
15:02:03 <frankbrockners> #info Could we bring up the "Jira federation with other upstream projects" as a topic in the next TSC - given that we missed it this time?
15:02:08 <ChrisPriceAB> #action rpaik to report back to the TSC on the list after 3 months
15:02:22 <ChrisPriceAB> #action chrispriceab to add the Jira discussion to next weeks agenda
15:02:36 <ChrisPriceAB> #endmeeting