15:00:29 <fdegir> #startmeeting Infra WG Weekly Meeting
15:00:29 <collabot> Meeting started Wed Sep 14 15:00:29 2016 UTC.  The chair is fdegir. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:29 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:00:29 <collabot> The meeting name has been set to 'infra_wg_weekly_meeting'
15:00:39 <fdegir> #topic Roll Call
15:00:50 <jmorgan1> #info Jack Morgan (Pharos)
15:01:09 <bramwelt> #info Trevor Bramwell
15:01:38 <fdegir> #chair jmorgan1
15:01:38 <collabot> Current chairs: fdegir jmorgan1
15:02:26 <ulik> #info Uli Kleber
15:02:32 <fdegir> #chair ulik
15:02:32 <collabot> Current chairs: fdegir jmorgan1 ulik
15:02:39 <fdegir> so I can make ulik chair :)
15:02:57 <fdegir> #link https://wiki.opnfv.org/display/INF/Infra+Working+Group#InfraWorkingGroup-Agenda
15:03:46 <aricg> #info Aric Gardner
15:03:57 <fdegir> #topic Hight prio items for Colorado release
15:04:51 <fdegir> #info No release specific item has been brought up
15:05:10 <fdegir> dmcbride: ping?
15:05:19 <fdegir> dmcbride: will you join the infra wg meeting?
15:05:40 <fdegir> dmcbride: if not, can you type in any release specific infra item?
15:05:47 <dmcbride> on my way
15:05:52 <dmcbride> kid problems :)
15:06:00 <fdegir> #undo
15:06:00 <collabot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2847090>
15:06:35 <fdegir> #info The docker issue with LF POD1 has been fixed
15:07:03 <fdegir> #info morgan_orange and trozet fixed the docker issue on LF POD1 jumphost
15:08:01 <fdegir> #info jmorgan1 asked armband to add information in to pharos documentation for colorado.1.0
15:08:40 <fdegir> #info The next question is how we should store and make arm fuel isos available on opnfv.org
15:10:11 <fdegir> #info aricg will check this with LF Webteam and Marketing
15:10:38 <fdegir> #undo
15:10:38 <collabot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2ccb750>
15:10:45 <fdegir> #action aricg will check this with LF Webteam and Marketing
15:10:53 <fdegir> #undo
15:10:53 <collabot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x2a564d0>
15:11:05 <fdegir> #action aricg will check how to present armband artifacts on opnfv.org with LF Webteam and Marketing
15:11:46 <fdegir> #topic Action Item Followup
15:12:05 <fdegir> #link https://wiki.opnfv.org/display/INF/Infra+Working+Group#InfraWorkingGroup-Agenda
15:12:27 <fdegir> #info Follow up the collection of scenario/POD mapping - jmorgan1
15:12:43 <fdegir> #action jmorgan1 will continue working on collection of scenario/POD mapping
15:13:12 <fdegir> #info Force change ID by setting the "Require Change-Id in commit message" has been implemented by aricg
15:13:57 <fdegir> #info Bring up additional build servers done
15:14:10 <fdegir> #action fdegir install packages on lf-build2
15:15:29 <fdegir> #action jmorgan1 to check with Trevor Cooper to find out latest status regarding UCS support
15:16:16 <fdegir> #action fdegir to check with frankbrockners to see who can help us with UCS in LF POD
15:17:13 <fdegir> #info Have a proposal regarding dynamic POD allocation
15:17:29 <fdegir> #link http://lists.opnfv.org/pipermail/opnfv-tech-discuss/2016-September/012466.html
15:18:06 <fdegir> #action Daniel Smith to send the proposal regarding dynamic POD allocation
15:18:36 <fdegir> #info Intel POD8 Jenkins connection has been fixed
15:19:41 <fdegir> #info Intel POD8 needs to be checked to see if compass jobs can be set to run on this pod
15:19:53 <fdegir> #action Mei to report the status of POD8
15:20:50 <fdegir> #info Ericsson lab migration has been started
15:21:08 <fdegir> #info fdegir will keep Infra WG up to date regarding the migraiton
15:21:46 <fdegir> #info Colorado release standup meetings have been setup; modn, thurday, friday
15:21:52 <fdegir> #info 8AM pacific
15:23:12 <fdegir> #info Prerequisites for CI Evolution plans have been added to Wiki and will be discussed when the topic comes
15:23:40 <fdegir> #info Propose mechanism to track upstream contributions using apex as example and make example available in releng repo for infra contributions
15:23:50 <fdegir> #link https://gerrit.opnfv.org/gerrit/#/c/21057/
15:24:33 <B_Smith> 4~/j #c64
15:26:26 <jmorgan1> B_Smith: this is not the Commodore 64 channel ;)
15:28:26 <lhinds> LOAD "DONKEYKONG",8
15:28:43 <jmorgan1> heh
15:31:50 <fdegir> #action jmorgan1 Start a new wiki page for resource onboarding
15:32:46 <frankbrockners> fdegir - jlinkes can help with LF POD - but we're in the middle of release ops...
15:33:00 <fdegir> aricg: ^
15:33:24 <fdegir> #topic How to properly scrape html into wiki, there is a paid option
15:34:18 <fdegir> #info bramwelt and jmorgan1 had a discussion regarding how to present auto generated docs on Wiki
15:35:19 <fdegir> #info Pharos needs to standardize how to document lab information and present it on the wiki
15:36:23 <fdegir> #info Pharos to bring this to LF to see if the paid option can be activated
15:36:38 <fdegir> #topic OPNV-Gerrit-bot too verbose
15:37:00 <bryan_att> anyone know how to get the OPNFV Stackalytics updated? Not all OPNFV projects are currently represented.
15:37:21 <fdegir> #info OPNV-Gerrit-bot will log info when there is new patchset and when it gets merged
15:37:31 <fdegir> #topic CI Evolution
15:37:32 <bryan_att> e.g. is there a Jira project for that (as well as bitergia apps) ?
15:37:52 <fdegir> #link https://wiki.opnfv.org/display/INF/CI+Evolution#CIEvolution-Prerequisites
15:40:42 <bryan_att> another question - do we have an artifacts repo where we can post binaries use in opnfv tests etc, and how do we access that repo?
15:41:32 <bryan_att> currently I have to customize an ubuntu xenial image for the Models project and am pulling it from my godaddy server, which is not reliable enough
15:43:22 <bryan_att> fdegir: you have my support for the CI evolution objective and approach, but I have no resources to help you currently.
15:43:35 <fdegir> #info Everyone is requested to provide feedback regarding CI Evolution
15:44:11 <ChrisPriceAB> As far as I recall we have a plan to get this done once Colorado is done, even the Apex team would do this after Colorado right?
15:44:26 <fdegir> #info Prerequisites must be fulfilled in order for us to proceed with later phases
15:44:30 <ChrisPriceAB> The eventual plan is to have the CI Evolution work completed during D release
15:44:34 <jmorgan1> ChrisPriceAB: that is my understnading as well
15:45:05 <fdegir> #action bramwelt to work with apex to align job structures
15:46:03 <fdegir> #topic Infra plans and status for D-release
15:46:42 <fdegir> #info jmorgan1 has been looking into common configuration files to make this happen for D-release
15:47:35 <fdegir> #info jmorgan1 will discuss the subject of common configuration files genesis/installer projects
15:48:15 <fdegir> #info A prototype will be created for Intel Lab to use with pharos validator/dashboard to get some progress
15:49:39 <fdegir> #info Current scenario handling/naming doesn't scale well and we need to go over this again
15:53:22 <fdegir> #info One of the reasons for having scenarios named this way is to increase the readability on Jenkins for example
15:53:57 <fdegir> #info An idea could be simply numbering them and storing what a certain scenario consists of which components
15:54:35 <fdegir> #info Problem is not just about the naming but about handling them since we have large number of scenarios
15:55:06 <bryan_att> the problem is the permutations. we need to have more functionality be part of the base system and compatible with other similar functions, which is applied controlled through some config parameter.
15:55:30 <bryan_att> e.g. there is no reason we should not have both ONOS and ODL in a scenario
15:56:06 <bryan_att> if the SDNCs are used for different purposes (e.g. overlay vs underlay) then they both should be in the build
15:56:38 <fdegir> #action ulik to come up with the description of the problem with OPNFV scenario handling and propose way forward
15:57:03 <ChrisPriceAB> ulik: do you want some time on the TSC to present this item for community discussion?
15:57:47 <ulik> ChirsPriceAB: I will need that. but I am not sure I need it next week.
15:59:58 <fdegir> #info Handling scenarios with specific needs also require discussion
16:01:01 <fdegir> #info Ideas are kept on Wiki and etherpad regarding Dynamic POD allocation/pooling
16:01:09 <jmorgan1> #link https://wiki.opnfv.org/display/INF/Dynamic+Allocation
16:02:04 <fdegir> #endmeeting